Autor Thema: Hilfe bei Einrichtung eines RFXtrx433 von RFXCOM  (Gelesen 11319 mal)

Offline FHEM-User22

  • Full Member
  • ***
  • Beiträge: 288
  • Viele Grüße aus Grimma
Hilfe bei Einrichtung eines RFXtrx433 von RFXCOM
« am: 01 November 2013, 17:07:51 »
Hallo,
ich habe einen Raspi incl.  COC 868 Mhz und 1wire.

Nun möchte ich den  RFXtrx433 am USB anschließen, aber mir fehlt jeglicher Anfang dazu. Wie muß ich das RFXtrx433 in der fhem.cnf eintragen?

Dankeschön für Eure Hilfe.


FHEM auf Raspberry Pi und Proxmox und... und.... und....

Offline Willi

  • Sr. Member
  • ****
  • Beiträge: 594
Antw:Hilfe bei Einrichtung eines RFXtrx433 von RFXCOM
« Antwort #1 am: 01 November 2013, 17:31:34 »
Wenn autocreate mit "usb create" eingeschaltet ist: RFXtrx433 einstecken und abwarten.
Sollte in der mit FHEM mitgelieferten fhem.cfg entsprechend schon eingetragen sein. Ansonsten schau mal in der Commandref.

Danach wird RFxtrx433 erkannt und auch alle Geräte automatisch angelegt, die empfangen werden.
Bei nicht so geläufigen Sendern musst Du dann nur noch die Weblinks anlegen. Bei anderen geht das automatisch.

Von einem Einsatz von RFXtrx433 ohne autocreate würde ich abraten.

Grüße

Willi
FHEM@Q600(debian) mit DS9490R (1Wire) | FHEM@Sheevaplug(debian) mit RFXCOM-Receiver(80002), CULv3 & USB-WDE1 | FHEM@odroid mit CULv2 & RFXtrx433

Offline Icebear

  • Full Member
  • ***
  • Beiträge: 340
Antw:Hilfe bei Einrichtung eines RFXtrx433 von RFXCOM
« Antwort #2 am: 01 November 2013, 18:58:57 »
Hallo,

bitte vergess nicht mit RFXMgr die benötigten Protokolle einzustellen (und vor allem die nicht benötigen abzuschalten)

und da bitte auf save settings klicken (set mode speichert es NICHT im RFXTrx und nach dem abstoepseln sind die daten weg :)

Bei mir eingestellt : Hideki (für TFA sensoren) AC, ARC (für intertechno), HomeEasy und Oregon Scientific
Das wars
Raspberry PI mod B (Wheezy), Fhem 5.4, CUL868, CUL433 , RfxTrx, HM-USB-CFG2, Wlan, HomeEasy, IT, FS20, TFA, HomeMatic, Oregon Scientific, HMLand auf Fritzbox
Raspberry PI mod B (RaspBMC)
Gefällt mir Gefällt mir x 1 Liste anzeigen

Offline FHEM-User22

  • Full Member
  • ***
  • Beiträge: 288
  • Viele Grüße aus Grimma
Antw:Hilfe bei Einrichtung eines RFXtrx433 von RFXCOM
« Antwort #3 am: 03 November 2013, 15:23:10 »
Hallo,
dankeschön. Es funkioniert wohl. Habe schon Temperaturfühler (wohl aus der Nachbarschaft) empfangen, auf 433 MHz.

Ich weiß nur noch nicht, wie ich die Funkprotokolle ausschalten kann.

Schönenn Sonntag
FHEM auf Raspberry Pi und Proxmox und... und.... und....

Offline Icebear

  • Full Member
  • ***
  • Beiträge: 340
Antw:Hilfe bei Einrichtung eines RFXtrx433 von RFXCOM
« Antwort #4 am: 03 November 2013, 15:25:47 »
Hi,

im RFXManager .. wo kein Haken wird auch nicht empfangen ...

und wech
Raspberry PI mod B (Wheezy), Fhem 5.4, CUL868, CUL433 , RfxTrx, HM-USB-CFG2, Wlan, HomeEasy, IT, FS20, TFA, HomeMatic, Oregon Scientific, HMLand auf Fritzbox
Raspberry PI mod B (RaspBMC)

Offline FHEM-User22

  • Full Member
  • ***
  • Beiträge: 288
  • Viele Grüße aus Grimma
Antw:Hilfe bei Einrichtung eines RFXtrx433 von RFXCOM
« Antwort #5 am: 03 November 2013, 15:43:51 »
Haaaaaaalt... nich weg...

Erst sagen, wo der RFXManager zu finden ist.....

Dankeschön
FHEM auf Raspberry Pi und Proxmox und... und.... und....

Offline ext23

  • Hero Member
  • *****
  • Beiträge: 2987
    • Homepage
Antw:Hilfe bei Einrichtung eines RFXtrx433 von RFXCOM
« Antwort #6 am: 03 November 2013, 16:29:15 »
HM, FS20, 1-Wire, PanStamp, AVR-NET-IO, SIS-PM, EM1000EM, PCA301, EC3000, HM-LAN, CUL868, RFXtrx433, LGW, DMX @Ubuntu-Server (Hauptsystem) & Raspberry Pi (Satellit)

Offline FHEM-User22

  • Full Member
  • ***
  • Beiträge: 288
  • Viele Grüße aus Grimma
Antw:Hilfe bei Einrichtung eines RFXtrx433 von RFXCOM
« Antwort #7 am: 06 November 2013, 11:29:18 »
Dankeschön,
scheint erstmal erkant worden zu sein.

2013.11.06 06:18:58 1: Including fhem.cfg
2013.11.06 06:19:01 3: telnetPort: port 7072 opened
2013.11.06 06:19:03 3: WEB: port 8083 opened
2013.11.06 06:19:03 3: WEBphone: port 8084 opened
2013.11.06 06:19:04 3: WEBtablet: port 8085 opened
2013.11.06 06:19:05 3: Opening COC device /dev/ttyAMA0
2013.11.06 06:19:06 3: Setting COC baudrate to 38400
2013.11.06 06:19:06 3: COC device opened
2013.11.06 06:19:06 3: COC: Possible commands: mCFiAZOGMRTVWXefltux
2013.11.06 06:19:07 3: Opening TRX_0 device /dev/ttyUSB0
2013.11.06 06:19:07 3: Setting TRX_0 baudrate to 38400
2013.11.06 06:19:07 3: TRX_0 device opened
2013.11.06 06:19:07 1: TRX: Init OK
2013.11.06 06:19:07 1: TRX: Init status: '433.92MHz transceiver, firmware=69, protocols enabled: LaCrosse Mertik OREGON HOMEEASY AC ARC X10 '
2013.11.06 06:18:57 3: No I/O device found for mumbi_1
2013.11.06 06:18:57 1: Including ./log/fhem.save
2013.11.06 06:18:57 1: usb create starting
2013.11.06 06:19:03 1: usb create end
2013.11.06 06:19:03 0: Server started (version Fhem 5.3 (DEVELOPMENT), $Id: fhem.pl 1996 2012-10-20 07:11:56Z rudolfkoenig $, pid 2014)

Ich werde weiter testen.

Dankeschön
FHEM auf Raspberry Pi und Proxmox und... und.... und....

Offline Björn

  • New Member
  • *
  • Beiträge: 13
Antw:Hilfe bei Einrichtung eines RFXtrx433 von RFXCOM
« Antwort #8 am: 28 November 2013, 19:09:02 »
Hallo,

ich komm nicht weiter.
Was machen wenn der RFX nicht erkannt wird.
Habe das Gerät in meine FB eingesteckt. Wird von FB erkannt aber FHEM macht keine Anstalten das Gerät zu erkennen.
Wie lange dauert das erkennen denn?

Gruß Björn

Offline Willi

  • Sr. Member
  • ****
  • Beiträge: 594
Antw:Hilfe bei Einrichtung eines RFXtrx433 von RFXCOM
« Antwort #9 am: 28 November 2013, 20:22:24 »
Hallo Björn,

hast Du  "usb create" in der Konfig (siehe commandref)? Danach FHEM neu starten oder FB neu booten. Wenn ich mich richtig erinnere, werden die Interfaces von FHEM nur beim Start getestet.

Wenn das nicht hilft, erst mal RFXtrx433 an einem Windows-PC mit dem mitgelieferten Programm RFXmngr (siehe auch Download bei der RFXCOM-Homepage) testen. Ein Firmware-Update geht auch über den Windows-PC mittels RFXflash. Siehe auch das Handbuch des RFXtrx433.

-- Willi
« Letzte Änderung: 28 November 2013, 20:25:26 von Willi »
FHEM@Q600(debian) mit DS9490R (1Wire) | FHEM@Sheevaplug(debian) mit RFXCOM-Receiver(80002), CULv3 & USB-WDE1 | FHEM@odroid mit CULv2 & RFXtrx433

Offline Björn

  • New Member
  • *
  • Beiträge: 13
Antw:Hilfe bei Einrichtung eines RFXtrx433 von RFXCOM
« Antwort #10 am: 28 November 2013, 22:07:19 »
Hallo Willi,

also in meiner FHEM.cfg steht folgendes drin:

define initialUsbCheck notify global:INITIALIZED usb create

von dem her gehe ich aus, dass usb create aktiv ist.
Ich habe jetzt gerade den RFXtrx433 geflasht.
Mal schauen ob ich nun bessere karten habe.
Ich kenn mich mit dem Coding noch nicht so aus.
Bin froh, dass Fhem schon meine Heizungen steuert....
Gruß Björn

Offline Björn

  • New Member
  • *
  • Beiträge: 13
Antw:Hilfe bei Einrichtung eines RFXtrx433 von RFXCOM
« Antwort #11 am: 01 Dezember 2013, 12:35:37 »
Hallo,

ich habe nun einen FHEM Server auf einem Raspberry Pi aufgesetzt.
Jetzt klappt es so wie beschrieben.
Offensichtlich hatte ich mir AUTOCONFIG auf meiner FB zerschossen.

Gruß Björn

Offline TimoD

  • Jr. Member
  • **
  • Beiträge: 51
Antw:Hilfe bei Einrichtung eines RFXtrx433 von RFXCOM
« Antwort #12 am: 11 Mai 2019, 20:32:39 »
Hallo, ich bekomme leider auch kein Autocreate für mein rfxtrx.

Laut Raspberry wurde das Gerät wie folgt erkannt:

usb-RFXCOM_RFXtrx433XL_DO3FNRXF-if00-port0 -> ../../ttyUSB1

Leider wird aber kein trx Gerät automatsch erstellt (ich kann kein Gerät unter "Everything" finden!?

ebenso bekomme ich das Gerät nicht angezeigt, wenn ich "usb scan" ausführe.

Hat mir noch jemand einen Tipp?

Offline TimoD

  • Jr. Member
  • **
  • Beiträge: 51
Antw:Hilfe bei Einrichtung eines RFXtrx433 von RFXCOM
« Antwort #13 am: 12 Mai 2019, 10:49:51 »
Hab nun das Update durchgeführt auf 1039 (Device 433XLPro)

in fhem steht aber weiterhin:
 Probing TRX device ttyUSB1
  wrong answer

Konfiguriert habe ich lediglich die Protokolle! Muss ich noch was anderes einrichten?