Autor Thema: Modul für Pushover  (Gelesen 112928 mal)

Offline Garbsen

  • Full Member
  • ***
  • Beiträge: 307
  • Learning by doing und copy paste
Antw:Modul für Pushover
« Antwort #585 am: 06 Februar 2017, 13:52:44 »
Das ist schon klar, meine konkrete(re)n Fragen:
Kennt jemand dieses Verhalten?
Funktioniert bei anderen glance ohne dieses Verhalten?
Kann es an der Syntax der Meldung liegen oder müssen noch Attribute gesetzt werden?

Hier noch ein List

Internals:
   APP_TOKEN  .....
   DEF        ......  .....
   NAME       pushmsg
   NR         687
   STATE      connected
   TYPE       Pushover
   USER_KEY   ......
   VALIDATION_TIMER 1486405047.414
   Readings:
     2017-02-06 11:35:44   apiLimit        7500
 
     2017-02-06 13:17:27   apiRemaining    7456
 
     2017-02-06 11:35:44   apiReset        1488348000
 
     2017-02-06 10:29:21   available       1
     2017-01-12 20:47:50   devices         ipad,iphone-K-H
     2017-01-07 20:47:50   group           0
     2017-02-06 12:14:14   lastAction      -
     2017-02-06 13:17:27   lastDevice      ipad,iphone-K-H
     2017-02-06 12:14:14   lastMessage     1
     2017-02-06 12:14:14   lastPriority    0
     2017-02-06 13:17:27   lastRequest     aa4c7304a2473182fd33ef8ddcd891d4
     2017-02-06 13:17:27   lastResult      ok
     2017-02-06 11:43:42   lastSubtext     Some more info
     2017-02-06 13:17:27   lastText        2
     2017-02-06 13:17:27   lastTitle
     2017-02-06 10:29:21   state           connected
     2017-01-07 20:47:50   tokenState      valid
     2017-01-07 20:47:50   userState       valid
Attributes:
   room       Allgemein,Pushover
FHEM und Homebridge auf Intel NUC, CUL 868 v 1.66, CUL466 V 1.66, SOMFY RTS Rolläden, HM-LC-Bl1PBU-FM, HM-LC-BL1-FM, HM-SEC-SC-2, HM-SEC-RHS, HM-WDS10-TH-O, HM-SEC-WDS-2, HM-Sen-LI-O, HM-CC-RT-DN, HM-LC-Sw1-Pl-DN-R1, HM-SCI-3-FM, HM-Sec-Sir-WM, HM-PB-2-WM55-2, HM-RC-8, HM-LC-SW1-PL2, Alpha2

Offline Klaus.A

  • Jr. Member
  • **
  • Beiträge: 50
Antw:Modul für Pushover
« Antwort #586 am: 13 Februar 2017, 00:54:55 »
Das Problem mit der Apple Watch habe ich auch: Die Pushover Messages aus FHEM kommen alle (!) auf dem iPhone zuverlässig an, aber auf der Watch nur zufallsbedingt bzw. mit erheblicher Verzögerung. Das sieht aber nicht nach FHEM aus, sondern wie ein Apple-Watch OS Problem (seit Watch OS 3.1.3 oder dem neuesten iOS Update).

Sonderbar ist nur das ich mit der alten Syntax bei Aufruf aus einem Notify (set FHEM ...) korrekte Ergebnisse habe, bei Aufruf aus einem DOIF aber plötzlich die Probleme aufgetreten sind.
Da aber auf dem iPhone alles zuverlässig ankommt, kann die Ursache nicht in FHEM bzw. dem Pushover Modul liegen.

Gruß, Klaus
FHEM auf CubieTruck, 1 x HMLAN, 3 x HM-LGW-O-TW-W-EU-2, mehr als 90 HomeMatic Sensoren und Aktoren, Velux-Fenster-Interfaces, diverse ZWave-Sensoren und Aktoren (Fibaro), Philips Hue Bridge, Amazon Echo Dot/Alexa, AutoMower via API ...
Zustimmung Zustimmung x 1 Liste anzeigen

Offline Thyraz

  • Full Member
  • ***
  • Beiträge: 377
Antw:Modul für Pushover
« Antwort #587 am: 16 Februar 2017, 12:08:19 »
Bei mir werden die Pushnachrichten auch nicht an die Watch weitergeleitet.
Verstehe aber nicht warum, normal spiegelt die Watch doch einfach die Notifications vom iPhone.

Man merkt auch den Unterschied:
Wenn normal (z.B. bei anderen Apps) bei entsperrter Watch eine Nachricht reinkommt, bleibt das iPhone stumm und vibriert nicht.
Dafür "tippt" einen die Watch  an.

Bekomme ich jetzt aber PushNotifications von PushOver, vibriert direkt das Handy und nicht die Watch.
Wusste gar nicht, dass das technisch überhaupt so möglich ist, solang an in der Watch App für die jeweilige Anwendung "iPhone Benachrichtigungen spiegeln" aktiv hat. :-/

Bei allen anderen Apps klappts...

Offline peterk_de

  • Sr. Member
  • ****
  • Beiträge: 642
Antw:Modul für Pushover
« Antwort #588 am: 16 März 2017, 09:26:40 »
Das Problem mit der Apple Watch habe ich auch: Die Pushover Messages aus FHEM kommen alle (!) auf dem iPhone zuverlässig an, aber auf der Watch nur zufallsbedingt bzw. mit erheblicher Verzögerung. Das sieht aber nicht nach FHEM aus, sondern wie ein Apple-Watch OS Problem (seit Watch OS 3.1.3 oder dem neuesten iOS Update).

Sonderbar ist nur das ich mit der alten Syntax bei Aufruf aus einem Notify (set FHEM ...) korrekte Ergebnisse habe, bei Aufruf aus einem DOIF aber plötzlich die Probleme aufgetreten sind.
Da aber auf dem iPhone alles zuverlässig ankommt, kann die Ursache nicht in FHEM bzw. dem Pushover Modul liegen.

Gruß, Klaus

Ich reihe mich hier einmal ein, genau das gleiche Problem. Manche Benachrichtigungen kommen bis zur Watch durch, manche nicht, auf dem iPhone klappt es währenddessen super. WatchOS/ IOS sind aktuell.

Was ich bez. FHEM herausgefunden habe: Alte vs. neue Modul-Syntax kann ich definitiv ausschließen, es klappt bei beiden mal ja und mal nicht. Ich hab jetzt schon viel probiert und es scheint wirklich rein zufällig zu sein. Selbst die identische Nachricht (selber Titel, selber text) klappt manchmal, manchmal aber nicht. Und interessant ist auch, dass es bei anderen Apps (z.B. Telegram, Threema etc.) sehr zuverlässig funktioniert.



« Letzte Änderung: 16 März 2017, 09:30:24 von peterk_de »
Intel NUC5i5 -> Proxmox -> Ubuntu 16.04 LTS
IOdevs: 2x Homematic, CUL868, HarmonyHub
Frontends: 3x TabletUI Android-Tablets mit AMAD+FullyBrowser, Homebridge/Siri
Aktoren/Sensoren: 86x Homematic, 15x WMBUS/Techem, 7x WiFi, 5x BLE, 2x BT, Geofencing
FHEM2FHEM-Roomnodes: 5x Raspi, 1x Cubietruck

Offline farin1337

  • New Member
  • *
  • Beiträge: 11
Antw:Modul für Pushover
« Antwort #589 am: 17 März 2017, 12:41:00 »
Moin,

erst einmal vielen Dank für das tolle Modul es funktioniert fast alles wie gewünscht. Ich habe nur ein Problem mit der Callback-Funktion. Das Reading "cbAck_*" bleibt bei mir dauerhaft auf "0", obwohl ich das Atrribut "callbackUrl" gesetzt habe. Habe "verbose" auf 5 gesetzt und bekomme auch eine Bestätigung im Logfile, dass der entsprechende User die Pushover-Meldung acknowledged hat:

2017.03.17 12:24:37 4: Pushover pushmsg callback: link='/pushCallback1' URI='receipt=******&acknowledged=1&acknowledged_at=1489749876&acknowledged_by=******&acknowledged_by_device=farin'

Dennoch bleibt das Reading cbAck_* auf 0. Meine Callbackurl sieht folgendermaßen aus:
   
https://api:passwort@webhook.meinedomain.de/webhook/pushCallback1

Ich arbeite hier mit einem Apache reverseproxy und kann z.B. auch erfolgreich per HTTP readings setzen. Ich bin unter anderem nach folgender Anleitung gegangen: https://wiki.fhem.de/wiki/Anwesenheitserkennung#Webhook_weiter_absichern
Ich habe auch schon probiert das ganze ohne Authentifizierung zu machen, jedoch hat auch dies nicht den gewünschten Erfolg gebracht. Hat jemand vllt. noch eine Idee dazu?

Gruß
Farin1337


Offline Loredo

  • Developer
  • Hero Member
  • ****
  • Beiträge: 2808
  • ~ Challenging Innovation ~
Antw:Modul für Pushover
« Antwort #590 am: 18 März 2017, 14:38:00 »
An alle Apple Watch Glance Ausprobierer:
Ich muss euch nochmals mit der Nase auf ein Zitat in der API Dokumentation stoßen (was ich hier schon öfters getan habe):

Zitat
Please note that our Glances API is currently in beta and may be subject to change.

und

Zitat
These pieces of data should be low-priority since they often cannot get updated in real-time or very frequently, and they must be concise because they are often viewed on small screens such as a watch face.

und

Zitat
Pushing data to the Apple Watch must be done infrequently, or WatchOS will stop processing updates due to battery concerns. Please note that Pushover does not do any throttling of your data updates, so it is up to you to throttle your Glances API calls. When sending data to the Apple Watch, we recommend at least 20 minutes between each call. If you have pushed too much data and WatchOS stops processing updates, this resets overnight.

Remember, the data presented through our Glances API should be low-priority (something to be occasionally glanced at). If you need to send data that is delivered right away and presented to the user, use our Messages API.

Die korrekte Schlussfolgerung ist also, dass ihr beim testen einfach zu viel und oft updated und die Verzögerungen in erster Linie dadurch entstehen, weil die Apple Watch API nicht für dauerhaftes Echtzeitupdate ausgelegt ist, um Strom zu sparen. Das ist nichts, was die Pushover App ändern könnte (oder gar das FHEM Modul, wie peterk_de richtig analysiert).
FHEM-Module: ENIGMA2, GEOFANCY, ONKYO_AVR, PHTV, RESIDENTS, ROOMMATE, GUEST, HP1000, powerMap, Pushover, THINKINGCLEANER, Wunderground | FHEM-Befehl: msg

FHEM 5.9dev auf Intel NUC mit Proxmox VE
Homematic via HMCCU, Hue Color Bulbs
ONKYO TX-NR626, Philips 55" PFL8008S, Sonos 1xS1, 1xS3, 2xS5

Offline Loredo

  • Developer
  • Hero Member
  • ****
  • Beiträge: 2808
  • ~ Challenging Innovation ~
Antw:Modul für Pushover
« Antwort #591 am: 18 März 2017, 15:17:15 »
Ich habe nur ein Problem mit der Callback-Funktion. Das Reading "cbAck_*" bleibt bei mir dauerhaft auf "0", obwohl ich das Atrribut "callbackUrl" gesetzt habe. Habe "verbose" auf 5 gesetzt und bekomme auch eine Bestätigung im Logfile, dass der entsprechende User die Pushover-Meldung acknowledged hat:

2017.03.17 12:24:37 4: Pushover pushmsg callback: link='/pushCallback1' URI='receipt=******&acknowledged=1&acknowledged_at=1489749876&acknowledged_by=******&acknowledged_by_device=farin'


Gibt es denn Readings, die im Namen den Wert von "receipt" beinhalten? Da wäre ein "list" und ein nicht geschwärztes Log interessant.
FHEM-Module: ENIGMA2, GEOFANCY, ONKYO_AVR, PHTV, RESIDENTS, ROOMMATE, GUEST, HP1000, powerMap, Pushover, THINKINGCLEANER, Wunderground | FHEM-Befehl: msg

FHEM 5.9dev auf Intel NUC mit Proxmox VE
Homematic via HMCCU, Hue Color Bulbs
ONKYO TX-NR626, Philips 55" PFL8008S, Sonos 1xS1, 1xS3, 2xS5

Offline choenig

  • Jr. Member
  • **
  • Beiträge: 57
Antw:Modul für Pushover
« Antwort #592 am: 20 März 2017, 10:03:02 »
Hi,

ich gehöre auch zu den "Apple Watch Glance Ausprobierern" :).

Es ist zur Zeit nicht nur umständlich möglich, "count" und "percent" wieder auf '0' zu setzen.

Folgendes setzt zwar "percent" auf '25', aber "count" bleibt unverändert:
set Pushover glance count=0 percent=25
Folgendes ist der Workaround, mit dem ich es doch schaffe, "count" auf 0 zu setzen:
set Pushover glance count="-0" percent=50
Durch kontinuierliches ändern des Percent-Wertes kann ich sicherstellen, dass die Änderungen auf der Applewatch ankommen und nicht durch das WatchOS blockiert werden.

Nach einem kurzen Blick in den Pushover-Code würde ich davon ausgehen, dass folgendes bei '0' nicht funktioniert:
    $values{count}   = $h->{count}   ? $h->{count}   : undef;
    $values{percent} = $h->{percent} ? $h->{percent} : undef;

Meine Perl-Fähigkeiten sind aber nicht gut genug, um hier sicher zu sein und einen Fix vorzuschlagen.

Vielen Dank im Voraus
LG
Christian

Offline Loredo

  • Developer
  • Hero Member
  • ****
  • Beiträge: 2808
  • ~ Challenging Innovation ~
Antw:Modul für Pushover
« Antwort #593 am: 20 März 2017, 11:56:07 »
Es ist zur Zeit nicht nur umständlich möglich, "count" und "percent" wieder auf '0' zu setzen.


Fair enough. Habe einen Patch dazu eingecheckt.
FHEM-Module: ENIGMA2, GEOFANCY, ONKYO_AVR, PHTV, RESIDENTS, ROOMMATE, GUEST, HP1000, powerMap, Pushover, THINKINGCLEANER, Wunderground | FHEM-Befehl: msg

FHEM 5.9dev auf Intel NUC mit Proxmox VE
Homematic via HMCCU, Hue Color Bulbs
ONKYO TX-NR626, Philips 55" PFL8008S, Sonos 1xS1, 1xS3, 2xS5
Gefällt mir Gefällt mir x 1 Liste anzeigen

Offline farin1337

  • New Member
  • *
  • Beiträge: 11
Antw:Modul für Pushover
« Antwort #594 am: 20 März 2017, 12:58:42 »

Gibt es denn Readings, die im Namen den Wert von "receipt" beinhalten? Da wäre ein "list" und ein nicht geschwärztes Log interessant.

Danke für deine Antwort und sorry, dass ich mich erst jetzt melde. Das Reading "cb_*" hat nur den Wert von receipt. Unter "list" finde ich keine Reading, die im Namen den Wert von "receipt" beinhalten. Ich habe das ganze bis jetzt nur mit einem Android Client probiert, werde es heute Abend einmal mit einem Apple Gerät ausprobieren. Anbei das entsprechende Logfile:

2017.03.20 12:46:55 4: Pushover pushmsg: RCV messages.json/title=Notfall&message=Sicherheits-Alarm im Wohnzimmer.&device=farin&priority=2&sound=siren&retry=30&expire=120&callback=https://user:passwort@domain.de/webhook/pushCallback1&token=<MEINTOKEN>&user=<MEINUSER>
2017.03.20 12:46:55 5: Pushover pushmsg: RES messages.json/title=Notfall&message=Sicherheits-Alarm im Wohnzimmer.&device=farin&priority=2&sound=siren&retry=30&expire=120&callback=https://user:passwort@domain.de/webhook/pushCallback1&token=<MEINTOKEN>&user=<MEINUSER>
{"receipt":"rtj7cf11ufzgb7bogypv8h7q3j7vxg","status":1,"request":"304ccd84-3620-4145-8c18-779f2859eb21"}

2017.03.20 12:48:19 4: Pushover pushmsg callback: link='/pushCallback1' URI='receipt=rtj7cf11ufzgb7bogypv8h7q3j7vxg&acknowledged=1&acknowledged_at=1490010496&acknowledged_by=uirpG2u*******&acknowledged_by_device=farin'

Hier die entsprechenden Readings:
cbAck_1490010534  0                                                     2017-03-20 12:46:55
cbDev_1490010534 farin                                                 2017-03-20 12:46:55
cbMsg_1490010534 Sicherheits-Alarm im Wohnzimmer. 2017-03-20 12:46:55
cbPrio_1490010534 2                                                      2017-03-20 12:46:55
cbTitle_1490010534 Notfall                                              2017-03-20 12:46:55
cb_1490010534   rtj7cf11ufzgb7bogypv8h7q3j7vxg       2017-03-20 12:46:55
lastRequest 304ccd84-3620-4145-8c18-779f2859eb21  2017-03-20 12:46:55

Gruß
Farin





 

Offline Loredo

  • Developer
  • Hero Member
  • ****
  • Beiträge: 2808
  • ~ Challenging Innovation ~
Antw:Modul für Pushover
« Antwort #595 am: 20 März 2017, 14:32:56 »
Danke für deine Antwort und sorry, dass ich mich erst jetzt melde. Das Reading "cb_*" hat nur den Wert von receipt. Unter "list" finde ich keine Reading, die im Namen den Wert von "receipt" beinhalten.


Ok, ich denke ich konnte da was finden und habe einen Patch eingecheckt.
FHEM-Module: ENIGMA2, GEOFANCY, ONKYO_AVR, PHTV, RESIDENTS, ROOMMATE, GUEST, HP1000, powerMap, Pushover, THINKINGCLEANER, Wunderground | FHEM-Befehl: msg

FHEM 5.9dev auf Intel NUC mit Proxmox VE
Homematic via HMCCU, Hue Color Bulbs
ONKYO TX-NR626, Philips 55" PFL8008S, Sonos 1xS1, 1xS3, 2xS5

Offline Loredo

  • Developer
  • Hero Member
  • ****
  • Beiträge: 2808
  • ~ Challenging Innovation ~
Antw:Modul für Pushover
« Antwort #596 am: 20 März 2017, 17:32:53 »
Ab morgen ist es außerdem möglich, dass man die Aufforderung zur Bestätigung bei Priorität 2 Nachrichten vorzeitig beenden kann.
Siehe auch https://forum.fhem.de/index.php/topic,69281.0.html
FHEM-Module: ENIGMA2, GEOFANCY, ONKYO_AVR, PHTV, RESIDENTS, ROOMMATE, GUEST, HP1000, powerMap, Pushover, THINKINGCLEANER, Wunderground | FHEM-Befehl: msg

FHEM 5.9dev auf Intel NUC mit Proxmox VE
Homematic via HMCCU, Hue Color Bulbs
ONKYO TX-NR626, Philips 55" PFL8008S, Sonos 1xS1, 1xS3, 2xS5

Offline l2r

  • Full Member
  • ***
  • Beiträge: 489
Antw:Modul für Pushover
« Antwort #597 am: 20 März 2017, 20:47:15 »
ist das dann auch über den msg-Befehl bedienbar oder muss es über Optionen gelöst werden?

gruß Michael
Wissen ist Macht.
Ich weiß nix.
Macht nix.

Offline Loredo

  • Developer
  • Hero Member
  • ****
  • Beiträge: 2808
  • ~ Challenging Innovation ~
Antw:Modul für Pushover
« Antwort #598 am: 20 März 2017, 23:14:58 »
Ja wird über die Advanced Options unterstützt.
FHEM-Module: ENIGMA2, GEOFANCY, ONKYO_AVR, PHTV, RESIDENTS, ROOMMATE, GUEST, HP1000, powerMap, Pushover, THINKINGCLEANER, Wunderground | FHEM-Befehl: msg

FHEM 5.9dev auf Intel NUC mit Proxmox VE
Homematic via HMCCU, Hue Color Bulbs
ONKYO TX-NR626, Philips 55" PFL8008S, Sonos 1xS1, 1xS3, 2xS5

Offline l2r

  • Full Member
  • ***
  • Beiträge: 489
Antw:Modul für Pushover
« Antwort #599 am: 20 März 2017, 23:19:38 »
Ok, danke schau ich mir dann morgen mal an.

Gruß Michael


Gesendet von iPhone mit Tapatalk Pro
Wissen ist Macht.
Ich weiß nix.
Macht nix.