Autor Thema: RFXtrx 433E nicht erkannt  (Gelesen 2101 mal)

DeepB

  • Gast
RFXtrx 433E nicht erkannt
« am: 01 Oktober 2016, 23:07:00 »
Hallo,

ich habe den rfxtrx-433E, und habe diesen an fhem angeschlossen. "usb create" ergibt folgendes:

2016.10.01 23:04:35 1: usb create starting
2016.10.01 23:04:36 3: Probing TCM_ESP3 device /dev/ttyUSB0
2016.10.01 23:04:36 3: Probing TCM_ESP2 device /dev/ttyUSB0
2016.10.01 23:04:36 3: Probing FHZ device /dev/ttyUSB0
2016.10.01 23:04:36 3: Probing TRX device /dev/ttyUSB0
2016.10.01 23:04:37 3: Probing ZWDongle device /dev/ttyUSB0
2016.10.01 23:04:37 3: Probing FRM device /dev/ttyUSB0
2016.10.01 23:04:50 1: usb create end

Dann habe ich den rfxtrx an einem windows pc angeschlossen, die firmware geupdatet, mit rfxmanager getestet, wieder an fhem angeschlossen, leider mit dem gleichen ergebnis.
Mache ich etwas falsch?

vielen Dank
Daniel

EDIT: das Z-wave dongle wird aber erkannt
« Letzte Änderung: 01 Oktober 2016, 23:13:11 von DeepB »

Offline KernSani

  • Moderator
  • Hero Member
  • ***
  • Beiträge: 3535
Antw:RFXtrx 433E nicht erkannt
« Antwort #1 am: 01 Oktober 2016, 23:19:52 »
Eigentlich sollte der RFXTRX per autocreate erkannt werden. Hängt er direkt an deinem Server oder über USB-Hub?
Du kannst auch mal folgendes probieren:
define TRX_0 TRX /dev/ttyUSB0@38400
RasPi: RFXTRX, HM, zigbee2mqtt, mySensors, JeeLink, miLight, squeezbox, Alexa, Siri, ...

DeepB

  • Gast
Antw:RFXtrx 433E nicht erkannt
« Antwort #2 am: 01 Oktober 2016, 23:48:37 »
016.10.01 23:47:12 3: Opening TRX_0 device /dev/ttyUSB0
2016.10.01 23:47:12 3: Setting TRX_0 serial parameters to 38400,8,N,1
2016.10.01 23:47:12 3: TRX_0 device opened
2016.10.01 23:47:12 1: TRX: Initialization Error hexline='140100010253060800250001021c03000000000000', expected 0d0100......................
2016.10.01 23:47:12 1: PERL WARNING: Use of uninitialized value $char in concatenation (.) or string at ./FHEM/45_TRX.pm line 245.
2016.10.01 23:47:12 1: Cannot init /dev/ttyUSB0, ignoring it (TRX_0)

DeepB

  • Gast
Antw:RFXtrx 433E nicht erkannt
« Antwort #3 am: 02 Oktober 2016, 16:52:28 »
es funktioniert mit
define TRX_0 TRX /dev/ttyUSB0@38400 noinit

 

decade-submarginal