Autor Thema: Fehler im Weekprofile  (Gelesen 8392 mal)

Offline janvonnebenan

  • New Member
  • *
  • Beiträge: 8
Antw:Fehler im Weekprofile
« Antwort #30 am: 25 Februar 2017, 08:19:52 »
Moin Justme,

ja das ist geplant. Allerdings habe ich gerade extrem wenig Zeit. Hast du den Patch bei dir auch erfolgreich ausprobiert. Das würde mich ja brennend interessieren.

Patchen geht übrigens so:
sudo patch -p1 /opt/fhem/FHEM/10_MAX.pm < ./fix_weekprofile_bug.patch

Das muss man dann aber nach jedem Update erneut durchführen.

Herzliche Grüße
Jan
« Letzte Änderung: 28 Februar 2017, 18:09:11 von janvonnebenan »

Offline Shardan

  • New Member
  • *
  • Beiträge: 41
Antw:Fehler im Weekprofile
« Antwort #31 am: 25 Februar 2017, 18:25:47 »
Hallo zusammen,

bei mir tritt ebenfalls ein 17°-Problem auf.
Aufgefallen ist mir das bei dem Versuch, die Heizkörperthermostate per "Presence" zu steuern.

set MAX_xxxxxx desiredTemperature eco"funktioniert einwandfrei, wenn presence auf "absent" geht.

Umgekehrt geht das nicht:
set MAX_xxxxxx desiredTemperature autosteuert einen der Thermostate wieder ins Wochenprogramm, alle anderen gehen auf 17°....

Kann man das irgendwie beheben?

Shardan


Edit:
Ich hab den Patch grade eingespielt, der hilft leider nicht weiter.
Möglicherweise ein Problem einer bestimmten Firmware-Version?
Der eine Tehrmostat, der funktioniert, ist neuere als die anderen.
S.
« Letzte Änderung: 25 Februar 2017, 18:47:49 von Shardan »
FHEM auf RPi3 - CUNX mit Pigator, 433 + 868 MHZ.
MAX!-HK-Ventile, ESP8266-Sensoren und -Aktoren
Schaltsteckdosen IT / NetIO230B / Netio4

Offline justme75

  • New Member
  • *
  • Beiträge: 13
Antw:Fehler im Weekprofile
« Antwort #32 am: 01 März 2017, 16:18:52 »
Moin moin,

Moin Justme,

ja das ist geplant. Allerdings habe ich gerade extrem wenig Zeit. Hast du den Patch bei dir auch erfolgreich ausprobiert. Das würde mich ja brennend interessieren.

Patchen geht übrigens so:
sudo patch -p1 /opt/fhem/FHEM/10_MAX.pm < ./fix_weekprofile_bug.patch

Das muss man dann aber nach jedem Update erneut durchführen.

Herzliche Grüße
Jan

Ich hab es bisher noch nicht bei mir ausprobiert, weil ich im Moment nur am Wochenende zu Hause bin (Grund für die Einrichtung von FHEM) und nach dem letzten Update offenbar ein Problem mit weekprofile habe, was ich gerade versuche zu debuggen - das hätte ich gerne zuerst gelöst.
Wie man patcht weiß ich, danke :-) (zumindest unter unixoidem OS - hier hätte ich mit Windows mangels jeglicher Erfahrung seit Win98SE größere Probleme).

So wie das klingt wärst Du ja über eine größere Testtiefe nicht unglücklich - dann werd ich mal versuchen, ob ich da am WE weiterkomme und den Patch einbauen, wenn alles andere läuft.

lg,
justme
RaspPi 2, Raspbian Jessie mit SCC868, 2x MAX WT+, 2x MAX HT+, 3x MAX HT, 4x MAX FK

Offline justme75

  • New Member
  • *
  • Beiträge: 13
Antw:Fehler im Weekprofile
« Antwort #33 am: 18 März 2017, 12:42:53 »
Moin moin,

Moin Justme,

ja das ist geplant. Allerdings habe ich gerade extrem wenig Zeit. Hast du den Patch bei dir auch erfolgreich ausprobiert. Das würde mich ja brennend interessieren.


so, seit gestern läuft ein gepatchtes 10_MAX.pm auch bei mir - funktionieren tut es schon mal.
Was mir aufgefallen ist: ich verwende weekprofile mit useTopics=1, übermittle also im Normalfall neue/geänderte Einstellungen mittel restore_topic an die Thermostate.
Nachdem ich gestern fhem mit dem gepatchten MAX-Modul neu gestartet habe habe ich die bisher in allen Profilen an allen Tagen liegende 23:55-Einstellung entfernt und die geänderten Profile an die Thermostate geschickt - dabei zeigten meine beiden Wandthermostate das äußerst merkwürdige Verhalten, daß trotz des lt. Reading korrekt übermittelten Profils diese auf eine nirgends in ihrem Profil vorhandene tiefere Temperatur (einer auf 8°C und der andere auf 12°C)  als Sollwert sprangen (und auch die jeweils verbundenen Heizkörper entsprechend abregelten) - wieder auf den korrekten Wert ließen sie sich setzen, indem ich einmal die Modes von Auto über Man und Urlaub zurück auf Auto durchgetoggelt habe. Die beiden Räume, in denen nur Heizkörperthermostate verbaut sind zeigten ein derartiges Verhalten nicht, und mit dem originalem MAX-Code habe ich sowas auch noch nie gesehen. Ich werd das Ganze erstmal etwas weiter beobachten...

lg, justme
RaspPi 2, Raspbian Jessie mit SCC868, 2x MAX WT+, 2x MAX HT+, 3x MAX HT, 4x MAX FK