Autor Thema: Fehler im Weekprofile  (Gelesen 20886 mal)

Offline D3ltorohd

  • Full Member
  • ***
  • Beiträge: 300
Antw:Fehler im Weekprofile
« Antwort #45 am: 01 November 2019, 10:26:58 »
Habe den Patch eingecheckt.
Sorry fuer die spaete Reaktion, ich verdraenge immer wieder erfolgreich, dass ich kommissarisch fuer das Modul zustaendig bin.
Falls jemand das Modul uebernehmen will, bitte melden.

Somit sollte das Problem behoben sein und man muss am Ende des Tages keine Schaltzeit um 23:55 mehr mit einbauen ?
Base : Intel NUC Debian 9, FHEM aktuell || Zigbee (Coordinator FW Z-Stack 1.2 default Koenkk) || MaxCUL (culfw V 1.67 nanoCUL868) || SIGNALduino 433MHz (V 3.3.2.1-rc8 ) || Shelly s1

Offline dennisk

  • Newbie
  • Beiträge: 2
Antw:Fehler im Weekprofile
« Antwort #46 am: 01 November 2019, 17:57:47 »
@rudolfkoenig vielen Dank!

Bei meinen Thermostaten kann ich mit dem Patch jedenfalls keine Probleme feststellen. Und ich habe keine extra Schaltzeitpunkte kurz vor Mitternacht eingerichtet.
Gefällt mir Gefällt mir x 1 Liste anzeigen

Offline mickym

  • New Member
  • *
  • Beiträge: 3
Antw:Fehler im Weekprofile
« Antwort #47 am: 05 November 2019, 16:32:29 »
So ich melde nun auch mal Interesse an dem Patch an.

Der Thread ist zwar schon ewig alt und ich habe aber auch das 17°C Problem. Ich bin erst gar nicht auf die Idee gekommen, dass dieses Problem immer noch existiert.

Trotz Patch mal zur Info - wie ich mir bislang geholfen habe:
Ausgangszustand:
Ich habe die Profile über FHEM gesetzt - dann 17°C Problem, wenn man auf AUTO umschaltet - egal welche Temperatur im Wochenprofil aktiv war.
In der MAX-Software wurden korrekt die Wochenprofile angezeigt, die über FHEM gesetzt wurden, aber beim Schalten auf AUTO egal, ob am Gerät direkt oder auch der MAX Software - AUTO ist immer 17°C.
Habe dann das Gerät mit der MAX Software aus dem CUBE gelöscht - und dann wieder mit dem CUBE gekoppelt. Beim erneuten Verbinden des Wandthermostats oder des Heizkörperthermostats wurden dann die korrekten Profile übernommen (ohne dass ich noch eine Zeit kurz vor Mitternacht eingetragen habe).

« Letzte Änderung: 05 November 2019, 22:43:39 von mickym »

Offline Johnnyflash

  • Jr. Member
  • **
  • Beiträge: 80
Antw:Fehler im Weekprofile
« Antwort #48 am: 06 November 2019, 08:45:57 »
Hallo,
ich habe auch noch einige Änderungen an der 10_MAX.pm vollzogen. Grund dafür war, dass gewissen Daten (WeekProfile, Boost-Dauer, Boost-ValvePosition, etc) in einem Raum sowohl an das Wandthermostat als auch an die Ventile geschickt werden müssen. Dies wird über die GroupID gelöst. Wer möchte, kann das ja mal mit angehängter Version testen, bevor der Patch eingecheckt wird.
To Do ist allerdings noch, dass die entsprechenden Readings bei allen Geräten mit gleicher GroupID geändert werden müssen. Weiterhin ist das Problem noch nicht gelöst, dass die GroupID regelmäßig auf 0 zurückgesetzt wird.

Offline mickym

  • New Member
  • *
  • Beiträge: 3
Antw:Fehler im Weekprofile
« Antwort #49 am: 06 November 2019, 10:24:08 »
Die group-ID bleibt bei mir erhalten - aber ich habe auch noch zusätzlich die Verbindung zu ELV Portal offen - da mir der Cube sonst die Konfig irgendwie vergisst. Mit der Verbindung bleibt aber die group ID erhalten. Ich habe bis jetzt halt die weekProfiles immer an den Wandthermostat und an die Heizkörperthermostate geschickt.

Der Patch scheint aber Fehler bei der Definition dieser Group-ID zu haben. Ich schick mal das LOG mit. Ich hoffe, ich hab mir sonst nichts zerschossen. ;)

Nachtrag:
Ich habe mir bislang bei Änderungen am Wochenprofil oder ähnlichen Einstellungen angewöhnt, dass in der Regel in einem Raum immer an den Wandthermostat und an den Heizkörperthermostat zu schicken, damit keine Inkonsistenzen entstehen.
Ohne es belegen zu können, habe ich generell den Verdacht, dass auf den MAX-Portalen irgendwelche Konfigeinstellungen gespeichert werden. Ich hatte das Portal mal für ein paar Wochen abgeklemmt, da ich dachte, dass ich das ja nun nicht mehr brauche, das lief auch alles, bis ich den Cube mal für mehrere Stunden stromlos machen musste. Danach musste ich jedes Gerät neu anlernen. FHEM hat zwar eine Verbindung zum CUBE aufgebaut, konnte aber auch keine Geräte mehr finden.
« Letzte Änderung: 06 November 2019, 13:15:24 von mickym »

Offline Johnnyflash

  • Jr. Member
  • **
  • Beiträge: 80
Antw:Fehler im Weekprofile
« Antwort #50 am: 06 November 2019, 13:36:27 »
Der Patch scheint aber Fehler bei der Definition dieser Group-ID zu haben. Ich schick mal das LOG mit. Ich hoffe, ich hab mir sonst nichts zerschossen. ;)
Mein Fehler, hatte ein paar Änderungen rausgenommen, weil sie nur zum testen drin waren. Dabei habe ich ein paar Zeilen zu viel entfernt. Hier die korrigierte Variante.
Ich habe mir bislang bei Änderungen am Wochenprofil oder ähnlichen Einstellungen angewöhnt, dass in der Regel in einem Raum immer an den Wandthermostat und an den Heizkörperthermostat zu schicken, damit keine Inkonsistenzen entstehen.
Genau das möchte ich vermeiden, ich komme damit schnell an die Credit-Grenze in meiner Installation (Habe 16 Heizkörperthermostate und 14 Wandthermostate im Einsatz). Die Original Max Software im Cube arbeitet höchstwahrscheinlich genau so, dass über die GroupID die entsprechenden Parameter an alle Komponenten eines Raumes geschickt werden. Wollte das immer mal analysieren, habe aber keine Cube hier.

Offline Johnnyflash

  • Jr. Member
  • **
  • Beiträge: 80
Antw:Fehler im Weekprofile
« Antwort #51 am: 06 November 2019, 17:54:24 »
Irgendwas scheint da mit meiner Änderung aber noch nicht ganz zu stimmen. Habe mir heute mal einen cube geliehen, der Cube schickt die Broadcast Nachrichten pro Raum mit dem Flag 05, nicht 04. Hat eigentlich irgendjemand eine Protokollbeschreibung zum MAX! Funkprotokoll? Ich finde nur was zum LAN Protokoll des Cubes.

 

decade-submarginal