Autor Thema: Neues Modul: Text2Speech  (Gelesen 131137 mal)

Offline martin2day

  • Full Member
  • ***
  • Beiträge: 119
Antw:Neues Modul: Text2Speech
« Antwort #750 am: 19 März 2017, 19:36:19 »
Hallo,

nein. Entweder oder... MPD ist derzeit deaktiviert...

Martin

Offline Otto123

  • Hero Member
  • *****
  • Beiträge: 7088
    • Otto's Technik Blog
Antw:Neues Modul: Text2Speech
« Antwort #751 am: 19 März 2017, 19:38:32 »
Was ist wenn Du /usr/bin/mplayer -ao alsa:device=hw=0.0  -nolirc -noconsolecontrols cache/e73c942070af13045c7ee77855c224a3.mp3Auf Kommandozeile (Terminal) abspielst?

Geht sowas "/usr/bin/mplayer -ao alsa:device=hw=0.0  -nolirc -noconsolecontrols <irgendeine mp3 datei>"  aus der FHEM Kommandozeile?

Gruß Otto
Viele Grüße aus Leipzig
RaspberryPi,HMLAN,HMUART,Homematic,Fritz!Box 7490,Sonos,ET9200,Arduino nano,ESP8266

Offline martin2day

  • Full Member
  • ***
  • Beiträge: 119
Antw:Neues Modul: Text2Speech
« Antwort #752 am: 19 März 2017, 19:44:18 »
Hallo Otto,

da erhalte ich eine Menge Fehler... :-)
pi@Bad_OG:~ $ /usr/bin/mplayer -ao alsa:device=hw=0.0  -nolirc -noconsolecontrols cache/e73c942070af13045c7ee77855c224a3.mp3
MPlayer2 2.0-728-g2c378c7-4+b1 (C) 2000-2012 MPlayer Team
Cannot open file '/home/pi/.mplayer/input.conf': No such file or directory
Failed to open /home/pi/.mplayer/input.conf.
Cannot open file '/etc/mplayer/input.conf': No such file or directory
Failed to open /etc/mplayer/input.conf.

Playing cache/e73c942070af13045c7ee77855c224a3.mp3.
Cannot open file 'cache/e73c942070af13045c7ee77855c224a3.mp3': No such file or directory
Failed to open cache/e73c942070af13045c7ee77855c224a3.mp3.


Exiting... (End of file)

Martin

Offline Wzut

  • Developer
  • Hero Member
  • ****
  • Beiträge: 1584
Antw:Neues Modul: Text2Speech
« Antwort #753 am: 19 März 2017, 19:49:32 »
ersetze cache/ durch den vollen Pfad , also vermutlich
/opt/fhem/cache/e73c942070af13045c7ee77855c224a3.mp3
Maintainer der Module: MPD, EDIPLUG, UbiquitiMP, UbiquitiOut, SIP

Offline martin2day

  • Full Member
  • ***
  • Beiträge: 119
Antw:Neues Modul: Text2Speech
« Antwort #754 am: 19 März 2017, 19:54:26 »
Hallo,

mein Fehler, sorry :-)
Jetzt funktioniert der Befehl, aber es passiert nichts. Es knackt immer noch wie vorher ...  im Terminal wird der Vorschritt angezeigt.
Scheint wohl ein mplayer Problem zu sein.

/usr/bin/mplayer -ao alsa:device=hw=0.0  -nolirc -noconsolecontrols /opt/fhem/cache/1a736ed3824cafda02d407ef65c0af26.mp3
MPlayer2 2.0-728-g2c378c7-4+b1 (C) 2000-2012 MPlayer Team
Cannot open file '/home/pi/.mplayer/input.conf': No such file or directory
Failed to open /home/pi/.mplayer/input.conf.
Cannot open file '/etc/mplayer/input.conf': No such file or directory
Failed to open /etc/mplayer/input.conf.

Playing /opt/fhem/cache/1a736ed3824cafda02d407ef65c0af26.mp3.
Detected file format: MP2/3 (MPEG audio layer 2/3) (libavformat)
[mp3 @ 0x75bd85b8]Estimating duration from bitrate, this may be inaccurate
[lavf] stream 0: audio (mp3), -aid 0
Load subtitles in /opt/fhem/cache/
Selected audio codec: MPEG 1.0/2.0/2.5 layers I, II, III [mpg123]
AUDIO: 24000 Hz, 2 ch, s16le, 32.0 kbit/4.17% (ratio: 4000->96000)
AO: [alsa] 22050Hz 2ch s16le (2 bytes per sample)
Video: no video
Starting playback...
A:   1.3 (01.2) of 1.3 (01.3)  1.1%


Exiting... (End of file)

Martin
« Letzte Änderung: 19 März 2017, 19:56:29 von martin2day »

Offline Otto123

  • Hero Member
  • *****
  • Beiträge: 7088
    • Otto's Technik Blog
Antw:Neues Modul: Text2Speech
« Antwort #755 am: 19 März 2017, 20:02:36 »
mir fällt gerade auf, ändere mal die DEF im TTS_BadOG  auf default anstatt hw=0.0
Viele Grüße aus Leipzig
RaspberryPi,HMLAN,HMUART,Homematic,Fritz!Box 7490,Sonos,ET9200,Arduino nano,ESP8266

Offline martin2day

  • Full Member
  • ***
  • Beiträge: 119
Antw:Neues Modul: Text2Speech
« Antwort #756 am: 19 März 2017, 20:09:21 »
Otto,
aber wenn es direkt vom Terminal über mplayer nicht geht, dann wird das nicht viel helfen... :-)
Auf dem funktionierendem System steht auch hw=0.0...

Martin

Offline Otto123

  • Hero Member
  • *****
  • Beiträge: 7088
    • Otto's Technik Blog
Antw:Neues Modul: Text2Speech
« Antwort #757 am: 19 März 2017, 20:10:21 »
Dann versuche
mplayer /opt/fhem/cache/1a736ed3824cafda02d407ef65c0af26.mp3
Ich denke hw=0.0 ist bei Dir nicht der default Ausgang.
Viele Grüße aus Leipzig
RaspberryPi,HMLAN,HMUART,Homematic,Fritz!Box 7490,Sonos,ET9200,Arduino nano,ESP8266

Offline martin2day

  • Full Member
  • ***
  • Beiträge: 119
Antw:Neues Modul: Text2Speech
« Antwort #758 am: 19 März 2017, 20:15:36 »
Hallo Otto,

gleiche Ausgabe aus den Lautsprechern wie bei den anderen Befehlen...
mplayer /opt/fhem/cache/1a736ed3824cafda02d407ef65c0af26.mp3
MPlayer2 2.0-728-g2c378c7-4+b1 (C) 2000-2012 MPlayer Team
Cannot open file '/home/pi/.mplayer/input.conf': No such file or directory
Failed to open /home/pi/.mplayer/input.conf.
Cannot open file '/etc/mplayer/input.conf': No such file or directory
Failed to open /etc/mplayer/input.conf.

Playing /opt/fhem/cache/1a736ed3824cafda02d407ef65c0af26.mp3.
Detected file format: MP2/3 (MPEG audio layer 2/3) (libavformat)
[mp3 @ 0x75bb65b8]Estimating duration from bitrate, this may be inaccurate
[lavf] stream 0: audio (mp3), -aid 0
Load subtitles in /opt/fhem/cache/
Selected audio codec: MPEG 1.0/2.0/2.5 layers I, II, III [mpg123]
AUDIO: 24000 Hz, 2 ch, s16le, 32.0 kbit/4.17% (ratio: 4000->96000)
AO: [pulse] Init failed: Connection refused
AO: [alsa] 22050Hz 2ch s16le (2 bytes per sample)
Video: no video
Starting playback...
A:   1.3 (01.2) of 1.3 (01.3)  1.1%


Exiting... (End of file)

Aber aplay-l sagt doch:
aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: sndrpihifiberry [snd_rpi_hifiberry_amp], device 0: HifiBerry AMP HiFi tas5713-hifi-0 []
  Subdevices: 1/1
  Subdevice #0: subdevice #0


Martin

Offline Otto123

  • Hero Member
  • *****
  • Beiträge: 7088
    • Otto's Technik Blog
Antw:Neues Modul: Text2Speech
« Antwort #759 am: 19 März 2017, 20:54:37 »
Hallo Martin,

da bin ich jetzt langsam mit meinen Ideen am Ende.

Ich mag mplayer sowieso nicht, wenn Du willst kannst Du mal play versuchen.
Installation sudo apt-get install sox libsox-fmt-allDann mal einfach play <mp3 Datei>

Gruß Otto
Viele Grüße aus Leipzig
RaspberryPi,HMLAN,HMUART,Homematic,Fritz!Box 7490,Sonos,ET9200,Arduino nano,ESP8266

Offline martin2day

  • Full Member
  • ***
  • Beiträge: 119
Antw:Neues Modul: Text2Speech
« Antwort #760 am: 20 März 2017, 08:48:50 »
Guten Morgen Otto,

damit bekomme ich ebenfalls einen Fehler.
pi@Bad_OG:~ $ play /opt/fhem/cache/1a736ed3824cafda02d407ef65c0af26.mp3
play FAIL formats: can't open output file `default': snd_pcm_hw_params error: Invalid argument
Ich ahne, dass es etwas mit der HifiBerry AMP zu tuen hat...
Nach dieser Anleitung habe ich es installiert: https://www.hifiberry.com/build/documentation/hifiberry-software-configuration/

Gruß Martin

Offline Otto123

  • Hero Member
  • *****
  • Beiträge: 7088
    • Otto's Technik Blog
Antw:Neues Modul: Text2Speech
« Antwort #761 am: 20 März 2017, 09:39:51 »
Moin Martin,

das vermute ich auch. Leider habe ich bisher die Soundsysteme von Linux/raspbian nicht wirklich verstanden, obwohl ich da schon viel versucht habe (Bluetooth, alsa, pulse-audio).
Am Ende war mir alles was über die onboard Klinke hinausging zu kompliziert / nicht wirklich begreifbar. Es hat immer mal was funktioniert, aber warum?
Tut mir leid, da kann ich nicht weiterhelfen.

Gruß Otto
Viele Grüße aus Leipzig
RaspberryPi,HMLAN,HMUART,Homematic,Fritz!Box 7490,Sonos,ET9200,Arduino nano,ESP8266

Offline martin2day

  • Full Member
  • ***
  • Beiträge: 119
Antw:Neues Modul: Text2Speech
« Antwort #762 am: 20 März 2017, 14:11:28 »
Hallo Otto,

da ich gelesen habe, dass es eventuell Probleme mit MP3 und MPLAYER geben kann, habe ich auch mal eine WAV Datei getestet. Leider auch hier kein positives Ergebnis.

Ich teste weiter.

Martin

Offline martin2day

  • Full Member
  • ***
  • Beiträge: 119
Antw:Neues Modul: Text2Speech
« Antwort #763 am: 20 März 2017, 21:28:48 »
Guten Abend,

kurze Zwischenmeldung von mir:
Ich habe kurzer Hand die 3,5mm Klinke wieder aktiviert.
Nun kann ich mit dem Befehl /usr/bin/mplayer -ao alsa:device=hw=0.0 -nolirc -noconsolecontrols /opt/fhem/cache/e73c942070af13045c7ee77855c224a3.mp3die Ansage über die Klinke hören...

Aber, mit: /usr/bin/mplayer -ao alsa:device=hw=1.0 -nolirc -noconsolecontrols /opt/fhem/cache/e73c942070af13045c7ee77855c224a3.mp3höre ich wieder nur ein Rauschen auf den Boxen...
Ich werde das Gefühl nicht los, dass es ein Problem mit dem Hifiberry AMP+ gibt.... HifiBerry direkt sagt nur es könnte eine defekte Speicherkarte sein.... tztztztz

Gruß Martin

Offline martin2day

  • Full Member
  • ***
  • Beiträge: 119
Antw:Neues Modul: Text2Speech
« Antwort #764 am: 22 März 2017, 21:16:27 »
Guten Abend,

es liegt wohl an der Abtastrate (SampleRate) Ich habe mal eine andere MP3 abgespielt mit 44,1kHz die funktioniert super.
Text2Speech gibt 24kHz aus... mittels TTS_Quality habe ich versucht auf 44,1kHz zu verstellen, aber es kommt dennoch eine MP3 mit 24kHz heraus...
Ich denke das macht MP3Wrap...?

Was kann ich ändern? :-)

Martin

 

decade-submarginal