FHEM - Hausautomations-Systeme > Unterstützende Dienste

Neues Modul: 70_Jabber.pm

<< < (58/61) > >>

acw81:
UPDATE: mittlerweile läuft der Jabberclient unter FHEM nun wieder mit den im letzten Beitrag genannten Versionen. Leider habe ich aber immer noch das Problem das ein Gajim Client FHEM zum Absturz bringt.


--- Code: ---Not a CODE reference at /usr/share/perl5/Net/XMPP/Protocol.pm line 3537.

--- Ende Code ---

Devender:
Ich hab die besagte Zeile, bzw. die Schleife auskommentiert in der Protocol.pm
Seit langer Zeit keine Probleme damit gehabt

creativeHQ:
Vielen Dank!

nach ca. 20 Abstürzen und diversen versuchen, alle möglichen Felermeldungen nachzugehen bringt mich das deutlich weiter. Ich habe auf jeden Fall nun endlich einen Connect zum meinem Server... Wenn es keine Probleme verursacht, dann bleibt das so.

Besser als alles bisher...

Grüße,

Niko

Sir Volvic:
Da ich mein fhem Zuhause in einen lxc-Container umgezogen habe, musste ich die Pakete entsprechend des Wikis neu im Container Debian10 installieren.

Ich hielt mich zum Großteil an den Wiki-Eintrag: https://wiki.fhem.de/wiki/Jabber

Allerdings liegt das Paket libnet-xmpp-perl_1.02-3_all.deb mittlerweile im debian-archive. Der wget Aufruf muss folglich:

--- Code: ---wget http://ftp.de.debian.org/debian-archive/debian/pool/main/libn/libnet-xmpp-perl/libnet-xmpp-perl_1.02-3_all.deb
--- Ende Code ---
lauten.


--- Zitat von: acw81 am 16 Oktober 2019, 10:24:04 ---...Wenn ich mit APT die Lib installiere, werden als Abhängigkeiten aber wieder Stream und XMPP mit installiert. Ich drehe mich also im Moment irgendwie im Kreis. Hat dieses Problem schon jemand von euch gelöst?

--- Ende Zitat ---
Das passierte mir auch.
Wenn man libnet-jabber-perl nach

--- Code: ---dpkg -i libxml-stream-perl_1.23-2_all.deb
dpkg -i libnet-xmpp-perl_1.02-3_all.deb
--- Ende Code ---
installiert, passiert das nicht. Dann hat er die Abhängigkeiten erfüllt.

Kurz zusammengefasst, für Debian10:

--- Code: ---apt-get remove libnet-xmpp-perl
apt-get remove libxml-stream-perl
apt-get remove libotr5 libotr5-dev

apt-get install build-essential
wget http://ftp.de.debian.org/debian-archive/debian/pool/main/libn/libnet-xmpp-perl/libnet-xmpp-perl_1.02-3_all.deb
wget http://ftp.de.debian.org/debian/pool/main/libx/libxml-stream-perl/libxml-stream-perl_1.23-2_all.deb
dpkg -i libxml-stream-perl_1.23-2_all.deb
dpkg -i libnet-xmpp-perl_1.02-3_all.deb
apt-get install libnet-jabber-perl
--- Ende Code ---

denis.robel:
Hallo,

ich hab seid kurzem keine Verbindung mehr zum Server.
ich sehe nur noch bei CONNINFO Jabber connect error (Connection refused)

Auf der Server Seite (Prosody) sehe ich in den log files gar nichts.
Die Firewall und das Netzwerk hab ich schon geprüft und andere XMPP Cliens könne sich mit meinem Server verbinden.
Wo kann ich noch ansetzen?

VG Denis

Navigation

[0] Themen-Index

[#] Nächste Seite

[*] Vorherige Sete

Zur normalen Ansicht wechseln