FHEM - Hausautomations-Systeme > Unterstützende Dienste

Neues Modul: 70_Jabber.pm

<< < (2/60) > >>

BioS:
Hi,

ich hab den Fehler mit SSL gefunden.
Im ejabberd gibt es 4 verschiedene Möglichkeiten SSL bzw. TLS zu aktivieren ;)

Du hast in deiner config vermutlich "tls" drin, ich arbeite mit "starttls", da die "tls" Option anscheinend im xmpp deprecated ist.
Nun ist wohl unter dem ejabberd tls == ssl und starttls == tls, sehr witzig..

Egal wie es nun geconft ist, ich habe das Modul im 1. Post aktualisiert, jetzt hat man hinten 2 Optionen, einmal <tls> und <ssl>

Du kannst dann ja mal probieren ob es besser geht wenn du die tls option auf 0 setzt und die ssl option auf 1
So sieht das neue define aus:

--- Code: ---define <name> Jabber <server> <port> <username> <password> <tls> <ssl>
--- Ende Code ---

Grüße,
BioS

mrmarbury:
Hi,

ja, habe tls in der config. aber auch starttls. Ich supporte sowieso Beides - auf unterschiedlichen Ports. Es gibt doch tatsächlich Clients, die noch nie TLS gehört haben. Aber ich habe auch beide Ports ausprobiert. Ich werde aber bei nächster Gelegenheit mal Dein aktualisiertes Modul ausprobieren und berichten.

Der Server läuft schon seit Jahren und ist auch schon mehrfach umgezogen ( was mit ejabberd absolut keinen Spaß macht. Dafür ist er sehr stabil und läuft und läuft) und recht gut besucht.  Aber vll hilft es ja Abschätzungen für das Modul zu machen, wenn Du auch andere Configs gesehen hast? Ist aber recht Standard und übersichtlich.
 
Die Config, nur zur info und nicht relevante Teile durch Platzhalter ersetzt oder weggelassen (ja, auch der cert-path ;) ):


--- Code: ---
...

{listen,
 [
  %%
  %% TLS
  %%
  {5222, ejabberd_c2s, [

                        {certfile, "/path/to/my/cert"}, starttls,
                        {access, c2s},
                        {shaper, c2s_shaper},
                        {max_stanza_size, 65536}
                       ]},

  %%
  %% Legacy SSL
  %%
  {5223, ejabberd_c2s, [

                        {access, c2s},
                        {shaper, c2s_shaper},
                        {certfile, "/path/to/cert"}, tls,
                        {max_stanza_size, 65536}
                       ]},

  %%
  %% MEH - Never route this to the outside world!
  %%
  {5224, ejabberd_c2s, [
                        {access, c2s},
                        {shaper, c2s_shaper},
                        {max_stanza_size, 65536}
                       ]},

... weitere ports, aber für Interconnectivity zu anderen Servern ...
]}

--- Ende Code ---

Cheers,
Stefan

martinschm:
Hi BioS,

hört sich sehr interessant an.

Ich brauche dafür nicht zwangsläufig einen eigenen Jabber Server, oder?

Wie kann man gewährleisten, dass der FHEM Jabber-Account keinen Input von anderen annimmt?
Wenn der Useraccount nicht bekannt ist, hilft das etwas aber ein wirklicher Schutz ist es ja auch nicht.

ciao
Martin

BioS:
Hi Martin,

Du brauchst nicht zwangsläufig einen eigenen jabber Server.
Es reicht wenn du einen Account bei irgendeinem free Anbieter erstellst.

Eine Liste mit free Anbietern findest du auf http://jabber.org

Das Plugin hat eine Option in der man einstellen kann von wem der FHEM Server Nachrichten akzeptiert.

D.h. dort kannst du deine jabber Adresse eintragen und dann kannst nur du deinem Server was schreiben :)

Soweit ich weis sind diese Adressen auch nicht fake-bar, da ein jabber Server immer nur mit seinen eigenen usern arbeitet und sich gegenüber anderen Servern authentifiziert im dns wie auch mit einem ssl Zertifikat.

Also nicht so wie bei EMails bei denen ein Server Mails von anderen Accounts weiterleiten kann..

Grüße,
BioS

Gesendet von meinem XT910 mit Tapatalk

martinschm:
Ok cool. Danke für die schnelle Antwort.

Navigation

[0] Themen-Index

[#] Nächste Seite

[*] Vorherige Sete

Zur normalen Ansicht wechseln