Autor Thema: Neuartiges 1-Wire Interface  (Gelesen 123668 mal)

Offline UweH

  • Hero Member
  • *****
  • Beiträge: 1492
  • Manchmal hilft auch kein Popcorn
Antw:Neuartiges 1-Wire Interface
« Antwort #435 am: 12 November 2017, 18:11:29 »
Wenn nach einem FHEM-Update das WLAN-Modul nicht mehr funktioniert, ist in der Regel nicht das WLAN-Modul Schuld.
Wie aus diesem und dem anderen Thread, in dem Du diese Fragen gestellt hast, hervorgeht, hast Du ziemlich massiv die OWX-Module hin- und her kopiert und offenbar ja auch was mit OWX_ASYNC vermischt. Hast Du (was man ja haben sollte) ein Backup Deiner FHEM-Instanz vor dem bewussten Update? Mal eingespielt? Funktioniert der Kram dann wieder?

Gruß
Uwe

EDIT: Noch was. In einem der anderen Beiträge sprichst Du von einem USB-Interface:
Zitat
Das Gateway habe ich definiert
define 1W_USB OWX /dev/ttyUSB1

Funktionieren Deine Sensoren damit?
« Letzte Änderung: 12 November 2017, 18:23:08 von UweH »
*bewertungshäkchenblödsinnverweigerer*
||##div.moderatorbar in ABP wirkt Wunder||

Offline Jewe

  • Full Member
  • ***
  • Beiträge: 359
Antw:Neuartiges 1-Wire Interface
« Antwort #436 am: 12 November 2017, 18:18:30 »
Ja klar, und das funktioniert eben nicht.
Deshalb die Vermutung, daß die Busmaster nun nicht mehr funktioniern.

Und das hin und herkopieren der Dateien habe ich gemacht, weil owx_async nach dem Update nicht mehr funktioniert hat und nach dem Update im Oktober das ich wegen einem anderen Modul gemacht hatte ging wieder nix mehr. Naja den Rest kann man hier ja lesen...

Die Dateien sollte aber mit dem Update und alles auf dem aktuellen Stand sein.

Gesendet von meinem F5121 mit Tapatalk


Offline locutus

  • Sr. Member
  • ****
  • Beiträge: 815
  • No support over PM! Please use the thread ...
Antw:Neuartiges 1-Wire Interface
« Antwort #437 am: 12 November 2017, 23:25:52 »
Um ein Hardwaredefekt auszuschließen, würde ich eine andere Softwareumgebung, wie z. B. owTools für Testzwecke nehmen.

Ich bin sicher, locutus hat hier irgendwo den Downloadlink und Infos zur ESP8266-Firmware versteckt. Und Infos zur Konfiguration auch.
... immer noch da, wo sie hingehören.
https://forum.fhem.de/index.php/topic,18996.msg489913.html#msg489913
« Letzte Änderung: 28 März 2018, 22:19:32 von locutus »
Produktivsystem: Raspberry Pi 3, Add-On Board mit 1.8" TFT LCD, FHEM V5.8, miniCUL-WLAN, FS20, ESA2000, Oregon, Sonoff, JeeLink Clone, LaCrosse, EMT7110, 1-Wire, WiFi LED Controller, Yamaha AVR
Testumgebung: NanoPi Neo, ESP8266, HMIP, LaCrosseGateway, mapleCUL, Tablet UI, RaspberryMatic

Offline Jewe

  • Full Member
  • ***
  • Beiträge: 359
Antw:Neuartiges 1-Wire Interface
« Antwort #438 am: 17 November 2017, 23:27:43 »
Hallo,

den OneWireViewer habe ich installiert. Nach dem Starten kommt die Auswahl des Adapters bzw. des Port´s. Der 1-Wire-Adapter wird bei mir als COM5 erkannt. Diesen wähle ich aus. Danach kommt die Fehlermeldung
1-Wire Net not available
* * * * * * * * * * * * * * * * * * * * * * * * * * * * * * *
Cannot load default adapter. Please check that the adapter
is connected and that no other application is using the
port.

If you have checked the adapter, the default port might
not be selected.  Either set the value of the TMEX default
using the utility provided with the TMEX Runtime, or create
a new file in the <user.home>/OneWireViewer folder called
onewireviewer.properties with two lines, similar to the
following:

#native win32 drivers adapter.name={DS9097U}
  adapter.port=COM1
#or javax.comm drivers adapter.name=DS9097U
  adapter.port=COM1

The full path to this file should be:
 C:\Users\moab\OneWireViewer\onewireviewer.properties

Heist das nun, dass der Adapter einen Schuss weg hat ?

Offline locutus

  • Sr. Member
  • ****
  • Beiträge: 815
  • No support over PM! Please use the thread ...
Antw:Neuartiges 1-Wire Interface
« Antwort #439 am: 19 November 2017, 22:11:42 »
In der Vergangenheit hat sich der Umschalter SW1 als potentielle Fehlerquelle herauskristallisiert. Also Kontakte prüfen, gegebenenfalls überbrücken. Ansonsten ist das Gerät nur bedingt reparabel. Die Gründe dafür werden hier erläutert.
Produktivsystem: Raspberry Pi 3, Add-On Board mit 1.8" TFT LCD, FHEM V5.8, miniCUL-WLAN, FS20, ESA2000, Oregon, Sonoff, JeeLink Clone, LaCrosse, EMT7110, 1-Wire, WiFi LED Controller, Yamaha AVR
Testumgebung: NanoPi Neo, ESP8266, HMIP, LaCrosseGateway, mapleCUL, Tablet UI, RaspberryMatic

Offline Jewe

  • Full Member
  • ***
  • Beiträge: 359
Antw:Neuartiges 1-Wire Interface
« Antwort #440 am: 19 November 2017, 23:46:38 »
Hallo Locutus,
habe an den Schaltern rumgespielt und siehe da er funktioniert wieder.

Danke.

Offline PeMue

  • Developer
  • Hero Member
  • ****
  • Beiträge: 4211
Antw:1-Wire-USB-Adapter mit WLAN-Schnittstelle
« Antwort #441 am: 08 Januar 2018, 22:08:51 »
Hallo zusammen,

ich habe das 1-Wire-Interface mit dem ESP8266-WLAN-Funkmodul redesignt und auf die Größe eines USB-Sticks reduziert.

Schaltplan, Stückliste und Gerberdaten im Anhang.
Hallo locutus,

ich habe mir gerade die Stückliste bzw. Deine Bilder des 1-Wire-USB-Adapter mit WLAN-Schnittstelle angeschaut. Ist das wirklich ein ESP-12, der verbaut ist? Der müsste doch eine PCB Antenne haben. Ich meine, auf den Bildern ist ein ESP-07 verbaut.

Danke für eine kurze Info.

Gruß PeMue
1x FB7170 (29.04.88) 5.7 1xCUNO2 1.67 2xEM1000WZ 2xUniroll 1xASH2200 3xHMS100T(F)
1x RPi BV2LCDCSM 1.63 5.7 2xMAX HKT, 1xMAX RT, V200KW1
1xFB 7490 (113.06.05) 5.7 1xCUL V3 1.63 1xHM-CC-RT-DN 1.4 1xHM-TC-IT-WM 1.1 1xHB-UW-Sen-THPL-O 0.15 1x-I 0.14OTAU 1xRFXtrx 90 1xWT440H 1xCM160 3xTFA30.3150 5xFA21

Offline habeIchVergessen

  • Sr. Member
  • ****
  • Beiträge: 690
Antw:Neuartiges 1-Wire Interface
« Antwort #442 am: 12 Januar 2018, 18:58:42 »
der ESP-07 ist pinkompatibel mit einem 12E (exkl. der zusätzlichen Pins).
ich habe auch esp-link geflasht, da locutus Vorschlag bei W-LAN Kennwörtern auf 30 Zeichen begrenzt ist.

Offline PeMue

  • Developer
  • Hero Member
  • ****
  • Beiträge: 4211
Antw:Neuartiges 1-Wire Interface
« Antwort #443 am: 13 Januar 2018, 17:13:48 »
... der ESP-07 ist pinkompatibel mit einem 12E (exkl. der zusätzlichen Pins).
Danke für die Info, ich war der Meinung, dass die beiden nicht pinkompatibel seien  ???

Gruß PeMue
1x FB7170 (29.04.88) 5.7 1xCUNO2 1.67 2xEM1000WZ 2xUniroll 1xASH2200 3xHMS100T(F)
1x RPi BV2LCDCSM 1.63 5.7 2xMAX HKT, 1xMAX RT, V200KW1
1xFB 7490 (113.06.05) 5.7 1xCUL V3 1.63 1xHM-CC-RT-DN 1.4 1xHM-TC-IT-WM 1.1 1xHB-UW-Sen-THPL-O 0.15 1x-I 0.14OTAU 1xRFXtrx 90 1xWT440H 1xCM160 3xTFA30.3150 5xFA21

Offline Lucky2k12

  • Full Member
  • ***
  • Beiträge: 220
Antw:Neuartiges 1-Wire Interface
« Antwort #444 am: 02 März 2018, 18:26:48 »
Moin,

ich habe noch Probleme, den Stick von locutus zum Fliegen zu kriegen.
Ich hoffe, ihr könnt mir hier weiterhelfen.

Ich benutze den busmaster im WLAN Modus und habe einen 2fach 1W Counter dran, ebenfalls von locutus.
Teilweise wurde der auch erkannt, dann wieder nicht mehr.
Den SW1 Schalter hab ich gemessen, der scheint ok.

Wenn ich mich mit putty auf den busmaster verbinde, und FF sende, antwortet er mit GG, bei F0 mit G1. (Was bedeutet das?)

Früher hatte ich einen 4fach Counter von locutus dran, mit den identischen Problemen. Also liegt es wohl eher am Busmaster..

fhem.log mit verbose=5:
2018.03.02 18:05:20 1: OWX_Init called for bus OWXWIFI with interface state opened, now going for detect
2018.03.02 18:05:20 1: OWX_TCP::Query OWXWIFI: Sending out0xc1
2018.03.02 18:05:20 5: SW: c1
2018.03.02 18:05:20 5: OWX_TCP::Query OWXWIFI: Received 1 of 1 bytes in first attempt and state opened
2018.03.02 18:05:20 1: OWX_TCP::Query OWXWIFI: Sending out0x17 0x45 0x5b 0x0f 0x91
2018.03.02 18:05:20 5: SW: 17455b0f91
2018.03.02 18:05:20 5: OWX_TCP::Query OWXWIFI: Received 5 of 5 bytes in first attempt and state opened
2018.03.02 18:05:20 1: OWX_TCP::Detect 1-Wire bus OWXWIFI: interface master DS2480 detected for the first time
2018.03.02 18:05:20 1: OWX_TCP::Query OWXWIFI: Sending out0xe3 0xc5
2018.03.02 18:05:20 5: SW: e3c5
2018.03.02 18:05:20 5: OWX_TCP::Query OWXWIFI: Received 1 of 1 bytes in first attempt and state opened
2018.03.02 18:05:20 4: OWX_TCP: No presence detected on bus OWXWIFI
2018.03.02 18:05:20 1: OWX_TCP::Query OWXWIFI: Sending out0xe1 0xf0 0xe3 0xb5
2018.03.02 18:05:20 5: SW: e1f0e3b5
2018.03.02 18:05:20 5: OWX_TCP::Query OWXWIFI: Received 1 of 1 bytes in first attempt and state opened
2018.03.02 18:05:20 1: OWX_TCP::Query OWXWIFI: Sending out0xe1 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0xe3 0xa5
2018.03.02 18:05:20 5: SW: e100000000000000000000000000000000e3a5
2018.03.02 18:05:20 5: OWX_TCP::Query OWXWIFI: Received 16 of 16 bytes in first attempt and state opened
2018.03.02 18:05:20 1: OWX_TCP::Search CRC failed on bus OWXWIFI
2018.03.02 18:05:20 1: OWX_Discover: 1-Wire devices found on bus OWXWIFI ()

list des OVX Devices
Internals:
   ALARMED    no
   ASYNCHRONOUS 0
   DEF        192.168.178.43:2323
   DeviceName 192.168.178.43:2323
   FD         32
   INITDONE   1
   INTERFACE  DS2480
   NAME       OWXWIFI
   NR         468
   PARTIAL   
   PRESENT    1
   ROM_ID     FF
   STATE      opened
   TYPE       OWX
   interval   60
   timeout    8
   version    7.05
   DEVHASH:
     OWXWIFI    Busmaster
   DEVS:
   READINGS:
     2018-03-02 18:18:12   queue           0
     2018-03-02 18:18:12   state           opened
Attributes:
   asynchronous 0
   interval   60
   room       OWX
   timeout    8
   verbose    5

Edit: noch mehr log-Auszüge von Gestern:
2018.03.01 07:23:38 3: Opening OWXWIFI device 192.168.178.43:2323
2018.03.01 07:23:38 3: OWXWIFI device opened
2018.03.01 07:23:48 3: OWCOUNT:  Device OWX_1D_40DA84000005 defined.
2018.03.01 07:23:48 3: OWCOUNT:  Device OWX_1D_41DA84000005 defined.
...
2018.03.01 07:24:08 1: OWXCOUNT_BinValues getpage: OWX_1D_40DA84000005: invalid CRC, 255 255 0xff 0xff 0xff 0xff 0xff 0xff 0xff 0xff 0xff 0xff 0xff 0xff 0xff 0xff 0xff 0xff 0xff 0xff 0xff 0xff 0xff 0xff 0xff 0xff 0xff 0xff 0xff 0xff 0xff 0xff 0xff 0xff 0xff 0xff 0xff 0xff 0xff 0xff 0xff 0xff 0xff 0xff
2018.03.01 07:24:08 1: OWXCOUNT_BinValues getpage: OWX_1D_40DA84000005: invalid CRC, 255 255 0xff 0xff 0xff 0xff 0xff 0xff 0xff 0xff 0xff 0xff 0xff 0xff 0xff 0xff 0xff 0xff 0xff 0xff 0xff 0xff 0xff 0xff 0xff 0xff 0xff 0xff 0xff 0xff 0xff 0xff 0xff 0xff 0xff 0xff 0xff 0xff 0xff 0xff 0xff 0xff 0xff 0xff
2018.03.01 07:24:15 1: OWX_TCP::Query OWXWIFI: 5 of 54 bytes - something wrong with the 1-Wire device ???
2018.03.01 07:24:21 1: OWX_TCP::Query OWXWIFI: 29 of 54 bytes - something wrong with the 1-Wire device ???
2018.03.01 07:24:25 1: PERL WARNING: Use of uninitialized value $minInt in numeric lt (<) at fhem.pl line 4543.

....
2018.03.01 07:24:39 1: OWX_Init called for bus OWXWIFI with interface state opened, now going for detect
2018.03.01 07:24:39 1: OWX_TCP::Detect 1-Wire bus OWXWIFI: interface master DS2480 detected for the first time
2018.03.01 07:24:39 1: OWX_TCP::Search CRC failed on bus OWXWIFI
2018.03.01 07:24:39 1: OWX_Discover: Device OWX_1D_40DA84000005 of type OWCOUNT is unused, consider deletion !
2018.03.01 07:24:39 1: OWX_Discover: Device OWX_1D_41DA84000005 of type OWCOUNT is unused, consider deletion !
2018.03.01 07:24:39 1: OWX_Discover: 1-Wire devices found on bus OWXWIFI ()
...
2018.03.01 07:28:51 1: OWX_TCP::Query OWXWIFI: 32 of 54 bytes - something wrong with the 1-Wire device ???
2018.03.01 07:28:53 3: connexoon: request active
2018.03.01 07:29:16 1: OWX_TCP::Query OWXWIFI: 18 of 54 bytes - something wrong with the 1-Wire device ???
...
2018.03.01 20:57:43 1: OWX_TCP::Search reset failed on bus OWXWIFI

Danke für eure Unterstützung!
« Letzte Änderung: 02 März 2018, 18:32:34 von Lucky2k12 »
Raspi3, Jeelink, LGW, mapleCUL868+434

Offline cwagner

  • Full Member
  • ***
  • Beiträge: 497
Antw:Neuartiges 1-Wire Interface
« Antwort #445 am: 05 März 2018, 10:49:40 »
Leider musste auch ich jetzt frierend die Erfahrung machen, dass reopen in der aktuell per update ausgelieferten Fassung bei 00_OWX.pm nicht funktioniert, ja schlimmer: Bei mir beliebig wiederholbar das FHEM komplett abschießt.

Ich hatte einen Watchdog, der aufgrund meiner Beobachtung, dass vereinzelt mein Device auf disconnected springt, ein Reopen selbständig nach 2 Minuten ausführt. Dieser Fall trat nun bei einer 2-tägigen Abwesenheit und Temperaturen von -6 Grad ein. Da war es dann gestern Abend bei Rückkehr schnukelig kalt...

Ich habe das dann fünf- sechsmal noch mit neu gestartetem FHEM wiederholt und die Gegenprobe gemacht: Bei der vorherige Fassung (die bei mir am 19.2. geupdatet wurde) habe ich keine Probleme mit set OWio reopen…


Herzliche Grüße

Christian


« Letzte Änderung: 05 März 2018, 10:51:19 von cwagner »
Raspi 2B +3B gekoppelt mit FHEM2FHEM: 5.8 DEV Perl v5.20.2, 270 Entities in DbLog u.a. HM (CUL), 1-Wire (FT232RL & DS2480B) und EnOcean (EnOceanPi). Im Einsatz u.a.DOIF, PID20, Threshold, OWX New Gen; Micropelt IRTV, HM Zählermodule; Steuerung von Heizung, Solarkollektoren, Lüftung und Smarthome

Offline Frank_Huber

  • Hero Member
  • *****
  • Beiträge: 2235
Antw:Neuartiges 1-Wire Interface
« Antwort #446 am: 05 März 2018, 11:06:52 »
Leider musste auch ich jetzt frierend die Erfahrung machen, dass reopen in der aktuell per update ausgelieferten Fassung bei 00_OWX.pm nicht funktioniert, ja schlimmer: Bei mir beliebig wiederholbar das FHEM komplett abschießt.

Ich hatte einen Watchdog, der aufgrund meiner Beobachtung, dass vereinzelt mein Device auf disconnected springt, ein Reopen selbständig nach 2 Minuten ausführt. Dieser Fall trat nun bei einer 2-tägigen Abwesenheit und Temperaturen von -6 Grad ein. Da war es dann gestern Abend bei Rückkehr schnukelig kalt...

Ich habe das dann fünf- sechsmal noch mit neu gestartetem FHEM wiederholt und die Gegenprobe gemacht: Bei der vorherige Fassung (die bei mir am 19.2. geupdatet wurde) habe ich keine Probleme mit set OWio reopen…


Herzliche Grüße

Christian

Hier gehts zum Thema:
https://forum.fhem.de/index.php/topic,85007.0.html

Hab deinen Beitrag dort verlinkt.

Offline Lucky2k12

  • Full Member
  • ***
  • Beiträge: 220
Antw:Neuartiges 1-Wire Interface
« Antwort #447 am: 06 März 2018, 16:37:00 »
Dass ein reload fhem abschießt habe ich auch beobachtet...
Aber das hat wohl nicht unbedingt mit meinem o.g. Problem (#444) zu tun.

Der Counter wird mal erkannt und dann wieder nicht.
Am Wlan kann es nicht liegen, da hab ich einen ping mitlaufen lassen.

Keiner ne Idee, was ich noch machen könnte?
Raspi3, Jeelink, LGW, mapleCUL868+434

Offline PeMue

  • Developer
  • Hero Member
  • ****
  • Beiträge: 4211
Antw:Neuartiges 1-Wire Interface
« Antwort #448 am: 27 März 2018, 20:28:09 »
Hallo zusammen,

ich baue gerade für jemanden locutus' 1-wire Interface nach. Das Interface wird von FHEM erkannt, der (direkt) angeschlossene Sensor DS18B20 leider nicht. Aus meiner Sicht kann das nur am Pegelwandler liegen, ich verwende diesen hier. Oder der Ausgangsfilter ist so intolerant, dass nur 470 pF/62 Ohm gehen, ich verwende (mangels vorhandenen Bauteilen) C9 = 100 nF bzw. R3 = 27 Ohm (Grenzfrequenz ist ähnlich).
Dummerweise passiert das bei drei gleich aufgebauten Modulen  >:( >:( >:(
Ein get <name> devices findet etwas, aber mit der Adresse OWX_Discover: 1-Wire devices found on bus PM1WUSB01
00.000000000000      unknown        OWX_00_000000000000
das Log sagt folgendes:
2018.03.27 20:23:25 3: OWX_SER::Reset Alarm presence detected on bus PM1WUSB01
2018.03.27 20:23:26 3: OWX_SER::Reset Alarm presence detected on bus PM1WUSB01
2018.03.27 20:23:26 1: OWX_SER::Search CRC failed on bus PM1WUSB01
2018.03.27 20:23:26 2: OWX_Discover: Device with unknown family code '00' found on bus PM1WUSB01
2018.03.27 20:23:26 1: OWX_Discover: 1-Wire devices found on bus PM1WUSB01 (OWX_00_000000000000)
Und schließlich das List:
Internals:
   ALARMED    yes
   ASYNCHRONOUS 0
   BLOCK      0
   BUSY       0
   DEF        /dev/ttyUSB3
   DeviceName /dev/ttyUSB3
   FD         18
   INITDONE   0
   INTERFACE 
   NAME       PM1WUSB01
   NR         653
   PARTIAL   
   PRESENT    0
   ROM_ID     FF
   STATE      opened
   TYPE       OWX
   interval   300
   timeout    2
   DEVHASH:
     OWX_00_000000000000 00.000000000000.00
     PM1WUSB01  Busmaster
   DEVS:
     00.000000000000.00
   READINGS:
     2018-03-27 20:16:38   state           opened
Attributes:
   room       Radio
Hat jemand einen Tipp für mich, wo ich noch suchen kann?

Danke + Gruß

Peter
1x FB7170 (29.04.88) 5.7 1xCUNO2 1.67 2xEM1000WZ 2xUniroll 1xASH2200 3xHMS100T(F)
1x RPi BV2LCDCSM 1.63 5.7 2xMAX HKT, 1xMAX RT, V200KW1
1xFB 7490 (113.06.05) 5.7 1xCUL V3 1.63 1xHM-CC-RT-DN 1.4 1xHM-TC-IT-WM 1.1 1xHB-UW-Sen-THPL-O 0.15 1x-I 0.14OTAU 1xRFXtrx 90 1xWT440H 1xCM160 3xTFA30.3150 5xFA21

Offline Prof. Dr. Peter Henning

  • Developer
  • Hero Member
  • ****
  • Beiträge: 5732
Antw:Neuartiges 1-Wire Interface
« Antwort #449 am: 28 März 2018, 07:11:47 »
Sieht sehr nach Hardwareproblem aus. Hast Du mal das einfache Ding hier probiert: https://wiki.fhem.de/wiki/1-Wire_Pegelwandler

LG

pah