FHEM - Hausautomations-Systeme > ZWave

ZWave Devices schalten nicht immer an/aus

<< < (2/8) > >>

rudolfkoenig:
Ich habe unlaengst einen Fix eingebaut, der das Schalten von mehreren ZWave-Geraeten mit einem set fuer mich ermoeglicht hat. Ist euer FHEM up-to-date? Es waere auch moeglich, dass wegen diesem Fix das Schalten nicht mehr funktioniert, da ich auf eine Rueckmeldung vom Stick warte, bovor ich die naechsten Daten sende. Wenn ihr "list zwDongle" eingibt, was steht bei SendStack?


--- Zitat ---Wäre interessant zu wissen das das "set" tatsächlich macht.
--- Ende Zitat ---
attr zwdongle verbose 5

extraem:
Hallo

seit heute geht es anscheinend wieder (zumindest jetzt)

Ich mache fast täglich die Updates
Der Server macht jeden Tag um 7:00 Uhr einen Neustadt

hier die Ausgabe von list ZWDongle_0


--- Code: ---Internals:
   CFGFN      /opt/fhem/FHEM/zwave.cfg
   CallbackNr 0
   Clients    :ZWave:
   DEF        /dev/zwave@115200
   DeviceName /dev/zwave@115200
   FD         13
   NAME       ZWDongle_0
   NR         65
   PARTIAL   
   READ_TS    1390473920.89196
   STATE      Initialized
   TYPE       ZWDongle
   homeId     0161de03
   Matchlist:
     1:ZWave    .*
   Readings:
     2014-01-22 21:38:30   caps            Vers:3 Rev:7 ManufID:0086 ProductType:0002 ProductID:0001 SERIAL_API_GET_INIT_DATA,SERIAL_API_APPL_NODE_INFORMATION,APPLICATION_COMMAND_HANDLER,ZW_GET_CONTROLLER_CAPABILITIES,SERIAL_API_SET_TIMEOUTS,SERIAL_API_GET_CAPABILITIES,ZW_SET_SLEEP_MODE,ZW_SEND_NODE_INFORMATION,ZW_SEND_DATA,ZW_SEND_DATA_MULTI,ZW_GET_VERSION,ZW_SEND_DATA_ABORT,ZW_R_F_POWER_LEVEL_SET,MEMORY_GET_ID,MEMORY_GET_BYTE,MEMORY_PUT_BYTE,MEMORY_GET_BUFFER,ZW_GET_NODE_PROTOCOL_INFO,ZW_REPLICATION_COMMAND_COMPLETE,ZW_REPLICATION_SEND_DATA,ZW_ASSIGN_RETURN_ROUTE,ZW_DELETE_RETURN_ROUTE,ZW_REQUEST_NODE_NEIGHBOR_UPDATE,ZW_APPLICATION_UPDATE,ZW_ADD_NODE_TO_NETWORK,ZW_CREATE_NEW_PRIMARY,ZW_SET_LEARN_MODE,ZW_ASSIGN_SUC_RETURN_ROUTE,ZW_ENABLE_SUC,ZW_REQUEST_NETWORK_UPDATE,ZW_SET_SUC_NODE_ID,ZW_DELETE_SUC_RETURN_ROUTE,ZW_GET_SUC_NODE_ID,ZW_REDISCOVERY_NEEDED,ZW_REQUEST_NODE_INFO,ZW_REMOVE_FAILED_NODE_ID,ZW_IS_FAILED_NODE
     2014-01-22 21:38:52   ctrlCaps        PRIMARY
     2014-01-23 11:45:20   homeId          HomeId:0161de03 CtrlNodeId:01
     2014-01-22 21:39:26   nodeInfo_1      STATIC_CONTROLLER STATIC_CONTROLLER listening 40kBaud Vers:3 Security:0
     2014-01-22 21:39:45   nodeInfo_2      SLAVE SWITCH_BINARY listening routing 40kBaud Vers:3 Security:0
     2014-01-22 21:40:06   nodeInfo_4      ROUTING_SLAVE sleeping routing 40kBaud Vers:3 Security:0
     2014-01-23 10:39:18   nodeInfo_5      ROUTING_SLAVE SWITCH_BINARY listening routing 40kBaud Vers:4 Security:0
     2014-01-22 21:40:43   nodeInfo_6      ROUTING_SLAVE SWITCH_BINARY listening routing 40kBaud Vers:4 Security:0
     2014-01-22 22:51:19   nodeList        1,2,4,5,6
     2014-01-22 21:42:14   version         Z-Wave 2.78 STATIC_CONTROLLER
   SendStack:
Attributes:
   room       90_System
   verbose    5

--- Ende Code ---

Ich habe jetzt heute meine neuen Geräte noch hinzugefügt und auch die Zwischenstecker gehen (da habe ich zwar noch ein anderes Problem aber dazu gibt es dann einen neuen Eintrag


Danke
Franz

larry:
hier ist mein Ergebnis von "list zwDongle":


--- Code: ---list ZWDongle_0
Internals:
   CallbackNr 0
   Clients    :ZWave:
   DEF        /dev/ttyUSB0@115200
   DeviceName /dev/ttyUSB0@115200
   FD         11
   NAME       ZWDongle_0
   NR         22
   PARTIAL
   RAWMSG     011301
   READ_TS    1390502995.50391
   STATE      Initialized
   TYPE       ZWDongle
   ZWDongle_0_MSGCNT 99
   ZWDongle_0_TIME 2014-01-23 10:49:55
   homeId     0184c73d
   Matchlist:
     1:ZWave    .*
   Readings:
     2014-01-22 14:34:55   homeId          HomeId:0184c73d CtrlNodeId:01
Attributes:
   room       Office

--- Ende Code ---

Interessanterweise werden bei mir die devices nicht gelistet und sendstack sehe ich auch nicht - ich werde am Wochenende mal ein update machen.

extraem:
Hallo

die Geräte werden nur deshalb angezeigt weil ich zuvor  get nodeinfo gemacht hatte

larry:
Hier nochmal nach dem update:


--- Code: ---list ZWDongle_0
Internals:
   CallbackNr 0
   Clients    :ZWave:
   DEF        /dev/ttyUSB0@115200
   DeviceName /dev/ttyUSB0@115200
   FD         11
   NAME       ZWDongle_0
   NR         22
   PARTIAL
   RAWMSG     0004000603250300
   READ_TS    1390504880.59993
   STATE      Initialized
   TYPE       ZWDongle
   ZWDongle_0_MSGCNT 8
   ZWDongle_0_TIME 2014-01-23 11:13:43
   homeId     0184c73d
   Matchlist:
     1:ZWave    .*
   Readings:
     2014-01-23 11:13:41   homeId          HomeId:0184c73d CtrlNodeId:01
     2014-01-23 11:20:56   nodeInfo_1      STATIC_CONTROLLER STATIC_CONTROLLER listening 40kBaud Vers:3 Security:0
     2014-01-23 11:21:03   nodeInfo_2      ROUTING_SLAVE SWITCH_BINARY listening routing 40kBaud Vers:4 Security:0
     2014-01-23 11:21:08   nodeInfo_3      ROUTING_SLAVE THERMOSTAT listening routing 40kBaud Vers:3 Security:0
     2014-01-23 11:21:14   nodeInfo_5      ROUTING_SLAVE SWITCH_BINARY listening routing 40kBaud Vers:4 Security:0
     2014-01-23 11:21:20   nodeInfo_6      ROUTING_SLAVE SWITCH_BINARY listening routing 40kBaud Vers:4 Security:0
     2014-01-23 11:19:46   nodeList        1,2,3,5,6
   SendStack:
Attributes:
   room       Office

--- Ende Code ---

Navigation

[0] Themen-Index

[#] Nächste Seite

[*] Vorherige Sete

Zur normalen Ansicht wechseln