Autor Thema: Keinen Bezug zu Forum-User bei Versand von emails über das Forum  (Gelesen 2033 mal)

Offline betateilchen

  • Developer
  • Hero Member
  • ****
  • Beiträge: 13680
  • Das "S" in "IoT" steht für "Security"
Könnte man irgendwo in der email-Funktion des Forums eine Möglichkeit einbauen, damit beim Versand von emails über das Forum ein Bezug zum Forum-Nickname des Absenders hergestellt werden kann? Aus der email selbst (weder aus dem Betreff noch aus dem Mailtext) kann man als Empfänger nämlich nicht ohne weiteres auf einen Absender schließen, den man im Forum irgendwie zuordnen könnte. Dort steht als Absender nur die email-Adresse des Forumusers.

Danke.
« Letzte Änderung: 18 Februar 2014, 14:02:19 von betateilchen »
-----------------------
Nächster Hamburg-Stammtisch: 15.12.2017

Offline Thorsten Pferdekaemper

  • Developer
  • Hero Member
  • ****
  • Beiträge: 4220
  • Finger weg von der fhem.cfg
Antw:Keine Bezug zu Forum-User bei Versand von emails über das Forum
« Antwort #1 am: 27 Januar 2014, 09:39:37 »
Hi,
schreib' doch einfach Deinen Nickname mit in die Mail, wenn Du das willst. ...oder geht das nicht?
Gruß,
   Thorsten
RasPi
Heizkessel-Steuerung per Arduino und HTTPMOD
und einen Haufen Homematic (Wired)

Offline betateilchen

  • Developer
  • Hero Member
  • ****
  • Beiträge: 13680
  • Das "S" in "IoT" steht für "Security"
Antw:Keine Bezug zu Forum-User bei Versand von emails über das Forum
« Antwort #2 am: 27 Januar 2014, 11:30:06 »
Dein Tipp nützt mir nix als Empfänger...
-----------------------
Nächster Hamburg-Stammtisch: 15.12.2017

Offline Thorsten Pferdekaemper

  • Developer
  • Hero Member
  • ****
  • Beiträge: 4220
  • Finger weg von der fhem.cfg
Antw:Keine Bezug zu Forum-User bei Versand von emails über das Forum
« Antwort #3 am: 27 Januar 2014, 12:10:16 »
Auch wieder richtig, zumindest wenn der Sender zu dusselig ist seine Identität preiszugeben.
RasPi
Heizkessel-Steuerung per Arduino und HTTPMOD
und einen Haufen Homematic (Wired)

Offline betateilchen

  • Developer
  • Hero Member
  • ****
  • Beiträge: 13680
  • Das "S" in "IoT" steht für "Security"
Antw:Keine Bezug zu Forum-User bei Versand von emails über das Forum
« Antwort #4 am: 27 Januar 2014, 12:14:29 »
es geht nicht um zu dusslig...

In > 99,9% aller Foren, die ich kenne, wird der Benutzername automatisch (per Variable) entweder in den Betreff oder in einen automatisch eingefügten Textvorspann im Mailtext eingetragen.

Ich käme als Forumbenutzer auch nicht auf die Idee, meinen Benutzernamen selbst in eine email zu schreiben, da ich einfach davon ausgehe, dass das die Software automatisch macht. Das ist das erste und einzige Forum, das ich kenne und in dem ich aktiv bin, das sich so verhält.

-----------------------
Nächster Hamburg-Stammtisch: 15.12.2017

Offline Martin Thomas Schrott

  • Full Member
  • ***
  • Beiträge: 232
Antw:Keine Bezug zu Forum-User bei Versand von emails über das Forum
« Antwort #5 am: 27 Januar 2014, 13:55:20 »
...und das ist nur eines der probleme mit diesem Forum im Bezug auf Emails.
weiters steht öfter mal topicboard statt dem namen des unterforums im Betreff, was auch sehr angenehm ist.
und am schlimmsten ist, dass die Mails aus dem Forum sich nicht nach topic sortieren lassen, weil jede Mail ein neues topic ist. :-(
So übersichtlich, dass man am liebsten garnichts mehr mitliest.
Aber die hoffnung stirbt ja bekanntlich zu letzt und ich hoffe weiter, dass es irgendwann eine Lösung gibt, die auch tatsächlich wieder funktioniert, wie damals die Mailingliste :-)
Da konnte man auch von einem primitiven Mobiltelefon umgehend antworten, jetzt müsste man ins internet gehen und umständlich auf der Seite rumsuchen und tippen.
Tja und der tolle jabber/xmpp Chat ist ja auch wieder verschwunden ... oder gibt es hier einen neuen der nicht angekündigt wurde?

so, genug gejammert, zumindest die user sind und bleiben einmalig und top! Danke dafür und weiter so!

Offline betateilchen

  • Developer
  • Hero Member
  • ****
  • Beiträge: 13680
  • Das "S" in "IoT" steht für "Security"
Antw:Keinen Bezug zu Forum-User bei Versand von emails über das Forum
« Antwort #6 am: 18 Februar 2014, 13:51:15 »
Aus gegebenem Anlass schubse ich das Thema nochmal hoch.

Zwar habe ich inzwischen rausgefunden, dass man unter "Mitglieder -> Mitglieder suchen" auch Leute anhand der email-Adresse identifizieren kann, trotzdem fände ich es einfacher, wenn der Benutzername im Mail-Body stehen würde. In der Benachrichtigungmail im Rahmen einer Forum-Neuanmeldung funktioniert das doch schließlich auch.

Danke & Grüße
« Letzte Änderung: 18 Februar 2014, 14:02:47 von betateilchen »
-----------------------
Nächster Hamburg-Stammtisch: 15.12.2017

Offline betateilchen

  • Developer
  • Hero Member
  • ****
  • Beiträge: 13680
  • Das "S" in "IoT" steht für "Security"
Antw:Keinen Bezug zu Forum-User bei Versand von emails über das Forum
« Antwort #7 am: 27 Februar 2017, 00:46:58 »
Aus aktuellem Anlass muss ich dieses Thema nach drei Jahren mal wieder aus der Versenkung holen, weil sich diesbezüglich immer noch nix entscheidendes verbessert hat.



-----------------------
Nächster Hamburg-Stammtisch: 15.12.2017

Offline Markus Bloch

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 3243
Antw:Keinen Bezug zu Forum-User bei Versand von emails über das Forum
« Antwort #8 am: 27 Februar 2017, 16:29:04 »
Habe es mir auf Todo geschrieben. Werde mich drum kümmern sobald Zeit besteht. Bin momentan viel unterwegs.

Gruß
Markus
Developer für Module: YAMAHA_AVR, YAMAHA_BD, FB_CALLMONITOR, FB_CALLLIST, PRESENCE, Pushsafer, LGTV_IP12, version

aktives Mitglied des FHEM e.V. (Technik)

Offline betateilchen

  • Developer
  • Hero Member
  • ****
  • Beiträge: 13680
  • Das "S" in "IoT" steht für "Security"
Antw:Keinen Bezug zu Forum-User bei Versand von emails über das Forum
« Antwort #9 am: 27 Februar 2017, 22:04:37 »
Danke. Da ich jetzt schon mehrere Jahre auf eine Änderung warte, kommt es nun auf ein paar Tage auch nicht mehr an :)
-----------------------
Nächster Hamburg-Stammtisch: 15.12.2017

Offline PeMue

  • Developer
  • Hero Member
  • ****
  • Beiträge: 3637
Antw:Keinen Bezug zu Forum-User bei Versand von emails über das Forum
« Antwort #10 am: 16 Oktober 2017, 09:02:39 »
Hallo zusammen,

da ich ebenfalls bei Mailkontakt über das Forum den Nicknamen nicht zuordnen kann, wäre eine entscheidende Verbesserung (zumindest für mich), wenn der Nicknamen automatisch mitgesendet werden würde.
Als Provisorium werde ich mal die von betateilchen beschriebene Suchfunktion stressen, mal sehen, was dabei rauskommt ...

Danke + Gruß

PeMue

Edit: Manche Mailadressen werden nicht gefunden, vermutlich weil die Forums-Mailadresse nicht mit der verwendeten übereinstimmt  >:(
« Letzte Änderung: 16 Oktober 2017, 09:12:04 von PeMue »
1x FB7170 (29.04.88) 5.7 1xCUNO2 1.67 2xEM1000WZ 2xUniroll 1xASH2200 3xHMS100T(F)
1x RPi BV2LCDCSM 1.63 5.7 2xMAX HKT, 1xMAX RT, V200KW1
1xFB 7490 (113.06.05) 5.7 1xCUL V3 1.63 1xHM-CC-RT-DN 1.4 1xHM-TC-IT-WM 1.1 1xHB-UW-Sen-THPL-O 0.15 1x-I 0.14OTAU 1xRFXtrx 90 1xWT440H 1xCM160 3xTFA30.3150 5xFA21