Autor Thema: HMLAN Adapter wechselt permanent zwischen disconnected / connected  (Gelesen 136627 mal)

Offline Tommy82

  • Hero Member
  • *****
  • Beiträge: 2869
Antw:HMLAN Adapter wechselt permanent zwischen disconnected / connected
« Antwort #45 am: 04 Dezember 2014, 15:05:24 »
Hallo,
ich habe auch häufige disconnect und connect
2014.12.04 03:43:12.217 1: 192.168.188.27:1000 disconnected, waiting to reappear (HmLanAdapter)
2014.12.04 03:43:12.223 1: HMLAN_Parse: HmLanAdapter new condition disconnected
2014.12.04 03:44:13.289 1: 192.168.188.27:1000 reappeared (HmLanAdapter)
2014.12.04 03:44:13.296 1: HMLAN_Parse: HmLanAdapter new condition init
2014.12.04 03:44:13.470 1: HMLAN_Parse: HmLanAdapter new condition ok
2014.12.04 03:46:02.536 1: 192.168.188.27:1000 disconnected, waiting to reappear (HmLanAdapter)
2014.12.04 03:46:02.539 1: HMLAN_Parse: HmLanAdapter new condition disconnected
usw.

Ich habe dann mal mit Performance Monitor geschaut, das ergibt im Log direkt nach dem shutdown restart einiges an:
2014.12.04 13:30:44.412 1: Perfmon: possible freeze starting at 13:30:41, delay is 3.412
2014.12.04 13:30:58.345 1: Perfmon: possible freeze starting at 13:30:55, delay is 3.345
2014.12.04 13:31:12.377 1: Perfmon: possible freeze starting at 13:31:09, delay is 3.377
hab dann verbose auf 5 geändert und dabei sind mir dann diese Punkte aufgefallen, die sich dann häufiegr im Log finden:

2014.12.04 13:37:09.278 1: Perfmon: possible freeze starting at 13:36:54, delay is 15.277
2014.12.04 13:37:09.279 4: HTTPMOD: GetUpdate called, hash = HASH(0x22735e0), name = TV_Programme
2014.12.04 13:37:09.280 4: HttpUtils url=http://www.tvmovie.de/tv-programm-jetzt-im-tv.html?tv-stations-count=100&time=now&form_build_id=form-7f6a9332d4b1e7b5bc6af20e39353673&form_id=dikr_tvm_tv_guide_tv_stations_count_form
2014.12.04 13:37:09.311 4: HTTPMOD: GetUpdate called, hash = HASH(0x254ab28), name = TV_Programme_next
2014.12.04 13:37:09.312 4: HttpUtils url=http://www.tvmovie.de/tv-programm-gleich-im-tv.html?tv-stations-count=100&time=soon&form_build_id=form-6c71e36a9e9651420736eccb5287fdec&form_id=dikr_tvm_tv_guide_tv_stations_count_form


2014.12.04 13:37:55.372 1: Perfmon: possible freeze starting at 13:37:52, delay is 3.372
2014.12.04 13:37:55.464 5: FBAHA/RAW: /0703001c000000214e2000000000000c0000001400040000000000000703001c000000214e2000000000000c0000001400040000000000000703001c000000214e2000000000000c0000001400040000000000000703001c000000214e2000000000000c000000140004000000000000
2014.12.04 13:37:55.465 5: FBSmartHome dispatch 0703001c000000214e2000000000000c000000140004000000000000
2014.12.04 13:37:55.467 4: Payload: 000000140004000000000000 -> power: 0.00 W
2014.12.04 13:37:55.468 5: FBDECT_Parse for device Powerline done
2014.12.04 13:37:55.469 5: FBSmartHome dispatch 0703001c000000214e2000000000000c000000140004000000000000

2014.12.04 13:38:48.009 1: Perfmon: possible freeze starting at 13:38:45, delay is 3.008
2014.12.04 13:38:52.017 4: iTunes_HTTP_Request http://192.168.188.22:3689/login?pairing-guid=0x42b352fdd013f43c: Can't connect to http://192.168.188.22:3689

2014.12.04 13:38:52.137 1: Perfmon: possible freeze starting at 13:38:49, delay is 3.137
2014.12.04 13:38:52.137 5: HMLAN_Send:  HmLanAdapter I:K
2014.12.04 13:38:52.141 5: HMLAN/RAW: /HHM-LAN-IF,03C1,KEQ0852050,23A503,000041,09256140,000B

2014.12.04 13:39:01.045 1: Perfmon: possible freeze starting at 13:38:58, delay is 3.044
2014.12.04 13:39:01.045 5: ENIGMA2 VU_Ultimo: called function ENIGMA2_ReceiveCommand()
2014.12.04 13:39:01.080 4: https://root:xxx@192.168.188.24:444/web/timerlist: HTTP response code 200
2014.12.04 13:39:01.081 4: HttpUtils https://root:xxx@192.168.188.24:444/web/timerlist: Got data, length: 68
2014.12.04 13:39:01.081 5: ENIGMA2 VU_Ultimo: called function ENIGMA2_ReceiveCommand()
2014.12.04 13:39:01.082 4: ENIGMA2 VU_Ultimo: RCV timerlist
2014.12.04 13:39:01.082 5: ENIGMA2 VU_Ultimo: RES timerlist

2014.12.04 13:39:06.075 1: Perfmon: possible freeze starting at 13:39:03, delay is 3.075
2014.12.04 13:39:06.076 5: ENIGMA2 Uno_Schlafzimmer: called function ENIGMA2_GetStatus()
2014.12.04 13:39:06.076 5: ENIGMA2 Uno_Schlafzimmer: called function ENIGMA2_SendCommand()
2014.12.04 13:39:06.076 4: ENIGMA2 Uno_Schlafzimmer: REQ powerstate
2014.12.04 13:39:06.077 5: ENIGMA2 Uno_Schlafzimmer: GET https://root:xxx@192.168.188.29:443/web/powerstate
2014.12.04 13:39:06.077 4: HttpUtils url=https://root:xxx@192.168.188.29:443/web/powerstate

2014.12.04 13:39:20.179 1: Perfmon: possible freeze starting at 13:39:17, delay is 3.179
2014.12.04 13:39:22.997 5: HMLAN/RAW: /E222529,0000,0925D9C7,FF,FFCD,0286102225290000000A98C70C0416

2014.12.04 13:40:32.166 1: Perfmon: possible freeze starting at 13:40:31, delay is 1.165
2014.12.04 13:40:32.166 5: ENIGMA2 Uno_Kellerbar: called function ENIGMA2_GetStatus()
2014.12.04 13:40:32.167 5: ENIGMA2 Uno_Kellerbar: called function ENIGMA2_SendCommand()
2014.12.04 13:40:32.168 4: ENIGMA2 Uno_Kellerbar: REQ powerstate
2014.12.04 13:40:32.168 5: ENIGMA2 Uno_Kellerbar: GET https://root:xxx@192.168.188.30:443/web/powerstate
2014.12.04 13:40:32.169 4: HttpUtils url=https://root:xxx@192.168.188.30:443/web/powerstate
2014.12.04 13:40:32.193 4: https://root:xxx@192.168.188.24:444/web/timerlist: HTTP response code 200
2014.12.04 13:40:32.194 4: HttpUtils https://root:xxx@192.168.188.24:444/web/timerlist: Got data, length: 68
2014.12.04 13:40:32.194 5: ENIGMA2 VU_Ultimo: called function ENIGMA2_ReceiveCommand()
2014.12.04 13:40:32.195 4: ENIGMA2 VU_Ultimo: RCV timerlist
2014.12.04 13:40:32.195 5: ENIGMA2 VU_Ultimo: RES timerlist

Das sieht mir so aus, alsob das Enigma2 Modul, iTunes, FBDect/FBSmartHome,HttpMod bei mir für verzögerungen sorgen!?
Interpretiere ich das richtig?

Dann würde ich ja was enigma2 und iTunes am besten mal im entsprechenden Thread fragen oder wie seht ihr das?

Ich hab dann auch mal noch mit apptime geschaut, das sieht dann so aus:
       name             function    max  count    total  average param Max call
                                XBMC           XBMC_Ready   3014  12951    93219     7.20 HASH(0x3944c98)
              tmr-WOL_UpdateReadings      HASH(0x39272f8)   2066     12    24638  2053.17 HASH(0x39272f8)
              tmr-WOL_UpdateReadings      HASH(0x33ff5c8)   2064     12    24622  2051.83 HASH(0x33ff5c8)
                                 WEB              FW_Read    947    124    11898    95.95 HASH(0x392d0f8)
        FHEMWEB:192.168.188.73:52585              FW_Read    482      1      482   482.00 HASH(0x3bb9da0)
                         FBSmartHome           FBAHA_Read    455   1299    32303    24.87 HASH(0x3d50b28)
                        HmLanAdapter           HMLAN_Read     70    172     3855    22.41 HASH(0x3406860)
               tmr-HttpUtils_ReadErr      HASH(0x3ba9490)     53      1       53    53.00 HASH(0x3ba9490)
               tmr-HttpUtils_ReadErr      HASH(0x3d93ac8)     46      1       46    46.00 HASH(0x3d93ac8)
               tmr-HTTPMOD_GetUpdate      HASH(0x2fbdcb0)     39     31      302     9.74 HASH(0x2fbdcb0)
                   FBDECT_Temperatur          notify_Exec     16    108      182     1.69 HASH(0x33bff10); HASH(0x33c6b28)
                   FBDECT_20000_temp            dummy_Set     14     36      163     4.53 HASH(0x2ae54f8); FBDECT_20000_temp; 21.9
        FHEMWEB:192.168.188.73:52577              FW_Read     12      4       18     4.50 HASH(0x39450b8)
               tmr-ENIGMA2_GetStatus      HASH(0x2e0db60)     11     21       76     3.62 HASH(0x2e0db60)
              tmr-FW_closeOldClients                          10     31      113     3.65
                            Alarm_nt          notify_Exec      9   2409      278     0.12 HASH(0x33c2d38); HASH(0x33c6b28)
              Wohnzimmer_Heizung_nty          notify_Exec      9   2409       25     0.01 HASH(0x33c84f8); HASH(0x33c6b28)
                             Logfile          FileLog_Log      8   2409       11     0.00 HASH(0x3d50ea0); HASH(0x33c6b28)
        FHEMWEB:192.168.188.73:52585            FW_Notify      7    294      737     2.51 HASH(0x3bb9da0); HASH(0x33ff5c8)
                 tmr-CUL_HM_ActCheck       ActionDetector      7      3       18     6.00 ActionDetector
         FileLog_Fenster_neben_Couch          FileLog_Set      6      4       21     5.25 HASH(0x3d510e0); FileLog_Fenster_neben_Couch; ?

Das sieht aus als ob das XBMC Modul und das WOL Modul für viele belastung sorgt!?

Könnte das für meine disconnects verantworlich sein?

Danke


EDIT
Hab XBMC mal rausgeschmissen, da ich das aktuell eh nicht nutze, mal sehn ob das schon hilft
« Letzte Änderung: 04 Dezember 2014, 15:44:05 von Tommy82 »
Fhem Cubitruck  Armbian Buster with Linux 5.3.9-sunxi
HM-CC_RT-DN, HM-Sec-RHS,HM-Sec-SD, HM-Sec-SCo,IT1500,1xIT GRR-3500 Fritz!Dect200,Powerline546E,Enigma2 Modul mit 3 Vu+,Wol Modul für WinServer2016 und WinServer 2019,FB6590
Allnetl Wandtablett mit FTUI

Offline frank

  • Hero Member
  • *****
  • Beiträge: 10684
Antw:HMLAN Adapter wechselt permanent zwischen disconnected / connected
« Antwort #46 am: 04 Dezember 2014, 16:19:35 »
Zitat
Das sieht mir so aus, alsob das Enigma2 Modul, iTunes, FBDect/FBSmartHome,HttpMod bei mir für verzögerungen sorgen!?
Interpretiere ich das richtig?
nicht wirklich.

entscheidend sind aktionen, die zur angegebenen zeit aktiv wurden.
Perfmon: possible freeze starting at 13:37:52, delay is 3.372also um 13:37:52. da ist dann aber nichts.

XBMC           XBMC_Ready   3014  12951    93219     7.20 HASH(0x3944c98) das ist auch nicht schön, aber eigentlich noch kein grund. ausserdem sind ja keine disconnects im log, während verbose=5.

dein netzwerk ist aber schon sehr aktiv. einfach weiter beobachten.
FHEM: 6.0(SVN) => Pi3(buster)
IO: CUL433|CUL868|HMLAN|HMUSB2|HMUART
CUL_HM: CC-TC|CC-VD|SEC-SD|SEC-SC|SEC-RHS|Sw1PBU-FM|Sw1-FM|Dim1TPBU-FM|Dim1T-FM|ES-PMSw1-Pl
IT: ITZ500|ITT1500|ITR1500|GRR3500
WebUI [HMdeviceTools.js (hm.js)]: https://forum.fhem.de/index.php/topic,106959.0.html

Offline Tommy82

  • Hero Member
  • *****
  • Beiträge: 2869
Antw:HMLAN Adapter wechselt permanent zwischen disconnected / connected
« Antwort #47 am: 04 Dezember 2014, 16:37:38 »
Hallo frank, ok Schade, hatte gehofft hätte schon mal ein paar Probleme identifiziert.

Ich hab XBMC jetzt mal deinstaliiert, mal sehen ob es jetzt besser wird.

An der CPU und Speicher auslastund solte es eigentlich nicht liegen
Zitat
Load average:    0.00 0.03 0.05
RAM:    Total: 1999.16 MB, Used: 72.30 MB, 3.62 %, Free: 1926.86 MB


Hab im Log aber immer noch einige Freetzer, werd das mal weiter beobachten
2014.12.04 15:59:39.102 1: Perfmon: possible freeze starting at 15:59:15, delay is 24.101
2014.12.04 15:59:42.720 1: Perfmon: possible freeze starting at 15:59:41, delay is 1.72
2014.12.04 16:07:11.009 1: Perfmon: possible freeze starting at 16:07:10, delay is 1.009
2014.12.04 16:08:41.081 1: Perfmon: possible freeze starting at 16:08:40, delay is 1.081
2014.12.04 16:10:11.007 1: Perfmon: possible freeze starting at 16:10:10, delay is 1.007
2014.12.04 16:13:15.179 1: Perfmon: possible freeze starting at 16:13:14, delay is 1.178
2014.12.04 16:14:47.222 1: Perfmon: possible freeze starting at 16:14:46, delay is 1.221
2014.12.04 16:16:19.494 1: Perfmon: possible freeze starting at 16:16:18, delay is 1.494
2014.12.04 16:17:51.439 1: Perfmon: possible freeze starting at 16:17:50, delay is 1.439
2014.12.04 16:19:23.392 1: Perfmon: possible freeze starting at 16:19:22, delay is 1.392
2014.12.04 16:20:55.447 1: Perfmon: possible freeze starting at 16:20:54, delay is 1.447
2014.12.04 16:22:11.110 1: Perfmon: possible freeze starting at 16:22:10, delay is 1.11
2014.12.04 16:22:27.502 1: Perfmon: possible freeze starting at 16:22:26, delay is 1.501
2014.12.04 16:23:59.570 1: Perfmon: possible freeze starting at 16:23:58, delay is 1.569
2014.12.04 16:25:31.716 1: Perfmon: possible freeze starting at 16:25:30, delay is 1.715
2014.12.04 16:26:58.535 1: Perfmon: possible freeze starting at 16:26:39, delay is 19.535
Fhem Cubitruck  Armbian Buster with Linux 5.3.9-sunxi
HM-CC_RT-DN, HM-Sec-RHS,HM-Sec-SD, HM-Sec-SCo,IT1500,1xIT GRR-3500 Fritz!Dect200,Powerline546E,Enigma2 Modul mit 3 Vu+,Wol Modul für WinServer2016 und WinServer 2019,FB6590
Allnetl Wandtablett mit FTUI

Offline Tommy82

  • Hero Member
  • *****
  • Beiträge: 2869
Antw:HMLAN Adapter wechselt permanent zwischen disconnected / connected
« Antwort #48 am: 05 Dezember 2014, 11:44:52 »
Kleine zwischen Meldung, hab zwar die ganze Nacht Meldungen im Log wie diese hier:
2014.12.05 00:00:03.981 1: Perfmon: possible freeze starting at 00:00:00, delay is 3.98
2014.12.05 00:00:18.065 1: Perfmon: possible freeze starting at 00:00:14, delay is 4.065
2014.12.05 00:00:32.010 1: Perfmon: possible freeze starting at 00:00:28, delay is 4.01
2014.12.05 00:00:46.059 1: Perfmon: possible freeze starting at 00:00:43, delay is 3.059
2014.12.05 00:01:00.118 1: Perfmon: possible freeze starting at 00:00:57, delay is 3.118
2014.12.05 00:01:14.080 1: Perfmon: possible freeze starting at 00:01:11, delay is 3.08
2014.12.05 00:01:28.160 1: Perfmon: possible freeze starting at 00:01:25, delay is 3.16
2014.12.05 00:01:42.120 1: Perfmon: possible freeze starting at 00:01:39, delay is 3.119
2014.12.05 00:01:56.139 1: Perfmon: possible freeze starting at 00:01:53, delay is 3.139
2014.12.05 00:02:10.321 1: Perfmon: possible freeze starting at 00:02:07, delay is 3.321
2014.12.05 00:02:17.650 1: Perfmon: possible freeze starting at 00:02:16, delay is 1.65
2014.12.05 00:02:24.238 1: Perfmon: possible freeze starting at 00:02:21, delay is 3.238
2014.12.05 00:02:26.286 1: Perfmon: possible freeze starting at 00:02:25, delay is 1.286
2014.12.05 00:02:38.294 1: Perfmon: possible freeze starting at 00:02:35, delay is 3.293
2014.12.05 00:02:52.220 1: Perfmon: possible freeze starting at 00:02:49, delay is 3.219
2014.12.05 00:03:06.240 1: Perfmon: possible freeze starting at 00:03:03, delay is 3.239
2014.12.05 00:03:20.354 1: Perfmon: possible freeze starting at 00:03:17, delay is 3.353
2014.12.05 00:03:34.279 1: Perfmon: possible freeze starting at 00:03:31, delay is 3.279

allerdings keine disconnects mehr, ich denke das mein Poblem das XBMC Modul war welches die disconnects ausgelöst hat, die jetzigen delays kann ich glaub ich erstmal ignorieren!?
Fhem Cubitruck  Armbian Buster with Linux 5.3.9-sunxi
HM-CC_RT-DN, HM-Sec-RHS,HM-Sec-SD, HM-Sec-SCo,IT1500,1xIT GRR-3500 Fritz!Dect200,Powerline546E,Enigma2 Modul mit 3 Vu+,Wol Modul für WinServer2016 und WinServer 2019,FB6590
Allnetl Wandtablett mit FTUI

Offline justme1968

  • Developer
  • Hero Member
  • ****
  • Beiträge: 21048
Antw:HMLAN Adapter wechselt permanent zwischen disconnected / connected
« Antwort #49 am: 05 Dezember 2014, 11:47:44 »
hast du für das xbmc modul das fork attribut gesetzt? sonst bleibt das modul hängen wenn der player aus ist.

gruss
  andre
FHEM5.4,DS1512+,2xCULv3,DS9490R,HMLAN,2xRasPi
CUL_HM:HM-LC-Bl1PBU-FM,HM-LC-Sw1PBU-FM,HM-SEC-MDIR,HM-SEC-RHS
HUEBridge,HUEDevice:LCT001,LLC001,LLC006,LWL001
OWDevice:DS1420,DS18B20,DS2406,DS2423
FS20:fs20as4,fs20bs,fs20di
AKCP:THS01,WS15
CUL_WS:S300TH

Offline strauch

  • Hero Member
  • *****
  • Beiträge: 1133
  • Anfänger :-)
Antw:HMLAN Adapter wechselt permanent zwischen disconnected / connected
« Antwort #50 am: 05 Dezember 2014, 12:02:31 »
Ich hab kein fork gesetzt und bei mir schmiert auch nichts ab?!
FHEM 5.6 VMware mit Debian. 1 CUL für FS20 und HMLAN für Homematic, HM-CC-RT-DN, HM-LC_Sw1PBU-FM, HM-LC-Bl1PBU-FM,  HM-SEC-SC, HM-SEC-SC-2, HM-LC-Sw1-Pl2, HM-Sec-RHS, ASH2200, FHT80B, S20KSE, Sonos, XBMC, FB_Callmonitor, SMLUSB, Arduino Firmata, uvm.

Offline justme1968

  • Developer
  • Hero Member
  • ****
  • Beiträge: 21048
Antw:HMLAN Adapter wechselt permanent zwischen disconnected / connected
« Antwort #51 am: 05 Dezember 2014, 12:06:04 »
wo steht etwas von anschmieren?
FHEM5.4,DS1512+,2xCULv3,DS9490R,HMLAN,2xRasPi
CUL_HM:HM-LC-Bl1PBU-FM,HM-LC-Sw1PBU-FM,HM-SEC-MDIR,HM-SEC-RHS
HUEBridge,HUEDevice:LCT001,LLC001,LLC006,LWL001
OWDevice:DS1420,DS18B20,DS2406,DS2423
FS20:fs20as4,fs20bs,fs20di
AKCP:THS01,WS15
CUL_WS:S300TH

Offline strauch

  • Hero Member
  • *****
  • Beiträge: 1133
  • Anfänger :-)
Antw:HMLAN Adapter wechselt permanent zwischen disconnected / connected
« Antwort #52 am: 05 Dezember 2014, 12:20:12 »
Was meinst du dann mit "bleibt" das Modul hängen? Ich hatte mit bleib hängen verstanden, dass es quasi nicht mehr funktioniert: Umgangsprachlich quasi absturz. Ich will jetzt keine Haare spalten, scheinbar hab ich dich falsch verstanden?
FHEM 5.6 VMware mit Debian. 1 CUL für FS20 und HMLAN für Homematic, HM-CC-RT-DN, HM-LC_Sw1PBU-FM, HM-LC-Bl1PBU-FM,  HM-SEC-SC, HM-SEC-SC-2, HM-LC-Sw1-Pl2, HM-Sec-RHS, ASH2200, FHT80B, S20KSE, Sonos, XBMC, FB_Callmonitor, SMLUSB, Arduino Firmata, uvm.

Offline Tommy82

  • Hero Member
  • *****
  • Beiträge: 2869
Antw:HMLAN Adapter wechselt permanent zwischen disconnected / connected
« Antwort #53 am: 05 Dezember 2014, 12:25:03 »
Hi, ich bin mir relativ sicher das ich das fork Attribut gesetzt hatte, kann es aber nicht 100% garantieren da ich das xbmc Modul erstmal gelöscht hab.
Und seit dem sind auf jeden Fall meine disconnects weg.
Fhem Cubitruck  Armbian Buster with Linux 5.3.9-sunxi
HM-CC_RT-DN, HM-Sec-RHS,HM-Sec-SD, HM-Sec-SCo,IT1500,1xIT GRR-3500 Fritz!Dect200,Powerline546E,Enigma2 Modul mit 3 Vu+,Wol Modul für WinServer2016 und WinServer 2019,FB6590
Allnetl Wandtablett mit FTUI

Offline justme1968

  • Developer
  • Hero Member
  • ****
  • Beiträge: 21048
Antw:HMLAN Adapter wechselt permanent zwischen disconnected / connected
« Antwort #54 am: 05 Dezember 2014, 12:45:33 »
bleibt hängen heisst das es verzögerungen beim verbundungsazfbau gibt und fhem regelmässig mehrere sekunden hängen bleibt. genau um das zu vermeiden gibt es ja das fork attribut.
FHEM5.4,DS1512+,2xCULv3,DS9490R,HMLAN,2xRasPi
CUL_HM:HM-LC-Bl1PBU-FM,HM-LC-Sw1PBU-FM,HM-SEC-MDIR,HM-SEC-RHS
HUEBridge,HUEDevice:LCT001,LLC001,LLC006,LWL001
OWDevice:DS1420,DS18B20,DS2406,DS2423
FS20:fs20as4,fs20bs,fs20di
AKCP:THS01,WS15
CUL_WS:S300TH

Offline strauch

  • Hero Member
  • *****
  • Beiträge: 1133
  • Anfänger :-)
Antw:HMLAN Adapter wechselt permanent zwischen disconnected / connected
« Antwort #55 am: 05 Dezember 2014, 13:24:07 »
Danke für die Info

Gesendet von meinem Smartphone

FHEM 5.6 VMware mit Debian. 1 CUL für FS20 und HMLAN für Homematic, HM-CC-RT-DN, HM-LC_Sw1PBU-FM, HM-LC-Bl1PBU-FM,  HM-SEC-SC, HM-SEC-SC-2, HM-LC-Sw1-Pl2, HM-Sec-RHS, ASH2200, FHT80B, S20KSE, Sonos, XBMC, FB_Callmonitor, SMLUSB, Arduino Firmata, uvm.

Offline Tommy82

  • Hero Member
  • *****
  • Beiträge: 2869
Antw:HMLAN Adapter wechselt permanent zwischen disconnected / connected
« Antwort #56 am: 05 Januar 2015, 21:06:14 »
Hi, hab heute plötzlich den Log wieder voll mit
2015.01.05 00:00:00.864 1: HMLAN_Parse: HmLanAdapter new condition timeout
2015.01.05 00:00:00.887 1: 192.168.188.27:1000 disconnected, waiting to reappear (HmLanAdapter)
2015.01.05 00:00:00.891 1: HMLAN_Parse: HmLanAdapter new condition disconnected
2015.01.05 00:01:05.662 1: 192.168.188.27:1000 reappeared (HmLanAdapter)
2015.01.05 00:01:05.670 1: HMLAN_Parse: HmLanAdapter new condition init
2015.01.05 00:01:05.779 1: HMLAN_Parse: HmLanAdapter new condition ok
2015.01.05 00:08:38.117 1: HMLAN_Parse: HmLanAdapter new condition timeout
2015.01.05 00:08:38.146 1: 192.168.188.27:1000 disconnected, waiting to reappear (HmLanAdapter)
2015.01.05 00:08:38.151 1: HMLAN_Parse: HmLanAdapter new condition disconnected
2015.01.05 00:09:40.131 1: 192.168.188.27:1000 reappeared (HmLanAdapter)
2015.01.05 00:09:40.136 1: HMLAN_Parse: HmLanAdapter new condition init
2015.01.05 00:09:40.235 1: HMLAN_Parse: HmLanAdapter new condition ok
2015.01.05 00:29:52.827 1: HMLAN_Parse: HmLanAdapter new condition timeout
2015.01.05 00:29:52.847 1: 192.168.188.27:1000 disconnected, waiting to reappear (HmLanAdapter)
2015.01.05 00:29:52.852 1: HMLAN_Parse: HmLanAdapter new condition disconnected
2015.01.05 00:30:59.438 1: 192.168.188.27:1000 reappeared (HmLanAdapter)
2015.01.05 00:30:59.446 1: HMLAN_Parse: HmLanAdapter new condition init
2015.01.05 00:30:59.663 1: HMLAN_Parse: HmLanAdapter new condition ok
2015.01.05 00:59:13.037 1: HMLAN_Parse: HmLanAdapter new condition timeout
2015.01.05 00:59:13.056 1: 192.168.188.27:1000 disconnected, waiting to reappear (HmLanAdapter)
2015.01.05 00:59:13.060 1: HMLAN_Parse: HmLanAdapter new condition disconnected
2015.01.05 01:00:19.701 1: 192.168.188.27:1000 reappeared (HmLanAdapter)
2015.01.05 01:00:19.708 1: HMLAN_Parse: HmLanAdapter new condition init
2015.01.05 01:00:34.546 1: HMLAN_Parse: HmLanAdapter new condition ok
2015.01.05 01:00:43.741 1: HMLAN_Parse: HmLanAdapter new condition timeout
2015.01.05 01:00:43.761 1: 192.168.188.27:1000 disconnected, waiting to reappear (HmLanAdapter)

Das letzte mal wo ich soviele Meldungen dazu hatte ist ca. 1 Monat her, und habe auch zumindest gestern und vorgestern keine Updates eingespielt, und heute dann plötzlich wieder jede Menge disconnect....,
mal abwarten was morgen passiert
Fhem Cubitruck  Armbian Buster with Linux 5.3.9-sunxi
HM-CC_RT-DN, HM-Sec-RHS,HM-Sec-SD, HM-Sec-SCo,IT1500,1xIT GRR-3500 Fritz!Dect200,Powerline546E,Enigma2 Modul mit 3 Vu+,Wol Modul für WinServer2016 und WinServer 2019,FB6590
Allnetl Wandtablett mit FTUI

Offline martinp876

  • Moderator
  • Hero Member
  • ***
  • Beiträge: 11085
Antw:HMLAN Adapter wechselt permanent zwischen disconnected / connected
« Antwort #57 am: 06 Januar 2015, 09:52:21 »
Ist eintimeout, wie du sehen kannst. Irgendwer blockiert. Netzwerk, cpu oder fhem. Ich wuerde mit fhem anfangen. Kann auch dein netz sein.....

Offline ollir

  • Full Member
  • ***
  • Beiträge: 174
Antw:HMLAN Adapter wechselt permanent zwischen disconnected / connected
« Antwort #58 am: 07 Januar 2015, 08:46:29 »
Hallo,
ich hatte auch ständig diconnects. Immer wenn ich eine Seite mit vielen SVGs aufgerufen habe.
Durch andere Netzwerkprobleme (verzögertes aufrufen der Webseite, timeouts TW etc.)
habe ich meine WLAN einstellungen kontrolliert.
Standart ist beim RPi Weezey PowerSave on (o.ä.)

Über
Zitat
sudo iwconfig wlan0 power off
habe ich den Modus ausgeschaltet.

Seitdem keine disconnects und keine Probleme beim Verbindungsaufbau.

Vieleicht mal checken

Vg
« Letzte Änderung: 07 Januar 2015, 09:10:57 von ollir »

Offline Tommy82

  • Hero Member
  • *****
  • Beiträge: 2869
HMLAN Adapter wechselt permanent zwischen disconnected / connected
« Antwort #59 am: 07 Januar 2015, 08:54:17 »
Also wenn ich das jetzt richtig versteh hast du das wlan am pie worauf fhem läuft einfach deaktiviert? Kann ich natürlich auch mal versuchen, da ich eh alles über lan mache.
Es ist auch seltsam, Gesten z.b hatte ich über den ganzen Tag nur 5 disconnect, denke das ist durchaus vertretbar. Mal sehn wie es heute aussieht.
Werd dann heut Abend mal das wlan deaktivieren
« Letzte Änderung: 07 Januar 2015, 08:56:10 von Tommy82 »
Fhem Cubitruck  Armbian Buster with Linux 5.3.9-sunxi
HM-CC_RT-DN, HM-Sec-RHS,HM-Sec-SD, HM-Sec-SCo,IT1500,1xIT GRR-3500 Fritz!Dect200,Powerline546E,Enigma2 Modul mit 3 Vu+,Wol Modul für WinServer2016 und WinServer 2019,FB6590
Allnetl Wandtablett mit FTUI

 

decade-submarginal