Autor Thema: Änderungen an Modul KS300.pm?  (Gelesen 7853 mal)

Offline tetzlav

  • Jr. Member
  • **
  • Beiträge: 62
Änderungen an Modul KS300.pm?
« am: 28 Februar 2014, 15:07:34 »
Hallo,

ich habe vorgestern ein update des fhem auf der Fritzbox gemacht und jetzt zeigt der log und acu die plots der Wetterstation KS300 nur noch Mist.

Im log ist zu sehen, dass sich auch das Format geändert hat:
2014-02-26_21:11:02 KS300 T: 7.8  H: 74  W: 0.8  R: 585.7  IR: no
2014-02-26_21:13:35 KS300 T: 7.8  H: 74  W: 0.5  R: 585.7  IR: no
2014-02-26_21:16:07 KS300 T: 7.8  H: 74  W: 0.2  R: 585.7  IR: no
2014-02-26_21:18:40 KS300 T: 7.7  H: 74  W: 0.0  R: 585.7  IR: no
2014-02-26_21:23:45 KS300 T: 7.6  H: 74  W: 0.0  R: 585.7  IR: no
------------------------------- update --------------------------------------
2014-02-26_21:36:28 KS300 T: 7.6  H: 74  W: 0.0  R: 0.0  IR: yes  Wi: 0
2014-02-26_21:39:00 KS300 T: 7.6  H: 74  W: 0.0  R: -585.7  IR: yes  Wi: 0
2014-02-26_21:41:33 KS300 T: 7.6  H: 74  W: 0.0  R: -1171.5  IR: yes  Wi: 0
2014-02-26_21:49:10 KS300 T: 7.6  H: 74  W: 0.0  R: -1757.2  IR: yes  Wi: 0
2014-02-26_21:51:43 KS300 T: 7.6  H: 74  W: 0.0  R: -2342.9  IR: yes  Wi: 0
2014-02-26_21:54:15 KS300 T: 7.6  H: 74  W: 0.0  R: -2928.7  IR: yes  Wi: 0

Es regnet nur noch :( die Regenmenge wird ins Negative kummuliert und ein neues Reading "Wi" ??? ist aufgetaucht. Das passt leider auch so gar nicht zu meinen liebevollen gplot-Definitionen.  :-\

Ist das gewollt oder ein Käfer?
Am Code des Moduls  wurde ja bisschen was gebastelt...

Offline rudolfkoenig

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 19491
Antw:Änderungen an Modul KS300.pm?
« Antwort #1 am: 28 Februar 2014, 15:51:35 »
Wi gibts, weil manche die Windgeschwindigkeit zusaetzlich als Beaufort angezeigt haben wollen. Wenn ich so nachdenke, meine ich, es waere besser diese Umrechnung direkt im SVG zu machen. Bei mir laeuft die geaenderte KS300.pm seit 11 Tagen ohne Probleme, ich vermute also, dass die negativen Werte eine andere Ursache haben.

Offline schka17

  • Sr. Member
  • ****
  • Beiträge: 845
Antw:Änderungen an Modul KS300.pm?
« Antwort #2 am: 28 Februar 2014, 16:02:29 »
Hallo,

Ich habe leider dasselbe Problem, es regnet andauernd und unmögliche negative Rengenmengen. Ich bin nur leider nicht dazugekommen das genauer zu analysieren, aber da dieser beitrag geschrieben wurde hänge ich mich gleich dran. Dieses Problem trat nach einem Update vomvorletzen wochenende auf.


Sent from my iPad using Tapatalk
M: Thinclient x64 Debian | CUL FS20, HMS100WD, HMS100TF, HMS100T, HMS100CO, S300, S555TH | OWServer DS1420, DS18B20, DS2408 | RFXCOM UVN128, THWR800, THGR228N,RTGR328, PCR800 |Jeelink PCA301 EC3000|CUNO+IR|HMLAN|HMUSB|CUL433 Somfy|mySensors|espEasy
S1:Raspberry mit BPM810, Jeelink EC3000

Offline betateilchen

  • Developer
  • Hero Member
  • ****
  • Beiträge: 15263
  • s/fhem\.cfg/configDB/g
Antw:Änderungen an Modul KS300.pm?
« Antwort #3 am: 28 Februar 2014, 16:28:32 »
Mit der Regenmengenberechnung hat Wi aber ursächlich nichts zu tun.

Und Wi wurde genau deshalb ganz an Ende von "state" angehängt (und nicht direkt nach der Windgeschwindigkeit) damit bestehende gplot-Definitionen nicht beeinflusst werden.

Also am neuen Reading einfach nicht stören.

@Rudi: hattest Du nicht nach der Wi-Implementation nochmal irgendwas geändert, was vielleicht ursächlich sein könnte?

KS300: use hex for newer perl versions
-----------------------
Unaufgeforderte Anfragen per email werden von mir nicht beantwortet. Dafür ist das Forum da.
-----------------------
Nächster Hamburg-Stammtisch: 14.12.2018 - 18:30 Uhr

Offline betateilchen

  • Developer
  • Hero Member
  • ****
  • Beiträge: 15263
  • s/fhem\.cfg/configDB/g
Antw:Änderungen an Modul KS300.pm?
« Antwort #4 am: 28 Februar 2014, 16:32:13 »
Wenn ich so nachdenke, meine ich, es waere besser diese Umrechnung direkt im SVG zu machen.

Die Anforderung für die Änderung war aber, die umgerechnete Windgeschwindigkeit als reading zu haben. Da hilft es nix, wenn das im SVG errechnet wird.
-----------------------
Unaufgeforderte Anfragen per email werden von mir nicht beantwortet. Dafür ist das Forum da.
-----------------------
Nächster Hamburg-Stammtisch: 14.12.2018 - 18:30 Uhr

Offline rudolfkoenig

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 19491
Antw:Änderungen an Modul KS300.pm?
« Antwort #5 am: 28 Februar 2014, 16:55:58 »
Zitat
KS300: use hex for newer perl versions   

Wenn ueberhaupt, dann sollte das nur das Vorzeichen der Temperatur betreffen.

Zitat
Die Anforderung für die Änderung war aber, die umgerechnete Windgeschwindigkeit als reading zu haben

Sowas kann man auch mit userReadings machen, jedenfalls seit der Umstellung auf readings*Update :)
Wir sollten es aber erstmal dabei lassen, ich sehe keinen wirklichen Grund fuers entfernen von Wi.

Offline betateilchen

  • Developer
  • Hero Member
  • ****
  • Beiträge: 15263
  • s/fhem\.cfg/configDB/g
Antw:Änderungen an Modul KS300.pm?
« Antwort #6 am: 28 Februar 2014, 16:59:49 »
Andere Frage: Hattest Du in dem originalen Modifikationsthread schon gesehen dass es noch ein kleines Problem gibt?

http://forum.fhem.de/index.php/topic,20281.msg142714.html#msg142714

    my %repchanged = ("rain"=>1, "wind"=>1, "humidity"=>1, "temperature"=>1,
        "israining"=>1);

In der Liste fehlt der Wi, was dazu führt, dass eine Änderung kein readingsUpdate auslöst.
-----------------------
Unaufgeforderte Anfragen per email werden von mir nicht beantwortet. Dafür ist das Forum da.
-----------------------
Nächster Hamburg-Stammtisch: 14.12.2018 - 18:30 Uhr

Offline rudolfkoenig

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 19491
Antw:Änderungen an Modul KS300.pm?
« Antwort #7 am: 28 Februar 2014, 17:02:10 »
Das ist aus meiner Sicht kein Problem sondern Feature, wollte nicht noch mehr "Unsinn" als Event durch die Gegend schicken :)
Benoetigt ihr das wirklich?

Offline betateilchen

  • Developer
  • Hero Member
  • ****
  • Beiträge: 15263
  • s/fhem\.cfg/configDB/g
Antw:Änderungen an Modul KS300.pm?
« Antwort #8 am: 28 Februar 2014, 17:10:18 »
Das Problem ist - wie aaO spezifisch beschrieben - dass nicht nur der Event nicht kommt (das wäre nicht schlimm), sondern das Reading komplett fehlt, wenn Wi in repchanged fehlt:


    for(my $i = 0; $i < $max; $i++) {
      readingsBulkUpdate($def, $txt[$i], $v[$i])
                if(defined($repchanged{$txt[$i]}));
    }


Wi steckt nämlich in $v[9]
« Letzte Änderung: 28 Februar 2014, 17:14:34 von betateilchen »
-----------------------
Unaufgeforderte Anfragen per email werden von mir nicht beantwortet. Dafür ist das Forum da.
-----------------------
Nächster Hamburg-Stammtisch: 14.12.2018 - 18:30 Uhr

Offline schka17

  • Sr. Member
  • ****
  • Beiträge: 845
Antw:Änderungen an Modul KS300.pm?
« Antwort #9 am: 28 Februar 2014, 20:23:12 »
Hallo nochmal,

das reading stört mich nicht, nur das seit dem update von 13_KS300.pm am 23.2.2014 die regenwerte nicht mehr stimmen (und es scheinbar dauernd regnet, da muss man ja trübsinnig werden:-) :

2014-02-23_19:58:07 Outdoor_Weather T: 4.6  H: 60  W: 0.0  R: -7643.6  IR: yes  Wi: 0
2014-02-23_19:47:57 Outdoor_Weather T: 4.7  H: 59  W: 0.0  R: -6948.8  IR: yes  Wi: 0
2014-02-23_19:40:19 Outdoor_Weather T: 4.8  H: 58  W: 0.0  R: -6253.9  IR: yes  Wi: 0
2014-02-23_19:35:14 Outdoor_Weather T: 4.8  H: 58  W: 0.0  R: -5559.0  IR: yes  Wi: 0
2014-02-23_19:32:42 Outdoor_Weather T: 4.9  H: 58  W: 0.0  R: -4864.1  IR: yes  Wi: 0
2014-02-23_19:19:59 Outdoor_Weather T: 4.9  H: 58  W: 0.0  R: -4169.2  IR: yes  Wi: 0
2014-02-23_19:17:27 Outdoor_Weather T: 4.9  H: 58  W: 0.0  R: -3474.4  IR: yes  Wi: 0
2014-02-23_19:09:50 Outdoor_Weather T: 5.3  H: 57  W: 0.0  R: -2779.5  IR: yes  Wi: 0
2014-02-23_19:07:17 Outdoor_Weather T: 5.4  H: 57  W: 0.0  R: -2084.6  IR: yes  Wi: 0
2014-02-23_19:04:44 Outdoor_Weather T: 5.5  H: 57  W: 0.0  R: -1389.8  IR: yes  Wi: 0
2014-02-23_19:02:11 Outdoor_Weather T: 5.6  H: 57  W: 0.0  R: -694.9  IR: yes  Wi: 0
2014-02-23_18:59:47 Outdoor_Weather T: 5.8  H: 56  W: 0.0  R: 0.0  IR: yes  Wi: 0
2014-02-23_18:57:07 Outdoor_Weather T: 5.9  H: 56  W: 0.0  R: 694.9  IR: no
2014-02-23_18:41:51 Outdoor_Weather T: 6.6  H: 54  W: 0.0  R: 694.9  IR: no
2014-02-23_18:39:19 Outdoor_Weather T: 6.6  H: 54  W: 0.2  R: 694.9  IR: no
2014-02-23_18:36:46 Outdoor_Weather T: 6.1  H: 55  W: 0.2  R: 694.9  IR: no
2014-02-23_18:31:41 Outdoor_Weather T: 6.2  H: 53  W: 0.0  R: 694.9  IR: no
2014-02-23_18:26:36 Outdoor_Weather T: 6.6  H: 53  W: 0.0  R: 694.9  IR: no
2014-02-23_18:24:04 Outdoor_Weather T: 6.7  H: 53  W: 0.0  R: 694.9  IR: no
2014-02-23_18:16:26 Outdoor_Weather T: 6.9  H: 52  W: 0.0  R: 694.9  IR: no
2014-02-23_18:13:54 Outdoor_Weather T: 7.0  H: 52  W: 0.0  R: 694.9  IR: no
2014-02-23_18:11:21 Outdoor_Weather T: 7.2  H: 52  W: 0.0  R: 694.9  IR: no
2014-02-23_18:06:16 Outdoor_Weather T: 7.6  H: 51  W: 0.0  R: 694.9  IR: no
2014-02-23_18:03:44 Outdoor_Weather T: 7.8  H: 49  W: 0.0  R: 694.9  IR: no
2014-02-23_17:58:39 Outdoor_Weather T: 8.1  H: 49  W: 0.0  R: 694.9  IR: no

hab jetzt mal ein älteres KS300.pm zurückkopiert, jetzt hats mal zu regnen aufgehört, aber wie kann ich jetzt die ganzen falsch regenmenge zurücksetzen?

danke u gruss

Karl
M: Thinclient x64 Debian | CUL FS20, HMS100WD, HMS100TF, HMS100T, HMS100CO, S300, S555TH | OWServer DS1420, DS18B20, DS2408 | RFXCOM UVN128, THWR800, THGR228N,RTGR328, PCR800 |Jeelink PCA301 EC3000|CUNO+IR|HMLAN|HMUSB|CUL433 Somfy|mySensors|espEasy
S1:Raspberry mit BPM810, Jeelink EC3000

Offline betateilchen

  • Developer
  • Hero Member
  • ****
  • Beiträge: 15263
  • s/fhem\.cfg/configDB/g
Antw:Änderungen an Modul KS300.pm?
« Antwort #10 am: 28 Februar 2014, 20:41:42 »
hab jetzt mal ein älteres KS300.pm zurückkopiert, jetzt hats mal zu regnen aufgehört, aber wie kann ich jetzt die ganzen falsch regenmenge zurücksetzen?

Da Du den alten Wert ja noch im Log hast, kannst Du den vermutlich einfach per setreading() wieder zurückschreiben. (Nur eine Vermutung, da ich das Modul selbst nicht nutze)
-----------------------
Unaufgeforderte Anfragen per email werden von mir nicht beantwortet. Dafür ist das Forum da.
-----------------------
Nächster Hamburg-Stammtisch: 14.12.2018 - 18:30 Uhr

Offline rudolfkoenig

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 19491
Antw:Änderungen an Modul KS300.pm?
« Antwort #11 am: 01 März 2014, 08:37:31 »
@betateilchen: habs (hoffentlich jetzt richtig) gefixed und eingecheckt.
@tezlav/@schka17: ihr habt vermutlich beide das Attribut "rainadjustment" gesetzt, und ich vermute, dass durch das gerade behobene Problem die negativen Werte reinkommen. Soweit ich es sehe, muss man, um das Problem zu fixen, die KS300 readings in der fhem.state Datei vor dem Neustart entfernen. Was ich noch nicht verstehe ist, wieso das beim Einspielen der alten Version nicht notwendig war.

Das Log selber wuerde ich mit dem Editor fixen, und danach entweder fhem neustarten, oder im FileLog "reopen" setzen.

Offline tetzlav

  • Jr. Member
  • **
  • Beiträge: 62
Antw:Änderungen an Modul KS300.pm?
« Antwort #12 am: 01 März 2014, 11:19:28 »
@tezlav/@schka17: ihr habt vermutlich beide das Attribut "rainadjustment" gesetzt, und ich vermute, dass durch das gerade behobene Problem die negativen Werte reinkommen. Soweit ich es sehe, muss man, um das Problem zu fixen, die KS300 readings in der fhem.state Datei vor dem Neustart entfernen. Was ich noch nicht verstehe ist, wieso das beim Einspielen der alten Version nicht notwendig war.

Genau so wars. "rainadjustment" deaktiviert (warum auch immer das Attribut gesetzt war?), mit sed über das logfile sed -ie 's/R: -[0-9]\+.[0-9]\+  IR: yes/R: 585.7  IR: no/g' log/KS300-2014.log und Neustart, und schon ist das Wetter wieder schön...

Online det.

  • Hero Member
  • *****
  • Beiträge: 1101
Antw:Änderungen an Modul KS300.pm?
« Antwort #13 am: 01 März 2014, 13:21:13 »
Soweit ich es sehe, muss man, um das Problem zu fixen, die KS300 readings in der fhem.state Datei vor dem Neustart entfernen. Was ich noch nicht verstehe ist, wieso das beim Einspielen der alten Version nicht notwendig war.
Vielen Dank! Soeben genau so gemacht - und funktioniert perfekt.
l.g. det.

Offline Michael

  • Full Member
  • ***
  • Beiträge: 442
  • Rechtschreibfehler dürfen Behalten werden!
Antw:Änderungen an Modul KS300.pm?
« Antwort #14 am: 23 März 2014, 12:46:27 »
Moin

Nun bin ich wohl auch vom rainadjustment Betroffen.

Zitat
Zitat von: rudolfkoenig am 01 März 2014, 08:37:31
.... , um das Problem zu fixen, die KS300 readings in der fhem.state Datei vor dem Neustart entfernen ...
Zitat
sed -ie 's/R: -[0-9]\+.[0-9]\+  IR: yes/R: 585.7  IR: no/g' log/KS300-2014.log
Und bekomme es mit den beiden Varianten nicht im Griff.

Kann mir jemand eine Anleitung für Dummies geben?  :o
Gruß, Michael

FHEM 5.9 auf RPi 3
CUL V3 868 Mhz | JeeLink LaCrosse & PCA301
FS20 ST-2/3 | BMP085(180) | 14x TX29DTH-IT | 2x TX25IT/Helligkeitssensor | 5x PCA 301 | SMA Peripheries | MobileAlerts MA-10(100,120PRO,200,251,410,650,660,800)

Offline betateilchen

  • Developer
  • Hero Member
  • ****
  • Beiträge: 15263
  • s/fhem\.cfg/configDB/g
Antw:Änderungen an Modul KS300.pm?
« Antwort #15 am: 23 März 2014, 13:00:58 »
hast Du das rainadjustment auch deaktiviert?
-----------------------
Unaufgeforderte Anfragen per email werden von mir nicht beantwortet. Dafür ist das Forum da.
-----------------------
Nächster Hamburg-Stammtisch: 14.12.2018 - 18:30 Uhr

Offline Michael

  • Full Member
  • ***
  • Beiträge: 442
  • Rechtschreibfehler dürfen Behalten werden!
Antw:Änderungen an Modul KS300.pm?
« Antwort #16 am: 23 März 2014, 13:30:54 »
Ich denke schon.  :-[

Habe auch extra ein neues Decive angelegt.
Gruß, Michael

FHEM 5.9 auf RPi 3
CUL V3 868 Mhz | JeeLink LaCrosse & PCA301
FS20 ST-2/3 | BMP085(180) | 14x TX29DTH-IT | 2x TX25IT/Helligkeitssensor | 5x PCA 301 | SMA Peripheries | MobileAlerts MA-10(100,120PRO,200,251,410,650,660,800)

Offline tupol

  • Developer
  • Hero Member
  • ****
  • Beiträge: 1379
  • Wiki lesen hilft. Support geb ich im Forum.
Tages-Regenmenge fehlt
« Antwort #17 am: 25 März 2014, 15:27:10 »
Bei mir wird seit kurzem der Regenwert im Reading avg_day nicht mehr aktualisiert. D.h. der Mitternachtswert bleibt unverändert.

avg_day   T: 2.8 H: 78 W: 0.0 R: 0.0   2014-03-25 00:00:08 
FHEM 5.5 auf RPi B Rev.2 (mit LCD4Linux, BMP180 und CUL v3 868.35 MHz), FB7490, Fritz!DECT 200, FS20, FHT80TF-2, S300TH, KS300, Homematic, PRESENCE
Modul-Entwickler von: FRITZBOX, statistics, PROPLANTA, OPENWEATHER, JSONMETER, LUXTRONIK2

Offline Michael

  • Full Member
  • ***
  • Beiträge: 442
  • Rechtschreibfehler dürfen Behalten werden!
Antw:Änderungen an Modul KS300.pm?
« Antwort #18 am: 18 April 2014, 19:07:38 »
Moin

Nach vielen Versuchen das Problem in den Griff zubekommen bin ich kurz vorm aufgeben.

Habe das Device KS300 neu angelegt.

 - erste mal mit autocreate
 - zweite mal per Hand in die Fhem.cfg geschrieben mit dem attr rainadjustment 0
 - dritte mal per Hand in die Fhem.cfg geschrieben mit dem attr rainadjustment 1

Die Werte wurden jedesmal aus der fhem.save gelöscht.
Updates sind jeden Tag gemacht wurden.  (# $Id: 13_KS300.pm 5545 2014-04-17 20:08:54Z rudolfkoenig $)

Was mir aufgefallen ist, ist das die Werte unregelmäßig an kommen.
Batterien sind gewechselt wurden.

2014.04.18 18:16:00 4: KS300 1234: 810d04xx4027a0017127048000010f
2014.04.18 18:16:00 4: KS300 1234: T: 7.2  H: 84  W: 0.0  R: 4.1  IR: yes  Wi: 0
2014.04.18 18:18:32 4: KS300 1234: 810d04xx4027a0017117048000110f
2014.04.18 18:18:32 4: KS300 1234: T: 7.1  H: 84  W: 0.0  R: 4.3  IR: yes  Wi: 0
2014.04.18 18:23:37 4: KS300 1234: 810d04xx4027a0017107058000110f
2014.04.18 18:23:37 4: KS300 1234: T: 7.0  H: 85  W: 0.0  R: 4.3  IR: no  Wi: 0
2014.04.18 18:28:42 4: KS300 1234: 810d04xx4027a00171960580001108
2014.04.18 18:28:42 4: KS300 1234: T: 6.9  H: 85  W: 0.0  R: 4.3  IR: no  Wi: 0
2014.04.18 18:33:47 4: KS300 1234: 810d04xx4027a00171070680002102
2014.04.18 18:33:47 4: KS300 1234: T: 7.0  H: 86  W: 0.0  R: 4.6  IR: yes  Wi: 0
2014.04.18 18:43:57 4: KS300 1234: 810d04xx4027a00171370680003106
2014.04.18 18:43:57 4: KS300 1234: T: 7.3  H: 86  W: 0.0  R: 4.8  IR: yes  Wi: 0
2014.04.18 18:49:02 4: KS300 1234: 810d04xx4027a00171370680005108
2014.04.18 18:49:02 4: KS300 1234: T: 7.3  H: 86  W: 0.0  R: 5.4  IR:

Was ist bei mir los. Bitte um Hilfe.  :'(
Gruß, Michael

FHEM 5.9 auf RPi 3
CUL V3 868 Mhz | JeeLink LaCrosse & PCA301
FS20 ST-2/3 | BMP085(180) | 14x TX29DTH-IT | 2x TX25IT/Helligkeitssensor | 5x PCA 301 | SMA Peripheries | MobileAlerts MA-10(100,120PRO,200,251,410,650,660,800)

Offline rudolfkoenig

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 19491
Antw:Änderungen an Modul KS300.pm?
« Antwort #19 am: 19 April 2014, 07:56:15 »
Zitat
Was ist bei mir los.

Das "nicht klar beschreiben, was fehlt" Syndrom. Das Problem mit rainadjustments war doch, dass man negative Werte bekommen hat, in deine Liste sehe ich nur positive Werte. Dass die Werte nicht regelmaessig kommen, ist aus normal, es gibt diverse Massnahmen den Empfang zu verbessern, wie bessere Antennen, Anpassung der relativen Position der Antennen, Frequenz-Tuning, CUL_RFR, etc. Ein Empfang der Daten alle 10 Minuten ist aber meiner Ansicht nach auch voellig ausreichend.

Offline Noname

  • Full Member
  • ***
  • Beiträge: 123
Antw:Änderungen an Modul KS300.pm?
« Antwort #20 am: 19 April 2014, 09:24:03 »
Hallo rudolfkoenig,

ich hatte vor längerer Zeit das Modul optimiert.
Mittelwertbildung der Windgeschwindigkeit und Regenmenge / Tag
vielleicht wollen sie diese Funktionen mit übernehmen?


Auch wenn's nicht hierher passt, vielleicht hat jemand Interesse:
Ich habe das FS20 Modul erweitert, um Füllstände, Messwerte, Meldungen zu verarbeiten
z.B. S0Schnittstelle von Stromzählern. (Cul Firmware braucht nicht verändert werden)
Grundvoraussetzung ist das Modul FS20S8M mit neuster Version der Spezialfirmware V1.40

Schöne Ostern


Offline Michael

  • Full Member
  • ***
  • Beiträge: 442
  • Rechtschreibfehler dürfen Behalten werden!
Antw:Änderungen an Modul KS300.pm?
« Antwort #21 am: 19 April 2014, 11:42:34 »
Hallo rudolfkoenig

Zitat
Das "nicht klar beschreiben, was fehlt"
Sorry, meine Schlud.  :-[

Das Problem ist, das ich im Reading rain an den folge Tag immer noch der Wert vom vor Tag ist.

Zitat
Ein Empfang der Daten alle 10 Minuten ist aber meiner Ansicht nach auch voellig ausreichend.
Sehe ich auch so. Aber bei mir kommen die Daten Unterschiedlich.

Zitat
Anpassung der relativen Position der Antennen, Frequenz-Tuning, ...
Da hat sich nichts geändert.

Schöne Osterfeiertag
Gruß, Michael

FHEM 5.9 auf RPi 3
CUL V3 868 Mhz | JeeLink LaCrosse & PCA301
FS20 ST-2/3 | BMP085(180) | 14x TX29DTH-IT | 2x TX25IT/Helligkeitssensor | 5x PCA 301 | SMA Peripheries | MobileAlerts MA-10(100,120PRO,200,251,410,650,660,800)

Offline stromer-12

  • Hero Member
  • *****
  • Beiträge: 1349
Antw:Änderungen an Modul KS300.pm?
« Antwort #22 am: 19 April 2014, 19:03:42 »
Ich musste bei mir die Bandbreite etwas größer einstellen, damit ich die Werte regelmäßiger reinbekomme.
FHEM 5.9(SVN) auf cubietruck mit HMUSB
FHEM 5.9(SVN) auf RPi1B mit HMser | CUNO
FHEM 5.9(SVN) virtuell mit HMLAN | CUL

Offline rudolfkoenig

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 19491
Antw:Änderungen an Modul KS300.pm?
« Antwort #23 am: 19 April 2014, 19:27:18 »
@Michael:
Zitat
Das Problem ist, das ich im Reading rain an den folge Tag immer noch der Wert vom vor Tag ist.
Das kann ich aber aus deinem Screenshot nicht nachvollziehen.

Zitat
Da hat sich nichts geändert.
Sowas kann schon ein-zwei Tage in Anspruch nehmen, biss man das optimal hinbekommen hat.

@Noname:
Zitat
Mittelwertbildung der Windgeschwindigkeit und Regenmenge / Tag
Dafuer ist inzwischen das average Modul zustaendig. Das KS300 Modul hatte diese Durchschnittswerte aber schon frueher gehabt, und ich wollte diese nicht entfernen.

Zitat
Ich habe das FS20 Modul erweitert, um Füllstände, Messwerte, Meldungen zu verarbeiten
Stimmt, passt nicht hierher. Bitte fuer sowas neue Diskussionen oeffnen.
Die Aenderungen kann ich ohne passende Doku (en+de) nicht uebernehmen, sonst habe ich nichts dagegen.

Offline Michael

  • Full Member
  • ***
  • Beiträge: 442
  • Rechtschreibfehler dürfen Behalten werden!
Antw:Änderungen an Modul KS300.pm?
« Antwort #24 am: 20 April 2014, 09:06:47 »
Hallo rudolfkoenig

Hier nochmal ein Auszug aus der Fhem.save.

2014.04.18 18:43:57 4: KS300 1234: 810d04xx4027a00171370680003106
2014.04.18 18:43:57 4: KS300 1234: T: 7.3  H: 86  W: 0.0  R: 4.8  IR: yes  Wi: 0 #Hier Regnete es
...
...
2014.04.19 22:28:47 4: KS300 1234: 810d04xx4027a00171221678001207
2014.04.19 22:28:47 4: KS300 1234: T: 12.2  H: 76  W: 0.8  R: 8.4  IR: no  Wi: 0
...
...
2014.04.20 08:28:38 4: KS300 1234: 810d04xx4027a00171901288001209
2014.04.20 08:28:38 4: KS300 1234: T: 10.9  H: 82  W: 0.8 R: 8.4  IR: no  Wi: 0
...
...
2014.04.21 14:05:18 4: KS300 1234: 810d04xx4027a0017129195000620c
2014.04.21 14:05:18 4: KS300 1234: T: 19.2  H: 59  W: 0.0 R: 9.7  IR: no  Wi: 0 #heute Nacht hatte es geregnet, aber nicht so viel.

Die Aktualisierungszeit des R: Wertes wird immer mit erneuert.

Zitat
Zitat
Da hat sich nichts geändert.
Zitat
Sowas kann schon ein-zwei Tage in Anspruch nehmen, biss man das optimal hinbekommen hat.
Gemeint war von mir, das sich auf der Empfangs Seite der Aufbau sich nicht verändert hat.
Die KS300 ist auch maximal 6 Meter vom RasPi durch eine Ytong getrennt.

Frohe Ostern

Edit: 21.04.2014 Werte hinzugefügt.
« Letzte Änderung: 21 April 2014, 14:21:22 von Michael »
Gruß, Michael

FHEM 5.9 auf RPi 3
CUL V3 868 Mhz | JeeLink LaCrosse & PCA301
FS20 ST-2/3 | BMP085(180) | 14x TX29DTH-IT | 2x TX25IT/Helligkeitssensor | 5x PCA 301 | SMA Peripheries | MobileAlerts MA-10(100,120PRO,200,251,410,650,660,800)

Offline dadoc

  • Sr. Member
  • ****
  • Beiträge: 727
Antw:Änderungen an Modul KS300.pm?
« Antwort #25 am: 05 Juni 2014, 11:27:00 »
Hallo,
auch bei mir hat die KS300 plötzlich nicht mehr so funktioniert wie vorher, konkret: Keine readings mehr geliefert. Da ich in der initialen Experimentierphase mit FHEM bin, kann ich nicht mehr nachvollziehen, was dazu geführt haben könnte. Löschen, Neuanlegen usw. hat jedenfalls nichts gebracht (es gab immer genau ein Reading, dann war Schluss).
Mit den Hinweisen aus diesem Threads scheint es mir aber nun gelungen zu sein, sie wieder in Gang zu bringen. Um anderen das Probieren zu ersparen:
Die hier erwähnte Datei fhem.state konnte ich in meiner Installation nicht finden. Ich vermute, gemeint ist die fhem.save. Sie liegt bei mir in fritz.nas/fhem/opt/fhem/log/

Darin habe ich sämtliche Einträge mit "KS300" gelöscht. Danach shutdown restart, und jetzt trudeln die Readings wieder wie gewohnt ein.
Viele Grüße
Martin
Standort 1: FS20 mit CUL und FHEM (immer aktuelle Ver.) auf Raspberry Pi
Standort 2: Homematic (Wired) über CCU2 und PocketHome HD
3 x Raspi3 mit piCorePlayer/Kodi für Multiroom Audio (+ Tablets/iPeng/iPods)

 

decade-submarginal