Autor Thema: FHZ1300 PC sendet nicht  (Gelesen 2514 mal)

mr_hooge

  • Gast
FHZ1300 PC sendet nicht
« am: 06 März 2014, 16:50:23 »
Bin neu hier und bitte um Hilfe

Angaben zu meinem System:
  Release : 5.5
  Branch   : DEVELOPMENT
  OS         : linux
  Arch       : arm-linux-gnueabi-thread-multi auf Dockstar
  Perl        : v5.10.1
  $Id: fhem.pl 4208 2013-11-12 17:43:33Z rudolfkoenig $

  FHZ1300PC als Sender und Empfänger mit div. FS20 und FHT80b

Die FHZ1300 blinkt beim anstecken an den USB-Port und beim Starten von fhem sowie beim Senden und Empfangen von Signalen.

Nach Update auf
  $Id: fhem.pl 5126 2014-03-04 16:27:09Z rudolfkoenig $

Tut sich folgendes Problem auf, welches ich nicht gelöst bekomme:

Die FHZ1300 blinkt beim Anstecken an den USB-Port. Beim Starten von fhem passiert nichts, die FHZ1300 empfängt alle Daten sendet aber nicht.

Habe bereits die:
  define MyFHZ FHZ /dev/ttyUSB0 strangetty geändert
keine Änderung

Habe im Forum folgendes entdeckt:
  http://forum.fhem.de/index.php/topic,5916.msg23311.html#msg23311mir Link auf
  https://groups.google.com/forum/#!topic/fhem-users/x7lcb5tceI4

Befehl:FHZ1300PC vom USB-Port entfernt und neu verbunden.

Die FHZ1300 blinkt beim Anstecken an den USB-Port
  stty -icrnl -ixon -opost -isig -icanon -iexten -echo < /dev/ttyUSB0 ausgeführt

fhem neu gestartet

Die FHZ1300 blinkt beim Starten von fhem sowie beim Empfangen von Signalen.
Senden geht nicht.

Habe mein fhem wieder auf den alten Stand gebracht um zu senden. Kann jederzeit wieder updaten und nach Vorgaben repoduzieren

mr_hooge
« Letzte Änderung: 06 März 2014, 16:54:14 von mr_hooge »

Offline rudolfkoenig

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 25475
Antw:FHZ1300 PC sendet nicht
« Antwort #1 am: 06 März 2014, 18:50:03 »
Kannst Du bitte ein Sendevorgang mit verbose 5 mitschneiden und hier Posten?
Und dann noch Definition+Attribute vom FHZ und den fraglichen Aktors.

mr_hooge

  • Gast
Antw:FHZ1300 PC sendet nicht
« Antwort #2 am: 06 März 2014, 19:12:40 »
Kann ich machen. Kann aber erst morgen die Daten liefern.

Danke für die Hilfe

mr_hooge

  • Gast
Antw:FHZ1300 PC sendet nicht
« Antwort #3 am: 07 März 2014, 09:55:32 »
Ich habe mir jetzt ein Testsystem aufgebaut wo die FHZ1300PC nicht sendet aber alles empfängt:

Fhem info:
  Release  : 5.5
  Branch   : DEVELOPMENT
  OS       : linux
  Arch     : arm-linux-gnueabi-thread-multi
  Perl     : v5.10.1

# $Id: fhem.pl 5126 2014-03-04 16:27:09Z rudolfkoenig $
# $Id: 01_FHEMWEB.pm 5080 2014-03-01 08:02:45Z rudolfkoenig $
# $Id: 11_FHT.pm 5070 2014-02-28 07:48:55Z rudolfkoenig $
# $Id: 00_FHZ.pm 3738 2013-08-18 14:13:59Z rudolfkoenig $
# $Id: 10_FS20.pm 5002 2014-02-20 19:24:18Z rudolfkoenig $
# $Id: 92_FileLog.pm 5068 2014-02-28 07:15:18Z rudolfkoenig $
# $Id: 99_SUNRISE_EL.pm 4537 2014-01-03 08:28:59Z rudolfkoenig $
# $Id: 98_SVG.pm 5076 2014-03-01 06:30:23Z rudolfkoenig $
# $Id: 99_Utils.pm 3595 2013-08-05 05:38:48Z tobiasfaust $
# $Id: 99_VCONTROL.pm v 10.1 16.02.2014 13:50 adw $
# $Id: 90_at.pm 4844 2014-02-08 07:54:03Z rudolfkoenig $
# $Id: 99_myUtils.pm 2012-12-15 21:05:00 reinhard $
# $Id: 91_notify.pm 4933 2014-02-15 08:22:35Z rudolfkoenig $
# $Id: 98_telnet.pm 4844 2014-02-08 07:54:03Z rudolfkoenig $
# $Id: 98_weblink.pm 3770 2013-08-23 13:29:58Z rudolfkoenig $

Anbei als Anhang:
  fhem.cfg
  aktoren.cfg
  fht80b.cfg
  fhemtest-2014-03.log

Es ist ein Mitschnitt mit Sende/Empfangs-Befehlen welche auch Aktoren enthalten die nicht erfasst sind.

Ich hoffe das hilft 

 

decade-submarginal