FHEM - Hausautomations-Systeme > EnOcean

Kommunikation EnOcean Pi - Steckdose von Telefunken Joonior

(1/7) > >>

fm123:
Hallo zusammen,

ich habe eine Frage/Problem bezüglich Raspberry Pi mit EnOcean Pi Erweiterung und Telefunken Joonior Steckdose.

Zuerst die Liste mit den von mir verwendeten Geräten:
- Raspberry Pi Modell B
- EnOcean Pi 868 MHz Gateway
- Telefunken Joonior EnOcean Funktionsstecker SN: S3T8TVXUSYU896L 868,3MHz (Steckdose) (wird erkannt habe aber keine Möglichkeit diese zu schalten)
- Telefunken Joonior EnOcean Doppeltaster (wird erkannt und funktioniert)

Nach erfolgreicher Installation des FHEM-Servers habe ich den Doppeltaster im automatischen Anlernmodus in das System integriert. Wird der Taster betätigt, so erkennt der Server dies und der Schaltzustand wird erkannt.
Das Problem ist die Steckdose, diese wird zwar erkannt, es besteht aber keine Möglichkeit diese zu schalten.

Folgende Zeilen werden beim Anstecken der Steckdose im Config-File automatisch erstellt:

define EnO_UTE_01034683 EnOcean 01034683
attr EnO_UTE_01034683 room EnOcean
attr EnO_UTE_01034683 subType UTE
define FileLog_EnO_UTE_01034683 FileLog ./log/EnO_UTE_01034683-%Y.log EnO_UTE_01034683
attr FileLog_EnO_UTE_01034683 logtype text
attr FileLog_EnO_UTE_01034683 room EnOcean

Wenn ich ins Menü der Steckdose navigiere, habe ich keine Möglichkeit diese in irgendeiner Weise zu schalten.
Weiters stehen im Menüpunkt "State" drei Fragezeichen.

Ich habe hier im Forum leider kein entsprechendes Thema gefunden, daher habe ich folgende Fragen:
Wie schaffe ich es diese Steckdose zu schalten, bzw. welche Attribute muss ich ergänzen?
Besteht die Möglichkeit dass diese Geräte nicht kompatibel sind?
Welche alternativen Steckdosen wären für EnOcean Pi geeignet und gibt es dazu einen Beispielcode?

Vielen Dank im Voraus!

Beste Grüße, fm123

Puschel74:
Hallo,

was heisst

--- Zitat ---habe aber keine Möglichkeit diese zu schalten
--- Ende Zitat ---
Hier wäre ein Screenshot wieder hilfreich (für mich zumindest).
Ein Bild sagt eben mehr als 1000 Worte  8)

Hast du keine Befehlsschaltflächen zum anklicken (on oder off) oder hast du welche und die Steckdose reagiert nur nicht auf die Befehle?
Im Screenshot wäre das dann "Ein" und "Aus".
Dazwischen ist nur ein Slider zum dimmen - der braucht ja jetzt nicht interessieren.
Es geht rein nur um das "Ein" und "Aus".

Ich weiß ja nicht ob durch den subType automatisch schon Schaltflächen bereit gestellt werden.
Wenn nicht kannst du ein
--- Code: ---attr <Device> webCmd on:off
--- Ende Code ---
versuchen.

Allerdings weiß ich auch nicht ob die Steckdosen etwas senden - mir sind bisher nur Homematic-Geräte bekannt die sich "selbst" melden.

Grüße

P.S.: Die Tags machen den Text etwas leserlicher  ;)

klaus.schauer:
Für Telefunken Joonior EnOcean Funktionsstecker habe ich vor Wochen das entsprechende Profil actuator.01 bereitgestellt. Diese Geräte müssen mit Hilfe der teach-in Prozedur in Fhem angelernt werden.

1. Fhem in teach-in Modus bringen: set <IODev> teach <sec>
2. teach-in Schalter am Funktionsstecker betätigten
3. danach sollte ein Device mit dem Profil  actuator.01 angelegt sein.

Erst dann ist eine Bedienung des Gerätes erst möglich. Ob das Profil allerdings sauber läuft, konnte bisher nicht getestet werden. Deshalb benötige ich bei Fehlern jeweils die zentralen und Geräte-LOGs mit verbose 5 sowie die Daten des Device mit list <Name>.

Bitte in der commandref nachlesen, welche Befehle zur Verfügung stehen.

fm123:
Vielen Dank für die raschen Antworten.


--- Zitat ---Hast du keine Befehlsschaltflächen zum anklicken (on oder off) oder hast du welche und die Steckdose reagiert nur nicht auf die Befehle?
--- Ende Zitat ---
Es sind keine Befehlsschaltflächen vorhanden.


--- Zitat ---attr <Device> webCmd on:off
--- Ende Zitat ---
Mit Hilfe dieser Zeile erscheinen zwar Schaltflächen, bewirken jedoch nichts.


--- Zitat ---Allerdings weiß ich auch nicht ob die Steckdosen etwas senden - mir sind bisher nur Homematic-Geräte bekannt die sich "selbst" melden.
--- Ende Zitat ---
Die Steckdose muss meiner Meinung nach irgendwas senden, da sie im Config File erkannt wird.

Ich hätte da noch eine Frage zu Homematic Geräten?
Sind die einfacher anzuleren?
Grundsätzlich bin ich nicht fixiert auf Telefunken Geräte, da diese Steckdose nur geliehen ist.



--- Zitat ---1. Fhem in teach-in Modus bringen: set <IODev> teach <sec>
2. teach-in Schalter am Funktionsstecker betätigten
3. danach sollte ein Device mit dem Profil  actuator.01 angelegt sein.
--- Ende Zitat ---
Habe ich versucht, leider ändert sich nichts an der Lage.

Die Steckdose versucht (lt. Bedienungsanleitung) sich bei Erstinbetriebnahme mit dem System automatisch zu verbinden.
Weiters wird in der Bedienungsanleitung beschrieben wie man die Steckdose zurücksetzt.
Aus diesem Grund habe die Steckdose zurückgesetzt, danach den Befehl

--- Code: ---set TCM310_0 pairForSec 600
--- Ende Code ---
am Server ausgeführt und dann die Steckdose wieder eingesteckt.
Leider auch ohne Erfolg.


--- Zitat ---Bitte in der commandref nachlesen, welche Befehle zur Verfügung stehen.
--- Ende Zitat ---
Werde ich machen...

Grüße



Puschel74:
Hallo,


--- Zitat ---Ich hätte da noch eine Frage zu Homematic Geräten?
Sind die einfacher anzuleren?
--- Ende Zitat ---
Dafür haben wir einen eigenen Homematic-Bereich  ;)

Nur soviel von mir zu deiner Frage.
Wenn man den Dreh mal heraus hat sind die Homematic-Geräte recht schnell angelernt und eingebunden.
Einzig für das getConfig muss man etwas Geduld mitbringen.

Nun aber BTT und zu deinen Telefunken-Geräten.


--- Zitat ---Deshalb benötige ich bei Fehlern jeweils die zentralen und Geräte-LOGs mit verbose 5 sowie die Daten des Device mit list <Name>.
--- Ende Zitat ---
Liefer klaus mal die gewünschten Infos.
Er kann dir mit Sicherheit weiterhelfen.

Grüße

Navigation

[0] Themen-Index

[#] Nächste Seite

Zur normalen Ansicht wechseln