FHEM - Hausautomations-Systeme > EnOcean

Mit FGW14 an den Eltako RS485 Bus und mit FTD14 ins Enocean Funknetz

<< < (2/8) > >>

Spartacus:
Hallo Guido,
danke für den Tipp, allerdings verstehe ich den Ansatz nicht so ganz! Warum packe ich den enocean pi nicht direkt an die zentrale Stelle im Haus. Dann läuft fhem zwar nicht auf einem pi in der Verteilung, aber ist ja im Prinzip auch egal.

Die ext. Antenne des FAM14 aus der Verteilung ist ja stark genug und somit sollte der enocean pi die Bestätigungstelegramme der Aktoren im RS485-Bus ohne Probleme empfangen können. Für mein FTS14EM hänge ich einfach ein FTS14FA mit externer Antenne dazu. Dann sollte es auch keine Probleme mit dem enocean pi geben.

Oder macht es mehr Sinn, einen pi über ein RS485-GW direkt in den RS485-Bus zu hängen und dann über einen TCM310-pi die Funkbusankopplung mit ggf. weiteren dezentralen Aktoren zu bauen. Dann dürfte der enocean Pi allerdings keine Bestätigungstelegramme vom FAM14 verarbeiten, da der RS485-pi diese über den Bus bekommt?!?

sorry, aber so ganz verstehe ich Deinen Ansatz noch nicht  :(
Spartacus

NACHTRAG:
Ich habe den enocean pi jetzt auf die mittlere Etage gestellt. Aber so richtig überzeugt bin ich davon nicht. Ich habe einen FMS61-NP. Und selbst auf der gleichen Etage kann der enocean pi ihn nicht schalten. Ein PMT210 packt es zumindest bis in das nächste Geschoss meines EFHs, wenn ich den Sender in den Aktor einlerne. Aber wirklich toll ist das auch nicht! Das FAM14 im Keller kann ich mit dem enocean pi erreichen. Wie macht man so etwas bei größeren Installationen? Ich kann doch nicht jeden Aktor als Repeater betreiben, das funzt doch auch nicht! Ich bin ein wenig ratlos, den meine Hütte ist ein normales EFH mit UG,EG,OG und DG ca. 60m2 pro Etage.

Norberto:
Guten Morgen,

Ein Frage an die Experten: lokale Adressierung auf dem RS485-Bus Dezimal/Hexadezimal?

- Konfiguration wie in diesem Topic beschrieben über FGW14
- FSR14-2x mit PCT14 konfiguriert auf die Bus-IDs 11+12 Dezimal

Wieso kann ich dann den 1.Kanal des FSR14 sowohl über

    "define EnOcean_switch_FSR14 EnOcean 0000000B"

als auch mit

    "define EnOcean_switch_FSR14 EnOcean 00000011"

erreichen (2. Kanal 0xC und 0x11) ?

Hinweis: Rückmeldungen des 1. Kanals vom Aktor kommen nur über

    "define EnOcean_switch_FSR14 EnOcean 0000000B"

D.h. wenn man ein Device auf Adresse 0x11 anlegt und den Aktor darüber anspricht kommen die Aktor-Rückmeldungen über ein zweites Devive 0xB.

Habe ich hier etwas falsch verstanden oder ist dies eine ungewollte Fehlfunktion von FHEM ?

Grüße, Norbert

Spartacus:
Hallo Norberto,
ich würde gerne helfen, aber das kann ich leider nicht beantworten. Bin noch lange kein Experte.  Ich habe  2x FSR14-4x im Bus. wenn ich etwas testen soll, sag kurz Bescheid.

Meine Adressen im BUS habe ich von der Basisadresse (FAM14 Basisadresse: xxxx7280) hochgezählt, wobei Kanal 1 des ersten Aktors die xxxx7281 und Kanal 4 des zweiten Aktors  xxxx7288 hat.

Spartacus.

Norberto:

Hallo Spartacus,

Danke für das Angebot.
Ich habe die nächsten Tage keine Gelegenheit zu testen aber Du hasst mir schon einen Denkanstoss gegeben: Ich hatte die RS484 Devices bis jetzt nur über die lokale Adresse auf dem Bus (1..n ohne Basisadresse FAM14) angesprochen. Hatte nicht daran gedacht dass man wie über den Funkweg auch die Module über den Bus auch mit dazuaddierter Basisadresse ansprechen könnte.
Ich werde das Ende der Woche mal testen und beobachten ob ich den von mir beschriebenen Effekt dann immer noch sehe).

Gruß, Norbert

Spartacus:
Hallo,
ich muss hier doch noch mal in die Runde der Experten fragen:

FAM14 per USB an Rpi:

--- Code: ---define FAM14 TCM ESP2 /dev/ttyUSB0@57600
attr FAM14 comType RS485
attr FAM14 learningMode demand
attr FAM14 room EnOcean
attr FAM14 sendInterval 25
attr FAM14 verbose 3
--- Ende Code ---
#
Im RS485-Bus einen FSR14-4x

--- Code: ---define EnOcean_switch_FSR14 EnOcean FF9B7284
attr EnOcean_switch_FSR14 IODev FAM14
attr EnOcean_switch_FSR14 alias Lampe
attr EnOcean_switch_FSR14 group Hauseingang
attr EnOcean_switch_FSR14 gwCmd switching
attr EnOcean_switch_FSR14 icon light_outdoor
attr EnOcean_switch_FSR14 manufID 00D
attr EnOcean_switch_FSR14 room EnOcean
attr EnOcean_switch_FSR14 subType gateway
--- Ende Code ---

Wenn ich den Aktor betätige, dann schaltet er ein und aus, wie er es soll.
Von 10x Schalten, klappt es 8x. Im Protokoll von fhem steht, dass der Aktor geschaltet wurde, aber es scheint das Telegramm nicht anzukommen. Kann man an der o.a. Konfiguration noch irgendetwas optimieren? Das sendinterval habe ich auch schon mehrfach geändert!
Oder ist das einfach so bei fhem mit enOcean!
USB-Kabel ist 1m.
Rpi-FW ist aktuell wg. möglicher USB-Probleme, fehm aktuell,  FAM14-BA steht auf 5; 2 und 4 habe ich auch getestet.

Christian.

Navigation

[0] Themen-Index

[#] Nächste Seite

[*] Vorherige Sete

Zur normalen Ansicht wechseln