Autor Thema: [unrichtig]Problem mit HMConfig.pm  (Gelesen 711 mal)

Offline pwlr

  • Full Member
  • ***
  • Beiträge: 235
[unrichtig]Problem mit HMConfig.pm
« am: 04 Februar 2022, 18:26:45 »
Hallo,
es gibt ein kleines Problem mit der HMConfig.pm (# $Id: HMConfig.pm 25160 2021-10-30 17:38:52Z martinp876 $)

Für das Device HM-Sen-LI-O (SubType senBright) ist der Befehl peerChan nicht verfügbar.

Meines Erachtens fehlt der Eintrag
,senBright    =>{ peerChan       =>"-btnNumber- -actChn- [({single})] [({set}|unset)] [actor|remote|both]"}in dem Block ab Line 1795

Moin
Bernd

Edit: bitte vergessen - sorry, ich hatte übersehen, dass das Device brightness in Lux sendet und nicht wie z.B. die Bewegungsmelder als dimensionslose Zahl von 0 bis 255
« Letzte Änderung: 05 Februar 2022, 13:39:19 von pwlr »

Offline frank

  • Hero Member
  • *****
  • Beiträge: 11157
Antw:[unrichtig]Problem mit HMConfig.pm
« Antwort #1 am: 05 Februar 2022, 15:33:49 »
hm...
was hat das reading brigthness mit dem cmd peerchan zu tun?

peerchan existiert nur in einem sensor channel, der peerbar ist.
falls dieser sensor nur einen channel hat, sollte peerchan auch im device zu finden sein.

zeig mal vom sensor je ein list aller entities.
FHEM: 6.0(SVN) => Pi3(buster)
IO: CUL433|CUL868|HMLAN|HMUSB2|HMUART
CUL_HM: CC-TC|CC-VD|SEC-SD|SEC-SC|SEC-RHS|Sw1PBU-FM|Sw1-FM|Dim1TPBU-FM|Dim1T-FM|ES-PMSw1-Pl
IT: ITZ500|ITT1500|ITR1500|GRR3500
WebUI [HMdeviceTools.js (hm.js)]: https://forum.fhem.de/index.php/topic,106959.0.html

Offline pwlr

  • Full Member
  • ***
  • Beiträge: 235
Antw:[unrichtig]Problem mit HMConfig.pm
« Antwort #2 am: 05 Februar 2022, 23:47:36 »
Zitat
was hat das reading brigthness mit dem cmd peerchan zu tun?

Genau das hatte ich übersehen. Die Werte für brightness gehen in diesem Device deutlich über den für Switche "peerbaren" Bereich von 255 hinaus (mehrere 1000 Lux) und damit wird ein Peering sinnlos und funktioniert auch nicht. Insofern braucht man den Befehl auch nicht....

Könnte sein, dass ein Peering mit Wetterstationen etc. möglich wäre, das kann ich aber mangels Hardware nicht beurteilen. Da halte ich mich raus.

Offline Benni

  • Developer
  • Hero Member
  • ****
  • Beiträge: 2442
  • FHEMinist
Antw:[unrichtig]Problem mit HMConfig.pm
« Antwort #3 am: 06 Februar 2022, 11:00:38 »
Genau das hatte ich übersehen. Die Werte für brightness gehen in diesem Device deutlich über den für Switche "peerbaren" Bereich von 255 hinaus (mehrere 1000 Lux) und damit wird ein Peering sinnlos und funktioniert auch nicht. Insofern braucht man den Befehl auch nicht....

Könnte sein, dass ein Peering mit Wetterstationen etc. möglich wäre, das kann ich aber mangels Hardware nicht beurteilen. Da halte ich mich raus.

Der Wettersensor HM-WDS100-C6-O gibt brightness im Wert 0-255 aus.
Der Bewegunsmelder (HM-SEN-MDIR-O-2) glaube ich auch!

gb#