Autor Thema: nanoCUL (WMBUS) empfängt nichts - Abfrage Diehl Hydrus 171A beabsichtigt  (Gelesen 246 mal)

Offline americanium

  • New Member
  • *
  • Beiträge: 40
Hallo!

Ich habe einen nanoCUL (traxCUL) in FHEM in Betrieb genommen, ich bin mir nicht sicher ob er wirklich funktioniert.
Ich möchte meinen DIEHL Hydrus 171 auslesen. Dieser soll ja ca. alle 17 - 250Sekunden (je nach Einstellung) die Daten senden, aber mein CUL empfängt irgendwie nichts...

Könnt ihr mir hier weiterhelfen?

Foto im ANhang...

Danke!
« Letzte Änderung: Gestern um 21:55:20 von americanium »

Offline KölnSolar

  • Developer
  • Hero Member
  • ****
  • Beiträge: 5344
Hast Du den
Zitat
DIEHL Hydrus 171
hier im Forum als funktionsfähig gefunden ? Dann bitte den Link posten.

WMBus ist ein sehr spezielles Protokoll. Da lässt sich nicht drauf schließen, das ein Gerät empfangen wird, nur weil in dessen Beschreibung etwas von WMBus steht.  :-\

Und ist traxCUL jetzt nur der von Dir vergebene Name(dann gehörts nicht in den Betreff) oder soll das was anderes sein ? Hab ich zumindest noch nie gehört.

Grüße Markus
RPi3/2 buster/stretch-SamsungAV_E/N-RFXTRX-IT-RSL-NC5462-Oregon-CUL433-GT-TMBBQ-01e-CUL868-FS20-EMGZ-1W(GPIO)-DS18B20-CO2-USBRS232-USBRS422-Betty_Boop-EchoDot-OBIS(Easymeter-Q3/EMH-KW8)-PCA301(S'duino)-Deebot(mqtt2)-zigbee2mqtt

Offline americanium

  • New Member
  • *
  • Beiträge: 40
Hallo!

Ja, im Thread und in Kombination mit einer Fremdseite läuft der 171A mit cul und fhem zum auslesen.

traxCUL ist praktisch selbst vergeben ja....

Es scheitert bei mir auch am Wissen wie ich sehe ob das Ding wirklich funktionsfähig läuft und wie man sieht welche clients er gefunden hat.

Danke!

Offline KölnSolar

  • Developer
  • Hero Member
  • ****
  • Beiträge: 5344
Aha. Dann ändere mal den Betreff im 1. Post und schreib auch WMBUS rein, damit die, die damit Erfahrung haben, drauf gestoßen werden.
Du könntest ihn mal im rfmode slowRF(häufigstes Funkprotokoll) laufen lassen und hoffen, dass es bei Dir oder in der Nachbarschaft passende Gerätschaften gibt. Wenn Du was empfängst ist der CUL physikalisch/elektrisch i.O. Dann kannst Du wieder auf WMBus_T gehen. Edit: Was mich gerade wundert: ich habe 3 WMBus-Protokolle mit der aculfw. Ich spekuliere, dass am WMBus-Protokoll weiter gefeilt wurde, diese aber nicht in die von Dir genutzte culfw 1.67 eingeflossen sind. Dann müsstest Du die aktuelle aculfw flashen.Und WMbus_T ist richtig ?

Edit2: und weil ich den https://forum.fhem.de/index.php/topic,24517.885.html gerade sah: Schreib dort mal kurz Dein Problem und verlinke Deinen Thread.
« Letzte Änderung: Gestern um 21:53:51 von KölnSolar »
RPi3/2 buster/stretch-SamsungAV_E/N-RFXTRX-IT-RSL-NC5462-Oregon-CUL433-GT-TMBBQ-01e-CUL868-FS20-EMGZ-1W(GPIO)-DS18B20-CO2-USBRS232-USBRS422-Betty_Boop-EchoDot-OBIS(Easymeter-Q3/EMH-KW8)-PCA301(S'duino)-Deebot(mqtt2)-zigbee2mqtt
Gefällt mir Gefällt mir x 1 Liste anzeigen

Offline Pfriemler

  • Hero Member
  • *****
  • Beiträge: 3997
  • geht nich gips nich
Die auszuwertenden Daten müssen alle in einen internen Puffer passen. Ich habe mit erst mit dem mapleCUN Daten empfangen können, bei mir gab es zudem auch einige Hänger und seltsame Probleme beim Umschalten des Modus, mehrere Tageslogs sind im 18-Sekunden-Takt aufgebläht worden mit Fehlermeldungen. Generell sicher und fehlerfrei war der Empfang - warum auch immer - erst nach einem Neustart von FHEM nach dem Einstellen des Modus. Ich fass das jetzt nicht mehr ohne Not an ...
Als der Kram einmal lief, hagelte es per autocreate Einträge (alles Zähler aus der (Reihenhaus-)Nachbarschaft.
Und ja, erst mal in anderem Modus testen ob überhaupt was empfangen wird. Und anständige Antenne ist auch nicht schlecht.
"Änd're nie in fhem.cfg, denn das tut hier allen weh!" *** Wheezy@Raspi(3), HMWLAN+HMUART, CUL868(SlowRF) für FHT+KS+FS20, miniCUL433, Rademacher DuoFern *** "... kaum macht man es richtig, funktioniert es ..."

Offline americanium

  • New Member
  • *
  • Beiträge: 40
OK, also Antenne ist eine gute Stabantenne.

D.h. ich teste jetz den SlowRF + am besten PI Neustart

Und wo genau sehe ich dann, ob er was findet und vor allem wie das Telegramm im Rohformat aussieht ?
Hättest du da ein Beispiel ?
Oder gibts passende Befehle dazu ?

Danke!

PS: Das mit Nachbarschaftsgeräten unter SlowRF wird schwer, viele Nachbarn habe ich nicht und die müssten zufällig passende 868er Geräte haben..

Offline Pfriemler

  • Hero Member
  • *****
  • Beiträge: 3997
  • geht nich gips nich
Meine Probleme traten vor allem im Zusammenhang mit der WMBUS.pm auf. Der CUL lieferte da schon längst Daten, die landeten auch im fhem.log, meine ich. Wurde ein Gerät einmal autocreated, landen die RAW-messages dort sichtbar, auch wenn die Entschlüsselung mangels Key (noch) fehlschlägt oder bei Nichtverfügbarkeit gar nicht gelingt.
Umschalten auf slowRF funktionierte immer. Test in der Pampa ohne Geräte ist natürlich schwieriger.
"Änd're nie in fhem.cfg, denn das tut hier allen weh!" *** Wheezy@Raspi(3), HMWLAN+HMUART, CUL868(SlowRF) für FHT+KS+FS20, miniCUL433, Rademacher DuoFern *** "... kaum macht man es richtig, funktioniert es ..."

Offline KölnSolar

  • Developer
  • Hero Member
  • ****
  • Beiträge: 5344
Zitat
Ich habe mit erst mit dem mapleCUN Daten empfangen können
Der hat aber die aculfw, oder ? Dann macht es Sinn, dass er die aculfw flashed ?  :-\
RPi3/2 buster/stretch-SamsungAV_E/N-RFXTRX-IT-RSL-NC5462-Oregon-CUL433-GT-TMBBQ-01e-CUL868-FS20-EMGZ-1W(GPIO)-DS18B20-CO2-USBRS232-USBRS422-Betty_Boop-EchoDot-OBIS(Easymeter-Q3/EMH-KW8)-PCA301(S'duino)-Deebot(mqtt2)-zigbee2mqtt

Offline americanium

  • New Member
  • *
  • Beiträge: 40
So, gleich mal ein Update:

Hab mir eine a-culf gesucht und geflashed - Jetzt empfange ich das signal mit der Meldung, dass der AES Key fehlt.
Das ist schon mal ein GROSSER Schritt :-)

Update:
AES Key als attr eingetragen und läuft.

Für alle die auch einen DIEHL HYDRUS 171A mit WMBUS (T) Schnittstelle auslesen möchten.
Mit der angehängten Version (a-culf) den CUL geflashed und hat funktioniert.
« Letzte Änderung: Heute um 09:03:15 von americanium »
Informativ Informativ x 1 Liste anzeigen

Offline Pfriemler

  • Hero Member
  • *****
  • Beiträge: 3997
  • geht nich gips nich
Der hat aber die aculfw, oder ? Dann macht es Sinn, dass er die aculfw flashed ?  :-\
Das schon, aber..
In der Befehlsliste muss das kleine b vorhanden sein für WMBUS. Man kann eine a-culfw ja auch selbst frisieren und compilieren, etwa um Platz zu sparen. So soll es durchaus sinnvoll sein, sich eine spezielle Version dafür zu bauen und dafür diverse andere Modi herauszuwerfen.
Mein Busware-CUL mit V1.66 von 2017 hat das kleine b aber auch schon. Dass eine a-culfw Bedingung für WMBUS sei, würde mich daher wundern.

Aber is ja gut dass alles funktioniert.
"Änd're nie in fhem.cfg, denn das tut hier allen weh!" *** Wheezy@Raspi(3), HMWLAN+HMUART, CUL868(SlowRF) für FHT+KS+FS20, miniCUL433, Rademacher DuoFern *** "... kaum macht man es richtig, funktioniert es ..."

 

decade-submarginal