FHEM - Hausautomations-Systeme > ZWave

multi sensor (AEON LABS) reports humidity wrong

(1/1)

cmillsy:
Hi. Since an update to the zwave module the humidity reported is wrong (13312%). When i first got the sensor there wasn't any handling so i changed the module to suit as so:

--- Code: ---parse => { "06310501(..)(....)" => 'sprintf("temperature:%0.1f %s",'.
                      'hex($2)/(10**int(hex($1)/32)), '.
                      'hex($1)&8 ? "F":"C")',
               "06310505(..)(..)" => 'sprintf("humidity:%0.1f %", '.
                      'hex($2)/(10**int(hex($1)/32)))'},},

--- Ende Code ---
This worked fine for my sensor. Since the update the humidity is reported incorrectly.

rudolfkoenig:
According to the spec, SENSOR_MULTILEVEL messages contain beside the value itself the bytecount of the value, precision and scale. ZWAVE.pm takes all these parameter into account to format the value.

Could you please send me the raw message, so I can check if the implementation is wrong, or your sensor is ignoring the spec. In the latter case you could help by using a userReading to reformat the message.

cmillsy:
here's a section from my log file

SW: 06
2014.07.10 10:33:43 5: ZWDongle_Read ZWDongle_1: 00040004063105030a03e8
2014.07.10 10:33:43 5: ZWDongle_1 dispatch 00040004063105030a03e8
2014.07.10 10:33:43 4: ZWDongle_1 CMD:APPLICATION_COMMAND_HANDLER ID:04 ARG:063105030a03e8
2014.07.10 10:33:44 5: ZWDongle/RAW: /010c0004080406310505013600fb
2014.07.10 10:33:44 5: SW: 06
2014.07.10 10:33:44 5: ZWDongle_Read ZWDongle_1: 0004080406310505013600
2014.07.10 10:33:44 5: ZWDongle_1 dispatch 0004080406310505013600
2014.07.10 10:33:44 4: ZWDongle_1 CMD:APPLICATION_COMMAND_HANDLER ID:04 ARG:06310505013600
2014.07.10 10:33:44 5: Triggering pir (1 changes)
2014.07.10 10:33:44 5: Notify loop for pir humidity: 13568 %
2014.07.10 10:33:44 4: eventTypes: ZWave pir humidity: 13568 % -> humidity: .* %
2014.07.10 10:33:44 5: ZWDongle/RAW: /010c0004000406310505013600f3
2014.07.10 10:33:44 5: SW: 06

I've also attached a pdf which shows the spec for the Aoen Labs multi sensor

rudolfkoenig:
The sensor sends two-bytes as value, but it flags it as one-byte.
FHEM ignored (partly) this length-information up till now, but I changed that.
The change is in the SVN repository, and available after tomorrow 8AM via update.

cmillsy:
THanks. That solved it!   :)

Navigation

[0] Themen-Index

Zur normalen Ansicht wechseln