Autor Thema: Opus XT300 /Imagintronix Soil sensor  (Gelesen 37802 mal)

Offline ext23

  • Hero Member
  • *****
  • Beiträge: 3133
    • Homepage
Antw:Opus XT300 /Imagintronix Soil sensor
« Antwort #90 am: 07 September 2016, 08:43:20 »
Über welche Firmware Version reden wir, und welche Protokolle hast du noch aktiviert?

/Daniel
HM, FS20, 1-Wire, PanStamp, AVR-NET-IO, SIS-PM, EM1000EM, PCA301, EC3000, HM-LAN, CUL868, RFXtrx433, LGW, DMX @Ubuntu-Server (Hauptsystem) & Raspberry Pi (Satellit)

Offline KernSani

  • Moderator
  • Hero Member
  • ***
  • Beiträge: 3389
Antw:Opus XT300 /Imagintronix Soil sensor
« Antwort #91 am: 08 September 2016, 17:37:53 »
Über welche Firmware Version reden wir, und welche Protokolle hast du noch aktiviert?
Das müsste die FW 1006 (Aug 2016) gewesen sein. Bei den Protokollen müsste ich nachschauen... War nichts spektakuläres. Kann ich das irgendwie am RasPi rausfinden, ohne über den RFXMngr am WIndows-Rechner zu gehen?

Grüße,

Oli
RasPi: RFXTRX, HM, zigbee2mqtt, mySensors, JeeLink, miLight, squeezbox, Alexa, Siri, ...

Offline PeMue

  • Developer
  • Hero Member
  • ****
  • Beiträge: 5271
    • PeMue's github
Antw:Opus XT300 /Imagintronix Soil sensor
« Antwort #92 am: 08 September 2016, 23:23:44 »
Das müsste die FW 1006 (Aug 2016) gewesen sein. Bei den Protokollen müsste ich nachschauen... War nichts spektakuläres. Kann ich das irgendwie am RasPi rausfinden, ohne über den RFXMngr am WIndows-Rechner zu gehen?
Ja, in fhem.log werden beim Starten dir Protokolle mitgeloggt.
1x FB7170 (29.04.88) 5.7 1xCUNO2 1.67 2xEM1000WZ 2xUniroll 1xASH2200 3xHMS100T(F)
1x RPi BV2LCDCSM 1.63 5.7 2xMAX HKT, 1xMAX RT, V200KW1
1xFB 7490 (113.06.05) 5.7 1xCUL V3 1.63 1xHM-CC-RT-DN 1.4 1xHM-TC-IT-WM 1.1 1xHB-UW-Sen-THPL-O 0.15 1x-I 0.14OTAU 1xRFXtrx 90 1xWT440H 1xCM160 3xTFA30.3150 5xFA21

Offline KernSani

  • Moderator
  • Hero Member
  • ***
  • Beiträge: 3389
Antw:Opus XT300 /Imagintronix Soil sensor
« Antwort #93 am: 08 September 2016, 23:32:13 »
Ja, in fhem.log werden beim Starten dir Protokolle mitgeloggt.
Oh, cool... vielleicht sollte man die mal in ein Reading schreiben...

TRX: Init status: '433.92MHz transceiver, firmware=1006, protocols enabled: RFU OREGON AC ARC X10 '
RasPi: RFXTRX, HM, zigbee2mqtt, mySensors, JeeLink, miLight, squeezbox, Alexa, Siri, ...

Offline ext23

  • Hero Member
  • *****
  • Beiträge: 3133
    • Homepage
Antw:Opus XT300 /Imagintronix Soil sensor
« Antwort #94 am: 09 September 2016, 07:58:21 »
Das müsste die FW 1006 (Aug 2016) gewesen sein. Bei den Protokollen müsste ich nachschauen... War nichts spektakuläres. Kann ich das irgendwie am RasPi rausfinden, ohne über den RFXMngr am WIndows-Rechner zu gehen?

Oh, cool... vielleicht sollte man die mal in ein Reading schreiben...

Es gab mal eine verbessertes Modul was das alles anzeigt, aber ich glaube das ist noch nicht Bestandteil des offiziellen FHEM.
HM, FS20, 1-Wire, PanStamp, AVR-NET-IO, SIS-PM, EM1000EM, PCA301, EC3000, HM-LAN, CUL868, RFXtrx433, LGW, DMX @Ubuntu-Server (Hauptsystem) & Raspberry Pi (Satellit)

Offline KernSani

  • Moderator
  • Hero Member
  • ***
  • Beiträge: 3389
Antw:Opus XT300 /Imagintronix Soil sensor
« Antwort #95 am: 09 September 2016, 08:29:31 »
Es gab mal eine verbessertes Modul was das alles anzeigt, aber ich glaube das ist noch nicht Bestandteil des offiziellen FHEM.

Off-topic: Habe mir auf die Schnelle selbst was gebaut: https://forum.fhem.de/index.php/topic,57509.msg489330.html#msg489330
RasPi: RFXTRX, HM, zigbee2mqtt, mySensors, JeeLink, miLight, squeezbox, Alexa, Siri, ...

Offline Stril

  • Full Member
  • ***
  • Beiträge: 471
Antw:Opus XT300 /Imagintronix Soil sensor
« Antwort #96 am: 13 September 2016, 18:43:11 »
Hallo!

Ich habe mir jetzt auch einmal welche bestellt, aber leider bekomme ich sie gar nicht in FHEM. Muss man sie irgendwie "anlernen", oder sollte das automatisch klappen?

Die Firmware meines TRX ist:
TRX: Init status: '433.92MHz transceiver, firmware=235, protocols enabled: OREGON AC ARC X10 '
Grüße
Phil

Offline KernSani

  • Moderator
  • Hero Member
  • ***
  • Beiträge: 3389
Antw:Opus XT300 /Imagintronix Soil sensor
« Antwort #97 am: 13 September 2016, 19:02:33 »
autocreate ist an? Sensor hat nachdem Einlegen der Batterie ein paar Sekunden blau geleuchtet?
RasPi: RFXTRX, HM, zigbee2mqtt, mySensors, JeeLink, miLight, squeezbox, Alexa, Siri, ...

Offline scooty

  • Sr. Member
  • ****
  • Beiträge: 515
Antw:Opus XT300 /Imagintronix Soil sensor
« Antwort #98 am: 13 September 2016, 20:34:04 »
Falsche Protokolle aktiviert?
Bei mir habe ich
TRX: Init status: '433.92MHz transceiver, firmware=1006, protocols enabled: RFU Lighting4 'und die XT300 Erstellung und nachfolgender Empfang mit meinem RFXtrx433E ohne Probleme.

Andreas
Fhem auf Gigabyte Brix
CUL V3 HM / CUL V3 MAX / MaxCube aFW Homematic&MAX / ZWave.me ZME_UZB1 / SDuino 433 / Velux KLF200
Homematic / MAX / Logitech Hub / ZWave / Wifi LED / div. 433 Temperatursensoren / pywws WH10880 / IO Homecontrol

Offline arne.dien

  • Jr. Member
  • **
  • Beiträge: 74
Antw:Opus XT300 /Imagintronix Soil sensor
« Antwort #99 am: 13 September 2016, 20:34:12 »
 Firmware ist schon ziemlich alt, könnte aber funktionieren.
Protokoll sollte RFU sein...
FHEM 5.9, RasPi 3 B, HM-LAN, RFXtrx433, Harmony
Homematic, Licht, Rolladen, Heizkörper, Rauchmelder...
ESP RGBWW, LD316...

Es ist selten zu spät aber immer höchste Zeit...

Offline Stril

  • Full Member
  • ***
  • Beiträge: 471
Antw:Opus XT300 /Imagintronix Soil sensor
« Antwort #100 am: 14 September 2016, 08:46:07 »
Hallo!

Dann muss ich wohl die Firmware aktualisieren. RFU fehlt bei mir ja.
Gibt es da irgendetwas zu beachten, oder kann ich das Tool+Firmware von http://www.rfxcom.com/ nehmen?

Wenn ja:
Wie finde ich heraus, ob ich einen
RFXtrx433E Ext
oder
RFXtrx433E Ext2
habe?
Sehe ich das irgendwo?

Grüße
Phil

Offline arne.dien

  • Jr. Member
  • **
  • Beiträge: 74
Antw:Opus XT300 /Imagintronix Soil sensor
« Antwort #101 am: 14 September 2016, 20:49:53 »
Das Tool ist das richtige.
Ext und Ext2 sind unterschiedliche Firmware-Versionen für die gleiche Hardware RFXtrx433E. Die Unterschiede sind im Readme oder der Dokumentation beschrieben.
Einfach mal runterladen und gucken....
FHEM 5.9, RasPi 3 B, HM-LAN, RFXtrx433, Harmony
Homematic, Licht, Rolladen, Heizkörper, Rauchmelder...
ESP RGBWW, LD316...

Es ist selten zu spät aber immer höchste Zeit...

Offline Stril

  • Full Member
  • ***
  • Beiträge: 471
Antw:Opus XT300 /Imagintronix Soil sensor
« Antwort #102 am: 14 September 2016, 22:14:28 »
Hallo!

Also mit der EXT2-Firmware meldete FHEM nur:
Cannot init /dev/serial/by-id/usb-RFXCOM_RFXtrx433_A1YHQVJC-if00-port0, ignoring it (TRX_0)
Die Ext-Firmware läuft grundsätzlich, findet aber nicht den Opus XT300...
2016.09.14 22:13:52 1: TRX: Init status: '433.92MHz transceiver, firmware=1006, protocols enabled: OREGON AC ARC X10 '

Habt ihr noch eine Idee?

Grüße
Phil


Offline schka17

  • Sr. Member
  • ****
  • Beiträge: 871
Antw:Opus XT300 /Imagintronix Soil sensor
« Antwort #103 am: 14 September 2016, 23:19:00 »
Hallo!

Also mit der EXT2-Firmware meldete FHEM nur:
Cannot init /dev/serial/by-id/usb-RFXCOM_RFXtrx433_A1YHQVJC-if00-port0, ignoring it (TRX_0)
Die Ext-Firmware läuft grundsätzlich, findet aber nicht den Opus XT300...
2016.09.14 22:13:52 1: TRX: Init status: '433.92MHz transceiver, firmware=1006, protocols enabled: OREGON AC ARC X10 '

Habt ihr noch eine Idee?

Grüße
Phil

Ich habe meine schon lange in Betrieb, ich habe aber mehr Protokolle enabled, ich kann mich aber nicht mehr erinnern welches das richtige war.

2016.09.14 23:16:04 1 : TRX: Init status: '433.92MHz transceiver, firmware=189, protocols enabled: RFU Lighting4 AE/Blyss BlindsT1/T2/T3/T4 LaCrosse LightwaveRF Visonic OREGON HOMEEASY AC X10 '

Sent from my iPad using Tapatalk
M: Thinclient x64 Debian | CUL FS20, HMS100WD, HMS100TF, HMS100T, HMS100CO, S300, S555TH | OWServer DS1420, DS18B20, DS2408 | RFXCOM UVN128, THWR800, THGR228N,RTGR328, PCR800 |Jeelink PCA301 EC3000|CUNO+IR|HMLAN|HMUSB|CUL433 Somfy|mySensors|espEasy
S1:Raspberry mit BPM810, Jeelink EC3000

Offline KernSani

  • Moderator
  • Hero Member
  • ***
  • Beiträge: 3389
Antw:Opus XT300 /Imagintronix Soil sensor
« Antwort #104 am: 14 September 2016, 23:29:59 »
Die Ext-Firmware läuft grundsätzlich, findet aber nicht den Opus XT300...
2016.09.14 22:13:52 1: TRX: Init status: '433.92MHz transceiver, firmware=1006, protocols enabled: OREGON AC ARC X10 '

Habt ihr noch eine Idee?

Grüße
Phil
Du musst mittels RFXMngr das Imagintronix/Opus Protokoll aktivieren - es erscheint in TRX init-Meldung als "RFU"

Grüße,

Oli
« Letzte Änderung: 14 September 2016, 23:40:37 von KernSani »
RasPi: RFXTRX, HM, zigbee2mqtt, mySensors, JeeLink, miLight, squeezbox, Alexa, Siri, ...