Autor Thema: Ansteuerung SolvisMax/Solvis-Remote  (Gelesen 42382 mal)

Offline SCMP77

  • Developer
  • Full Member
  • ****
  • Beiträge: 176
    • GitHub SolvisSmartHomeServer
SolvisSmartHomeServer V01.04.03
« Antwort #135 am: 27 Juli 2021, 17:13:18 »
Hallo,

auf GitHub liegt eine neue Bugfix-Version. Folgende Änderungen sind erfolgt:

  • Wurde während des Nachheizens die Warmwasser-Temperatur verstellt, wurde das Ende des Nachheizens nicht mehr erkannt.
  • Die Änderung von V01.04.02 arbeitetet nicht wie gewünscht. Gefixt.

Die Version ist unter Github unter folgendem Link zu finden:

https://github.com/GollmerSt/SolvisSmartHomeServer/releases/tag/v01.04.03

Es sind keinerlei Anpassungen im base.xml erforderlich.

Unter Linux reicht ein "sudo make update".

Unter Windows sollte der Server gestoppt werden, dann drüber installieren und danach ist der Server neu zu starten.

Viele Grüße
     Stefan
Raspberry Pi 3 Model B mit Rasbian, SolvisMax, AVM DECT 200, Sonoff mit Tasmota geflasht

Offline toka11

  • New Member
  • *
  • Beiträge: 9
Antw:Ansteuerung SolvisMax/Solvis-Remote
« Antwort #136 am: 27 August 2021, 08:09:36 »
Hallo,

ich habe nach Blitzschaden die Solvis remote ausgetauscht. Jetzt wird die Verbindung in Fhem nur kurz hergestellt (CONNECT) und dann kommen keine Werte mehr und im STATE steht auf opend. Ich vermute das die images der remot nicht richtig erkannt werden, da beim direkten Zugriff über das web auf Solvis Remote unter Fernbedienung nur verzerrte bzw. keine images angezeigt werden. Vor dem Blitzschlag hat alles bestens funktioniert.
Hat jemand einen Tip woher die verzerrten Images kommen oder was der Fehler sein könnte?

Offline SCMP77

  • Developer
  • Full Member
  • ****
  • Beiträge: 176
    • GitHub SolvisSmartHomeServer
Antw:Ansteuerung SolvisMax/Solvis-Remote
« Antwort #137 am: 27 August 2021, 11:56:01 »
Hallo,

ich habe nach Blitzschaden die Solvis remote ausgetauscht. Jetzt wird die Verbindung in Fhem nur kurz hergestellt (CONNECT) und dann kommen keine Werte mehr und im STATE steht auf opend. Ich vermute das die images der remot nicht richtig erkannt werden, da beim direkten Zugriff über das web auf Solvis Remote unter Fernbedienung nur verzerrte bzw. keine images angezeigt werden. Vor dem Blitzschlag hat alles bestens funktioniert.
Hat jemand einen Tip woher die verzerrten Images kommen oder was der Fehler sein könnte?

Was für einen Anlage besitzt Du (SolvisMax 6 oder 7)?

Wie sieht der Zugriff über den Browser aus? Sieht das ganz normal aus (speziell die Fernbedienung)?

Hat sich die Firmware-Version vielleicht geändert? Man findet die "Sonstig./weiter/System Informationen" unten links.

Von der "opend"-Meldung scheint der SolvisSmarthomeServer zwar vom Netzwerk erreichbar, er reagiert jedoch nicht mehr. Könnte sein, dass ein Thread abstürzt, nachdem er sich mit der SolvisRemote verbunden hat.

Hast Du schon in die Log-Datei des SolvisSmarthomeServers geschaut? Der liegt im "writablePathLinux". Wenn Du in der base.xml an der Stelle nichts geändert hast, steht dort "/opt/fhem". Dann befinden sich im Verzeichnis "/opt/fhem/SolvisServerData" folgende Dateien: solvis-tiny.log.X, solvis-error.log.X.

Wenn man da nichts sieht, wäre auch ein Dead-Lock möglich.

Hast Du die aktuelle SolvisSmarthomeServers-Version (mit dem aktuelen FHEM-Client)?

Hattest Du mal das Learning gezielt angestartet (sudo make learn). Läuft das durch?

Viele Grüße
   Stefan
Raspberry Pi 3 Model B mit Rasbian, SolvisMax, AVM DECT 200, Sonoff mit Tasmota geflasht

Offline SCMP77

  • Developer
  • Full Member
  • ****
  • Beiträge: 176
    • GitHub SolvisSmartHomeServer
Antw:Ansteuerung SolvisMax/Solvis-Remote
« Antwort #138 am: 27 August 2021, 12:03:45 »
Ich vermute das die images der remot nicht richtig erkannt werden, da beim direkten Zugriff über das web auf Solvis Remote unter Fernbedienung nur verzerrte bzw. keine images angezeigt werden.

Oh, das hatte ich irgenwie überlesen/nicht ganz verstanden. Also trotz ausgewechselter Solvisremode sind die Bilder verzerrt, ein schlechtes Zeichen, denn dann kann der  SolvisSmartHomeServer nicht mehr richtig arbeiten. kannst Du mal die verzerrte Darstellung hier mal als Grafik-Kopie reinlegen?

Trotzdem fände ich schon die Logs interessant, eigentlich sollte der Server - auch wenn er keine vernünftigen Bilder erhält - nicht in dieser Weise abstürzen/oder möglicherweise in eine Endlosschleife geraten. Wenn Du ein paar Grafik-Dateien hier posten könntest, wäre das ideal, dann kann ich das mal mit den Bildern untersuchen.

Am besten gehst Du über den Link "http://192.168.1.40/display.bmp?", wobei 192.168.1.40 durch die IP der Solvis-Control ersetzt werden muss. Dann wird die Grafik angezeigt, welche auch wirklich der Server sieht.

Viele Grüße
   Stefan
« Letzte Änderung: 27 August 2021, 12:06:03 von SCMP77 »
Raspberry Pi 3 Model B mit Rasbian, SolvisMax, AVM DECT 200, Sonoff mit Tasmota geflasht

Offline toka11

  • New Member
  • *
  • Beiträge: 9
Antw:Ansteuerung SolvisMax/Solvis-Remote
« Antwort #139 am: 27 August 2021, 18:21:36 »
Vielen Dank erstmal für die vielen Informationen. Im Anhang ein Beispiel wie die Images aussehen. Für Tips bin ich dankbar.

Offline toka11

  • New Member
  • *
  • Beiträge: 9
Antw:Ansteuerung SolvisMax/Solvis-Remote
« Antwort #140 am: 27 August 2021, 18:25:28 »
Hier noch die log files.

Offline SCMP77

  • Developer
  • Full Member
  • ****
  • Beiträge: 176
    • GitHub SolvisSmartHomeServer
Antw:Ansteuerung SolvisMax/Solvis-Remote
« Antwort #141 am: 27 August 2021, 19:02:52 »
Hallo toka11,

die Logs schaue ich mir an, ist zwar jetzt nicht die neueste Version. muss mal sehen woran das liegt. Aus dem Bildschirm glaubt er jedenfalls die Messagebox zu erkennen und danach gibt es einen Null-Pointer-Exception. Es wird dann zwar weiter gemacht, aber er hat dann Probleme die Größe des unbenutzten Rahmens zu ermitteln, das bringt dann wieder andere Fehler und er versucht es immer und immer wieder. Bei dem Bildschirminhalt ist das aber kein Wunder. Muss mal schauen, ob ich das besser löse, aber das sit eben nur die Folge von dem verhunsten Bildschirm.

Das Bildschirmfoto erinnert mich an alte Zeiten, von analogen Fernsehern, die einen Defekt in der horizontalen Synchronisation hatten.

Dumm ist, dass die Solvis-Schnittstelle eine BlackBox ist.

Wie ist das eigentlich, werden vernünftige Daten im Anlagenschema dargestellt?

Aber ich befürchte, dass nicht nur die SolvisRemote einen Schaden erlitten hat, sondern auch der Ausgang der SolvisRemote2, vermutlich ein Clock-Ausgang. Dass da überhaupt etwas dargestellt wird, ist trotzdem erstaunlich. Aber vielleicht tasten die Solvis-Leute bei einem nicht vorliegen eines Taktes die Datenleitung, auf dem das Bildsignal liegt, dann doch regelmäßig ab, aber eben nicht synchronisiert. Dann würde man ein Bild ähnlich wie in der Hardcopy sehen. Ich würde da Solvis mal per Mail kontaktieren. Die geben normalerweise auch Antwort.

Aber wie gesagt, ich befürchte, dass die Hauptplatine der SolvisControl2 noch getauscht werden müsste.

Viele Grüße
   Stefan
Raspberry Pi 3 Model B mit Rasbian, SolvisMax, AVM DECT 200, Sonoff mit Tasmota geflasht

Offline toka11

  • New Member
  • *
  • Beiträge: 9
Antw:Ansteuerung SolvisMax/Solvis-Remote
« Antwort #142 am: 27 August 2021, 19:20:19 »
Ja, ich befürchte auch, dass die SolvisControl einen Schaden hat. Leider kann mir der Heizungsinstallateur da nicht viel helfen. ich werde mal bei Solvis direkt nachfragen. Die scheinen die Remotecontrol wohl von einer anderen Firma (Prozeda GmbH) zu kaufen. Im Anlagenschema wird alles korrekt dargestellt und Werte werden auch geliefert.
Besten Dank erstmal.

Offline Scotty42

  • New Member
  • *
  • Beiträge: 9
Antw:Ansteuerung SolvisMax/Solvis-Remote
« Antwort #143 am: 05 September 2021, 11:18:36 »
Hallo zusammen,

ich habe heute Vormittag versucht vom alten Modul auf die aktuelle Version des SolvisSmartHomeServer umzusteigen.
Allerdings wirft der Learning-Prozess beim Starten SolvisSmartHomeServer.service beim Lernen des Anlagenstatus reproduzierbar Fehler, um dann komplett auszusteigen. Andere Screens werden angelernt.

Es ist eine SolvisMax7. Remote FW ist die neueste 2.22.01A mit WebApp 2.20.06. Ich habe keine extra erzeugten Status-Screens, zumindest habe ich keine erstellt. Ich füge die Bildsequenz hier an.

Wenn ich parallel zum Anlernen die WebApp offen habe und den Remote Click-Vorgängen zusehe, habe ich den Eindruck, dass das Blättern nicht funktioniert.
Bei jedem Blättern erhalten die .bmp eine neue Nummer.

Für Ideen und Hinweise wäre ich dankbar.
beste Grüße,
Markus

Sep 05 11:00:09 fhem java[3369]: 11:00:09,185|LEARN|de.sgollmer.solvismax.model.objects.screen.Screen - Screen <Anlagenstatus> not learned. Screen of sequence is not unique
Sep 05 11:00:16 fhem java[3369]: 11:00:16,682|LEARN|de.sgollmer.solvismax.model.objects.screen.Screen - Screen <Anlagenstatus> not learned. Screen of sequence is not unique
Sep 05 11:00:24 fhem java[3369]: 11:00:24,170|LEARN|de.sgollmer.solvismax.model.objects.screen.Screen - Screen <Anlagenstatus> not learned. Screen of sequence is not unique
Sep 05 11:00:39 fhem java[3369]: 11:00:39,631|LEARN|de.sgollmer.solvismax.model.objects.screen.Screen - Screen <Anlagenstatus> not learned. Screen of sequence is not unique
Sep 05 11:00:47 fhem java[3369]: 11:00:47,165|LEARN|de.sgollmer.solvismax.model.objects.screen.Screen - Screen <Anlagenstatus> not learned. Screen of sequence is not unique
Sep 05 11:00:54 fhem java[3369]: 11:00:54,660|LEARN|de.sgollmer.solvismax.model.objects.screen.Screen - Screen <Anlagenstatus> not learned. Screen of sequence is not unique
Sep 05 11:01:02 fhem java[3369]: 11:01:02,160|LEARN|de.sgollmer.solvismax.model.objects.screen.Screen - Screen <Anlagenstatus> not learned. Screen of sequence is not unique
Sep 05 11:01:09 fhem java[3369]: 11:01:09,660|LEARN|de.sgollmer.solvismax.model.objects.screen.Screen - Screen <Anlagenstatus> not learned. Screen of sequence is not unique
Sep 05 11:01:13 fhem java[3369]: 11:01:13,203|ERROR|de.sgollmer.solvismax.model.objects.screen.Screen - Learning of screen <Anlagenstatus> not possible. Learning terminated.
Sep 05 11:01:13 fhem java[3369]: 11:01:13,204|ERROR|de.sgollmer.solvismax.Main - Exception on reading configuration or learning files occured, cause:: de.sgollmer.solvismax.error.LearningTerminationException: Learning of screen <Anlagenstatus> not possible. Learning terminated.
Sep 05 11:01:13 fhem java[3369]:         at de.sgollmer.solvismax.model.objects.screen.Screen.learn(Screen.java:459)
Sep 05 11:01:13 fhem java[3369]:         at de.sgollmer.solvismax.model.objects.screen.Screen.learn(Screen.java:433)
Sep 05 11:01:13 fhem java[3369]:         at de.sgollmer.solvismax.model.objects.screen.Screen.learnScreens(Screen.java:364)
Sep 05 11:01:13 fhem java[3369]:         at de.sgollmer.solvismax.model.Solvis.learning(Solvis.java:549)
Sep 05 11:01:13 fhem java[3369]:         at de.sgollmer.solvismax.model.Instances.learn(Instances.java:97)
Sep 05 11:01:13 fhem java[3369]:         at de.sgollmer.solvismax.Main.execute(Main.java:336)
Sep 05 11:01:13 fhem java[3369]:         at de.sgollmer.solvismax.Main.main(Main.java:493)

Ich habe es gerade mit dem Debug Service erneut probiert, in der Hoffnung auf weitere Debug Ausgaben im Log. Jetzt wurden Solar und HK erkannt, der letzte Screen der Sequenz wieder nicht. Die Erkennung sieht mir korrekt aus, ich hänge die Learning Bilder hier auch mit an.

Sep 05 14:58:05 fhem java[4370]: 14:58:05,137|LEARN|de.sgollmer.solvismax.model.objects.screen.ScreenGraficDescription - Screen grafic <Anlagenstatus-HK Ben/Max7> learned.
Sep 05 14:58:09 fhem java[4370]: 14:58:09,089|LEARN|de.sgollmer.solvismax.model.objects.screen.ScreenGraficDescription - Screen grafic <Anlagenstatus-Solar Ben/Max7> learned.
Sep 05 14:58:13 fhem java[4370]: 14:58:13,043|LEARN|de.sgollmer.solvismax.model.objects.screen.Screen - Screen <Anlagenstatus> not learned. Screen of sequence is not unique
Sep 05 14:58:20 fhem java[4370]: 14:58:20,554|LEARN|de.sgollmer.solvismax.model.objects.screen.Screen - Screen <Anlagenstatus> not learned. Screen of sequence is not unique
Sep 05 14:58:28 fhem java[4370]: 14:58:28,057|LEARN|de.sgollmer.solvismax.model.objects.screen.Screen - Screen <Anlagenstatus> not learned. Screen of sequence is not unique
Sep 05 14:58:35 fhem java[4370]: 14:58:35,556|LEARN|de.sgollmer.solvismax.model.objects.screen.Screen - Screen <Anlagenstatus> not learned. Screen of sequence is not unique
Sep 05 14:58:43 fhem java[4370]: 14:58:43,065|LEARN|de.sgollmer.solvismax.model.objects.screen.Screen - Screen <Anlagenstatus> not learned. Screen of sequence is not unique
Sep 05 14:58:50 fhem java[4370]: 14:58:50,557|LEARN|de.sgollmer.solvismax.model.objects.screen.Screen - Screen <Anlagenstatus> not learned. Screen of sequence is not unique
Sep 05 14:58:58 fhem java[4370]: 14:58:58,060|LEARN|de.sgollmer.solvismax.model.objects.screen.Screen - Screen <Anlagenstatus> not learned. Screen of sequence is not unique
Sep 05 14:59:05 fhem java[4370]: 14:59:05,554|LEARN|de.sgollmer.solvismax.model.objects.screen.Screen - Screen <Anlagenstatus> not learned. Screen of sequence is not unique
Sep 05 14:59:13 fhem java[4370]: 14:59:13,054|LEARN|de.sgollmer.solvismax.model.objects.screen.Screen - Screen <Anlagenstatus> not learned. Screen of sequence is not unique
Sep 05 14:59:20 fhem java[4370]: 14:59:20,554|LEARN|de.sgollmer.solvismax.model.objects.screen.Screen - Screen <Anlagenstatus> not learned. Screen of sequence is not unique
Sep 05 14:59:28 fhem java[4370]: 14:59:28,055|LEARN|de.sgollmer.solvismax.model.objects.screen.Screen - Screen <Anlagenstatus> not learned. Screen of sequence is not unique
Sep 05 14:59:31 fhem java[4370]: 14:59:31,596|ERROR|de.sgollmer.solvismax.model.objects.screen.Screen - Learning of screen <Anlagenstatus> not possible. Learning terminated.
Sep 05 14:59:31 fhem java[4370]: 14:59:31,597|ERROR|de.sgollmer.solvismax.Main - Exception on reading configuration or learning files occured, cause:: de.sgollmer.solvismax.error.LearningTerminationException: Learning of screen <Anlagenstatus> not possible. Learning terminated.
Sep 05 14:59:31 fhem java[4370]:         at de.sgollmer.solvismax.model.objects.screen.Screen.learn(Screen.java:459)
Sep 05 14:59:31 fhem java[4370]:         at de.sgollmer.solvismax.model.objects.screen.Screen.learn(Screen.java:433)
Sep 05 14:59:31 fhem java[4370]:         at de.sgollmer.solvismax.model.objects.screen.Screen.learnScreens(Screen.java:364)
« Letzte Änderung: 05 September 2021, 15:04:38 von Scotty42 »

Offline SCMP77

  • Developer
  • Full Member
  • ****
  • Beiträge: 176
    • GitHub SolvisSmartHomeServer
Antw:Ansteuerung SolvisMax/Solvis-Remote
« Antwort #144 am: 05 September 2021, 20:12:12 »
Hallo Scotty,

Hallo zusammen,

ich habe heute Vormittag versucht vom alten Modul auf die aktuelle Version des SolvisSmartHomeServer umzusteigen.
Allerdings wirft der Learning-Prozess beim Starten SolvisSmartHomeServer.service beim Lernen des Anlagenstatus reproduzierbar Fehler, um dann komplett auszusteigen. Andere Screens werden angelernt.

Ich werde mir das ansehen. So wie die Fehlermeldung aussieht, schafft der Server es nicht den Anlagenstatus anzulernen.

Dieser Status hat mir schon immer Kopfzerbrechen bereitet, da bei Auswählen dieses Status eins der drei Bilder ausgewählt wird. Welches ist unklar. Um die Bilder trotzdem unterscheiden zu können, werden bestimmte Bereiche auf Weiß oder auf "mit Inhalt" grob getestet. Ich denke, das ist bei Dir mit der neuen Firmware/Konfiguration noch nicht ausreichend. Ich schau mir die Bilder vermutlich morgen an und vergleich das mit den überprüften Feldern. Sicher gibt es dann eine neue Version.

Viele Grüße
   Stefan
Raspberry Pi 3 Model B mit Rasbian, SolvisMax, AVM DECT 200, Sonoff mit Tasmota geflasht

Offline SCMP77

  • Developer
  • Full Member
  • ****
  • Beiträge: 176
    • GitHub SolvisSmartHomeServer
Antw:Ansteuerung SolvisMax/Solvis-Remote
« Antwort #145 am: 06 September 2021, 16:44:31 »
Hallo Scotty,

Allerdings wirft der Learning-Prozess beim Starten SolvisSmartHomeServer.service beim Lernen des Anlagenstatus reproduzierbar Fehler, um dann komplett auszusteigen. Andere Screens werden angelernt.

Es ist eine SolvisMax7. Remote FW ist die neueste 2.22.01A mit WebApp 2.20.06. Ich habe keine extra erzeugten Status-Screens, zumindest habe ich keine erstellt. Ich füge die Bildsequenz hier an.

Ich habe mir jetzt die Bilder angesehen.  Wie ich schon angenommen hatte, schlug die grobe Detektierung mittels MustBeWhite-Feldern mit der neueren Firmware fehl. Dadurch erkannte er keinen Unterschied zwischen Solar-Status und WW-Status und hat beide Bildschirme als Solarstatus interpretiert. Dadurch die Meldung "not unique".

Ich habe die MustBeWhite-Bereiche angepasst und auf GitHub den Release-Kandidaten V01.04.04-rc1 abgelegt. Kannst Du es damit mal testen?

Er liegt hier:

https://github.com/GollmerSt/SolvisSmartHomeServer/releases/tag/v01.04.04-rc1

Viele Grüße
   Stefan
Raspberry Pi 3 Model B mit Rasbian, SolvisMax, AVM DECT 200, Sonoff mit Tasmota geflasht

Offline Scotty42

  • New Member
  • *
  • Beiträge: 9
Antw:Ansteuerung SolvisMax/Solvis-Remote
« Antwort #146 am: 06 September 2021, 21:09:53 »
Hallo Stefan,

die 01.04.05-rc1 erkennt Anlagenstatus-HK,-WW,-Solar nun eindeutig.
Mir ist noch ein Warning aufgefallen:
Sep 06 21:02:52 fhem java[11391]: 21:02:52,187|LEARN|de.sgollmer.solvismax.model.objects.control.StrategyMode - Mode symbol not changed after touch, it will be waited a little longer.Aber das hindert nicht den Aufstart des Servers. Und mich eigentlich auch nicht im Betrieb. Normalerweise monitore ich die Daten, aber steuere nicht manuell bzw. fern. Das überlasse ich dem SC2.

Klasse, dass du die Erkennung so schnell stabilisieren konntest! :)

Die Client Einrichtung in FHEM muss ich morgen versuchen, das ist mir heute zu spät.

beste Grüße,
Markus

Offline SCMP77

  • Developer
  • Full Member
  • ****
  • Beiträge: 176
    • GitHub SolvisSmartHomeServer
Antw:Ansteuerung SolvisMax/Solvis-Remote
« Antwort #147 am: 07 September 2021, 08:15:22 »
Hallo Scotty,

das sieht jetzt ja schon gut aus.

Könntest Du die neueste Zip-Datei aus dem Ordner "SolvisServerdata/LearnedImages" posten? Die liegen in dem beschreibaren Linux-Pfad, der in der base.xml definiert ist. Dort liegt mindestens eine Zip-Datei mit allen Screens sowie den erkannten Symbolen. Dann kann ich die Screens der verschiedenen Firmware-Versionen vergleichen, möglicherweise gibt es da auch noch andere Abweichungen.

Mir ist noch ein Warning aufgefallen:
Sep 06 21:02:52 fhem java[11391]: 21:02:52,187|LEARN|de.sgollmer.solvismax.model.objects.control.StrategyMode - Mode symbol not changed after touch, it will be waited a little longer.

Diese Meldung kommt bei der SolvisMax7 recht häufig beim Anlernen. Genaugernommen handelt es sich um eine Maßnahme, welche ich speziell für die SolvisMax 7 eingebaut hatte. Die SolvisMax7 reagiert manchmal recht langsam auf die Touchs, langsamer als die SolvisMax6. Ich hätte die Wartezeit nach den Touchs noch deutlich vergrößern müssen, das wollte ich nicht. Das hätte das Ganze noch langsamer gemacht, daher überwacht der Server während des Anlernens, ob sich der Bildschirm nach einer gewissen Zeit auf den Touch hin etwas geändert hat. Wenn nicht, kommt diese Meldung und es wird nochmal diese Zeit gewartet. Da der Lernvorgang an dieser Stelle nicht mit einer Fehlermeldung abgebrochen wurde, muss sich nach der zweiten Wartezeit der Bildschirm geändert haben, der Server konnte die notwendigen Symbole sich merken und den Lernvorgang fortsetzen.

Später im eigentlichen Betrieb wird so ein zu spätes reagieren immer erkannt und korrigiert, da die Reaktion der SC2 auf jeden Touch immer überprüft wird (durch Erkennung der Veränderung der Symbole Veränderung der Werte mittels OCR). Die Touchbedienung arbeitet leider nicht immer zuverlässig, daher musste da ein höherer Aufwand betrieben werden.

Soweit ich das nun beurteilen kann, müsste das jetzt auch arbeiten. Kannst ja noch einen Rückmeldung geben, wenn Du mit dem FHEM-Client etwas experimentiert hast.

Viele Grüße
   Stefan
« Letzte Änderung: 07 September 2021, 08:19:33 von SCMP77 »
Raspberry Pi 3 Model B mit Rasbian, SolvisMax, AVM DECT 200, Sonoff mit Tasmota geflasht

Offline Scotty42

  • New Member
  • *
  • Beiträge: 9
Antw:Ansteuerung SolvisMax/Solvis-Remote
« Antwort #148 am: 07 September 2021, 21:30:03 »
Hallo Stefan,

die Einrichtung des FHEM Clients war problemlos möglich. Die Daten sind soweit ich es bisher nachvollziehen kann auch plausibel. Der RC hat meines Erachtens nach die Validierung bestanden :).
Ich hänge die zip der LearnedImages hier an. Außerdem noch einen ErrorScreen der im Lauf des Tages abgelegt wurde. Allerdings sieht das frappant nach dem normalen Home Screen aus. ...den Error nehme ich zurück. Heute ist der 7. - das bild ist vom 6.

beste Grüße, Markus

« Letzte Änderung: 07 September 2021, 21:35:03 von Scotty42 »

Offline SCMP77

  • Developer
  • Full Member
  • ****
  • Beiträge: 176
    • GitHub SolvisSmartHomeServer
Antw:Ansteuerung SolvisMax/Solvis-Remote
« Antwort #149 am: 07 September 2021, 21:52:22 »
Hallo Scotty,

ich sehe auf dem Home-Screen, dass die Anlage einen ständigen Fehler anzeigt. Das sieht man schon auf den angelernten Bildern. Normalerweise ist oberhalb des Euro-Buttons die Uhrzeit eingeblendet. Bei Dir ist stattdessen ein Button mit einem blinkenden Achtung-Schild.

Sprich Deine Anlage hat irgendwann einen Fehler gemeldet, welcher weggeklickt wurde. Kannst Du Dich daran noch erinnern. Um den erneut zu sehen, müsstest Du die Anlage mal aus und wieder einschalten.

Sonst scheint der Anlernvorgang geklappt zu haben. Das Anlernen der Modes erfolgte jedoch recht widerspenstig, hat dann beim dritten Anlauf geklappt. Vielleicht sollte ich bei der SolvisMax7 doch einen längere Zeit warten und zwar nur beim Anlernen. Das überlege ich mir nochmal.

Viele Grüße
   Stefan
Raspberry Pi 3 Model B mit Rasbian, SolvisMax, AVM DECT 200, Sonoff mit Tasmota geflasht

 

decade-submarginal