Autor Thema: Support of GeneralElectric enOcean smart plugs  (Gelesen 6326 mal)

Offline AlxDmr

  • Jr. Member
  • **
  • Beiträge: 59
Support of GeneralElectric enOcean smart plugs
« am: 03 November 2014, 19:53:00 »
Hello,
I get some General Electric enOcean smart plugs. They are detected as UTE device (?).
The device reference type is W1R16FP.

Internal description of the device as seen on Fhem is :
    DEF : 008770A0
    IODev : TCM310_0
    NAME : EnO_UTE_008770A0
    NR : 45
    STATE : ???
    TYPE : EnOcean

Did someone encountered that situation? And did someone knows how to extend the enOcean support and where to find descriptions of the devices?
Of course I tried to edit the file enOcean.pl but.... it's not that easy to get into it alone :)

Offline rudolfkoenig

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 24732
Antw:Support of GeneralElectric enOcean smart plugs
« Antwort #1 am: 03 November 2014, 23:23:29 »
I moved your thread into the EnOcean area, as it will get the attention of the EnOcean maintainer easier here.

There is a lot of information in the publicly available EnOcean Equipment Profiles PDF, but I don't know if this is needed in your case, as I am not up-to-date with all the EnOcean module details.

Offline klaus.schauer

  • Developer
  • Hero Member
  • ****
  • Beiträge: 1211
Antw:Support of GeneralElectric enOcean smart plugs
« Antwort #2 am: 04 November 2014, 06:23:20 »
Please update Fhem and send the complete description of the devices "list <name>"

Offline AlxDmr

  • Jr. Member
  • **
  • Beiträge: 59
Antw:Support of GeneralElectric enOcean smart plugs
« Antwort #3 am: 06 November 2014, 21:04:34 »
fhem> list EnO_UTE_0087BD6A
Internals:
   DEF        0087BD6A
   IODev      TCM310_0
   NAME       EnO_UTE_0087BD6A
   NR         49
   STATE      ???
   TYPE       EnOcean
Attributes:
   room       EnOcean
   subType    UTE


Offline klaus.schauer

  • Developer
  • Hero Member
  • ****
  • Beiträge: 1211
Antw:Support of GeneralElectric enOcean smart plugs
« Antwort #4 am: 07 November 2014, 06:26:29 »
Was the device deleted and teached in again?

Please do the following steps:
- update Fhem
- restart Fhem
- delete the UTE device
- set <iodev> teach 600
- send the teach-in telegram at the aktor
- check the new fhem device

Offline AlxDmr

  • Jr. Member
  • **
  • Beiträge: 59
Antw:Support of GeneralElectric enOcean smart plugs
« Antwort #5 am: 07 November 2014, 22:14:37 »
Ok, I used telnet to do update and delete, then the web UI for the rest.
Now I get :
fhem> list EnO_UTE_008770A0
Internals:
   CFGFN
   DEF        008770A0
   IODev      TCM310_0
   NAME       EnO_UTE_008770A0
   NOTIFYDEV  global
   NR         71
   NTFY_ORDER 50-EnO_UTE_008770A0
   STATE      ???
   TYPE       EnOcean
   Readings:
     2014-11-07 21:06:52   teach-in        EEP D2-01-06 Manufacturer: GE
Attributes:
   IODev      TCM310_0
   comMode    biDir
   devChannel FF
   eep        D2-01-06
   manufID    026
   room       EnOcean
   subType    actuator.01

It seems that I can not turn the plug on or off, I tried via web UI :
set EnO_UTE_008770A0 off

Offline klaus.schauer

  • Developer
  • Hero Member
  • ****
  • Beiträge: 1211
Antw:Support of GeneralElectric enOcean smart plugs
« Antwort #6 am: 08 November 2014, 07:21:22 »
Use
set EnO_UTE_008770A0 off 0or set it to default channel
attr EnO_UTE_008770A0 devChannel 0The device can also use a different channel. Please also check channel 1 ... 39 and read the Fhem commandref.

Offline AlxDmr

  • Jr. Member
  • **
  • Beiträge: 59
Antw:Support of GeneralElectric enOcean smart plugs
« Antwort #7 am: 09 November 2014, 16:03:37 »
Thanks!!
Now I am able to pilot the plug :)
I am now trying to get measurements for energy consomption, so here is what I do :
get  EnO_UTE_008770A0 measurement 0 power
or
get  EnO_UTE_008770A0 measurement 0 energy

In both case, nothing is returned, is there something that I should activated?
Those plug does measure consumption, I tested them with another (dedicated) system.

Thanks for your help :)

Offline klaus.schauer

  • Developer
  • Hero Member
  • ****
  • Beiträge: 1211
Antw:Support of GeneralElectric enOcean smart plugs
« Antwort #8 am: 09 November 2014, 18:28:56 »
EEP D2-01-06 supports Energy measurement only. The measuring unit is kWh. Probably it is displayed only after at least 1 kWh is consumed.

Offline AlxDmr

  • Jr. Member
  • **
  • Beiträge: 59
Antw:Support of GeneralElectric enOcean smart plugs
« Antwort #9 am: 09 November 2014, 20:49:43 »
Well the device is plugged to my laptop. In the system I used previously, I got notified every 10-15s about the cumulated consumption when something was plugged on it.
I consulted the log file of the plug and there was no log related to the consumption (nothing about power nor energy) although it has been plugged for a while.

Offline klaus.schauer

  • Developer
  • Hero Member
  • ****
  • Beiträge: 1211
Antw:Support of GeneralElectric enOcean smart plugs
« Antwort #10 am: 09 November 2014, 21:47:24 »
The device may send the consumption data under a different sender ID. Please set
attr TCM310_0 learningMode always , so that Fhem displays the telegrams of all received Sender IDs.

Offline AlxDmr

  • Jr. Member
  • **
  • Beiträge: 59
Antw:Support of GeneralElectric enOcean smart plugs
« Antwort #11 am: 11 November 2014, 10:24:51 »
Hello,
I discussed with the guy that implemented the energy measurement of General Electric smart plugs in his project. Actually the device do not emit ant consumption measurement by itself, it has to be explicitely interrogated (he was doing this every 10s), the device then send the measurement event if it has not changed.

I did what you advised and turn on forever the learning mode. I observed the traces during 10 mns and then activated following commands :
fhem> get  EnO_UTE_008770A0 measurement 0 power
fhem> get  EnO_UTE_008770A0 measurement 0 energy
fhem>

But there was no measurement logged, neither in telnet nor in the web log (every logs is related to another known device).

I am going to investigate more precisely how the measurements were done in the other project. Maybe a datagram is not catched or not well interpreted inside Fhem ? Anyway thanks for the help, all the more since you don't have the actual device, it may not be a piece of cake ^_^

Offline klaus.schauer

  • Developer
  • Hero Member
  • ****
  • Beiträge: 1211
Antw:Support of GeneralElectric enOcean smart plugs
« Antwort #12 am: 11 November 2014, 16:29:54 »
Which EEP datagram (data field) is sent in the other project to the smart plug?

Offline AlxDmr

  • Jr. Member
  • **
  • Beiträge: 59
Antw:Support of GeneralElectric enOcean smart plugs
« Antwort #13 am: 11 November 2014, 19:46:44 »
SOLVED :
sorry for having disturb you whith that problem. Actually it is possible to get the consumption using the following command :
get EnO_UTE_008770A0 measurement input power
as well as
get EnO_UTE_008770A0 measurement input energy
both return the same
2014-11-11 18:43:36 EnOcean EnO_UTE_008770A0 engergyUnitInput: Ws
2014-11-11 18:43:36 EnOcean EnO_UTE_008770A0 energyInput: 1749047

THANKS for the great job you did integrating enOcean stuff ! :)

 

decade-submarginal