Autor Thema: UniPi - The Universal Raspberry Pi add-on board  (Gelesen 46709 mal)

Offline betateilchen

  • Developer
  • Hero Member
  • ****
  • Beiträge: 16101
  • s/fhem\.cfg/configDB/g
Antw:UniPi - The Universal Raspberry Pi add-on board
« Antwort #90 am: 14 Dezember 2015, 20:47:09 »
tja, wieder mal jemand, der die Ankündigungen und Anpassungshinweise zu fhem 5.7 (oben rechts in rot auf jeder Seite zu finden!) nicht gelesen hat...

-----------------------
Unaufgeforderte Anfragen per email werden von mir nicht beantwortet. Dafür ist das Forum da.

Offline PEPITO82

  • Jr. Member
  • **
  • Beiträge: 86
Antw:UniPi - The Universal Raspberry Pi add-on board
« Antwort #91 am: 14 Dezember 2015, 21:13:18 »
Danke für den Hinweis...  :o
Mit $EVENT statt % funktioniert nun wieder alles.

Offline PEPITO82

  • Jr. Member
  • **
  • Beiträge: 86
Antw:UniPi - The Universal Raspberry Pi add-on board
« Antwort #92 am: 16 Dezember 2015, 09:41:33 »
Ich habe nun einen Luftqualitätsfühler mit analogem Ausgang (0-10V) an den analogen Eingang 1 (AI1+) verbunden.
In FHEM sind die analogen Eingänge als I2C_MCP342x angelegt.
Dort erhalte ich für Kanal 1 einen Wert von z.B. 404718.750 angezeigt.

Wie erhalte ich von diesem Wert eine übliche Spannungsangabe, z.B. 5,43 V ?
In der technischen Dokumentation des Unipi wird ein Korrekturfaktor von ca. 5.56 erwähnt.
« Letzte Änderung: 16 Dezember 2015, 09:50:49 von PEPITO82 »

Offline bemilic

  • New Member
  • *
  • Beiträge: 11
Antw:UniPi - The Universal Raspberry Pi add-on board
« Antwort #93 am: 28 Dezember 2015, 21:39:57 »
Ich habe das gleiche Problem mit den UniPi-Relay's.
Die Relay konnten monatelang problemlos über FHEM gesetzt werden.

Ja, ich habe mittlerweile die Infos zu 5.7 gelesen und bekomme es trotzdem nicht hin..
Grundlage ist das Image von UniPi: unipian_fhem v0.3 rpi

Log seit 5.7:
set relays0 PortA3 % : wrong value: % for "set relays0 PortA3" use one of: off,on
n_Relay5 return value: wrong value: % for "set relays0 PortA3" use one of: off,on

Ich habe dann in der Zeile  define n_Relay4 notify Relay4 {fhem("set relays0 PortA4 %")}
das % durch %EVENT bzw. $EVENT ersetzt (Unterschied?).
Dies bringt aber auch wieder einen Fehler:
set relays0 PortA3 %EVENT : wrong value: %EVENT for "set relays0 PortA3" use one of: off,on

Wo liegt den da mein Denkfehler????

Gruß
Bernd
1x RasPi with FHEM,HMLAN, HM-CC-TC, HM-CC-RT-DN, HM-LC-Bl1PBU-FM, HM-SEC-SC, OWDevice, HM-SEC-KEY, HM-SEC-MDIR-2,HM-SEC-SD

Offline klausw

  • Developer
  • Hero Member
  • ****
  • Beiträge: 1895
Antw:UniPi - The Universal Raspberry Pi add-on board
« Antwort #94 am: 29 Dezember 2015, 14:44:44 »
Ich habe das gleiche Problem mit den UniPi-Relay's.
Die Relay konnten monatelang problemlos über FHEM gesetzt werden.

Ja, ich habe mittlerweile die Infos zu 5.7 gelesen und bekomme es trotzdem nicht hin..
Grundlage ist das Image von UniPi: unipian_fhem v0.3 rpi

Log seit 5.7:
set relays0 PortA3 % : wrong value: % for "set relays0 PortA3" use one of: off,on
n_Relay5 return value: wrong value: % for "set relays0 PortA3" use one of: off,on

Ich habe dann in der Zeile  define n_Relay4 notify Relay4 {fhem("set relays0 PortA4 %")}
das % durch %EVENT bzw. $EVENT ersetzt (Unterschied?).
Dies bringt aber auch wieder einen Fehler:
set relays0 PortA3 %EVENT : wrong value: %EVENT for "set relays0 PortA3" use one of: off,on

Es funktionert nur noch $EVENT, das sollte anstelle des alten % funktionieren.
das bezieht sich natürlich nur auf notify und nicht auf das Eingabefeld
RasPi B v2 mit FHEM 18B20 über 1Wire, LED PWM Treiber über I2C, Luchtdruck-, Feuchtesensor und ein paar Schalter/LED\'s zum testen
Module: RPI_GPIO, RPII2C, I2C_EEPROM, I2C_MCP23008, I2C_MCP23017, I2C_MCP342x, I2C_PCA9532, I2C_PCF8574, I2C_SHT21, I2C_BME280

Offline bobo

  • New Member
  • *
  • Beiträge: 37
Antw:UniPi - The Universal Raspberry Pi add-on board
« Antwort #95 am: 04 Januar 2016, 15:10:28 »
Guten Tag,

kann mir jemand bitte zeigen wie ich den I2C_MCP342x mit dem UNIPI verbinde, bei mir funktioniert das nicht.

Danke
Bobo

Offline klausw

  • Developer
  • Hero Member
  • ****
  • Beiträge: 1895
Antw:UniPi - The Universal Raspberry Pi add-on board
« Antwort #96 am: 04 Januar 2016, 16:29:34 »
Die eckigen Klammern haben im DEF nix zu suchen
RasPi B v2 mit FHEM 18B20 über 1Wire, LED PWM Treiber über I2C, Luchtdruck-, Feuchtesensor und ein paar Schalter/LED\'s zum testen
Module: RPI_GPIO, RPII2C, I2C_EEPROM, I2C_MCP23008, I2C_MCP23017, I2C_MCP342x, I2C_PCA9532, I2C_PCF8574, I2C_SHT21, I2C_BME280

Offline bobo

  • New Member
  • *
  • Beiträge: 37
Antw:UniPi - The Universal Raspberry Pi add-on board
« Antwort #97 am: 05 Januar 2016, 08:01:08 »
Das habe ich übersehen, in der Beschreibung war das so angegeben.
Es funktioniert,

Danke

Bobo

Offline klausw

  • Developer
  • Hero Member
  • ****
  • Beiträge: 1895
Antw:UniPi - The Universal Raspberry Pi add-on board
« Antwort #98 am: 05 Januar 2016, 10:50:56 »
Das habe ich übersehen, in der Beschreibung war das so angegeben.
Es funktioniert,

Danke
Bitte

Eckige Klammern geben optionale Parameter an.
RasPi B v2 mit FHEM 18B20 über 1Wire, LED PWM Treiber über I2C, Luchtdruck-, Feuchtesensor und ein paar Schalter/LED\'s zum testen
Module: RPI_GPIO, RPII2C, I2C_EEPROM, I2C_MCP23008, I2C_MCP23017, I2C_MCP342x, I2C_PCA9532, I2C_PCF8574, I2C_SHT21, I2C_BME280

Offline bobo

  • New Member
  • *
  • Beiträge: 37
Antw:UniPi - The Universal Raspberry Pi add-on board
« Antwort #99 am: 05 Januar 2016, 16:18:18 »
Hallo clausw,

du hast recht, ich habe wohl zu schnell gelesen.

Danke für deine Hilfe

Offline klausw

  • Developer
  • Hero Member
  • ****
  • Beiträge: 1895
Antw:UniPi - The Universal Raspberry Pi add-on board
« Antwort #100 am: 08 Januar 2016, 10:47:04 »
The analog output works in the unipian_fhem v0.3 RPI image.
But the I2C analog output expansion board is not yet supported in fhem.
Apparently, a driver for the IC that is controlling the expansion board (PCA9685) is required. Does anyone have any idea on how to supply this in fhem?

PCA9685 ist now supported in FHEM
RasPi B v2 mit FHEM 18B20 über 1Wire, LED PWM Treiber über I2C, Luchtdruck-, Feuchtesensor und ein paar Schalter/LED\'s zum testen
Module: RPI_GPIO, RPII2C, I2C_EEPROM, I2C_MCP23008, I2C_MCP23017, I2C_MCP342x, I2C_PCA9532, I2C_PCF8574, I2C_SHT21, I2C_BME280

Offline Fred

  • New Member
  • *
  • Beiträge: 6
    • github.com
Antw:UniPi - The Universal Raspberry Pi add-on board
« Antwort #101 am: 11 Januar 2016, 23:14:48 »
Nachdem ich jetzt endlich erfolgreich den OWServer mit FHEM zum laufen gebracht habe, wollte ich euch an meinem Erfolg teilhaben lassen ;)

In dem configuration file /etc/owfs.conf  sollte folgende Anpassung gemacht werden:
! server: server = 4304

server: port = 4304

siehe: http://forum.fhem.de/index.php/topic,24413.msg178565.html#msg178565

@betateilchen: Vielleicht könntest du ja den ersten Beitrag anpassen.

Offline PEPITO82

  • Jr. Member
  • **
  • Beiträge: 86
Antw:UniPi - The Universal Raspberry Pi add-on board
« Antwort #102 am: 09 März 2016, 08:14:32 »
Bei mir hängen an den analogen Eingängen zwei Luftgütesensoren.
Leider kommt es immer wieder dazu, dass im Log keine Werte geschrieben werden - eigentlich sollte jede Minute ein Wert abgelegt werden:

2016-03-08_22:42:36 rg_dummy_airquality_state ai.Channel1: 450
2016-03-08_22:42:37 rg_dummy_airquality_state ai.Channel2: 475
2016-03-08_22:43:37 rg_dummy_airquality_state ai.Channel1: 459
2016-03-08_22:43:37 rg_dummy_airquality_state ai.Channel2: 485
2016-03-09_06:33:14 rg_dummy_airquality_state ai.Channel1: 567
2016-03-09_06:33:14 rg_dummy_airquality_state ai.Channel2: 469
2016-03-09_06:34:15 rg_dummy_airquality_state ai.Channel1: 564
2016-03-09_06:34:15 rg_dummy_airquality_state ai.Channel2: 467

Gegen 6:33h habe ich mit heute in FHEMWEB angemeldet. Erst nach Zugriff auf die Weboberfläche scheinen die Werte wieder gelesen bzw. geloggt zu werden.
Das passiert mittlerweile leider regelmäßig.

Meine Konfiguration sieht so aus:

# --- UniPi analog inputs
define ai I2C_MCP342x 104
attr ai IODev rpi2c
attr ai ch1factor 0.0011129362
attr ai ch1resolution 18
attr ai ch1roundDecimal 0
attr ai ch2factor 0.001112798
attr ai ch2resolution 18
attr ai ch2roundDecimal 0
attr ai poll_interval 1
attr ai room Luftqualität,UniPi

Woran könnte das liegen, dass die Werte nicht zuverlässig durchgehend gelesen werden?

Offline klausw

  • Developer
  • Hero Member
  • ****
  • Beiträge: 1895
Antw:UniPi - The Universal Raspberry Pi add-on board
« Antwort #103 am: 09 März 2016, 19:23:39 »
gibt es Fehlermeldungen im Log?
Wenn nicht, das Loglevel mal höhersetzen.
RasPi B v2 mit FHEM 18B20 über 1Wire, LED PWM Treiber über I2C, Luchtdruck-, Feuchtesensor und ein paar Schalter/LED\'s zum testen
Module: RPI_GPIO, RPII2C, I2C_EEPROM, I2C_MCP23008, I2C_MCP23017, I2C_MCP342x, I2C_PCA9532, I2C_PCF8574, I2C_SHT21, I2C_BME280

Offline PEPITO82

  • Jr. Member
  • **
  • Beiträge: 86
Antw:UniPi - The Universal Raspberry Pi add-on board
« Antwort #104 am: 09 März 2016, 19:42:07 »
Bisher keine Fehlermeldungen im Log.
Habe verbose für die analogen Eingänge nun auf 5 gesetzt.

Vermutlich werden die Messwerte heute Nacht wieder einschlafen.