Autor Thema: UniPi - The Universal Raspberry Pi add-on board  (Gelesen 50565 mal)

spaci76

  • Gast
Antw:UniPi - The Universal Raspberry Pi add-on board
« Antwort #120 am: 22 Juli 2017, 14:54:02 »
Hallo Ralf,

hast du die 1 Wire Thermometer über http angesteuert, wenn ja wie? Ich bekomme da einfach den value nicht angezeigt.

cu spaci76

ml76

  • Gast
Antw:UniPi - The Universal Raspberry Pi add-on board
« Antwort #121 am: 23 Januar 2018, 21:43:43 »
Hallo zusammen,

ich habe hier ein UniPi V1.1, welches ich mit meinem Pi3 (aktuelles Jessie) verbunden ist.
Nach der Anleitung von Seite 1 habe ich die Definitionen vorgenommen, über das definierte "Relais" Dummy kann ich auch die 8 Relais schalten.

Einzig der One-Wire Bus macht nicht wirklich etwas.
Ich kann über das Read des OWSERVER nichts finden.

Über i2cscan von der Linux Konsole kann ich aber meine Sensoren samt Adressen finden.
Hat hierzu jemand einen Rat für mich?

Oder wäre freundlicherweise jemand bereit einem absoluten Neuling diesbezüglich per Team Viewer o.ä. unter die Arme zu greifen?

Besten Dank & Gruß,
Markus

Offline origami

  • Newbie
  • Beiträge: 2
Antw:UniPi - The Universal Raspberry Pi add-on board
« Antwort #122 am: 16 März 2019, 16:42:50 »
Hallo Zusammen,
ich kämpfe zur Zeit mit dem Unipi board.
i2c Bibliothek ist geladen, jedoch kommt nach dem  #i2cdetect -y 1 keine Antwort, auch keine Fehlermeldung.
update und Neustart schon gemacht.
woran kann das liegen?

Danke für Hilfe

Dirk

Offline devien

  • Full Member
  • ***
  • Beiträge: 159
  • kommerziel ist nicht gleichzusetzen mit qualitativ
Antw:UniPi - The Universal Raspberry Pi add-on board
« Antwort #123 am: 22 August 2019, 16:28:52 »
Hallo Zusammen,
ich kämpfe zur Zeit mit dem Unipi board.
i2c Bibliothek ist geladen, jedoch kommt nach dem  #i2cdetect -y 1 keine Antwort, auch keine Fehlermeldung.
update und Neustart schon gemacht.
woran kann das liegen?

Danke für Hilfe

Dirk

na, hast das Problem schon gefunden?
Ich kann mir gut vorstellen das du die I2C Packete nicht installiert hast.

Gruß
FHEM + UniPi + Arduino = gute Lösung

Offline RZNYKJ

  • New Member
  • *
  • Beiträge: 3
Antw:UniPi - The Universal Raspberry Pi add-on board
« Antwort #124 am: 10 Mai 2020, 08:38:36 »
Guten Morgen,
habe mich nach langem Zögern für das Unipi 1.1 Board entschieden und gestern meine ersten Versuche damit unternommen. Leider gibt es dazu, bis auf diesen Thread, nicht besonders viele Infos. Nun ja, konnte alles soweit einbinden und die Relais kann ich auch schalten. Mir ist aber leider überhaupt nicht klar, wie ich die digitalen Eingänge lesen kann... Aus der Commandref wurde ich diesbezüglich auch nicht schlauer. Könnt ihr mir einen Tipp geben?

Danke und Gruß
Achim

Offline klausw

  • Developer
  • Hero Member
  • ****
  • Beiträge: 1925
Antw:UniPi - The Universal Raspberry Pi add-on board
« Antwort #125 am: 12 Mai 2020, 11:23:31 »
Hallo Achim,

die Eingänge gehen auf die GPIOs des Pi.
Dafür kannst du das Modul RPI_GPIO nutzen.
Die GPIO Nummern solltest du in der UniPi Doku finden

Klaus
RasPi B v2 mit FHEM 18B20 über 1Wire, LED PWM Treiber über I2C, Luchtdruck-, Feuchtesensor und ein paar Schalter/LED\'s zum testen
Module: RPI_GPIO, RPII2C, I2C_EEPROM, I2C_MCP23008, I2C_MCP23017, I2C_MCP342x, I2C_PCA9532, I2C_PCF8574, I2C_SHT21, I2C_BME280

Offline RZNYKJ

  • New Member
  • *
  • Beiträge: 3
Antw:UniPi - The Universal Raspberry Pi add-on board
« Antwort #126 am: 14 Mai 2020, 11:31:23 »
Danke, das hat geholfen. Dachte zunächst das wäre auf über I2C ansprechbar.

Offline Marco4321

  • Newbie
  • Beiträge: 1
Antw:UniPi - The Universal Raspberry Pi add-on board
« Antwort #127 am: 10 Juli 2020, 18:05:34 »
na, hast das Problem schon gefunden?
Ich kann mir gut vorstellen das du die I2C Packete nicht installiert hast.

Gruß

hab anscheinend auch das Problem.
wollte wie auf Seite 1 vorgehen, nach apt-get install i2c-tools libi2c-dev    und jetzt   i2cdetect -y 1  folgende Meldung :
Error: Could not open file `/dev/i2c-1' or `/dev/i2c/1': No such file or directory

jemand eine Idee, suche schon seit Stunden  :-[

10 min nach dem geschriebenen hab ich es dann doch noch gefunden. Musste erst in sudo raspi-config  --> interface option --> i2c  einschalten
« Letzte Änderung: 10 Juli 2020, 19:46:55 von Marco4321 »

 

decade-submarginal