Autor Thema: THZ Tecalor (LWZ Stiebel Eltron) Wärmepumpe -Optimierung und Erfahrungsaustausch  (Gelesen 269905 mal)

Online friesenjung

  • Full Member
  • ***
  • Beiträge: 238
Nur eine Idee. Ich hatte letztens ein DNS-Auflösungsproblem.

Geht eine Verbindung per IP-Adresse auch nicht?


Gesendet von iPhone mit Tapatalk
FHEM auf Raspi 2,  Jeelink-Clone 1x für PCA301 und 1x für Lacrosse, THZ304SOL, Homematic: CUL_HM / M-MOD-RPI-PCB, Pushover, Xiaomi s50

Offline TheTrumpeter

  • Sr. Member
  • ****
  • Beiträge: 502
Nur eine Idee. Ich hatte letztens ein DNS-Auflösungsproblem.

Geht eine Verbindung per IP-Adresse auch nicht?
Nein, im Heimnetz verwende ich ohnehin die (fixe) IP, sowohl für FHEM-Web als auch VNC.
FHEM auf RPi3, THZ (LWZ404SOL), RPII2C & I2C_MCP342x (ADCPiZero), PowerMap, CustomReadings, RPI_GPIO, Twilight, nanoCUL (WMBus für Diehl Wasserzähler & Regenerationszähler für BWT AqaSmart)

Offline willybauss

  • Hero Member
  • *****
  • Beiträge: 1595
Schon mal versucht, Bildschirm und Tastatur direkt an den Raspi zu hängen? Notfalls auch den Fernseher; die haben meist einen HDMI-Eingang.
FHEM auf Raspberry Pi B und 2B; THZ (THZ-303SOL), CUL_HM, TCM-EnOcean, SamsungTV, JSONMETER, SYSMON, OBIS, STATISTICS, CO20, FHEM2FHEM

Offline TheTrumpeter

  • Sr. Member
  • ****
  • Beiträge: 502
Schon mal versucht, Bildschirm und Tastatur direkt an den Raspi zu hängen? Notfalls auch den Fernseher; die haben meist einen HDMI-Eingang.
Genau das ist ja schwierig, weil der RasPi samt den ganzen Aufsatz-Boards in einem Schaltschrank hängt und ich da nicht so einfach ein HDMI-Kabel dranhängen kann.
Nur: Warum sollte dieser RasPi dann ein Bild mit der SD-Karte anzeigen, wenn's der andere RasPi nicht tut?

Ich spiel' grad ein neues Raspbian auf eine SD-Karte, um den 2. RasPi dann zum Auslesen der FHEM-SD-Karte sowie des USB-Sticks zu verwenden. Mal sehen was da drauf ist oder nicht drauf ist... Wie gesagt, alles irgendwie komisch.
FHEM auf RPi3, THZ (LWZ404SOL), RPII2C & I2C_MCP342x (ADCPiZero), PowerMap, CustomReadings, RPI_GPIO, Twilight, nanoCUL (WMBus für Diehl Wasserzähler & Regenerationszähler für BWT AqaSmart)

Offline willybauss

  • Hero Member
  • *****
  • Beiträge: 1595
... Warum sollte dieser RasPi dann ein Bild mit der SD-Karte anzeigen, wenn's der andere RasPi nicht tut? ...
ok, jetzt hab ich das auch verstanden. Beide Raspis sind identisch?
FHEM auf Raspberry Pi B und 2B; THZ (THZ-303SOL), CUL_HM, TCM-EnOcean, SamsungTV, JSONMETER, SYSMON, OBIS, STATISTICS, CO20, FHEM2FHEM

Offline TheTrumpeter

  • Sr. Member
  • ****
  • Beiträge: 502
ok, jetzt hab ich das auch verstanden. Beide Raspis sind identisch?
Die RasPis ja, die Peripherie nicht.

Habe nun einen kleinen Teilerfolg...
Den Inhalt vom Daten-USB-Stick kann ich auf frisch aufgesetzten Raspbian problemlos auslesen und auch die SD-Karte. Nach Manipulation der Config.txt und fstab kriege ich auch Bild, aber dann gleich eine Fehlermeldung, dass der SU-Account geloggt ist. Ausserdem kann die RAMDisk nicht gemountet werden?! Danach geht nix mehr.
Spiele gerade ein älteres Image auf, mal sehen was nach der fstab-Modifikation damit läuft oder nicht läuft.
FHEM auf RPi3, THZ (LWZ404SOL), RPII2C & I2C_MCP342x (ADCPiZero), PowerMap, CustomReadings, RPI_GPIO, Twilight, nanoCUL (WMBus für Diehl Wasserzähler & Regenerationszähler für BWT AqaSmart)

Offline TheTrumpeter

  • Sr. Member
  • ****
  • Beiträge: 502
So, RasPi läuft wieder, wenngleich nicht vom Letztstand.

Vorläufige Kurzzusammenfassung, vielleicht hilft's ja jemandem...

Problem 1: Durch eine spezielle Einstellung für RealVNC, die ich in der Config.txt gemacht habe (für sinnvolle Auflösung per VNC), wird kein Bild angezeigt, auch wenn ein Display dranhängt. Das lässt sich einfach durch Auskommentieren der RealVNC-Settings lösen.

Problem 2: Mit den aktuellen Images (inkl. RAMDisk) bekomme ich weiterhin die "root user gesperrt"-Fehlermeldung. Lt. Google deutet das auf eine unpassende fstab hin; die passt aber natürlich zu den Images, d.h. wie sich dieser Fehler lösen lässt, weiss ich nicht.

Vorübergehend habe ich daher das letzte verfügbare Image vor der RAMDisk-Installation wiederhergestellt, die fhem.cfg übernommen und an die geänderten Pfade/Rahmenbedingungen angepasst.
Blöderweise spiele ich nur die fhem.cfg ins Backup, nicht aber beispielsweise die gplot-Dateien. Jetzt muss ich dann also noch ein aktuelles Image auf eine SD-Karte spielen und die gplot-Dateien im 2. RasPi mittels USB-Adapter davon auslesen...

Aber im Großen und Ganzen läuft's erstmal wieder; wodurch dieses "root user locked" Problem verursacht wird bzw. wie ich es beheben kann, weiss ich noch nicht.
FHEM auf RPi3, THZ (LWZ404SOL), RPII2C & I2C_MCP342x (ADCPiZero), PowerMap, CustomReadings, RPI_GPIO, Twilight, nanoCUL (WMBus für Diehl Wasserzähler & Regenerationszähler für BWT AqaSmart)

Offline immi

  • Developer
  • Sr. Member
  • ****
  • Beiträge: 935
Do you have experience with fhembackup and with restoring such a backup?
willy
I never needed to recover my backup because my hardware has never died;
I recover sometimes from backups, because I test my software changes directly on my productive system :)
I do not use normally the fhem-backup;
Zitat
Usually running processes/programs should be stopped before backup actions.
As general approach you are right, nevertheless I expect fhem-backup not to give you any problems.
If you change the default fhembackup with backupcmd, you have to be more carefull (e.g. if you start non blocking jobs)

Anyways I am off-topic; backup belongs to CoolTux  and should be discussed in Sonstiges
 immi

Offline TheTrumpeter

  • Sr. Member
  • ****
  • Beiträge: 502
So, Problem mit der FHEM-Installation ist erstmal gelöst, das auslösende Thema der Nicht-Erreichbarkeit von Außen noch nicht, aber erstmal im Detail:

Ursache für das Nicht-Booten bzw. die "root account locked" Meldung war, dass sich ein Laufwerk aus der fstab nicht verbinden liess. Es handelte sich tatsächlich um die RAMDisk. Offenbar habe ich nach deren Installation das Einbinden mittels "mount -a" getestet und, nachdem es funktioniert hat, dann aber nicht mehr neu gestartet. Allerdings hatte ich in den fstab-Optionen einen Fehler bzgl. Beechtigungen, die beim erstmaligen Einbinden mittels "mount -a" kein Problem verursachen, beim Reboot dann aber "zuschlagen". Warum das so ist, verstehe ich nicht, es ist aber reproduzierbar.

Jetzt habe ich die fstab gleich so angepasst, dass ein nicht einbindbares Laufwerk übergangen wird und der Systemstart trotzdem fortgesetzt werden kann.

Nun muss ich nur noch das Thema "Erreichbarkeit" lösen. Mittlerweile habe ich diesbezüglich aber meinen Provider in Verdacht. Lt. Logs der Fritz.box wurden keinerlei Einstellungen geändert (habe ich ohnehin nicht gemacht, könnte höchstes per Provider-Fernzugriff passiert sein) und am RasPi habe ich ebenfalls nichts geändert. Trotzdem weist mir ein IPv6-Test nun aus, dass ich mittels IPv6 nicht erreichbar bin, weder am RasPi noch am PC. Als ich das damals aufgesetzt habe, war das ziemlich sicher auf beiden Geräte anders.


EDIT: Zumindest weiss ich jetzt, dass mein automatisches SD-Karten-Backup funktioniert & bzgl. fstab und config.txt habe ich auch wieder was dazugelernt.  >:(
FHEM auf RPi3, THZ (LWZ404SOL), RPII2C & I2C_MCP342x (ADCPiZero), PowerMap, CustomReadings, RPI_GPIO, Twilight, nanoCUL (WMBus für Diehl Wasserzähler & Regenerationszähler für BWT AqaSmart)

Offline willybauss

  • Hero Member
  • *****
  • Beiträge: 1595
...
Jetzt habe ich die fstab gleich so angepasst, dass ein nicht einbindbares Laufwerk übergangen wird und der Systemstart trotzdem fortgesetzt werden kann.
Da wäre ich an Details interessiert. Kann ja Jedem passieren. Bei mir wäre das ein eingebundenes NAS. Wenn das die Grätsche macht steht auch der Raspi  :-X
FHEM auf Raspberry Pi B und 2B; THZ (THZ-303SOL), CUL_HM, TCM-EnOcean, SamsungTV, JSONMETER, SYSMON, OBIS, STATISTICS, CO20, FHEM2FHEM

Offline TheTrumpeter

  • Sr. Member
  • ****
  • Beiträge: 502
Da wäre ich an Details interessiert. Kann ja Jedem passieren. Bei mir wäre das ein eingebundenes NAS. Wenn das die Grätsche macht steht auch der Raspi  :-X
Die zugehörige Option ist "nofail", wobei dann ein zusätzliches Setzen des Timeouts auf einen geringen Wert sinnvoll ist, weil der Standardwert recht hoch ist und daher eine signifikante Boot-Verzögerung versacht, also einfach die relevanten fstab-Einträge um folgendes ergänzen:
nofail,x-systemd.device-timeout=5
FHEM auf RPi3, THZ (LWZ404SOL), RPII2C & I2C_MCP342x (ADCPiZero), PowerMap, CustomReadings, RPI_GPIO, Twilight, nanoCUL (WMBus für Diehl Wasserzähler & Regenerationszähler für BWT AqaSmart)

Offline parabacus

  • Full Member
  • ***
  • Beiträge: 261
Wegen Nicht-Erreichbarkeit von aussen... - das Problem hatte ich auch mal!
Kann es sein, dass du bei Kabel-D/Vodafone bist? Die haben mich auch mal einfach ohne Ankündigung von IPv4 auf IPv6 geändert und da benutezn die ein "kastrietes" IP-V6 (..mir fällt eben der Fachbegriff nicht ein...  ???).
Schliesslich und endlich hab ich mir dann eine IPv4-WAN-Adresse legen lassen - so wie's vorher war und seit dem geht das auch wieder.
Stiebel Eltron LWZ 504 / FHEM auf Rasperry Pi 3 / THZ / Weather / TABLETUI / SB_SERVER / SB_PLAYER  / OBIS / Verkehrsinfo / speedtest / Presence / FRITZ / ZWDongle / ZWAVE / Calendar / CALVIEW/ IPCAM/ ABFALL / ESPEasy

Offline BigNose82

  • Full Member
  • ***
  • Beiträge: 252
Dualstack light  ;D
LWZ 304 Trend - Hausautomatisierung über z-wave mit dem Fibaro HC2

Offline TheTrumpeter

  • Sr. Member
  • ****
  • Beiträge: 502
Wegen Nicht-Erreichbarkeit von aussen... - das Problem hatte ich auch mal!
Kann es sein, dass du bei Kabel-D/Vodafone bist? Die haben mich auch mal einfach ohne Ankündigung von IPv4 auf IPv6 geändert und da benutezn die ein "kastrietes" IP-V6 (..mir fällt eben der Fachbegriff nicht ein...  ???).
Schliesslich und endlich hab ich mir dann eine IPv4-WAN-Adresse legen lassen - so wie's vorher war und seit dem geht das auch wieder.
Nein, lt. Anbieter hat sich nichts geändert.
Ich habe schon länger nur noch eine (statische) IPv6 und dafür einen externen Port-Weiterleitungsmechanismus einrichten müssen, um aus IPv4-Netzen (z.B. 4G) weiterhin auf FHEM-Web zugreifen zu können. Das lief nach einer anfänglich schwierigen Setup-Phase nun monatelang gut, seit Dienstag geht es plötzlich nicht mehr und niemand hat angeblich was gemacht. Ich weiss, dass ich nix gemacht habe und mein Provider sagt er war's auch nicht. Mitterweile wurden alle Geräte inkl. Modem/Router neu gestartet und es läuft immer noch nicht.
Ich kann nur noch ein anderes Image vom Raspberry versuchen, weil ich nicht 100%ig sicher bin, ob es mit dem letzten verfügbaren vor der RAMDisk-Installation schon funktionieren müsste. Sonst habe ich noch kein anderes Image probiert, weil ich nach dem gelösten fstab-Problem ja wieder den Letztstand (bei dem das Erreichbarkeitsproblem der Auslöser für den Reboot und die damit verbundenen fstab-Probleme war) eingespielt habe.
Ich kann meinen FHEM-Raspi von intern per IPv6 pingen und wenn ich FHEM-Web per IPv6 aufrufe, kann ich von intern zumindest mit dem IE verbinden, Mozilla stürzt nach der Anmeldung sofort (reproduzierbar) ab.
Damit schließe ich als Fehlerursache den RasPi bzw. FHEM eigentlich aus und das Problem kann nur noch beim Router/Modem, dem Portmapping-Dienst oder dem Provider liegen. Letzterer sagt er war's nicht, also mal weitersuchen  :(
FHEM auf RPi3, THZ (LWZ404SOL), RPII2C & I2C_MCP342x (ADCPiZero), PowerMap, CustomReadings, RPI_GPIO, Twilight, nanoCUL (WMBus für Diehl Wasserzähler & Regenerationszähler für BWT AqaSmart)

Offline parabacus

  • Full Member
  • ***
  • Beiträge: 261
Dualstack light  ;D

Korrekt - hatte nur noch DS-light im Kopf - also Abkürzung dessen, war mir aber nicht mehr sicher, ob das nicht was berufliches war... - hab zu viele Akronyme im Gebrauch....  ::)

Hast du mal versucht irgend einen anderen Web-Server eines Geräts im internen Netz für Zugriff von aussen freizugeben? Klappt's mit dem dann (..auch nicht)?
Ich hab jetzt nicht alles genau verfolgt - hast du einfach per Port-Mapping den RPi von aussen erreichbar gemacht oder geschützt über einen VPN?
Stiebel Eltron LWZ 504 / FHEM auf Rasperry Pi 3 / THZ / Weather / TABLETUI / SB_SERVER / SB_PLAYER  / OBIS / Verkehrsinfo / speedtest / Presence / FRITZ / ZWDongle / ZWAVE / Calendar / CALVIEW/ IPCAM/ ABFALL / ESPEasy