Autor Thema: THZ Tecalor (LWZ Stiebel Eltron) Wärmepumpe -Optimierung und Erfahrungsaustausch  (Gelesen 499122 mal)

Offline willybauss

  • Hero Member
  • *****
  • Beiträge: 1820
aber warum der Zuheizer bei mir dann um ca. 3:10 nicht eingeschaltet hat ist somit nicht zu erklären.
denn um ca. 7:00 hat er ja brav zugeschaltet. und in der zwischenzeit habe ich auch nix an meiner heizung umgestellt.
oder kann man das erklären?
Danke
Im Plot fehlen die Kurven für die Hysterese. So weiß man gar nicht, ob der HEizstab überhaupt angefordert wurde.
FHEM auf Raspberry Pi B und 2B; THZ (THZ-303SOL), CUL_HM, TCM-EnOcean, SamsungTV, JSONMETER, SYSMON, OBIS, STATISTICS, CO20, FHEM2FHEM

Offline The Spirit

  • Full Member
  • ***
  • Beiträge: 248
somit müsste ich ja nur die hystere 1 werte bzw. das integral mit anzeigen, oder?
die sind ja für das zuschalten bzw. abschalten der stufen zuständig.
ist das richtig?
Danke
THZ 304 Eco Baujahr 2015

Offline willybauss

  • Hero Member
  • *****
  • Beiträge: 1820
Du hast Die den von mir angehängten Plot nicht angeschaut? on-und offHysterese sind Bestandteile des readings sHC1.

Lesen von deren Bedeutung im Manual der Anlage wäre hilfreich.
FHEM auf Raspberry Pi B und 2B; THZ (THZ-303SOL), CUL_HM, TCM-EnOcean, SamsungTV, JSONMETER, SYSMON, OBIS, STATISTICS, CO20, FHEM2FHEM

Offline The Spirit

  • Full Member
  • ***
  • Beiträge: 248
Sorry, hatte das mit der onHysterese und offHysterese nicht gesehen.
Sieht jetzt so bei mir aus.
In dem manual was ich hab habe ich leider keine Erklärung zu onHystere oder offHysterese gefunden.
« Letzte Änderung: 11 Januar 2021, 12:11:20 von The Spirit »
THZ 304 Eco Baujahr 2015

Offline TheTrumpeter

  • Sr. Member
  • ****
  • Beiträge: 769
aber warum der Zuheizer bei mir dann um ca. 3:10 nicht eingeschaltet hat ist somit nicht zu erklären.
Doch, da wurde eindeutig abgetaut. Sieht man am Einbruch der HK-Temperatur.
FHEM auf RPi3, THZ (LWZ404SOL), RPII2C & I2C_MCP342x (ADCPiZero), PowerMap, CustomReadings, RPI_GPIO, Twilight, nanoCUL (WMBus für Diehl Wasserzähler & Regenerationszähler für BWT AqaSmart), ESPEasy, TPLinkHS110

Offline TheTrumpeter

  • Sr. Member
  • ****
  • Beiträge: 769
Das sind lt. TheTrumpeters Untersuchungen (blättere mal ein paar Hundert Seiten zurück ...  :) ) nur sehr kurze Phasen von ein paar Sekunden. Wenn das nicht gerade zufällig mit einem Log-Zeitpunkt zusammenfällt, sieht man das nicht.
Exakt. Und beeinflussen lässt sich das ein bisschen mittels p99FrostProtectionBoost.
Siehe dazu auch die Ausführungen in der Installationsanleitung:
Zitat
Einfrierschutz NE: Unterschreitet die Verflüssigertemperatur während des Abtauvorgangs den unter "EINFRIERSCHUTZ NE" definierten Grenzwert, wird die elektrische Nacherwärmung zugeschaltet, um ein weiteres Auskühlen des Heizungswassers zu vermeiden.


EDIT: Zu meiner "Bug-Theorie":
Ev. passiert das unabhängig vom Zuheizen während des Abtauens und es wird während des Abtauens beim Unterschreiten der Hysterese/Integrals generell keine weitere Heizstufe angefordert.
« Letzte Änderung: 11 Januar 2021, 14:29:05 von TheTrumpeter »
FHEM auf RPi3, THZ (LWZ404SOL), RPII2C & I2C_MCP342x (ADCPiZero), PowerMap, CustomReadings, RPI_GPIO, Twilight, nanoCUL (WMBus für Diehl Wasserzähler & Regenerationszähler für BWT AqaSmart), ESPEasy, TPLinkHS110

Offline zimb0

  • Full Member
  • ***
  • Beiträge: 100
doofe Frage in die Runde:
Meine WP läuft soweit rund, nun wollte ich den kleinen kosmetischen Fehler beheben:
p01 ist aktuell auf 20°C eingestellt. Im Haus hat es allerdings die gewünschten 22°C.
Nun wollte ich p14 abändern, die Heizkurve parallel nach unten verschieben und die p01 danach um 2°C erhöhen.
Leider steht p14 auf 1K und kann keine negativen Werte beinhalten.
Kann ich das irgendwie lösen?
Theoretisch noch über P86 (den Parameter finde ich gerade gar nicht im FHEM), allerdings ist mein Heizungsfühler bereits ca. 2° über reeller AT, würde somit auch nur das Gegenteil bewirken.

Ideen? :)
THZ504

Offline willybauss

  • Hero Member
  • *****
  • Beiträge: 1820
Sorry, hatte das mit der onHysterese und offHysterese nicht gesehen.
Sieht jetzt so bei mir aus.
In dem manual was ich hab habe ich leider keine Erklärung zu onHystere oder offHysterese gefunden.
Jetzt sieht man, dass 3:10 Uhr keine Anforderung für die Zuheizung war.

So andeutungsweise findet man im Manual das, was ich angehängt habe. Die "Leistungsstufen" im Text (Kap. 7.5) entsprechen den Heiz-Hysteresen in der Tabelle, wobei die Nummernzuordnung wiederum nicht zu dem passt, was in sHC1 steht...

In deinem Plot wird zwischen 1 und 2 geschaltet, lt. Tabelle sollte es aber 2 und 3 sein. Es sei denn Du hast kein Solar verbaut, dann wird das möglicherweise ausgeklammert; dann würde es wieder stimmen.

Bei meiner alten 303 war das besser erklärt. Irgendwo müssen die alten Anlagen ja besser sein  :).
« Letzte Änderung: 11 Januar 2021, 18:40:20 von willybauss »
FHEM auf Raspberry Pi B und 2B; THZ (THZ-303SOL), CUL_HM, TCM-EnOcean, SamsungTV, JSONMETER, SYSMON, OBIS, STATISTICS, CO20, FHEM2FHEM

Offline TheTrumpeter

  • Sr. Member
  • ****
  • Beiträge: 769
p01 ist aktuell auf 20°C eingestellt. Im Haus hat es allerdings die gewünschten 22°C.
Nun wollte ich p14 abändern, die Heizkurve parallel nach unten verschieben und die p01 danach um 2°C erhöhen.
Leider steht p14 auf 1K und kann keine negativen Werte beinhalten.
Kann ich das irgendwie lösen?
Ja, p14 auf 0 setzen. Lt. der mir vorliegenden Anleitung zur LWZ304/404SOL ist das der niedrigste mögliche Wert.

(Die Heizkurve um 1 K nach unten zu schieben bedeutet nicht zwangsweise, dass es im Haus um 1 K kälter wird, es könnte auch mehr oder weniger sein. Also einfach ausprobieren.)
FHEM auf RPi3, THZ (LWZ404SOL), RPII2C & I2C_MCP342x (ADCPiZero), PowerMap, CustomReadings, RPI_GPIO, Twilight, nanoCUL (WMBus für Diehl Wasserzähler & Regenerationszähler für BWT AqaSmart), ESPEasy, TPLinkHS110

Offline willybauss

  • Hero Member
  • *****
  • Beiträge: 1820
P86 dient der Korrektur der AUSSENtemperatur, nicht Innentemperatur. Es würde sich aber trotzdem lohnen, das zu kontrollieren:

=> stimmt die im Display angezeigte Außentemperatur mit der Temperatur überein, die ein gutes Außenthermometer an derselben Stelle (!) misst? Wenn nicht: mit P86 korrigieren.

Evtl. glaubt die Anlage wegen eines falsch messenden Außenfühlers, es sei kälter als es tatsächlich ist.

Oder die Position des Außenfühlers ist suboptimal. Wenn er z.B. direkt neben dem Abluftauslass der Anlage sitzt, dann misst er natürlich viel zu niedrige Temperaturen.

Für eine verlässliche Arbeitsweise der Anlage sind solche Basiseinstellungen natürlich nötig, um Würgarounds mit bewusst falsch eingestellter P01 zu vermeiden.

Und wie TheTrumpeter schon angedeutet hat: eine Parallelverschiebung der Heizkurve um 1° kann durchaus reichen, um 2° weniger Innentemperatur zu erreichen. Nach Änderungen mindestens 1 - 2 Tage abwarten, da ein solches System SEHR träge ist.
FHEM auf Raspberry Pi B und 2B; THZ (THZ-303SOL), CUL_HM, TCM-EnOcean, SamsungTV, JSONMETER, SYSMON, OBIS, STATISTICS, CO20, FHEM2FHEM

Offline Paul Keller

  • New Member
  • *
  • Beiträge: 6
Falsche Heissgastemperatur, wenn ich langes Kabel zur Verbindung mit FHEM anschließe.

Der Fehler tritt sowohl bei RS232 als auch bei USB (an Steuerplatine) auf. Langes Kabel bedeutet so ca. 5m
Mit einem kurzen Adapter (3Pol auf Sub-D 9-Pol) und RS232 auf USB Adapter funktioniert es.

Ich lasse die Heissgastemperatur am Display anzeigen, sie wird kurz nach dem Anschließen negativ bzw. -- dann kommt auch Fehlercode 22 (so bin ich auch auf die Heissgastemperatur gekommen)

Ich habe eine THZ 403 SOL.

Ich möchte eigentlich nicht, einen zusätzlichen RPI auf die Heizung legen, wenn der Server 5m entfernt ist.

Hab ihr eine Idee? Kennt jemand das Phänomen?
« Letzte Änderung: 16 Januar 2021, 22:25:30 von Paul Keller »

Offline willybauss

  • Hero Member
  • *****
  • Beiträge: 1820
5m sollten mit einem guten geschirmten Kabel kein Problem sein, zumindest mit RS232. Den Schirm nur einseitig an Gnd legen, andere Seite offen lassen, um Masseschleifen sicher auszuschließen.

Nach nochmaligem durchlesen: meinst Du, dass die Anlage einen Fehlercode wirft, wenn Du ein langes Kabel anschließt? Eine etwas klarere Beschreibung wäre hilfreich.

Evtl. würde auch ein kurzes RS232-Kabel helfen, nach dem -USB-Adapter dann den Rest als USB-Kabel. Aber sowas habe ich noch nie gehört. Sicher, dass in FHEM die richtige FW-Version der Anlage eingestellt ist? Evtl. gibt es da Unterschiede im Timing.
« Letzte Änderung: 16 Januar 2021, 22:42:42 von willybauss »
FHEM auf Raspberry Pi B und 2B; THZ (THZ-303SOL), CUL_HM, TCM-EnOcean, SamsungTV, JSONMETER, SYSMON, OBIS, STATISTICS, CO20, FHEM2FHEM

Offline Paul Keller

  • New Member
  • *
  • Beiträge: 6
Nach nochmaligem durchlesen: meinst Du, dass die Anlage einen Fehlercode wirft, wenn Du ein langes Kabel anschließt? Eine etwas klarere Beschreibung wäre hilfreich.

Ja genauso so ist es.

An der FHEM an sich liegt es vermutlich nicht. Das ist eher was "elektrisches".
Die Masseschleife kann ich mir nicht vorstellen. Da der erste Adapter (3Pol zu Sub-D) keine Masseverbindung hat.
Aber es trotzdem vermutlich so was in der Richtung.
Ich muss bei Gelegenheit noch etwas Experimentieren. u.a. die vorgeschlagene Variante ebenfalls testen.
Schon mal Danke für die Unterstützung.

Offline willybauss

  • Hero Member
  • *****
  • Beiträge: 1820
Was für ein Kabel verwendest Du? Liegt das parallel zu anderen Kabeln, die Störungen einstreuen? Ggf. mal mit Abstand verlegen.
FHEM auf Raspberry Pi B und 2B; THZ (THZ-303SOL), CUL_HM, TCM-EnOcean, SamsungTV, JSONMETER, SYSMON, OBIS, STATISTICS, CO20, FHEM2FHEM

Offline Paul Keller

  • New Member
  • *
  • Beiträge: 6
Was für ein Kabel verwendest Du?
Folgendes habe ich schon erfolglos probiert:
  • RS232: Telefonkabel 2DA geschirmt Ader-DM 0,6mm
  • RS232: Patchkabel Cat5 S/FTP mit Adapter auf RS232
  • USB-Kabel an Steuerplatine

Liegt das parallel zu anderen Kabeln, die Störungen einstreuen? Ggf. mal mit Abstand verlegen.
Nein es war auch wiederholbar, wenn ich die Kabel "quer spanne".

Ich hatte befürchtet das es einen Potentialunterschied gibt, der über GND der Seriellenverbindung ausgeglichen wird.
Aber der Fehler (Error 22) passierte heute schon als ich bei meinem funktionierenden Setup (RPI mit Ser2Net) das serielle Kabel verlängert habe.
Die Stromversorgung von RPI blieb dabei unverändert. ::)