Autor Thema: THZ Tecalor (LWZ Stiebel Eltron) Wärmepumpe -Optimierung und Erfahrungsaustausch  (Gelesen 596186 mal)

Offline willybauss

  • Hero Member
  • *****
  • Beiträge: 1832
Stiebel war vor 1,5 Wochen da, hat sich die Anlage von außen angeschaut (ohne das Gerät Mal zu öffnen), den Laptop angeschlossen, nichts festgestellt, den Fall intern weitergeleitet. Seitdem habe ich nichts gehört. Die Hoffnung ist also leider nicht hoch.
Den Laptop angeschlossen, um Vibrationen zu finden ...  ??? Das ist die Sorte Mechaniker, die ohne Diagnosestecker nicht mal rausfinden, warum nach dem Regen das Auto untenrum nass ist.

Aus meiner Sicht muss der Bauherr nicht akzeptieren, dass man versucht, die Anlage durch erhöhte Drehzahlen in einem eigentlich falschen Betriebszustand zu betreiben.

Im Notfall gibt es auch noch die Gerätespezifikation, die sicher auch Geräuschemissionen definiert. Höchstwahrscheinlich gibt es sowas auch in Baunormen oder gar im Bauvertrag. Somit sind Heizungshersteller und/oder Haushersteller zu einer dem entsprechenden Leistungserbringung verpflichtet. Wäre gut, wenn die Gewährleistungsfristen noch nicht um sind und eine (Bau-)Rechtschutzversicherung besteht.

Mit einem ähnlichen Ansatz (allerdings ohne die Rechtschutzversicherung) hatte ich erfolgreich bei der Bauabnahme die Lautstärke der Lüftungsanlage bemängelt. Der Subunternehmer des Hausherstellers hatte während der Bauzeit auf eigene Faust die Anlage entgegen der vertraglichen Spezifikationen geändert und in diesem Zusammenhang konkrete dB-Angaben gemacht - die dann prompt weit verfehlt wurden. Die Nachbesserung auf Kosten des Subunternehmers war dann erfolgreich. Also: nicht alles gefallen lassen, was einem so erzählt wird. Für die wahrscheinlich teuerste Investition in eurem Leben dürft ihr auch einen ordentlichen Gegenwert einfordern.
« Letzte Änderung: 03 Februar 2021, 16:49:11 von willybauss »
FHEM auf Raspberry Pi B und 2B; THZ (THZ-303SOL), CUL_HM, TCM-EnOcean, SamsungTV, JSONMETER, SYSMON, OBIS, STATISTICS, CO20, FHEM2FHEM

Offline tt2g

  • New Member
  • *
  • Beiträge: 9
Hallo zusammen,
ich habe eine Frage: Hat sich seit den am ursprünglichen Threadstart Post anhängenden Files fhem.cfg und den plots etwas geändert?
Ich bekomme leider lauter Bullshit Plots (s. Anhang) und komme nicht dahinter, da die Readings eigentlich passen sollten, meine ich zumindest.

Ich kriege es auch durch durchforsten nach Anhängen nicht anständig zum Laufen und würde mich über eine aktuell funktionsfähige Config sehr freuen. :)
Die hinterlegten Zeilen werden hier nicht übernommen, obwohl die currval Daten in der fhem.cfg hinterlegt wären.

v 0.193 ist aktuell im Einsatz.

Vielen Dank im Voraus.
« Letzte Änderung: 05 Februar 2021, 15:21:45 von tt2g »

Offline willybauss

  • Hero Member
  • *****
  • Beiträge: 1832
Die Plots werden aus dem Inhalt des Logfiles gebaut. Deshalb solltest Du zuerst mal schauen, welche Daten im Logfile ankommen. Passt der Inhalt des Logfiles zu den Daten, die Du in den Plots siehst?

Wenn das Logfile mit den erwarteten Daten gefüllt wird und nichts fehlt, dann kann ja nichts Grundsätzliches falsch sein.

Gib uns dazu mehr Infos, dann schauen wir mal.
FHEM auf Raspberry Pi B und 2B; THZ (THZ-303SOL), CUL_HM, TCM-EnOcean, SamsungTV, JSONMETER, SYSMON, OBIS, STATISTICS, CO20, FHEM2FHEM

Offline tt2g

  • New Member
  • *
  • Beiträge: 9
Servus @willybauss und vielen Dank für die prompte Rückmeldung!
In den Logs konnte ich tatsächlich knapp 35000 Fehlschläge feststellen, Auszug daraus:

2021.02.04 17:05:26 1: PERL WARNING: Use of uninitialized value in concatenation (.) or string at (eval 1617) line 1.
2021.02.04 17:05:26 3: eval: { "Innen $data{currval7}°C, Außen $data{currval8}°C, Luftfeuchtigk. $data{currval2}%, Brauchwasser $data{currval1}°C, HK1-Soll $data{currval5}°C, HK1-Ist $data{currval6}°C" }
2021.02.04 17:05:26 1: PERL WARNING: Use of uninitialized value in sprintf at (eval 1617) line 1.
2021.02.04 17:05:26 3: eval: { sprintf("HK1Soll-HK1Ist %0.1fK, Integralwert %0.1f", $data{currval1}, $data{currval2}) }
2021.02.04 17:05:27 1: PERL WARNING: Use of uninitialized value in numeric gt (>) at (eval 1633) line 1.
2021.02.04 17:05:27 3: eval: my $EVENT=   $evalSpecials->{'%EVENT'};my $EVTPART0=   $evalSpecials->{'%EVTPART0'};my $EVTPART1=   $evalSpecials->{'%EVTPART1'};my $EVTPART2=   $evalSpecials->{'%EVTPART2'};my $NAME=   $evalSpecials->{'%NAME'};my $SELF=   $evalSpecials->{'%SELF'};my $TYPE=   $evalSpecials->{'%TYPE'};{ if (((split ' ',ReadingsVal("Mythz","sHistory",0))[7]) > ReadingsVal("Mythz", "boosterDHW_old", 0)) { DebianMail('MEINNAME@t-online.de','Tecalor Mythz Alarm - boosterDHW','Zusatzheizung wurde fuer Warmwasser benutzt: '. $EVENT,''); fhem("setreading Mythz boosterDHW_old ". ((split ' ',ReadingsVal("Mythz","sHistory",0))[7])); } }
2021.02.04 17:05:27 1: PERL WARNING: Use of uninitialized value in numeric gt (>) at (eval 1634) line 1.
2021.02.04 17:05:27 3: eval: my $EVENT=   $evalSpecials->{'%EVENT'};my $EVTPART0=   $evalSpecials->{'%EVTPART0'};my $EVTPART1=   $evalSpecials->{'%EVTPART1'};my $NAME=   $evalSpecials->{'%NAME'};my $SELF=   $evalSpecials->{'%SELF'};my $TYPE=   $evalSpecials->{'%TYPE'};{ if (((split ' ',ReadingsVal("Mythz","sHistory",0))[7]) > ReadingsVal("Mythz", "boosterDHW_old", 0)) { DebianMail('MEINNAME@t-online.de','Tecalor Mythz Alarm - boosterDHW','Zusatzheizung wurde fuer Warmwasser benutzt: '. $EVENT,''); fhem("setreading Mythz boosterDHW_old ". ((split ' ',ReadingsVal("Mythz","sHistory",0))[7])); } }
2021.02.04 17:05:27 1: PERL WARNING: Use of uninitialized value in numeric gt (>) at (eval 1635) line 1.
2021.02.04 17:05:27 3: eval: my $EVENT=   $evalSpecials->{'%EVENT'};my $EVTPART0=   $evalSpecials->{'%EVTPART0'};my $EVTPART1=   $evalSpecials->{'%EVTPART1'};my $EVTPART2=   $evalSpecials->{'%EVTPART2'};my $NAME=   $evalSpecials->{'%NAME'};my $SELF=   $evalSpecials->{'%SELF'};my $TYPE=   $evalSpecials->{'%TYPE'};{ if (((split ' ',ReadingsVal("Mythz","sHistory",0))[9]) > ReadingsVal("Mythz", "boosterHeating_old",0)) { DebianMail('MEINNAME@t-online.de','Tecalor Mythz Alarm - boosterHeating','Zusatzheizung wurde zum heizen benutzt: '. $EVENT,''); fhem("setreading Mythz boosterHeating_old ". ((split ' ',ReadingsVal("Mythz","sHistory",0))[9])); } }
2021.02.04 17:05:27 1: PERL WARNING: Use of uninitialized value in numeric gt (>) at (eval 1636) line 1.
2021.02.04 17:05:27 3: eval: my $EVENT=   $evalSpecials->{'%EVENT'};my $EVTPART0=   $evalSpecials->{'%EVTPART0'};my $EVTPART1=   $evalSpecials->{'%EVTPART1'};my $NAME=   $evalSpecials->{'%NAME'};my $SELF=   $evalSpecials->{'%SELF'};my $TYPE=   $evalSpecials->{'%TYPE'};{ if (((split ' ',ReadingsVal("Mythz","sHistory",0))[9]) > ReadingsVal("Mythz", "boosterHeating_old",0)) { DebianMail('MEINNAME@t-online.de','Tecalor Mythz Alarm - boosterHeating','Zusatzheizung wurde zum heizen benutzt: '. $EVENT,''); fhem("setreading Mythz boosterHeating_old ". ((split ' ',ReadingsVal("Mythz","sHistory",0))[9])); } }
2021.02.04 17:05:27 1: ERROR evaluating my $EVENT=   $evalSpecials->{'%EVENT'};my $EVTPART0=   $evalSpecials->{'%EVTPART0'};my $EVTPART1=   $evalSpecials->{'%EVTPART1'};my $EVTPART2=   $evalSpecials->{'%EVTPART2'};my $NAME=   $evalSpecials->{'%NAME'};my $SELF=   $evalSpecials->{'%SELF'};my $TYPE=   $evalSpecials->{'%TYPE'};{ if (ReadingsVal("Mythz","inside_temp",22) > ReadingsVal("Mythz","inside_temp_max",0) ) { DebianMail('MEINNAME@t-online.de','Tecalor Mythz Alarm - insideTemp','Innentemperatur zu hoch',''); fhem("setreading Mythz inside_temp_max ". (ReadingsVal("Mythz","inside_temp",22))); } }: Undefined subroutine &main::DebianMail called at (eval 1639) line 1.

2021.02.04 17:05:27 3: Mythz.alarm_insideTempHigh return value: Undefined subroutine &main::DebianMail called at (eval 1639) line 1.

2021.02.04 17:05:27 1: ERROR evaluating my $EVENT=   $evalSpecials->{'%EVENT'};my $EVTPART0=   $evalSpecials->{'%EVTPART0'};my $EVTPART1=   $evalSpecials->{'%EVTPART1'};my $NAME=   $evalSpecials->{'%NAME'};my $SELF=   $evalSpecials->{'%SELF'};my $TYPE=   $evalSpecials->{'%TYPE'};{ if (ReadingsVal("Mythz","inside_temp",22) > ReadingsVal("Mythz","inside_temp_max",0) ) { DebianMail('MEINNAME@t-online.de','Tecalor Mythz Alarm - insideTemp','Innentemperatur zu hoch',''); fhem("setreading Mythz inside_temp_max ". (ReadingsVal("Mythz","inside_temp",22))); } }: Undefined subroutine &main::DebianMail called at (eval 1640) line 1.

2021.02.04 17:05:27 3: Mythz.alarm_insideTempHigh return value: Undefined subroutine &main::DebianMail called at (eval 1640) line 1.[b][/b]

Nun ist nur die Frage, was da falsch ist. Es kann sein, dass ich einen Mixup von fhem.cfg-Dateien verursacht hat, der keine validen Readings hat.
Strange ist hier nur, dass die fhem.cfg Datei vor der Neuinstallation mal einwandfrei funktioniert und auch saubere Logs mit funktionierenden Plots geschrieben hat. :/
Aber vielleicht seht Ihr in o.g. Fehlerausgaben mehr. Hier steige ich leider noch nicht durch. :(

Vielen Dank für das Feedback schon einmal.
Im Zweifel nehme ich auch eine funktionierende Config ;) :D

Offline willybauss

  • Hero Member
  • *****
  • Beiträge: 1832
Strange ist hier nur, dass die fhem.cfg Datei vor der Neuinstallation mal einwandfrei funktioniert und auch saubere Logs mit funktionierenden Plots geschrieben hat. :/
Aber vielleicht seht Ihr in o.g. Fehlerausgaben mehr. Hier steige ich leider noch nicht durch. :(
Sorry, hier steige ich auch nicht durch. Aber wenn es schon mal so funktioniert hat, dann kann es ja nicht an den veröffentlichten Dateien liegen (damit sind schon so Viele zurecht gekommen, dass ich das eigentlich ausschließen will). Dann ist bei der Neuinstallation irgendwas in die Brüche gegangen. Würde sagen zurück auf Start, wenn Du nicht genug Detailwissen hast um die Ursache selbst einzukreisen. Remote erscheint mir das nicht möglich.

Du kannst versuchsweise mal fhem stoppen, dann die originale cfg Datei reinkopieren (nach /opt/fhem), natürlich angepasst mit deinen Daten. Dann fhem neu starten.

Oder die übliche Antwort: das letzte Backup einspielen (das aber i.d.R. gar nicht exisitert).
FHEM auf Raspberry Pi B und 2B; THZ (THZ-303SOL), CUL_HM, TCM-EnOcean, SamsungTV, JSONMETER, SYSMON, OBIS, STATISTICS, CO20, FHEM2FHEM

Offline tt2g

  • New Member
  • *
  • Beiträge: 9
Jaaa, die Sache ist, dass die alte Konfiguration eben nicht mehr funktioniert. ;)
Auch die Konfiguration aus dem Startpost von dir schmeißt mir dieselben Fehler.

:(

FHEM stoppen, neue Konfig reinschieben und wieder starten - So läuft das seit Tagen ;D

Offline willybauss

  • Hero Member
  • *****
  • Beiträge: 1832
Da auch die alte Konfiguration nicht mehr tut liegt das definitiv nicht an den geposteten Beispielkonfigurationen. Ich würde mal das ganze fhem-Verzeichnis weghauen sowie eventuelle andere Verzeichnisse, wo evtl. Dateien (Logfiles ...) ausgelagert sind. Dann fhem komplett neu machen. So tief bin ich in fhem auch nicht drin, dass ich Dir sagen könnte, was da wem ins Knie schießt.

Den dezenten Hinweis aufs letzte Backup hast Du genauso dezent übergangen. Meine Vermutung scheint also zu stimmen ...
FHEM auf Raspberry Pi B und 2B; THZ (THZ-303SOL), CUL_HM, TCM-EnOcean, SamsungTV, JSONMETER, SYSMON, OBIS, STATISTICS, CO20, FHEM2FHEM

Offline tt2g

  • New Member
  • *
  • Beiträge: 9
Nein nein, das meinte ich schon mit dem letzten Backup ;)
Aber vom OS insgesamt gab es leider keines, ne. ;)

Edit:
Fehler gefunden: Sitzt vor dem Bildschirm. Habe die gplot-Dateien nicht hinterlegt...
Jetzt muss ich nur noch rausfinden, warum der Integralwert bei mir dennoch nicht korrekt angezeigt wird, aber das kriege ich dann auch noch irgendwie hin. Ist aktuell nur eine waagerechte Linie.

Vielen Dank dennoch für die Rückmeldungen.

P.S.: Systembackup ist nun eingerichtet und auch qualitätsgesichert. ;) Docker Containervolumes nun auch gefunden, somit steht einem möglichen Restore nichts mehr im Wege, wenn mal wieder was abraucht. :)
« Letzte Änderung: 06 Februar 2021, 13:50:31 von tt2g »

Offline willybauss

  • Hero Member
  • *****
  • Beiträge: 1832
Super. Danke für die Rückmeldung.

Wegen der Integralwerte: die sind Bestandteil des sHC1-Readings. In der Plotkonfiguration musst Du im Column-Feld eine 11 eintragen. Oder einfach nochmal die gplot-Datei mit der aus dem 1. Post überschreiben.

2021-02-06_14:28:20 Mythz sHC1: outsideTemp: 7.4 x08: 42.8 returnTemp: 25.5 integralHeat: -5 flowTemp: 33.9 heatSetTemp: 27.2 heatTemp: 27.9 seasonMode: winter integralSwitch: 200 hcOpMode: setback roomSetTemp: 21.5 x60: 0 x64: 563.2 insideTempRC: 21.6 x72: 1 x76: 2690.2 onHysteresisNo: 1 offHysteresisNo: 0 hcBoosterStage: 2
« Letzte Änderung: 06 Februar 2021, 14:33:42 von willybauss »
FHEM auf Raspberry Pi B und 2B; THZ (THZ-303SOL), CUL_HM, TCM-EnOcean, SamsungTV, JSONMETER, SYSMON, OBIS, STATISTICS, CO20, FHEM2FHEM

Offline tt2g

  • New Member
  • *
  • Beiträge: 9
Sieht alles soweit gut aus, auch der Wert ist valide, wenn man davon ausgeht, dass die Heizung nichts anderes sendet.
Habe hier immer eine 0, sollte aber ja bei der LWZ504 nicht abweichend zu den Vorgängern sein.

Offline willybauss

  • Hero Member
  • *****
  • Beiträge: 1832
Schau halt mal was im Reading sHC1 im Logfile steht. Wenn da immer 0 drinsteht könnte evtl. die Anlage nicht zur eingestellten Firmwareversion passen. Das solltest Du per Attribut anpassen können.

Auch mal drauf achten, of tatsächlich bei der 504 der Integralwert an 11. Stelle im Reading steht.
FHEM auf Raspberry Pi B und 2B; THZ (THZ-303SOL), CUL_HM, TCM-EnOcean, SamsungTV, JSONMETER, SYSMON, OBIS, STATISTICS, CO20, FHEM2FHEM

Offline tt2g

  • New Member
  • *
  • Beiträge: 9
Hi,
ich habe das Attribut Mythz Firmware einmal von 4.39 auf 5.39 gehoben. Nun wird statt n.a. bei model 5.39 angezeigt.
model
5.39_07.59HW239SW4.05
Entsprechend hat sich auch die Stelle im sHC1 Reading auf Stelle 7 verschoben (habe ich im Plot 2 angepasst), zeigt aber noch immer 0 an. Jetzt kann das durchaus an meinem Verständnisproblem bzgl. des Integralwerts liegen, aber ich gehe davon aus, dass quasi die meiste Zeit ein Wert <>0 als Integralwert vorliegen sollte, oder?
Kann es sein, dass evtl. für die LWZ 504 Readings aus der ISG notwendig wären, um hier die korrekte Anordnung zu haben?
sFirmware
version: 07.59

sFirmware-Id
HW: 239 SW: 4.05 Date: NOV 8 2018

sHC1
outsideTemp: 3 x08: 0 returnTemp: 35.1 integralHeat: 0 flowTemp: 38.3 heatSetTemp: 31.3 heatTemp: 35.9 seasonMode: winter integralSwitch: 100 hcOpMode: normal roomSetTemp: 22.5 x60: 0 x64: 0 insideTempRC: 22.5 x72: 51.4 x76: 2201.6 onHysteresisNo: 0 offHysteresisNo: 0 hcBoosterStage: 2

Edit:
Eben als known issue ausmachen können:
Siehe https://forum.fhem.de/index.php/topic,33211.msg703634/topicseen.html#msg703634 ff.

Tags: LWZ504 LWZ 504 THZ504 THZ 504 IntegralHeat
« Letzte Änderung: 08 Februar 2021, 09:58:00 von tt2g »

Offline willybauss

  • Hero Member
  • *****
  • Beiträge: 1832
OK, wusste ich auch nicht. Auf Besonderheiten der neueren Anlagen habe ich nie so genau geachtet.
Hast Du denn ein ISG? Und wenn ja: wird dort der Integralwert angezeigt?

Die Funktionsweise des Integralwerts hat ja TheTrumpeter in dem verlinkten thread beschrieben; ich glaub ich habs ebenfalls im 1. Beitrag angedeutet: Der Integralwert summiert die Über-/Unterschreitungen der Heizenergie (im Vergleich zum Sollwert) über der Zeit. Wenn die Summe der Über-/Unterschreitungen zu groß wird ist das ein Grund für die Anlage, sich ab-/anzuschalten.
Bei einer Inverteranlage ist die Differenz zwischen Soll und Ist eher gering, da sie sich ja in der Leistung den Anforderungen anpasst. Dennoch wird sie den Integralwert (oder eine ähnliche Messgröße) brauchen, da die Regelbandbreite ja nicht stufenlos von 0 bis 100% geht.
FHEM auf Raspberry Pi B und 2B; THZ (THZ-303SOL), CUL_HM, TCM-EnOcean, SamsungTV, JSONMETER, SYSMON, OBIS, STATISTICS, CO20, FHEM2FHEM

Offline tt2g

  • New Member
  • *
  • Beiträge: 9
OK, wusste ich auch nicht. Auf Besonderheiten der neueren Anlagen habe ich nie so genau geachtet.
Dachte ich mir schon. :) Ich finde es ja spitze, dass Ihr dennoch immer ein offenes Ohr habt für die N00bs unter uns, wie mich. :)
Hast Du denn ein ISG? Und wenn ja: wird dort der Integralwert angezeigt?
Ein ISG habe ich nicht, war mir zu teuer und kann ich ja mit FHEM soweit irgendwann auch darstellen, zusammen mit meinem Loxone-System.
Ich hatte gehofft, ein THZ / LWZ 504 Besitzer hat ein ISG und kann uns hier Rückmeldung geben.


Ich überarbeite die Plots anhand der veränderten Readings. und werde diese dann mit Gültigkeit für 5.39 hier anhängen, wenn die passen.

Offline kjmEjfu

  • Sr. Member
  • ****
  • Beiträge: 711
Ich hatte gehofft, ein THZ / LWZ 504 Besitzer hat ein ISG und kann uns hier Rückmeldung geben.

Das ISG zeigt keinen Integralwert an.

 

decade-submarginal