Autor Thema: THZ Tecalor (LWZ Stiebel Eltron) Wärmepumpe -Optimierung und Erfahrungsaustausch  (Gelesen 710065 mal)

Offline timtom2000

  • Jr. Member
  • **
  • Beiträge: 58
Sind die schlaggeräusche Metallisch oder eher gedämpft.
Ne, es ist eher als würde eine Flasche im Innern auf dem Metallboden umfallen. Aber SE kommt nochmal, dann sind wsl. ExVentil und Trockner dran, keine Ahnung ob das was damit zutun hat, trial & error nennt man das wsl. ::)
LWZ 304 (BJ 2017; FW 7.09); DHH o. Keller; 100m² Wohnfläche
FHEM auf USB-Stick an FritzBox 7560 (FW 7.12)

Offline hellijo

  • Jr. Member
  • **
  • Beiträge: 73
Ne, es ist eher als würde eine Flasche im Innern auf dem Metallboden umfallen. Aber SE kommt nochmal, dann sind wsl. ExVentil und Trockner dran, keine Ahnung ob das was damit zutun hat, trial & error nennt man das wsl. ::)

Hast du die Heißgastemperaturen mal geplotet? Daran könnte man sehen ob im Kältemittel ein Druckausgleich kommt. Das kann auch ganz schön „knallen“ und würde man auch in der Heißgastemperatur sehen -> könnten Rückschlüsse auf einen feuchten Trockner sein.
Ist bei dir ein Schauglas ob das Kältemittel Trocken ist? Das Schauglas sitzt in der Nähe vom Trockner.

Offline timtom2000

  • Jr. Member
  • **
  • Beiträge: 58
Danke für den Tipp! Ich habe meine Plots gerade um die Heißgastemp. erweitert, mal sehen ob man da einen Zusammenhang erkennt. Falls ein Druckausgleich kommt, müsste man wsl. einen Sprung in der Heißgastemp. sehen?!
Das Schauglas muss ich mal suchen, weiß ich nicht ob ich das habe. Dazu findet man aber interessante Videos wie es aussieht mit bzw. ohne Kältemittelverlust...wie sehe ich dem Schauglas denn an, ob das Kältemittel feucht oder trocken ist?
Übrigens gute Zeichnung, woher hast du die? Finde ich in meinem ganzen Installationsmanual nicht.
LWZ 304 (BJ 2017; FW 7.09); DHH o. Keller; 100m² Wohnfläche
FHEM auf USB-Stick an FritzBox 7560 (FW 7.12)

Offline hellijo

  • Jr. Member
  • **
  • Beiträge: 73
Danke für den Tipp! Ich habe meine Plots gerade um die Heißgastemp. erweitert, mal sehen ob man da einen Zusammenhang erkennt. Falls ein Druckausgleich kommt, müsste man wsl. einen Sprung in der Heißgastemp. sehen?!
Das Schauglas muss ich mal suchen, weiß ich nicht ob ich das habe. Dazu findet man aber interessante Videos wie es aussieht mit bzw. ohne Kältemittelverlust...wie sehe ich dem Schauglas denn an, ob das Kältemittel feucht oder trocken ist?
Übrigens gute Zeichnung, woher hast du die? Finde ich in meinem ganzen Installationsmanual nicht.

Ja genau. Es gibt die Gasgleichung mit p*V=m*r*T. Das Volumen, Masse und Gaskonstante sind gleich. Heißt der Druck und Temperatur sind voneinander abhängig. Bricht der Druck auf der Heißseite ein fällt die Temperatur und umgekehrt.

In den Schaugläsern ist normal ein idikator. Meißt gelb und grün - bin mir aber nicht sicher welcher nass und trocken ist.

Die Zeichnung ist in der Montage- und Gebrauchsanweisung.


Offline timtom2000

  • Jr. Member
  • **
  • Beiträge: 58
Ja genau. Es gibt die Gasgleichung mit p*V=m*r*T. Das Volumen, Masse und Gaskonstante sind gleich. Heißt der Druck und Temperatur sind voneinander abhängig. Bricht der Druck auf der Heißseite ein fällt die Temperatur und umgekehrt.

In den Schaugläsern ist normal ein idikator. Meißt gelb und grün - bin mir aber nicht sicher welcher nass und trocken ist.
Also, ich habe heute die Anlage mal aufgemacht und gesucht, aber ein Schauglas habe ich leider nicht :( schade, das wäre hilfreich.

Im Anhang habe ich einen Plot von heute angehängt. Die Heißgastemp. hat schon ein paar Ausschläge, aber ob die ungewöhnlich sind kann ich nicht beurteilen. Dass für WW und Heizen stark unterschiedliche Temperaturen nötig sind ist klar. Und dass die Temp. dann springt, wenn WW in Heizen übergeht erscheint mir auch plausibel. Wie sieht der Verlauf denn bei dir aus?
LWZ 304 (BJ 2017; FW 7.09); DHH o. Keller; 100m² Wohnfläche
FHEM auf USB-Stick an FritzBox 7560 (FW 7.12)

Offline hellijo

  • Jr. Member
  • **
  • Beiträge: 73
Also, ich habe heute die Anlage mal aufgemacht und gesucht, aber ein Schauglas habe ich leider nicht :( schade, das wäre hilfreich.

Im Anhang habe ich einen Plot von heute angehängt. Die Heißgastemp. hat schon ein paar Ausschläge, aber ob die ungewöhnlich sind kann ich nicht beurteilen. Dass für WW und Heizen stark unterschiedliche Temperaturen nötig sind ist klar. Und dass die Temp. dann springt, wenn WW in Heizen übergeht erscheint mir auch plausibel. Wie sieht der Verlauf denn bei dir aus?

Wie oft Tastet du die Heißgastemperatur ab? Alle 60 Sekunden? Schneller geht das nicht.
In der groben Zeitdarstellung wirkt es normal. Kann aber auch die „Glättung“ des Signals sein.
Ich lasse mir alles immer in „steps“ plotten.

Da bei mir die Anlage noch offen ist habe ich ein Bild von dem „Schauglas“ gemacht.
Die Schrift ist so kraxelig, da ich es nicht gewohnt bin mit dem Finger aufm Handy zu schreiben.
Gruß Jörg

Offline timtom2000

  • Jr. Member
  • **
  • Beiträge: 58
Hm, so ein Schauglas ist bei meiner Anlage leider nicht vorhanden :(
Ich habe nochmal einen Plot von heute angehängt (60s Abtastung, steps), aber da sehe ich keine ungewöhnlichen Verläufe. War aber in jedem Fall einen Versuch wert!
LWZ 304 (BJ 2017; FW 7.09); DHH o. Keller; 100m² Wohnfläche
FHEM auf USB-Stick an FritzBox 7560 (FW 7.12)

Offline martincfd

  • New Member
  • *
  • Beiträge: 12
Nach einigem Herumexperimentieren und einer spannenden Beobachtung von sakko, habe ich jetzt dank fhem Einstellungen für meine 504 gefunden, die ich gerne mal teilen möchte. Mein Problem ist, dass im interessanten Bereich von 0-10°C Aussentemperatur die Heizlast vom Haus unterhalb der Minimalheizlast der 504 liegt. Damit kommt der PID-Regler und die An/Auslogik nicht gut klar. Ausgangspunkt war:

...
Ich habe Integralanteil-INV jetzt auf 0 und damit vermutlich 100% Steuerung durch Hysterese. Die erratischen Leistungsanstiege nach Kompressorstart sind nunmehr passé - jippieh!
Komischerweise fällt HC1-Ist nie mehr unter HC1- Soll. Womit hängt das zusammen?
...
Bei mir funktionierte diese Einstellung allerdings nicht, weder mit PropAnteil 10%/K noch etwas kleineren Werten. Und daher habe ich erstmal versucht zu verstehen, was hier passiert. Setzt man Integralanteil Inv auf 0, dann wird der Intergralregelanteil im PID ausgeschaltet und man bekommt einen PD-Regler. Das HC1-Ist nicht unter HC1-Soll fällt, wie von sakko beobachtet, liegt wohl daran, dass intern der Integralwert nicht gelöscht wird, es erfolgt einfach kein update des Integralwertes mehr. Bei meinen Experimenten habe ich daher nach dem Setzen auf 0 immer auch ein Regler-Reset ausgeführt, um diese Störgröße auf 0 zu bekommen.
Ein PD-Regler ist eigentlich keine gute Sache, da er nicht auf das Soll regeln kann, es bleibt immer eine Regelabweichung da. Aber es ist tatsächlich möglich, T_soll so einzustellen, dass das T_ist gegen das *gewünschte* T_soll konvergiert (falls die Heizlast oberhalb vom Minimum liegt), oder zumindest das Haus in langen Takten mit sehr geringer Leistung langsam aufgeheizt wird. Leider laufen damit die eingestellte und die reale Heizkurve (weit) auseinander, und man muss etwas um die Ecke denken. Meine aktuellen Überlegungen und Einstellungen sehen wie folgt aus:

Der Verdichter wird gestartet, wenn heatingRelativePower (HRP) 40% überschreitet, und ausgeschaltet, wenn der Wert 20% unterschreitet (so ganz exakt scheint das noch nicht zu stimmen, aber fast).
Ohne I-Anteil im PID Regler wird HRP errechnet aus:
HRP = HRP_0(Kennlinie mit T_aussen) + K_p*(T_soll-T_ist) + D-Anteil

Den D-Anteil ignoriere ich im weiteren. K_p ist ungefähr PropAnteil, aber nicht exakt. Mein PropAnteil steht im Moment auf 6.7%/K, während K_p=7.4%/K zu sein scheint. HRP wird von fhem ausgelesen. Damit sieht der Wert HRP_0(T_aussen), geplottet mit der Formel HRP-K_p*(T_soll-T_ist), ziemlich konstant aus, wenn man die aktuelle und nicht die gefilterte Aussentemperatur betrachtet und diese im betrachtet Zeitraum etwa konstant ist.
Einschalten erfolgt bei T_ein=(40%-HRP_0)/K_p und Ausschalten bei T_aus=(20%-HRP_0)/K_p. Die Temperaturdifferenz von T_ist bei Ein- und Ausschalten ist damit ungefähr 20%/K_p. Für mein Haus ist 2.5K akzeptabel. Einschalten bei etwa T_ist=22°C und Ausschalten bei 24.5°C (abhängig von Aussentemperatur), sonst wird es zu kalt oder zu warm. Daraus ergibt sich K_p=8%/K, was aber noch zu gross ist, da HRP real etwas zappelt und statt mit 20% Regelband mit etwas weniger gerechnet werden muss. PropAnteil=6.7 und damit K_p=7.4%/K funktioniert bei mir gut.

Um T_soll setzen zu können, müßte ich wissen, wie HRP_0 bestimmt wird. Da habe ich noch keine Idee. Meine Annahme, die nicht völlig unsinnig zu sein scheint, ist: HRP_0 = -40/37 %/K * T_aussen + konstanten Wert, wobei Auslegungstemperatur -25°C und Leistung bei Auslegung 40% eingestellt ist (37=25+12 Temperaturdifferenz von Auslegungstemperatur zu 12°C, wo die Heizlast ungefähr 0kW sein müßte). Gerade bei niedrigen Temperaturen dürfte diese Formel nicht im Ansatz stimmen, aber wann haben wir hier schonmal Minusgrade.
Wenn ich T_soll auf einen konstanten Wert setze, ergibt sich daraus in meinem Fall eine effektive Steigung der realen Heizkurve von 40/37 / K_p = 0.145. Der im Display einstellbare Gradient Grad führt zu einem Gradienten von ungefähr 14*Grad/RT (siehe heatcurve im THZ Perlmodul), d.h. die 0.145 entsprechen ungefähr Grad=0.22 und damit einem halbwegs vernünftigen Wert, den ich auch vorher ungefähr hatte. T_soll habe ich mit etwas probieren auf ungefähr 26°C eingestellt (26=RT+Fusspunkt und Gradient = 0), so dass die Anlage bei ungefähr 21.5-22.5°C einschaltet, je nach Aussentemperatur. Die Theorie und groben Abschätzungen passen auch ungefähr zu den gemessenen Werten.

Mit diesen Einstellungen komme ich mit 1-2 mehr oder weniger langen Takten über den Tag (getestet bei -1°C bis 7°C Aussentemperatur). Nach dem Einstalten bei grundsätzlich ca. 40Hz fährt der Verdichter zügig auf 30Hz und dann weiter auf ca. 25-20Hz und geht schliesslich nach 3-7 Stunden wieder aus. Die Vorlauftemperatur ist ca. 26-26.5°C. Der vom Gerät "gemessene" COP liegt bei meist Qh/Pel = 6 bis 7.

Um die Leistung noch schneller zu reduzieren, habe ich den Vorlaufanteil momentan auf 25% gesetzt, andere Einstellung (also insbesondere Parallelverschiebung der Heizkurve wie sonst notwendig) muss ich nicht anpassen. Wenn der Verdichter aus ist, dann ist ungefähr T_vor=T_rück=T_ist, und das Einschaltverhalten ändert sich nicht. Wenn der Verdichter angeht, dann springt Vorlauf um ca. 3-4K hoch, damit geht T_ist um ca. 0.25*3.5K = 0.9K hoch und HRP geht um 0.9K * 7.4%/K = 6.5% runter. Damit bin ich nach kurzer Zeit unter 30Hz und der Heiztakt wird theoretisch länger und effizienter. Auf der anderen Seite schaltet die Anlage eher ab, weil die T_ist-Abschalttemperatur eher erreicht wird. Mit 25% Vorlaufanteil hält sich dies ungefähr bei mir die Waage. Aber ich werde mit dem Wert sicher noch etwas rumspielen und die effektiven Taktlängen vergleichen.

Ingesamt ist dies eine etwas verrückte (sprich unschöne) Form der Steuerung. Sie hat aber zusätzlich noch den Charme, dass man mit wenigen Schreiboperationen (zwei pro Heiztakt) über RT die Anlage und insbesondere die dauerhaft durchlaufende Heizkreispumpe gezielt ein- und ausschalten (in den Schnüffelmodus versetzen) kann. Denn es gilt einfach HRP_Tag - HRP_Absenk = K_p*(RT_Tag - RT_Nacht). Also kann ich, wenn RT_Nacht eingestellt ist, einfach HRP_Tag aus HRP_Nacht ausrechnen, und sobald dieser über 40% kommt, setze ich RT auf RT_Tag. Aber den fhem-Code mit allen potentiellen Ausnahmeregelungen dazu muss ich erst noch schreiben...

Angehängt sind meine Plots von heute. Die Anlage ist kurz vor dem Abschalten.
Ich hoffe, dass war nicht zu lang. Vielleicht hilft es ja jemanden beim Optimieren. Oder jemand hat noch interessante Anregungen und Verbesserungen?
« Letzte Änderung: 27 Januar 2022, 11:05:49 von martincfd »
FHEM auf Raspberry Zero 2W, THZ 504 mit FBH, 140qm+60qm (beheizt+unbeheizt, alles KWL), Heizlast 3.8kW bei NAT -10°C, PV 5.2kWp

Offline willybauss

  • Hero Member
  • *****
  • Beiträge: 1903
Respekt! Ich glaube, den Beitrag kannst Du direkt als Bewerbungsschreiben bei SE verwenden. Weiter helfen kann ich Dir aber nicht. Regelungstechnik ist 40 Jahre her und seither nicht mehr gebraucht.

Pure Neugier: wie hoch (bzw. wie gering) ist denn die Heizlast Deines Hauses bei -7°C?
FHEM auf Raspberry Pi B und 2B; THZ (THZ-303SOL), CUL_HM, TCM-EnOcean, SamsungTV, JSONMETER, SYSMON, OBIS, STATISTICS, CO20, FHEM2FHEM

Offline martincfd

  • New Member
  • *
  • Beiträge: 12
Lineare Interpolation ergibt 3.8kW *19/22 = 3.3kW (22 = Differenz von NAT -10°C und 12°C). Die bisherigen Messwerte passen gut zu Kennlinien und Theorie. Das Haut wohl tatsächlich ziemlich genau die theoretische Heizlast.
FHEM auf Raspberry Zero 2W, THZ 504 mit FBH, 140qm+60qm (beheizt+unbeheizt, alles KWL), Heizlast 3.8kW bei NAT -10°C, PV 5.2kWp

Offline willybauss

  • Hero Member
  • *****
  • Beiträge: 1903
ok. Scheint also praktisch gleich zu sein wie bei mir. Meine alte 303 SOL muss halt bei höheren Temperaturen takten. Ich löse das mit sehr hohem Integralanteil und hoher Hysterese. Dadurch nur 3 - 5 Takte pro Tag bei Temperaturen über null. Der Puffer, der dennoch Temperaturschwankungen im Haus verhindert, sind die 30 - 40 Tonnen Estrich. Keine Ahnung, wieviel das tatsächlich wiegt. Ich weiß nur, dass die angelieferte Trockenmasse 26 Tonnen waren. Plus Wasser ...
FHEM auf Raspberry Pi B und 2B; THZ (THZ-303SOL), CUL_HM, TCM-EnOcean, SamsungTV, JSONMETER, SYSMON, OBIS, STATISTICS, CO20, FHEM2FHEM

Offline martincfd

  • New Member
  • *
  • Beiträge: 12
Die Steuerung der 504 scheint für solche Heizlasten vielleicht noch ungeeigneter als bei deiner Anlage zu sein. Mit hohem Integralanteil lief ganz ok, aber so ist schon deutlich effizienter.
FHEM auf Raspberry Zero 2W, THZ 504 mit FBH, 140qm+60qm (beheizt+unbeheizt, alles KWL), Heizlast 3.8kW bei NAT -10°C, PV 5.2kWp

Offline willybauss

  • Hero Member
  • *****
  • Beiträge: 1903
Deine 504 hat ja bei -7°C eine Wärmeleistung von 8,34kW, meine 303 nur 3,5kW. So gesehen würde ich, falls ich mal eine neue Anlage brauche, eher in Richtung 5kW schielen. Aktuell wäre das dann die LWZ 5 S Plus. Dann komme ich sicher bis -10 ... -12°C ohne Heizstab. Aktuell ist bei -7° Schluss.
FHEM auf Raspberry Pi B und 2B; THZ (THZ-303SOL), CUL_HM, TCM-EnOcean, SamsungTV, JSONMETER, SYSMON, OBIS, STATISTICS, CO20, FHEM2FHEM

Offline martincfd

  • New Member
  • *
  • Beiträge: 12
Deine 504 hat ja bei -7°C eine Wärmeleistung von 8,34kW, meine 303 nur 3,5kW. So gesehen würde ich, falls ich mal eine neue Anlage brauche, eher in Richtung 5kW schielen. Aktuell wäre das dann die LWZ 5 S Plus. Dann komme ich sicher bis -10 ... -12°C ohne Heizstab. Aktuell ist bei -7° Schluss.
Aber die LWZ 5 S Plus hätte wie alle anderen vergleichbaren SE/Tecalor Anlagen die gleiche Minimalleistung, und an der haperts. Auch bei anderen Herstellern kommt man mit Innen aufgestellten Anlagen kaum unter 2kW. Wahrscheinlich hat deswegen unser Hausbauer die 504 genommen. Ist es für die sinnvoller, ganz wenige Anlagen in grösseren Mengen zu verbauen. Kommt am Ende evtl. auf den gleichen Preis heraus und Planungsfehler vermeidet man ausserdem.
Unser zukünftiger Nachbar bekommt eine LLWP. Nachdem ich erst etwas erstaunt war, dass solche Anlagen noch verbaut werden(BAFA: LLWP wird wegen mangelnder Effizienz nicht gefördert), musste ich feststellen, dass sie wieder modern sind, da sie offenbar besser mit der Minimalleistung von Niedrigenergiehäusern klarkommen. Aber meine 504 wird nun dank weniger Verdichterstarts und geringer Leistungsaufnahme hoffentlich 20+ Jahre halten.
« Letzte Änderung: 28 Januar 2022, 14:30:49 von martincfd »
FHEM auf Raspberry Zero 2W, THZ 504 mit FBH, 140qm+60qm (beheizt+unbeheizt, alles KWL), Heizlast 3.8kW bei NAT -10°C, PV 5.2kWp
Gefällt mir Gefällt mir x 1 Liste anzeigen

Offline awex102

  • Full Member
  • ***
  • Beiträge: 118
Hallo zusammen,

nach einem raspbery crash musste ich FHEM neu aufsetzen.

Die THZ Anbindung läuft, aber die Plots werden nicht korrekt dargestellt.

Im Log finde ich folgenden Fehler:

2022.01.29 10:31:38 1: PERL WARNING: Use of uninitialized value in concatenation (.) or string at (eval 1479) line 1.
2022.01.29 10:31:38 3: eval: { "Innen $data{currval7}°C, Außen $data{currval8}°C, Luftfeuchtigk. $data{currval2}%, Brauchwasser $data{currval1}°C, HC1-Soll $data{currval5}°C, HC1-Ist $data{currval6}°C" }

Die Defintion ist die aus 2015:

define Mythz_Plot1_Temp SVG FileLog_Mythz:thz1:CURRENT
attr Mythz_Plot1_Temp label "Innen $data{currval7}°C, Außen $data{currval8}°C, Luftfeuchtigk. $data{currval2}%, Brauchwasser $data{currval1}°C, HC1-Soll $data{currval5}°C, HC1-Ist $data{currval6}°C"
attr Mythz_Plot1_Temp plotsize 840,420
attr Mythz_Plot1_Temp room THZ

Ich kann keinen Syntax Fehler erkennen... Gabs da irgendeine Anpassung aufgrund von updates?

Danke!

 

decade-submarginal