Autor Thema: THZ Tecalor (LWZ Stiebel Eltron) Wärmepumpe -Optimierung und Erfahrungsaustausch  (Gelesen 294906 mal)

Offline awex102

  • Jr. Member
  • **
  • Beiträge: 91
Wirklich erstaunlich was die ZirkPumpe da wegnimmt. Ok, ich muss zugeben, ich muss jetzt schon 10-15 Sekunden Wasser laufen lassen bis es ansatzweise warm wird. Das bedeutet wohl auch, dass die Leitungen wohl irgendwie nicht besonders gut gedämmt sind. Vor allem in der Küche wundert mich das, die ist wirklich direkt über der THZ. Seltsam.

Nochmal eine Nachfrage zu 11.30 im Diagramm. Ich habe jetzt dank deines Wiki und deiner Geduld  verstanden, wie Ist  ./. Soll Wert und Integral in Verbindung stehen. Das sieht man ja auch wirklich klasse im Diagram. Von 09.00 bis 11.00 fällt der Integralwert in jedem Nachschaupumpenzyklus, dann kommt WW und der Integralwert fällt innerhalb von 30 Minuten auf -100. Ich hätte jetzt erwartet, dass er mehr oder weniger linear auf -100 sinkt. Wenn das per Reset geschieht würde das nicht bedeuten, dass eventuell noch genug Puffer im System ist und gar nicht geheizt werden müsste (Integralwert würde ja ohne WW Bereitung fast linear weiter sinken nehme ich an und dann eben irgendwann auf -100 gehen und erst dann heizen) ?

Offline willybauss

  • Hero Member
  • *****
  • Beiträge: 1623
Jetzt schaust Du schon genauer hin als ich ...  :)

Während der WW-Bereitung findet keine Integralwertbildung statt. Wie Du siehst misst die Anlage während der WW-Bereitung eher die WW-Temperatur, nicht die Heizkreistemperatur. Da würde den Integralwert völlig verfälschen. Deshalb fällt der Integralwert während der WW-Bereitung eben nicht, sondern bleibt konstant. Ich vermute, dass die Anlage nach der WW-Bereitung die fehlenden Messwerte interpoliert hinzu rechnet. Deshalb geht der Abfall der Integralkurve nach Ende der WW-Bereitung so schnell.

Der Reset kommt erst am Beginn der nächsten Heizperiode, nicht am Ende der WW-Bereitung. Reset geht auf den Wert 0, nicht auf -100.
FHEM auf Raspberry Pi B und 2B; THZ (THZ-303SOL), CUL_HM, TCM-EnOcean, SamsungTV, JSONMETER, SYSMON, OBIS, STATISTICS, CO20, FHEM2FHEM

Offline willybauss

  • Hero Member
  • *****
  • Beiträge: 1623
@awex102:
Nochmal zur Dauer, bis warmes Wasser kommt: das hängt natürlich stark vom Rohrvolumen ab, das erst mal mit WW gefüllt werden muss. Entweder die Rohrverlegung ist nicht so kurz wie Du denkst (könnte ja 3 mal ums Eck gehen), oder Du hast nen recht großen Rohrquerschnitt. Das lässt sich hinterher nicht mehr ändern. Und bei deiner geringen Wasserhärte wird auch der Querschnitt auf Dauer so groß bleiben.

Bei mir hat sich der Haushersteller was gedacht: direkt über der Anlage ist ein Loch in der Decke, durch das alle Wasserleitungen auf kürzestem Weg direkt ins EG laufen. Von dort auf kürzestem Weg zum Küchenwaschbecken. Bei mir vergehen in der Küche kaum 5 Sekunden, bis warmes Wasser kommt.
FHEM auf Raspberry Pi B und 2B; THZ (THZ-303SOL), CUL_HM, TCM-EnOcean, SamsungTV, JSONMETER, SYSMON, OBIS, STATISTICS, CO20, FHEM2FHEM

Offline awex102

  • Jr. Member
  • **
  • Beiträge: 91
Danke! Ich poste morgen nochmal die Logs. Der integralwert sinkt weiter brav. Noch kein Heizen. Bedeutet aber auch, dass falls interpoliert wird , zumindest aktuell der integralwert langsamer sinkt als zu dem Zeitpunkt als ww gemacht wurde. Mal sehen was die ächszen Stunden passiert.

Ich habe eben nochmal die Diagramme angeschaut und mir die Frage gestellt ob es sinnvoll ist nachts zu heizen. Wenn das mit den Kurven so herleitbar ist könnte man doch durch ein geschicktes reset der Anlage und damit des integral Wertes zumindest grob die heizphasen auf der Zeitachse gesehen verschieben können ? Das müsste ich dann aber gegen den Strom Nacht Tarif bewerten .... Überlegung richtig ?

Offline willybauss

  • Hero Member
  • *****
  • Beiträge: 1623
Musst Du abwägen. Einfacher wäre für sowas die Nachtabsenkung, die die Anlage ja von sich aus schon bietet. Aber kühlt das HAus nachts überhaupt merklich aus? Insofern: bringt das was?
FHEM auf Raspberry Pi B und 2B; THZ (THZ-303SOL), CUL_HM, TCM-EnOcean, SamsungTV, JSONMETER, SYSMON, OBIS, STATISTICS, CO20, FHEM2FHEM

Offline TheTrumpeter

  • Sr. Member
  • ****
  • Beiträge: 534
Ich habe eben nochmal die Diagramme angeschaut und mir die Frage gestellt ob es sinnvoll ist nachts zu heizen. Wenn das mit den Kurven so herleitbar ist könnte man doch durch ein geschicktes reset der Anlage und damit des integral Wertes zumindest grob die heizphasen auf der Zeitachse gesehen verschieben können ? Das müsste ich dann aber gegen den Strom Nacht Tarif bewerten .... Überlegung richtig ?
Soviel wie ich bisher verstanden habe, könntest Du das nur mit unterschiedlichen Soll-Temperaturen für Tag und Nacht beeinflussen.
Nachts ist der Wirkungsgrad aber wegen der geringeren Temperaturen auch schlechter.

Keine Ahnung wieviel günstiger der Nacht-Tarif ist. Ich habe nur einen Tarif, weil bei meinem geringen Verbrauch rechnerisch die Grundgebühr höher als die tatsächliche Ersparnis wäre.

Ich möchte daher in die andere Richtung gehen und wie immi weiter oben vorgeschlagen hat die Soll-Temperatur nachts leicht absenken, um eher tagsüber die Heizzyklen zu bekommen.
Vorher muss ich aber erstmal meine Heizkreise neu einstellen, um die richtige Spreizung zu bekommen, dann wahrscheinlich die Heizkurve noch absenken... und dann ist der Winter wahrscheinlich auch schon vorbei.
FHEM auf RPi3, THZ (LWZ404SOL), RPII2C & I2C_MCP342x (ADCPiZero), PowerMap, CustomReadings, RPI_GPIO, Twilight, nanoCUL (WMBus für Diehl Wasserzähler & Regenerationszähler für BWT AqaSmart)

Offline TheTrumpeter

  • Sr. Member
  • ****
  • Beiträge: 534
So, da uns die Kälte aktuell ziemlich im Griff hat, konnte ich die Leistungsgrenze meiner Anlage gestern mal ausprobieren...
Bivalenzpunkt ist aktuell bei -15°C.

Gestern Früh hatte es dann auch zwischen 01:30 und 09:20 permanent unter -10°C, Tiefststand bei -14,2°C um 08:00.
Die Heizung ist genau um 01:30 angesprungen und bis 11:30 gelaufen. Die Leistung hat gereicht, um die Heizkreistemperatur zumindest über den Sollwert zu heben. Als dann die Temperatur ab 08:00 wieder aufwärts ging, füllte sich auch das Integral stetig  :D
Heute war dagegen "Kindergeburtstag", Tiefststand bis jetzt bei -9,3°C. (Der Heizzyklus zwischen 09:00 und 13:00 schaut im Plot sehr linear aus, weil in der Zeit das Debug-Reading der LWZ-Register gelaufen ist...)

Allerdings fällt mir schon wieder die Heizkreispumpe negativ auf...
Warum hat die sich gestern um 16:00 eingeschaltet und hat das Integral dadurch vollgemacht? Hat für einen verhältnismässig kurzen Heizzyklus gesorgt, weil die Heizkreistemperatur beim Heizstart noch recht hoch war.
Dasselbe Spiel kurz vor Mitternacht wieder, aber da ist zumindest wg. niedriger Heizkreistemperatur geheizt worden.
Heute um 13:00 hat sich die Heizkreispumpe nach dem Heizzyklus wiederum nicht abgeschaltet. Nach 1 Stunde habe ich das mittels Anlagen-Reset beendet.
Und um 18:15 hat sie sich schon wieder auf Dauerbetrieb geschaltet, obwohl sie um 18:00 regulär 5min gelaufen ist & sie nur alle 30min laufen sollte. Auch da lief das Integral dann wieder voll  >:(

Kann es sein, dass das Debug-Lesen der Register bzw. kurze Abfrage-Intervalle der Signale die Anlage aus dem Tritt bringen?  :-\
(Ich habe heute um 16:00 die Intervalle für einige Signale (sowie 3 zusätzlich von mir definierte) auf zuerst 120 und dann 90 Sekunden gesetzt, weil ich auf der Suche nach dem Volumenstrom war/bin.)
« Letzte Änderung: 08 Januar 2017, 21:40:30 von TheTrumpeter »
FHEM auf RPi3, THZ (LWZ404SOL), RPII2C & I2C_MCP342x (ADCPiZero), PowerMap, CustomReadings, RPI_GPIO, Twilight, nanoCUL (WMBus für Diehl Wasserzähler & Regenerationszähler für BWT AqaSmart)

Offline willybauss

  • Hero Member
  • *****
  • Beiträge: 1623
Das klingt für mich eher nach einem Bug in der Firmware der Anlage. Oder Du forstest nochmal das Installationsmanual nach Parametern durch, die evtl. was damit zu tun haben könnten. Vieleicht gibts ja bei der 4er Serie was neues, das ich noch nicht kenne.
FHEM auf Raspberry Pi B und 2B; THZ (THZ-303SOL), CUL_HM, TCM-EnOcean, SamsungTV, JSONMETER, SYSMON, OBIS, STATISTICS, CO20, FHEM2FHEM

Offline friesenjung

  • Full Member
  • ***
  • Beiträge: 240
Hallo Zusammen,

@Willy Du hast Recht, kaum wirds Winter, wird an der THZ optimiert und die Fragen kommen ;)

Nun habe ich mich gerade mal durch die letzten Beiträge gewühlt (ist ja wieder einiges zusammengekommen). An der Stelle auch mein Dank für den Wiki-Beitrag! Meiner Meinung würde es auch Sinn machen Deinen ersten Beitrag direkt ins FHEM-Wiki zu verlegen und dort zu pflegen. Nur so ein Gedanke...

Hier noch ein Nachtrag von mir:
Ich hatte ja in den letzten Monaten Probleme mit dem Volumenstrom (vlt. erinnert Ihr Euch), was mittlerweile auch (hoffentlich) behoben wurde, aber echt Nerven gekostet hat. Alles zu erzählen würde den Beitrag sprengen. Kurz gefasst und eigentlich nicht zu fassen:
Die Anlage lief ja nach gewisser Zeit in den Fehler "zu niedriger Volumenstrom". Grund: Das Sieb im Rücklauffilter war immer wieder mit Rostpartikeln zugesetzt. Rost? JA, Rost. Ihr wollt garnicht wissen wie oft Stiebel bzw. unser Installateur da war und ... naja, egal. Stand Heute ist die Erkenntnis, dass es die bei uns verbauten Flex-Schläuche, die jeweils Vorlauf und Rücklauf der THZ mit dem Rest des Heizkreislaufes (bei mir gingen diese an die hydraulische Weiche) verbunden haben, der Grund für die Verschlammung der Anlage waren. Durch diese Schläuche diffundierte über lange Zeit Sauerstoff, so dass die Heizspirale im WW-Behälter rostete und das Sieb verschlammte. Stiebel sagt, das kommt äußerst selten vor, aber es kann eben vorkommen. Die Verrohrung wurde auf geste Rohre umgebaut und zusätzlich ein Schlammabscheider eingebaut. Ich hoffe, dass damit das Problem erledigt ist.
Die Flexschläuche sahen auch echt grauenvoll an den Innenwänden aus. Komplett zugesetzt mit Rost. Druckabfall im HK gab es nie, also Dicht war das System schon.
So, das dazu.

Ich hätte jetzt auch noch eine kleine Frage:
  • aktuell zu meinen Diagrammen (Anhang). Mittlerweile habe ich eigentlich eine für uns ideale Einstellung gefunden. Bedeutet, dass ich in allen Räumen über das Jahr verteilt konstante Temperaturen ohne Nachregulierung hinbekomme. Also das was bei uns im Raum ankommt ist wie wir es wollen. Nun waren es gestern auch bei uns recht niedrige Temperaturen(bis -10Grad) und mir fiel auf, dass der Kompressor fast 24h am Stück lief (hatte schon am Tag vorher ca. 20Uhr begonnen)! Ist das normal bzw. ist das bei Euch auch so?

@TheTrumpeter:
Das mit Deiner Heizkreispumpe versteh ich auch nicht recht. Ich habe eine 304, eigentlich der kleine Bruder der 404 und ich kenne dieses Verhalten definitiv nicht! Das einzige was mir direkt auffiel war die FW, die ist bei mir 5.19 statt 5.39
Zu dem Volumenstrom, den Du in den Registern suchst, kann ich nur sagen, dass es gut möglich ist, dass es nicht in der Einheit gespeichert wird, die im Display gezeigt wird. Im Display wird ja l/min angezeigt, im Programm des Stiebel-Technikers stand meines Wissens nach immer Kubikmeter je Stunde. Vielleicht hilfts.

@awex102
ich hatte auch am Anfang das Problem, dass der Installateur die Zirku-Pumpe einfach in die Steckdose gesteckt hat. Nicht mal mit ner Zeitschaltuhr! Tzzz. Mittlerweile mache ich das auch über Fhem (PCA301-Funksteckdose). Ich steuere unsere Weckzeiten für die Wochentage bzw. Wochenende über das FHEM-Roommate-Modul. Damit fahre ich auch zeitgesteuert die Rolläden morgens hoch und eben auch die Zirku-Pumpe für 3 Minuten etwa 10 Minuten vor dem Aufstehen an.

Ach ja eine Frage noch, hat jemand schonmal das Logging der THZ über das dblog-Device in eine SQL-Datenbank (o.ä.) realisiert und auch die Plots dazu angepasst?
Ich teste das dblog-Modul gerade und es sieht so aus, dass durch die Länge der Readings bzw. das Beinhalten mehrerer Values, z.B. in sGlobal, es problematisch ist die Plots korrekt und komplett darzustellen. Vielleicht hat da schon jemand mehr Erfahrung als ich...

Viele Grüße...

PS: allen auch noch ein gesundes Neues...
FHEM auf Raspi 2,  Jeelink-Clone 1x für PCA301 und 1x für Lacrosse, THZ304SOL, Homematic: CUL_HM / M-MOD-RPI-PCB, Pushover, Xiaomi s50

Offline TheTrumpeter

  • Sr. Member
  • ****
  • Beiträge: 534
@TheTrumpeter:
Das mit Deiner Heizkreispumpe versteh ich auch nicht recht. Ich habe eine 304, eigentlich der kleine Bruder der 404 und ich kenne dieses Verhalten definitiv nicht! Das einzige was mir direkt auffiel war die FW, die ist bei mir 5.19 statt 5.39
Zu dem Volumenstrom, den Du in den Registern suchst, kann ich nur sagen, dass es gut möglich ist, dass es nicht in der Einheit gespeichert wird, die im Display gezeigt wird. Im Display wird ja l/min angezeigt, im Programm des Stiebel-Technikers stand meines Wissens nach immer Kubikmeter je Stunde. Vielleicht hilfts.
Naja mal sehen wie das mit der Heizkreispumpe weitergeht. Ich habe nach dem Reset gestern um 14:00 nicht weiter eingegriffen; nach dem darauffolgenden Heizzyklus läuft auch wieder alles wie erwartet.
Leider bin ich bzgl. Volumenstrom auch noch nicht fündig geworden. Die 3 gefundenen Kandidaten musste ich dann leider alle ausschließen, sodass tatsächlich in l/min bzw. cl/min nichts mehr übrig scheint. Werde dann noch nach l/h (bzw. m³/h) suchen, muss ja wo sein. Eine andere sinnvolle Einheit fällt mir nicht mehr ein.

Die 5.39er Firmware ist übrigens die letzte Version, die es für die 304/404SOL gibt. Daran wird nichts mehr geändert.
FHEM auf RPi3, THZ (LWZ404SOL), RPII2C & I2C_MCP342x (ADCPiZero), PowerMap, CustomReadings, RPI_GPIO, Twilight, nanoCUL (WMBus für Diehl Wasserzähler & Regenerationszähler für BWT AqaSmart)

Offline awex102

  • Jr. Member
  • **
  • Beiträge: 91
Guten Morgen,

hier die neuen Plots. Auch gleich eine Frage dazu:

Gegen 2 Uhr wird Wasser gemacht. Danach fällt die Integralwert statt auf 100 zu steigen, der Heizvorgang wird beendet. Auch hier zum Verständnis die Frage warum? Die WW Aufbereitung scheint generell den Heizvorgang zu beeinflussen.

In Plot 4 nochmal das Thema WW Temp. Nach dem Duschen fällt der Wert nun stark ab, mit der ZPumpe war das eher ein kleiner Knick. Einfach weil jetzt direkt kaltes Wasser in die Anlage gepumpt wird?

Und noch eine Frage zur ZPumpe: Ich werde die in jedem Fall morgens anschalten. Dummerweise startet die nach Stromtrennung im Auto Modus, mal sehen ob die dann sofort loslegt. Muss die ZPumpe regelmäßig über den Tag verteilt laufen (z.B. 1x / Stunde) oder kann ich das nach belieben zum Beispiel einmal morgens und einmal Mittags laufen lassen (Hintergrund Keime) ?
« Letzte Änderung: 09 Januar 2017, 07:57:14 von awex102 »

Offline willybauss

  • Hero Member
  • *****
  • Beiträge: 1623
@friesenjung:
Irgendwann ist es eben so kalt, dass die Anlage an ihre Leistungsgrenze kommt. Das ist kein Fehler, sondern der Plan. Du kannst auch eine stärkere Anlage nehmen, die bis -20° schafft. die ist dann an 364 Tages des Jahres unausgelastet und deshalb evtl. ineffizient.

@awex102:
Am Beginn der WW-Bereitung waren Integalwert und Soll-Ist bereits im positiven Bereich, d.h. es bestand "eigentlich" kein Heizbedarf mehr. Lediglich die Erreichung von Hysterese- bzw. Integral-Maximum wäre noch der Grund gewesen, weiter zu heizen. Kann sein, dass das am Ende der WW-Bereitung auch noch genauso war; dafür müsste man aber schon mit der Lupe hinschauen, das scheint grade im Grenzbereich zu sein. Jedenfalls nichts, was falsch läuft. Der Heizbedarf war ja erst mal gedeckt, und die Tatsache, dass der Integralwert in den nächsten Stunden kaum negativ wurde, zeigt ja auch, dass es erst mal gereicht hat.

Mit Zirku wird auch kaltes Wasser nachgefüllt; sonst würde der Speicher ja leer laufen. Aber ohne die fehlende Umwälzung vermischt sich warmes mit kaltem Wasser nicht.

Das Thema Keime hatten wir bereits. Solange regelmäßig Wasser fließt ist das kein Thema, wegen ein paar Stunden Stillstand schon gar nicht. Wie oft Du die Pumpe einschaltest ist Deine persönliche Entscheidung. Sinnvoll wäre es sicher, sie dann einzuschalten, wenn man voraussichtlich warmes Wasser braucht. Zu anderen Zeiten dürfte es eher sinnfrei sein.

Checke mal die Anleitung der Pumpe, evtl. kann man sie umprogrammieren, damit sie gleich los läuft. Oder evtl. hat sie ja einen Fernsteuerungs-Eingang, so dass sie gar nicht stromlos werden muss.
FHEM auf Raspberry Pi B und 2B; THZ (THZ-303SOL), CUL_HM, TCM-EnOcean, SamsungTV, JSONMETER, SYSMON, OBIS, STATISTICS, CO20, FHEM2FHEM

Offline awex102

  • Jr. Member
  • **
  • Beiträge: 91


Mit Zirku wird auch kaltes Wasser nachgefüllt; sonst würde der Speicher ja leer laufen. Aber ohne die fehlende Umwälzung vermischt sich warmes mit kaltem Wasser nicht.


Pumpe geht an sobald sie am Strom hängt, geht also.

Nochmal eine Frage zum WW: Ich habe eben nur ein paar Liter entnommen. Sofort wieder dieser Starke knick nach unten. Woran liegt das nochmal genau? Wenn ich das so richtig deute wie es jetzt ist wird beim Duschen usw sofort die Heizung angehen auch wenn der Speicher doch eigentlich noch 250 Liter drin hat. Warum sinkt die Temperatur so schnell? Liegt das an der Position des Fühlers im Speicher?

Dann noch eine Frage zur Lüftung: Soll und ist Wert weichen im Diagram stark voneinander ab. Gibt´s da irgendwelche Parameter, die den eingestellten Wert überschreiben ?
« Letzte Änderung: 09 Januar 2017, 19:58:23 von awex102 »

Offline TheTrumpeter

  • Sr. Member
  • ****
  • Beiträge: 534
Nochmal eine Frage zum WW: Ich habe eben nur ein paar Liter entnommen. Sofort wieder dieser Starke knick nach unten. Woran liegt das nochmal genau? Wenn ich das so richtig deute wie es jetzt ist wird beim Duschen usw sofort die Heizung angehen auch wenn der Speicher doch eigentlich noch 250 Liter drin hat. Warum sinkt die Temperatur so schnell? Liegt das an der Position des Fühlers im Speicher?
Ich habe den Fühler auch noch in der unteren (ungünstigen) Position, dusche aber ohne, dass danach Warmwasser erwärmt werden muss. Wenn Du also wirklich nur "ein paar Liter" entnommen hast, kann das eigentlich nicht sein.

Dann noch eine Frage zur Lüftung: Soll und ist Wert weichen im Diagram stark voneinander ab. Gibt´s da irgendwelche Parameter, die den eingestellten Wert überschreiben ?
Soll und Ist haben komplett unterschiedliche Einheiten, das passt schon.
Ist-Wert ist die Lüfterdrehzahl in Hertz, der Soll-Wert irgendwelche Prozent oder so. Du stellst ja auch m³/h ein und der Ist-Wert ist in Hertz.
FHEM auf RPi3, THZ (LWZ404SOL), RPII2C & I2C_MCP342x (ADCPiZero), PowerMap, CustomReadings, RPI_GPIO, Twilight, nanoCUL (WMBus für Diehl Wasserzähler & Regenerationszähler für BWT AqaSmart)

Offline TheTrumpeter

  • Sr. Member
  • ****
  • Beiträge: 534
Dann noch eine Frage zur Lüftung: Soll und ist Wert weichen im Diagram stark voneinander ab. Gibt´s da irgendwelche Parameter, die den eingestellten Wert überschreiben ?
Doch noch was... danach hast Du zwar nicht gefragt, aber warum hast Du so unterschiedliche Ist-Werte für Zu- und Abluft???
Hast Du so unterschiedliche Luftmengen? Du "bläst" das Haus ja regelrecht auf.
Bei meiner LWZ404 sind 30Hz ca. 175m³. Das wäre bei Dir Abluft. 40Hz sind ca. 275m³, Deine Zuluft läuft aber auf 50Hz, das ist vermutlich Max!
FHEM auf RPi3, THZ (LWZ404SOL), RPII2C & I2C_MCP342x (ADCPiZero), PowerMap, CustomReadings, RPI_GPIO, Twilight, nanoCUL (WMBus für Diehl Wasserzähler & Regenerationszähler für BWT AqaSmart)