Autor Thema: THZ Tecalor (LWZ Stiebel Eltron) Wärmepumpe -Optimierung und Erfahrungsaustausch  (Gelesen 403436 mal)

Offline willybauss

  • Hero Member
  • *****
  • Beiträge: 1743
Den Fall mit der Pumpe hatte ich gestern am späten Nachmittag auch. In beiden Fällen war die Außentemperatur deutlich fallend. Evtl. ist das (wenn kein Bug) eine fiese Methode, die Anlage zum "vorausschauenden heizen" zu zwingen, obwohl sie lt. Integralwert und lt. Soll-Ist noch nicht heizen müsste. Mal schauen, ob frühere Fällen diese Theorie stützen könnten.

Die Heizenergie ist dabei ja nicht "verloren". Sie kommt den Haus zugute. Dann wird halt zu einem späteren Zeitpunkt kürter oder gar nicht geheizt. Insofern kein Anlass zur Sorge wegen $$$.

Auch hier das Wichtigste: hatte es Auswirkungen auf die Innentemperatur. Wohl kaum; also - so what.

Die Zeitpunkte der Verbindungsausfälle passen nur so ganz grob - SEHR grob. Mal ne Statistik machen und nach 20 Werten nochmal anschauen. Dabei ALLE Verbindungsausfälle und ALLE falschen Pumpenläufe auflisten, egal ob es einen zeitlich zusammenhängenden Partner gab oder nicht.
FHEM auf Raspberry Pi B und 2B; THZ (THZ-303SOL), CUL_HM, TCM-EnOcean, SamsungTV, JSONMETER, SYSMON, OBIS, STATISTICS, CO20, FHEM2FHEM

Offline awex102

  • Jr. Member
  • **
  • Beiträge: 91
Den Fall mit der Pumpe hatte ich gestern am späten Nachmittag auch. In beiden Fällen war die Außentemperatur deutlich fallend. Evtl. ist das (wenn kein Bug) eine fiese Methode, die Anlage zum "vorausschauenden heizen" zu zwingen, obwohl sie lt. Integralwert und lt. Soll-Ist noch nicht heizen müsste. Mal schauen, ob frühere Fällen diese Theorie stützen könnten.

Ist mir auch aufgefallen. Scheint bei fallender Außentemp. und deutlichen Minusgraden aufzutreten. Mal weiter beobachten.

Hier hab ich einen ähnlichen Fall gefunden, der Thread Ersteller geht von einem Softwarebug aus und stand wohl auch mit SE in Verbindung. http://www.haustechnikdialog.de/Forum/t/165727/Heizkreispumpe-laeuft-bei-0-C-durch-Tecalor-THZ-303-Sol

Offline willybauss

  • Hero Member
  • *****
  • Beiträge: 1743
Hier hab ich einen ähnlichen Fall gefunden, der Thread Ersteller geht von einem Softwarebug aus und stand wohl auch mit SE in Verbindung. http://www.haustechnikdialog.de/Forum/t/165727/Heizkreispumpe-laeuft-bei-0-C-durch-Tecalor-THZ-303-Sol
Den kenne ich. Hab mich heute morgen wieder dran erinnert, dass ich deswegen mit ihm in Emailkontakt war. Nachfrage läuft bereits.
FHEM auf Raspberry Pi B und 2B; THZ (THZ-303SOL), CUL_HM, TCM-EnOcean, SamsungTV, JSONMETER, SYSMON, OBIS, STATISTICS, CO20, FHEM2FHEM

Offline TheTrumpeter

  • Sr. Member
  • ****
  • Beiträge: 646
Den Fall mit der Pumpe hatte ich gestern am späten Nachmittag auch. In beiden Fällen war die Außentemperatur deutlich fallend.
Leider muss ich die Theorie gleich wieder zunichte machen...
Ich hatte in den letzten Tagen keinen Tag ohen "abnormalen" Heizzyklus, zuletzt ist es immer öfter aufgetreten...
Die Plots bis inkl. 16.01.2017 sind weiter oben schon gepostet, hier dann die Plots danach.

  • 11.01.2017 08:00: Pumpe läuft 1h durch, dann Heizzyklus. Temperatur konstant
  • 11.01.2017 18:00: Pumpe läuft 1h durch, dann Heizzyklus. Temperatur konstant bis leicht steigend
  • 12.01.2017 01:00: Pumpe läuft 1h durch, dann Heizzyklus. Temperatur konstant
  • 12.01.2017 08:00: Pumpe läuft nach Warmwasserbereitung an und dann 1h durch, bis der Heizzyklus beginnt. Heizzyklus endet vor Erreichen des Integrals oder der Hysterese. Temperatur konstant bis leicht steigend
  • 13.01.2017: ohne Auffälligkeit
  • 14.01.2017 08:00: Pumpe läuft 1h durch, Heizzyklus beginnt, endet aber vor Erreichen des Integrals oder der Hysterese. Pumpe läuft kurz nach, dann wieder "alles normal". Temperatur stark steigend.
  • 15.01.2017: ohne Auffälligkeit
  • 16.01.2017 15:00: Pumpe läuft 1h, bis die Heizung wegen Integral abstellt. Nach Heizstopp läuft sie eine weitere Stunde "nach". Aussentemperatur war vor dem Pumpenanlauf stabil und beim Pumpennachlauf höchstens minimal fallend.
  • 17.01.2017 04:00: Pumpe läuft 1h durch, danach wieder normaler Zyklus. Zu dem Zeitpunkt ist die Aussentemperatur stabil bis leicht stigend.
  • 17.01.2017 23:00: Pumpe läuft 30min durch, gefolgt vom Heizbeginn. Aussentemperatur stabil.
  • 18.01.2017 08:00: Heizzyklkus beginnt normal, endet aber ohne Integral oder Hysterese "einfach so", Pumpe läuft 1h nach und hört dann auf. Temperatur steigend.
  • 18.01.2017 18:00: Pumpe läuft 1h durch, dann startet der Heizzyklus, der vom Warmwasser unterbrochen wird und anschliessend wieder aufgenommen wird. Temperatur fallend
  • 19.01.2017 01:00: Pumpe läuft 1h durch, dann startet ein Heizzyklus. Temperatur leicht fallend
  • 19.01.2017 08:00: Pumpe läuft 1h durch, dann startet ein Heizzyklus. Temperatur konstant bis leicht steigend
  • 20.01.2017 03:00: Pumpe läuft 1h durch und hört dann wieder auf. Temperatur leicht fallend
  • 20.01.2017 14:00: Pumpe läuft 1h durch und wird dann vom Warmwasser unterbrochen, Temperatur steigend
  • 20.01.2017 20:00: Pumpe läuft nach Warmwasserbereitung an und ca. 45min durch bis der Heizzyklus beginnt. Temperatur fallend
  • 21.01.2017 01:00: Pumpe läuft am Ende des Heizzyklus 1h nach, Temperatur leicht fallend bis stabil.
  • 21.01.2017 14:00: Pumpe läuft 1h durch, dann Heizzyklus. Temperatur stark steigend
  • 21.01.2017 22:00: Pumpe läuft 15min durch, dann Heizzyklus, obwohl weder Integral noch Hysterese erreicht. Temperatur konstant
  • 22.01.2017 04:00: Pumpe läuft 1h durch, dann Heizzyklus. Temperatur konstant bis leicht steigend.
  • 22.01.2017 10:00: Pumpe läuft 1h durch, dananch habe ich die Elektronik zurückgesetzt (zu sehen an der geilfterten Aussentemperatur). Mal sehen wie lange es jetzt wieder "gut" geht.

Zusammengefasst:
Meistens führt eine durchlaufende Pumpe zum Volllaufen des Integrals, sodass ein Heizzyklus folgt.
Manchmal endet der Pumpenlauf aber bevor das Integral voll ist.
Manchmal läuft die Pumpe nach dem Heizzyklus noch nach.
Manchmal endet ein Heizzyklus, obwohl weder das Integral noch die Hysterese erreicht ist.

Ich kann noch keinen Zusammenhang zu physikalischen Randbedingungen erkennen. In den letzten Tagen habe ich keinerlei "Experimente" in FHEM gemacht, wo ich häufig und viele Werte gelesen hätte. Einzig Freitagabend habe ich den RasPi mehrmals heruntergefahren und neu gestartet, d.h. da wurden alle Parameter mehrmals hintereinander neu ausgelesen.
Der "Pumpendauerlauf" von Anfang Jänner ist bisher nicht mehr aufgetreten. Damals habe ich lange Zeit den "Debug-Read"-Modus laufen gehabt.
FHEM hängt bei mir am Diagnoseanschluss der LWZ und geht auf die serielle Schnittstelle vom RasPi.

In den meisten Zeiten wo die Pumpe "falsch läuft", habe ich 100%ig nichts über FHEM umgestellt.

Ich habe in den Plots irgendwann die Display-Anzeige "Warmwasser" und "Heizbetrieb" aufgenommen, um zu sehen ob die Anlage in den Heizbetrieb wechselt ohne den Verdichter zu starten, ist aber nicht so.
FHEM auf RPi3, THZ (LWZ404SOL), RPII2C & I2C_MCP342x (ADCPiZero), PowerMap, CustomReadings, RPI_GPIO, Twilight, nanoCUL (WMBus für Diehl Wasserzähler & Regenerationszähler für BWT AqaSmart)

Offline awex102

  • Jr. Member
  • **
  • Beiträge: 91
Noch ein Thema: Ich habe aufgrund meines WW Problems (schnelles Absinken um mehrere Grad bei Wasserentnahme) das WW Programm auf 14.15-16.15 Uhr Tagbetrieb eingestellt und die Temp im Nachtbetrieb auf 10 Grad eingestellt um zu verhindern, dass die Anlage WW macht, nachdem WW entnommen wurde. Warmes Wasser kommt nämlich weiterhin, auch wenn die Temp zb auf 20 Grad sinkt.

Jetzt macht meine Anlage jeden Tag um 12.15 Wasser statt um 14.15 ? Ist bekannt, ob die Uhr spinnt?


Offline TheTrumpeter

  • Sr. Member
  • ****
  • Beiträge: 646
Jetzt macht meine Anlage jeden Tag um 12.15 Wasser statt um 14.15 ? Ist bekannt, ob die Uhr spinnt?
Schau' mal auf welchem Wert P59 steht... ich tippe auf 120min.
FHEM auf RPi3, THZ (LWZ404SOL), RPII2C & I2C_MCP342x (ADCPiZero), PowerMap, CustomReadings, RPI_GPIO, Twilight, nanoCUL (WMBus für Diehl Wasserzähler & Regenerationszähler für BWT AqaSmart)

Offline awex102

  • Jr. Member
  • **
  • Beiträge: 91
Macht hochgradig Sinn. Ok, bedeutet, ich stelle das WW Programm jetzt auf 16.15-18.15 und dann läuft die Anlage um 14.15 Uhr los. Oder den Parameter auf 0.

Bei der THZ 403 ist dieser Wert übrigens im "Inbetriebnahme Menü" unter

12.8.4 Max. Vorverlegung
Mit dem Parameter können Sie dafür sorgen, dass sie zum Ablauf
der Absenkzeit ein beheiztes Gebäude vorfinden, indem sie das
Wiedereinschalten vorverlegen. Damit werden vorzeitig die Heizkreissolltemperaturen
angefahren.

zu finden.
« Letzte Änderung: 22 Januar 2017, 16:47:58 von awex102 »

Offline willybauss

  • Hero Member
  • *****
  • Beiträge: 1743
Ich habe von dem Kollegen aus dem HaustechnikDialog-Forum Antwort bekommen zum Thema "unnötiger Pumpenlauf":

Zitat
Stiebel hat meine Anlage Monate lang mitgelogget. Dann viel uns auf, dass es ziemlich die gleichen Zeiten immer sind wo die HKP durchläuft.
Danach ist mir dann eine Idee gekommen, dass ich vielleicht mal die Sperrzeiten bei EON anfrage und siehe da, Volltreffer!
Uhrzeit passt genau.
Das heißt immer wenn eine Sperrzeit ist, dann schaut das im Log so aus, als würde nur die HK durchlaufen und sonst nichts passieren.
Die WP will heizen kann aber nicht weil der Verdichter ausgeschaltet ist 
Das kannst wahrscheinlich sogar nachstellen, wenn du einfach im Heizmodus die Sicherung des Verichters abschaltest, dann dürfte das Log genauso aussehen.
Das fällt natürlich nur in den Zeiten auf wo es wirklich sehr kalt ist, weil da die WP natürlich länger läuft.
Aber bei mir ist es kein defekt, sondern einfach die Sperrzeit die EON macht 

Fragt doch mal bei eurem Stromanbieter, ob die Pumpenläufe ohne Verdichter mit Sperrzeiten matchen.

Bei mir scheint das nicht zu passen, denn ich hatte einen Fall, in dem die Pumpe und der Heizstab lief, der Verdichter war aber aus. Wie kann der Heizstab heizen, wenn die Stromzufuhr gekappt ist? Heizstab und Verdichter hängen definitiv am selben Stromkreis. Außerdem zeigt die "EVU-Sperre" Anzeige im Plot nichts an. Aber das könnte auch ein Bug im Mythz-Modul sein.
FHEM auf Raspberry Pi B und 2B; THZ (THZ-303SOL), CUL_HM, TCM-EnOcean, SamsungTV, JSONMETER, SYSMON, OBIS, STATISTICS, CO20, FHEM2FHEM

Offline awex102

  • Jr. Member
  • **
  • Beiträge: 91
Ich habe vorhin die Max. Vorverlegung auf 0 gesetzt.

Ich musste grade grinsen: Das gesamte Timing der Anlage scheint dann verändert zu werden. Im Diagram sieht man, wie die Kurve plötzlich Rückwärts läuft. Da scheint also bis hin zu den Readings ein Versatz eingerechnet zu werden, sprich: Eine "2.te interne Uhr" läuft wohl mit genau diesem Versatz.

Man sieht nun übrigens auch grade eben, 19.30 uhr, wie die Pumpe wieder anfängt durchzulaufen. Ich resette die Anlage sobald ich das mitbekomme. Heute das 2.te Mal. Ich werde versuchen das mit den Sperrzeiten rauszufinden.

Ich sehe allerdings auch wieder einen Verbindungsabbruch 2017-01-22 19:39:49

Habe mich grade im Sicherungskasten umgesehen. Der Rundsteuerempfänger RCR 131 Landis blinkt grün (relativ regelmäßig). Der blint normalerwesie glaube ich nicht. Habe im Netz nichts gefunden, kann ich daraus irgendwie ablesen, ob grade gesperrt wird?
« Letzte Änderung: 22 Januar 2017, 20:08:34 von awex102 »

Offline willybauss

  • Hero Member
  • *****
  • Beiträge: 1743
Weißt Du Details, wie die Anlage im Zählerschrank angeschlossen ist? Bei mir liegt die Steuerung auf dem Hausstromzähler, der von der EVU-Sperre nicht betroffen ist. Wenn das bei Dir anders ist bekommt die Steuerung womöglich beim Beginn der EVU-Sperre einen kurzen Stromaussetzer, der die Verbindungsabbrüche erklären würde.

Wie kann man Stromausfälle am besten mit fhem erkennen und loggen? Ich hätte da eine Steckdose hinter der Anlage, an der die Kondensat-Hebeanlage angeschlossen ist. Da könnte man ja irgendeine Art von Logging dran hängen. Habe ich mit meinen Homematic Schaltsteckdosen eine Chance?
FHEM auf Raspberry Pi B und 2B; THZ (THZ-303SOL), CUL_HM, TCM-EnOcean, SamsungTV, JSONMETER, SYSMON, OBIS, STATISTICS, CO20, FHEM2FHEM

Offline TheTrumpeter

  • Sr. Member
  • ****
  • Beiträge: 646
Ich habe generell keine EVU-Sperre, weil ich nur 1 Stromtarif habe...

Diese Theorie muss ich also auch gleich wieder kippen :-(
FHEM auf RPi3, THZ (LWZ404SOL), RPII2C & I2C_MCP342x (ADCPiZero), PowerMap, CustomReadings, RPI_GPIO, Twilight, nanoCUL (WMBus für Diehl Wasserzähler & Regenerationszähler für BWT AqaSmart)

Offline willybauss

  • Hero Member
  • *****
  • Beiträge: 1743
Hatte ich ja selbst schon angezweifelt. Zweifel bestätigt.
FHEM auf Raspberry Pi B und 2B; THZ (THZ-303SOL), CUL_HM, TCM-EnOcean, SamsungTV, JSONMETER, SYSMON, OBIS, STATISTICS, CO20, FHEM2FHEM

Offline TheTrumpeter

  • Sr. Member
  • ****
  • Beiträge: 646
Abgesehen davon wäre es so oder so ein Bug... die Anlage weiss ja, wann EVU-Sperre ist & darf in der Zeit eben nicht heizen.

Übrigens ist meine Heizung nach dem Reset heute um 10:30 erst um 18:00 angesprungen.
Beim Reset war das Integral schon bei -100 (von 150), d.h. beim Weiterlaufen wäre der Verdichter wohl um 11:00 angesprungen. Und selbst wenn die Pumpe dann plötzlich wieder "normal" weitergelaufen wäre, wäre es um ca. 13:00 soweit gewesen.
« Letzte Änderung: 22 Januar 2017, 22:16:21 von TheTrumpeter »
FHEM auf RPi3, THZ (LWZ404SOL), RPII2C & I2C_MCP342x (ADCPiZero), PowerMap, CustomReadings, RPI_GPIO, Twilight, nanoCUL (WMBus für Diehl Wasserzähler & Regenerationszähler für BWT AqaSmart)

Offline willybauss

  • Hero Member
  • *****
  • Beiträge: 1743
Abgesehen davon wäre es so oder so ein Bug... die Anlage weiss ja, wann EVU-Sperre ist & darf in der Zeit eben nicht heizen.
Richtig. Außerdem wäre dann der Wert von EVU-Release in sGlobal falsch. Der sagt nichts von Abschaltung.
FHEM auf Raspberry Pi B und 2B; THZ (THZ-303SOL), CUL_HM, TCM-EnOcean, SamsungTV, JSONMETER, SYSMON, OBIS, STATISTICS, CO20, FHEM2FHEM

Offline TheTrumpeter

  • Sr. Member
  • ****
  • Beiträge: 646
Hatte heute Nacht kurz nach Mitternacht erneut einen auffälligen Pumpenlauf... Pumpe ist für ca. 1h durchgelaufen und hat sich dann wieder abgedreht. Dann hat der "normale Pumpenzyklus" wieder begonnen. Die Stunde Dauerlauf hat das Integral gut gefüllt, sodass nach einem weiteren Zyklus die Heizung auch schon angesprungen ist.

Bei  mir treten die Dauerläufe quer verteilt über den Tag auf, d.h. selbst wenn es irgendein EVU-Bug wäre, kann er keinesfalls alle Pumpenläufe erklären. Die Aussentemperatur war zu dem Zeitpunkt übrigens auch stabil, genau wie die Innentemperatur (die wg. Raumeinfluss 0 aber ohnehin keine Bedeutung hat). Auch Heizkreis-Solltemperatur war seit über 12h stabil.


Hat hier jemand vor mal Kontakt mit SE aufzunehmen und nach der Pumpenlogik zu fragen?

Selbst wenn z.B. ein Interpolationsfehler in der Berechnung der aussentemperaturabhängigen Pumpenzyklen auftreten würde, dürfte das doch nicht zum Dauerlauf führen? Ausser natürlich, der Fehler führt zu einem Wert >=288, denn dann sollte die Pumpe in Intervallen <5min für 5min laufen, also praktisch dauerhaft.
Für die Berechnung ist ausschliesslich die Aussentemperatur verantwortlich, d.h. da könnte natürlich Kleinständerungen den Ausschlag geben.

Um das zu prüfen, könnte man P54 und P55 auf identische Werte (den von P55) setzen. Wenn es dann immer noch auftritt, ist der Interpolationsfehler meiner Meinung nach praktisch ausgeschlossen. (Bei den aktuellen Aussentemperaturen hätte das auch gar keine Auswirkung auf die Soll-Zyklen, da P56 aktuell wohl bei jedem über der aktuellen Aussentemperatur liegt...)

Als nächsten Schritt könnte man noch P56 auf eine extrem tiefe Temperatur, z.B. -20°C setzen. Dann würde sich die Berechnung immer innerhalb der Temperaturspanne P56 und P57 befinden.


EDIT: Werde heute Abend in den Debug-Dumps mal versuchen, ob ich da "48" (meine aktuellen Soll-Zyklen) finde. Vielleicht steht der Wert ja irgendwo und man könnte dann leicht prüfen, ob meine Interpolationsfehler-Theorie Substanz hat. (Theoretisch könnte natürlich auch "30min" oder der Wert in Sekunden oder sonsteiner Zeit-Einheit abgelegt sein...)
« Letzte Änderung: 23 Januar 2017, 07:00:14 von TheTrumpeter »
FHEM auf RPi3, THZ (LWZ404SOL), RPII2C & I2C_MCP342x (ADCPiZero), PowerMap, CustomReadings, RPI_GPIO, Twilight, nanoCUL (WMBus für Diehl Wasserzähler & Regenerationszähler für BWT AqaSmart)