Autor Thema: THZ Tecalor (LWZ Stiebel Eltron) Wärmepumpe -Optimierung und Erfahrungsaustausch  (Gelesen 301374 mal)

Offline willybauss

  • Hero Member
  • *****
  • Beiträge: 1643
Der Plot macht eine eigene Interpolation. Für genaue Werte einfach ins Logfile schauen nach den tatsächlichen Werten.

Ich habe Peaks bei jedem Pumpenanlauf zu Nicht-Heizzeiten gesehen. Den Rest muss ich mir nochmal in der Historie anschauen. Dummerweise sind die alten Plots alle im Cache und der Cache beinhalter den Plot_2 ohne zusätzliche x-Werte. Entweder ich muss den Cache leeren, um x60 zu sehen, oder ich baue tatsächlich für die x-Werte einen eigenen Plot. Wäre wahrscheinlich das beste.

Zusammenhänge zu anderen x-Werten konnte ich nicht erkennen. Aber wie gesagt: ich werde mit den Debug-Plot für alle unerklärten Werte bauen, dann schau' mer mal.

Evtl. würde mir auch ein Reset helfen, aber ich will erst sehen, wie sich das heute entwickelt. Heute Nacht ab 1 Uhr stieg (!) die Außentemperatur von -12 auf -6°. Ich will sehen, ob das Thema sich dadurch von alleine löst.
FHEM auf Raspberry Pi B und 2B; THZ (THZ-303SOL), CUL_HM, TCM-EnOcean, SamsungTV, JSONMETER, SYSMON, OBIS, STATISTICS, CO20, FHEM2FHEM

Offline TheTrumpeter

  • Sr. Member
  • ****
  • Beiträge: 551
Dummerweise sind die alten Plots alle im Cache und der Cache beinhalter den Plot_2 ohne zusätzliche x-Werte. Entweder ich muss den Cache leeren, um x60 zu sehen, oder ich baue tatsächlich für die x-Werte einen eigenen Plot. Wäre wahrscheinlich das beste.
Genau deshalb habe ich einen neuen Plot angelegt.

Zusammenhänge zu anderen x-Werten konnte ich nicht erkennen. Aber wie gesagt: ich werde mit den Debug-Plot für alle unerklärten Werte bauen, dann schau' mer mal.
Sehe ich auch nicht, habe die gestern alle durchgeschaut und ausgeschlossen, aber leider nicht für alle der x-Werte meine Anmerkungen notiert. Hier trotzdem, was ich habe:
DHW x20: sieht aus „wie HK-Pumpe“, wahrscheinlich keine Relevanz hier
DHW x36: stetig steigend, wahrscheinlich keine Relevanz hier
HC1 x64: konstant 691,2, wahrscheinlich keine Relevanz hier
HC1 x72: springt bei Heizbeginn auf und ab, danach konstant 0, wahrscheinlich keine Relevanz hier
HC1 x76: sieht aus wie „Verdichter ein für Heizbetrieb“, wahrscheinlich keine Relevanz hier

Evtl. würde mir auch ein Reset helfen, aber ich will erst sehen, wie sich das heute entwickelt. Heute Nacht ab 1 Uhr stieg (!) die Außentemperatur von -12 auf -6°. Ich will sehen, ob das Thema sich dadurch von alleine löst.
Mittlerweile hatte ich wieder einen Pumpendauerlauf. Leider habe ich den zu spät gesehen, sodass ich den Integralwert nicht mehr hochsetzen konnte, bevor es volllief. Daher weiss ich nicht, ob er wieder nach 1h aufgehört hätte, weil die Heizung vorher anspring.
Zumindest ist jetzt schonmal klar, dass der falsche EVU-Wert keinen Einfluss auf das Thema hat.
FHEM auf RPi3, THZ (LWZ404SOL), RPII2C & I2C_MCP342x (ADCPiZero), PowerMap, CustomReadings, RPI_GPIO, Twilight, nanoCUL (WMBus für Diehl Wasserzähler & Regenerationszähler für BWT AqaSmart)

Offline friesenjung

  • Full Member
  • ***
  • Beiträge: 240
...

Da hilft nur weiter beobachten... wäre super, wenn noch weitere User auf diese Pumpenläufe achten könnten, aber ausser uns dreien (Du, awex102 und ich) scheint das niemand zu haben bzw. sich niemand dazu zu äussern?

Hallo Zusammen,
meint Ihr sowas wie bei angehangenem Plot gegen 20:00?
(die Plotdarstellung zw. 21:00-22:00 könnt Ihr ignorieren, da fehlen Log-Daten wegen Datenbankproblem)

VG...
FHEM auf Raspi 2,  Jeelink-Clone 1x für PCA301 und 1x für Lacrosse, THZ304SOL, Homematic: CUL_HM / M-MOD-RPI-PCB, Pushover, Xiaomi s50

Offline awex102

  • Jr. Member
  • **
  • Beiträge: 91
Ja, genau das ist das Verhalten.

Offline friesenjung

  • Full Member
  • ***
  • Beiträge: 240
Bedeutet also 19:40 geht Kompressor, 20:07 "krätscht" WW dazwischen. Ansonsten wäre es nach aktueller Theorie weitergelaufen, bis etwa 1h voll gewesen wäre, richtig?

Habe übrigens THZ304SOL (SOL nicht angeschlossen), FW5.19, 1 HK mit hydraulische Weiche (also1x HK-Pumpe in der THZ, 1x außerhalb nach der hydr. Weiche, laufen synchron)

VG...
FHEM auf Raspi 2,  Jeelink-Clone 1x für PCA301 und 1x für Lacrosse, THZ304SOL, Homematic: CUL_HM / M-MOD-RPI-PCB, Pushover, Xiaomi s50

Offline awex102

  • Jr. Member
  • **
  • Beiträge: 91
Echt unglücklich. Habe mir ein VPN eingerichtet und sehe nun das die Pumpe wieder läuft. Integral rauscht zeitgleich in den Keller. Und ich kann hier immer  feststellen, dass ein Full Dump aller Werte ausgelöst wird (alle readings werden neu gelesen) mehr oder minder um den Zeitpunkt der Pumpenaktivierung.

Offline awex102

  • Jr. Member
  • **
  • Beiträge: 91
Bedeutet also 19:40 geht Kompressor, 20:07 "krätscht" WW dazwischen. Ansonsten wäre es nach aktueller Theorie weitergelaufen, bis etwa 1h voll gewesen wäre, richtig?

Habe übrigens THZ304SOL (SOL nicht angeschlossen), FW5.19, 1 HK mit hydraulische Weiche (also1x HK-Pumpe in der THZ, 1x außerhalb nach der hydr. Weiche, laufen synchron)

VG...

Zumindest ist es bei mir wie bei dir.

Mal ne andere Frage: Habe das gleiche Setup mit hydraulischer Weiche (THZ 403 SOL (nicht angeschlossen). Hast du den Volumenstrom der zwei Pumpen, die syncron laufen, irgendwie vernünftig und messbar abgleichen können?

Offline friesenjung

  • Full Member
  • ***
  • Beiträge: 240
Zumindest ist es bei mir wie bei dir.

Mal ne andere Frage: Habe das gleiche Setup mit hydraulischer Weiche (THZ 403 SOL (nicht angeschlossen). Hast du den Volumenstrom der zwei Pumpen, die syncron laufen, irgendwie vernünftig und messbar abgleichen können?
da hab ich selbst nichts eingestellt bzw. verändert. ist noch so wie vom Heizungsbauer eingestellt. Interne HK-Pumpe ist bei mir auf 70%
VG...
FHEM auf Raspi 2,  Jeelink-Clone 1x für PCA301 und 1x für Lacrosse, THZ304SOL, Homematic: CUL_HM / M-MOD-RPI-PCB, Pushover, Xiaomi s50

Offline awex102

  • Jr. Member
  • **
  • Beiträge: 91

Mittlerweile hatte ich wieder einen Pumpendauerlauf. Leider habe ich den zu spät gesehen, sodass ich den Integralwert nicht mehr hochsetzen konnte, bevor es volllief. Daher weiss ich nicht, ob er wieder nach 1h aufgehört hätte, weil die Heizung vorher anspring.
Zumindest ist jetzt schonmal klar, dass der falsche EVU-Wert keinen Einfluss auf das Thema hat.

Heute Vormittag: Vor der Heizphase GENAU eine Stunde Pumpenlauf, Integral auf -150 in dieser Zeit und dann dadurch Start Heizphase.

Offline TheTrumpeter

  • Sr. Member
  • ****
  • Beiträge: 551
Bedeutet also 19:40 geht Kompressor, 20:07 "krätscht" WW dazwischen. Ansonsten wäre es nach aktueller Theorie weitergelaufen, bis etwa 1h voll gewesen wäre, richtig?
Genau, 19:40 ist die Heizphase aus und die Heizkreispumpe sollte auch ausgehen. Die läuft aber weiter und wäre nach meiner Theorie genau 1h weitergelaufen, danach hätten die normalen Zyklen gemäss Zyklenanzahl/Tag laufen sollen. Wäre innerhalb dieser 1h das Integral vollgelaufen, wäre die Heizung wieder angegangen.
Du kannst meine Plots aus folgendem Beitrag durchschauen, da habe ich die Ereignisse auch entsprechend beschrieben. https://forum.fhem.de/index.php/topic,33452.msg566688.html#msg566688

Es kommt also aus meiner Sicht zu einem Heizkreispumpen-Dauerlauf, der genau 1h dauert, Ursache dafür ist noch unbekannt.
Läuft innerhalb dieser 1h das Integral voll oder wird Hysterese1 erreicht, beginnt während dieser 1h die Heizphase und man sieht daher nicht, wie lange die Pumpe gelaufen wäre. Ich hatte aber noch keinen Fall, wo die Pumpe länger als 1h durchgelaufen ist.
Am Ende der Heizphase ist entweder "alles normal" oder die Heizkreispumpe läuft für (genau) 1h nach.
Der Start dieses 1h-Dauerlaufs scheint "zufällig" zu passieren, d.h. er hält sich nicht an das durch die Zyklusanzahl vorgegebene Zeitintervall. Nach dem Dauerlauf scheint aber das Intervall neu zu starten, d.h. genau 30min später (bei 48 Zyklen) startet der nächste Pumpenlauf.
Nach einer Heizphase startet der Dauerlauf bei mir oft nach 2 oder 3 normalen Zyklen, ich habe aber auch Fälle mit 4 oder 5, und natürlich Phasen zwischen zwei Heizzyklen, die "normal" ausschauen.

Wenn ich mich nicht irre, habe ich auch schon in meinen Plots einen Fall gesehen, wo diese 1h wie bei Dir von einer WW-Phase unterbrochen und danach wieder fortgesetzt wurde, weil wie WW-Phase sehr kurz war und die 1h seit dem ersten Pumpenstart noch nicht abgelaufen waren. Danach müsste ich aber nochmal suchen.
FHEM auf RPi3, THZ (LWZ404SOL), RPII2C & I2C_MCP342x (ADCPiZero), PowerMap, CustomReadings, RPI_GPIO, Twilight, nanoCUL (WMBus für Diehl Wasserzähler & Regenerationszähler für BWT AqaSmart)

Offline willybauss

  • Hero Member
  • *****
  • Beiträge: 1643
Ich will euren Elan nicht bremsen, aber seid euch bewusst, dass dieses Problem nicht wirklich zu erhöhten Heizkosten führt, zumindest dann, wenn ihr einen Innentemperaturfühler habt. Der Pumpenlauf führt lediglich dazu, dass ein Heizzyklus (der ohnehin gekommen wäre) eben früher stattfindet. Ihr werdet wegen der etwas früher ins Haus eingebrachten Heizenergie von ca. 3 - 4 kWh keine messbare Temperaturerhöhung im Haus feststellen, und wenn doch, dann wird der Raumtemperaturfühler dafür sorgen, dass der nächste Heizzyklus eben etwas später kommt. Irgendwo muss die gewonnene Energie ja hin; sie wird nicht "versickern", nur weil sie zur Unzeit generiert wurde.

Viel ungünstiger ist da mein Phänomen, bei dem der Verdichter abschaltet und der Heizstab weiter läuft. Hier wird tatsächlich auf den Wirkungsgrad Faktor 3,5:1 verzichtet und statt dessen 1:1 geheizt. Aber auch das dürfte sich bisher auf nicht mehr als ca. 2 - 3€ in diesem Winter summiert haben.
FHEM auf Raspberry Pi B und 2B; THZ (THZ-303SOL), CUL_HM, TCM-EnOcean, SamsungTV, JSONMETER, SYSMON, OBIS, STATISTICS, CO20, FHEM2FHEM

Offline TheTrumpeter

  • Sr. Member
  • ****
  • Beiträge: 551
Ich will euren Elan nicht bremsen, aber seid euch bewusst, dass dieses Problem nicht wirklich zu erhöhten Heizkosten führt, zumindest dann, wenn ihr einen Innentemperaturfühler habt. Der Pumpenlauf führt lediglich dazu, dass ein Heizzyklus (der ohnehin gekommen wäre) eben früher stattfindet. Ihr werdet wegen der etwas früher ins Haus eingebrachten Heizenergie von ca. 3 - 4 kWh keine messbare Temperaturerhöhung im Haus feststellen, und wenn doch, dann wird der Raumtemperaturfühler dafür sorgen, dass der nächste Heizzyklus eben etwas später kommt. Irgendwo muss die gewonnene Energie ja hin; sie wird nicht "versickern", nur weil sie zur Unzeit generiert wurde.
Im Wesentlichen stimme ich Dir da zu.
Im Detail betrachtet gilt das aber nur unter mehreren Randbedingungen:
1. Dauerlauf findet "sporadisch" und spät statt, d.h. nicht relativ bald nach den Heizzyklen und vor allem nicht nach jedem Heizzyklus
2. Integralanteil und Hysterese1 bzw. Assymetrie sind so eingestellt, dass ein "Pumpennachlauf" nicht direkt wieder den Verdichter startet & dieser auch nicht gleich wieder ausgeht.
3. Raumanteil ist hinreichend hoch

Ist 1. nicht gegeben, werden die Abstände zwischen den Heizzyklen permanent verkürzt. (So ein Dauerlauf 2h nach Ende eines Heizzyklusses führt bei mir praktisch immer zum Volllaufen der -150kmin. Ohne Dauerlauf würde es 6-8h dauern, bis die Hysterese1 erreichtist.) Natürlich werden die Heizzyklen auch immer kürzer, weil der Integralanteil schneller erreicht wird. Insgesamt wird aber sicher mehr Wärmeenergie eingebracht.
Ist 2. nicht gegeben, führt ein Pumpennachlauf direkt wieder zum Einschalten des Verdichters, der darauffolgende Heizzyklus ist extrem kurz. Folgt dann gleich wieder ein Pumpennachlauf, beginnt das Spiel von vorne. (Ich meine, dass das meinen "Pumpendauerlauf" Anfang Jänner erklärt. Damals hatte ich noch 100kmin und Assymetrie 2 eingestellt.) Auch hier meine ich, dass insgesamt mehr Wärmeenergie eingebracht wird.
Ist 3. nicht gegeben, resultiert die zusätzliche Wärmeenergie in einer Raumtemperaturerhöhung.

Bei häufigem Auftreten der Pumpenläufe kommt es aber mindestens zu einer höheren Anzahl an Kaltstarts, was wir ja eigentlich vermeiden wollen.

Ich bin mittlerweile eher der Meinung, dass es sich dabei eher um ein "undokumentiertes Feature" als um einen Bug handelt. Einzig die Auslösebedingung ist noch unbekannt. Als Techniker möchte ich im ersten Schritt einfach nur verstehen, was diese Auslösebedingung ist. Eine einfache Beantwortung mittels Anruf bei SE wurde hier ja schon mehrfach angezweifelt und halte ich aufgrund meiner bisherigen Erfahrung mit denen auch für unwahrscheinlich. Entsprechend will ich versuchen noch ein bisschen mehr darüber zu verstehen, bevor ich doch versuche bei SE die gewünschten Antworten zu erhalten.

Viel ungünstiger ist da mein Phänomen, bei dem der Verdichter abschaltet und der Heizstab weiter läuft. Hier wird tatsächlich auf den Wirkungsgrad Faktor 3,5:1 verzichtet und statt dessen 1:1 geheizt. Aber auch das dürfte sich bisher auf nicht mehr als ca. 2 - 3€ in diesem Winter summiert haben.
Da stimme ich Dir absolut zu.
Allerdings kann ich diesbezüglich mangels eigener Beobachtungsmöglichkeit (Heizstab wg. Bivalenzpunkt -15°C de facto deaktiviert) nichts beitragen.
FHEM auf RPi3, THZ (LWZ404SOL), RPII2C & I2C_MCP342x (ADCPiZero), PowerMap, CustomReadings, RPI_GPIO, Twilight, nanoCUL (WMBus für Diehl Wasserzähler & Regenerationszähler für BWT AqaSmart)

Offline awex102

  • Jr. Member
  • **
  • Beiträge: 91
Guen Morgen,

hier nochmal meine Plots von heute Nacht (Integral jetzt auf 150 aber Hyst. auf 3 und Asym. auf ). Wieder eine Stunde nachlauf der Pumpe.

Dann noch mein Chaostag gestern. Kam alles zusammen:

Pumpenläufe vor und nach Heizphase
Wieder Abbruch der Heizphase durch WW Bereitung
Dauerabbruch der Verbindung (ok, dass kann ja auch an fhem liegen, aber im Chart gestern sieht man recht schön, dass die Verbindung genau dann abzubrechen scheint, wenn der verlängerte Pumpenlauf endet, kann aber auch "Zufall" sein)

Das Nachlaufen der Pumpe sorgt halt für ein maximal schnelles Volllaufen des Integrals, die Unterbrechung der Heizphase hat einen relativ starken Einfluss auf die Raumtemp.

Frage mich warum das jetzt wieder losgeht mit der WW Bereitung in Heizphasen und dem Abbruch der Heizphase.
« Letzte Änderung: 25 Januar 2017, 08:08:04 von awex102 »

Offline willybauss

  • Hero Member
  • *****
  • Beiträge: 1643
@Trumpeter:
Hast Du schon mal gecheckt, ob die Hysteresewerte zuverlässig passen? Die sollten entsprechend des Integralwertverlaufs zu- bzw. abnehmen.
sHC1: onHysteresisNo bzw. offHysteresisNo

@awex:
schon mal den fhem Server gecheckt? Evtl. läuft der mit sehr viel Last. Dafür gibt es ebenfalls fhem-Module.
FHEM auf Raspberry Pi B und 2B; THZ (THZ-303SOL), CUL_HM, TCM-EnOcean, SamsungTV, JSONMETER, SYSMON, OBIS, STATISTICS, CO20, FHEM2FHEM

Offline willybauss

  • Hero Member
  • *****
  • Beiträge: 1643
Ich glaube, ich habe gerade eine Möglichkeit gefunden, um die "Heizstab-ohne-Verdichter" Heizzyklen vorzeitig zu beenden. Ich habe einfach den Integralwert p30 von 200 auf 20 umgesetzt - das kann ich auch unterwegs per Handy. Innerhalb weniger Minuten war das Integral voll und der Heizstab hat sich sofort aus- und dafür den Verdichter eingeschaltet.

Evtl. hilft das ja auch bei den unnötigen Pumpenläufen. Ihr könnt's ja mal testen.
FHEM auf Raspberry Pi B und 2B; THZ (THZ-303SOL), CUL_HM, TCM-EnOcean, SamsungTV, JSONMETER, SYSMON, OBIS, STATISTICS, CO20, FHEM2FHEM