Autor Thema: THZ Tecalor (LWZ Stiebel Eltron) Wärmepumpe -Optimierung und Erfahrungsaustausch  (Gelesen 391095 mal)

Offline immi

  • Developer
  • Sr. Member
  • ****
  • Beiträge: 963
Hab seit heute folgenden Fehler:
Messages collected while initializing FHEM:
configfile: Cannot load module THZ
Keine Verbindung mehr zur THZ, obwohl ich außer einem Update uund ein paar Logfiles löschen nichts gemacht habe...
In logfile stehet das Du THZ nicht laden kannst.
existiert noch  in deinem filesystem den File 00_THZ.pm?
# ls -l /opt/fhem/FHEM/00_THZ.pm
-rw-r-----    **********  143325 Sep 24 23:56 /opt/fhem/FHEM/00_THZ.pm

probiere mit
update THZ
shutdown restart

Offline Stonemuc

  • Full Member
  • ***
  • Beiträge: 353
    • Baublog WeberHaus Citylife 500
Irgendwie hatte es die 00_THZ.pm  zerschossen - ich habe sie gelöscht und mit update neu eingespielt - ein normales Update brachte nichts.
Ich bin heute beim Umräumen im Technikraum irgendwie an den Netzstecker des Raspi gekommen und habe ihn durch Wackler mehrfach gelöst gehabt und dann wieder angesteckt.
Alexa-Fhem ist auch betroffen - angeblich nicht installiert, obwohl alled da ist.

Das THZ Modul hab ich wieder hinbekommen - alexa schau ich mir morgen an - ich installier es einfach nochmal drüber und füge die config dann wieder ein.

Ich schätze, dass ich da irgendwas bei der Aktion zerschossen habe, bin ja froh, dass alles andere läuft. Ich glaub ich muss mir mal langsam ein Backup Image meiner SD Card ziehen...
« Letzte Änderung: 25 September 2019, 00:31:00 von Stonemuc »
FHEM aus Raspberry PI 3 B+, Haussteuerung auf EnOcean Basis, Tecalor THZ 404eco Wärmepumpe

Offline TheTrumpeter

  • Sr. Member
  • ****
  • Beiträge: 635
Mal wieder was anderes...

Ich beobachte seit ca. dem Ende der letzten Heizsaison, dass die Drehzahlen von Zu- und Ablüfter kontinuierlich steigen, obwohl sich an den sonstigen Randbedingungen nichts geändert hat. Mittlerweile läuft der Zulüfter mit ca. 10% höherer Geschwindigkeit als vor einem halben Jahr, trotz ganz neuem Filter.

Die Filter sind neu/sauber & auch sonst gibt es im Ansaugbereich keinerlei Gründe für den Drehzahlanstieg.

Der Wärmetauscher kann ja eigentlich nicht verdreckt sein (F7-Filter in der Zuluft, G4 in der Abluft), oder?

Woran könnte es sonst noch liegen?
FHEM auf RPi3, THZ (LWZ404SOL), RPII2C & I2C_MCP342x (ADCPiZero), PowerMap, CustomReadings, RPI_GPIO, Twilight, nanoCUL (WMBus für Diehl Wasserzähler & Regenerationszähler für BWT AqaSmart)

Offline Stonemuc

  • Full Member
  • ***
  • Beiträge: 353
    • Baublog WeberHaus Citylife 500
Seit wann hast du den F7? Der ist ja recht "dicht" da muss der Lüfter natürlich mehr drehen um die Luftmenge zu erreichen, denke ich. Oder hattest du vorher auch den F7? Ich hab aktuell noch überall G4 drinnen, bis meine Matte aufgebraucht ist. Aber da sammelt sich echt viel an, mit den ganzen Baustellen rundum. Was ich da neulich rausgesaugt habe...
FHEM aus Raspberry PI 3 B+, Haussteuerung auf EnOcean Basis, Tecalor THZ 404eco Wärmepumpe

Offline willybauss

  • Hero Member
  • *****
  • Beiträge: 1735
Bei meiner alten 303 muss lt. Handbuch nach dem Filterwechsel ein Reste gemacht werden, damit die Anlage die Durchflussmengen neu "anlernt". Evtl. würde das auch bei dir helfen.

Alternativ: Bist Du sicher, dass alle Filter gewechselt wurden? Bei mir erfolgt die Luftansaugung hinten über den EWT-Anschluss. Es wurde aber bei der Installation nicht bedacht, dass dort ein Wärmetauscher ist, um die Frischluft anzuwärmen. Der war bei mir nach 1 Jahr komplett dicht. Ich habe dann außerhalb des Hauses direkt an der Luftansaug-Öffnung einen Hütchenfilter nachgerüstet, der ebenfalls regelmäßig gewechselt werden muss.
FHEM auf Raspberry Pi B und 2B; THZ (THZ-303SOL), CUL_HM, TCM-EnOcean, SamsungTV, JSONMETER, SYSMON, OBIS, STATISTICS, CO20, FHEM2FHEM

Offline TheTrumpeter

  • Sr. Member
  • ****
  • Beiträge: 635
Seit wann hast du den F7? Der ist ja recht "dicht" da muss der Lüfter natürlich mehr drehen um die Luftmenge zu erreichen, denke ich. Oder hattest du vorher auch den F7?
Ja, schon ewig, sogar gleicher Hersteller und gleiche Charge  ;)

Bei meiner alten 303 muss lt. Handbuch nach dem Filterwechsel ein Reste gemacht werden, damit die Anlage die Durchflussmengen neu "anlernt". Evtl. würde das auch bei dir helfen.
Klar, "Reset Filter" am Bedienteil im Menü "Lüftung - Service". Ändert nix, was meine Vermutung stärkt, dass die Filter nicht dicht waren.

Alternativ: Bist Du sicher, dass alle Filter gewechselt wurden? Bei mir erfolgt die Luftansaugung hinten über den EWT-Anschluss.
Klar, den versteckten da hinten reinige ich auch regelmässig; auch an dem liegt's leider nicht.
FHEM auf RPi3, THZ (LWZ404SOL), RPII2C & I2C_MCP342x (ADCPiZero), PowerMap, CustomReadings, RPI_GPIO, Twilight, nanoCUL (WMBus für Diehl Wasserzähler & Regenerationszähler für BWT AqaSmart)

Offline willybauss

  • Hero Member
  • *****
  • Beiträge: 1735
Dann fällt mir grade auch nichts mehr ein. Evtl. mal beim Tecalor-Service fragen, ob die noch ne Idee haben.
FHEM auf Raspberry Pi B und 2B; THZ (THZ-303SOL), CUL_HM, TCM-EnOcean, SamsungTV, JSONMETER, SYSMON, OBIS, STATISTICS, CO20, FHEM2FHEM

Offline TheTrumpeter

  • Sr. Member
  • ****
  • Beiträge: 635
Kurzer Zwischenstatus...

Habe am Wochenende mal die Luftbefeuchtungseinheit geöffnet und inspiziert... hat drin zwar anders ausgeschaut als erwartet, für erhöhten Luftwiderstand seit Ende der Heizperiode kann das aber nicht verantwortlich gewesen sein.

Den WT der LWZ werde ich voraussichtlich am kommenden Wochenende mal "angehen".
FHEM auf RPi3, THZ (LWZ404SOL), RPII2C & I2C_MCP342x (ADCPiZero), PowerMap, CustomReadings, RPI_GPIO, Twilight, nanoCUL (WMBus für Diehl Wasserzähler & Regenerationszähler für BWT AqaSmart)

Offline celle

  • New Member
  • *
  • Beiträge: 5
Ich habe eine THZ 5.5 Flex. Die scheint prinzipiell wie eine THZ 5.5 angesprochen zu werden. Hat damit schon wer Erfahrungen. Da ich den Integralwert nicht auslesen kann sind mir die Heizzyklen schleierhaft. Ich habe versucht mir das Integral selbst zu bauen über ein Custum Reading, jedoch hilft das nicht wirklich. Die hysteresen scheinen auch nicht wirklich erreicht zu werden, da scheinbar schon etwas wie ein Integral zieht. Das ändern des Integralparameters scheint auch nicht zu wirken. Die Pumpzyklen scheinen auch nicht immer zu ziehen. Manchmal macht er das was konfiguriert ist, manchmal nicht.

Alles in allem ist es schon etwas mysteriös. Hat wer ähnliches beobachtet?

Offline immi

  • Developer
  • Sr. Member
  • ****
  • Beiträge: 963
Hallo Celle
Wilkommen in Forum.
Schön dass Du Dein Tecalor via THZ-FHEM ansprechen kann.
>>Ich habe versucht mir das Integral selbst zu bauen über ein Custum Reading, jedoch hilft das nicht wirklich
Teile mit uns config-file logs und dein code für custom-reading.
immi

Offline celle

  • New Member
  • *
  • Beiträge: 5
Hallo,

hier meine Userreadings:

attr Mythz userReadings
AussenTemp {(split ' ',ReadingsVal("Mythz","sGlobal",0))[1]},
VorlaufTemp {(split ' ',ReadingsVal("Mythz","sGlobal",0))[3]},
RuecklaufTemp {(split ' ',ReadingsVal("Mythz","sGlobal",0))[5]},
WWTemp {(split ' ',ReadingsVal("Mythz","sGlobal",0))[9]},
HC1_Soll {(split ' ',ReadingsVal("Mythz","sHC1",0))[11]},
HC1_Ist {(split ' ',ReadingsVal("Mythz","sHC1",0))[13]},
HC1_diff {if ((split ' ',ReadingsVal("Mythz","sGlobal",0))[27] eq 1 and ((split ' ',ReadingsVal("Mythz","sHC1",0))[13] - (split ' ',ReadingsVal("Mythz","sHC1",0))[11]) < 4){(split ' ',ReadingsVal("Mythz","sHC1",0))[13] - (split ' ',ReadingsVal("Mythz","sHC1",0))[11]} else {0}},
HC1_diff_integral integral {ReadingsVal("Mythz", "HC1_diff", 0)/60}

HC1_diff gibt die Regelabweichung an, wenn die Heizkreispumpe läuft. Kurz nach dem Warmwasserzyklus ist der Wert kurzzeitig falsch. Deswegen nehme ich den Wert nur, wenn die Differenz kleiner 4 ist.
Ein Problem habe ich mit dem Zurücksetzen des Integrals. Wann wird das denn zurückgesetzt?

Hier noch die Settings von sonst, die teilweise scheinbar nicht wirklich ziehen:

p01RoomTempDayHC1 23 °C
p02RoomTempNightHC1 22 °C
programHC1_Mo-So_0 10:00--21:00
p13GradientHC1 0.25
p14LowEndHC1 0 K
p21Hyst1 4 K
p22Hyst2 3 K
p23Hyst3 3 K
p24Hyst4 2 K
p25Hyst5 2 K
p29HystAsymmetry 2
p30integralComponent 100 Kmin

zum testen habe ich jetzt mal sicheren Pumpendauerlauf gemacht:

p54MinPumpCycles 1
p55MaxPumpCycles 288
p56OutTempMaxPumpCycles 19 °C
p57OutTempMinPumpCycles 20 °C

« Letzte Änderung: 02 Oktober 2019, 12:28:08 von celle »

Offline TheTrumpeter

  • Sr. Member
  • ****
  • Beiträge: 635
p21Hyst1 4 K
p22Hyst2 3 K
p23Hyst3 3 K
p24Hyst4 2 K
p25Hyst5 2 K
p29HystAsymmetry 2
p30integralComponent 100 Kmin
Ich weiss nicht wie die 5.5 arbeitet bzw. was der Unterschied zu den hier bekannten 30x/40x ist. Für letztere wären p29 und p30 eher suboptimal eingestellt.
FHEM auf RPi3, THZ (LWZ404SOL), RPII2C & I2C_MCP342x (ADCPiZero), PowerMap, CustomReadings, RPI_GPIO, Twilight, nanoCUL (WMBus für Diehl Wasserzähler & Regenerationszähler für BWT AqaSmart)

Offline BigNose82

  • Full Member
  • ***
  • Beiträge: 359
Wozu sollte eine modulierende Anlage mit Hysteresen rumhampeln?
LWZ 304 Trend - Hausautomatisierung über z-wave mit dem Fibaro HC2

Offline celle

  • New Member
  • *
  • Beiträge: 5
Ich hatte p29 und p30 geändert. Die Wirkung war nicht zu sehen.

Zu dem Thema modulierende Anlage. Ja das ist ein Vorteil der THZ 5.5. Aber in der Übergangszeit schaltet sie trotzdem an und aus, da die minimale Leistung auch zu viel ist.

Offline BigNose82

  • Full Member
  • ***
  • Beiträge: 359
Schau dir doch zunächst mal die technischen Unterlagen deiner Anlage an, bevor du dich wunderst, dass eine Software, die im reverse engineering an einer Anlage der zweiten Vorgängerversion entwickelt wurde, nicht die Ergebnisse liefert, die du erwartest.
LWZ 304 Trend - Hausautomatisierung über z-wave mit dem Fibaro HC2

 

decade-submarginal