Autor Thema: FHEM-Dienst stürzt mit Fehlermeldung ab  (Gelesen 2235 mal)

Offline Nobby1805

  • Sr. Member
  • ****
  • Beiträge: 692
FHEM-Dienst stürzt mit Fehlermeldung ab
« am: 08 Februar 2015, 11:45:54 »
Hallo Forum,

seit Anfang des Jahres beschäftige ich mich mit HomeMatic und FHEM. Seit der letzten Änderung der Konfiguration bekomme ich Timeouts vom HMLAN und auch regelmäßige Abstürze mit dem Fehlercode 0xc0000008. Bei der letzten Änderung habe ich einen "Schaltaktor mit Leistungsmessung" hinzugefügt und die vorher vorhandenen Devices umbenannt und insgesamt etwas umstrukturiert.

FHEM ist bei mir auf einem Windows Server 2003 R2 (HomeServer v1) installiert, ich verwende Strawberry Perl 5.18.4.1 - 32bit und FHEM wird als Dienst gestartet.

Im DrWatson finde ich folgenden Hinweis
Funktion: ntdll!RtlIpv4StringToAddressExW
        7c96ce3b 008b55f868e8     add     [ebx+0xe868f855],cl
        7c96ce41 ce               into
        7c96ce42 96               xchg    eax,esi
        7c96ce43 7c89            jl ntdll!RtlIpv4StringToAddressExW+0xb608 (7c96cdce)
        7c96ce45 55               push    ebp
        7c96ce46 f0e8b5b0fbff     lock    call ntdll!DbgPrint (7c927f01)
        7c96ce4c 83c404           add     esp,0x4
        7c96ce4f e93402ffff       jmp     ntdll!RtlLockHeap+0x1e3 (7c95d088)
        7c96ce54 50               push    eax
        7c96ce55 e888b6fdff       call    ntdll!RtlRaiseStatus (7c9484e2)
FEHLER ->7c96ce5a cc               int     3
        7c96ce5b 90               nop
        7c96ce5c 90               nop
        7c96ce5d 90               nop
        7c96ce5e 90               nop
        7c96ce5f 90               nop
        7c96ce60 52               push    edx
        7c96ce61 54               push    esp
        7c96ce62 4c               dec     esp
        7c96ce63 3a20             cmp     ah,[eax]
        7c96ce65 45               inc     ebp
und im FHEM-Log steht zu diesem Zeitpunkt
Zitat
2015.02.08 11:04:58 1: HMLAN_Parse: HMLAN1 new condition timeout
2015.02.08 11:04:58 1: 192.168.1.42:1000 disconnected, waiting to reappear (HMLAN1)
2015.02.08 11:04:58 1: HMLAN_Parse: HMLAN1 new condition disconnected
2015.02.08 11:05:01 1: Perfmon: possible freeze starting at 11:04:59, delay is 2.75
2015.02.08 11:06:07 2: Perfmon: ready to watch out for delays greater than one second
2015.02.08 11:06:07 1: registering fhem as Windows Service
2015.02.08 11:06:07 1: starting fhem as a service
2015.02.08 11:06:07 1: Including C:/FHEM/fhem.cfg
2015.02.08 11:06:07 1: HMLAN_Parse: HMLAN1 new condition disconnected
2015.02.08 11:06:07 3: Opening HMLAN1 device 192.168.1.42:1000
2015.02.08 11:06:07 3: HMLAN1 device opened
2015.02.08 11:06:07 1: HMLAN_Parse: HMLAN1 new condition init
als Zeitpunkt des Fehlers wird im DrWatson 11:05:02.468 angegeben

Hat jemand eine Idee was dort passiert und was ich dagegen tun kann ?
FHEM-Featurelevel: 6   (fhem.pl:23904/2021-03-07) auf Windows 10 Pro mit Strawberry Perl 5.26.1.1-32bit
TabletUI: 2.7.15
IO: 2xHMLAN(0.965)|HMUSB2(0.967)