Autor Thema: keine Verbindung möglich zu LW12 - Adapter  (Gelesen 7650 mal)

Offline Alex85

  • Full Member
  • ***
  • Beiträge: 105
keine Verbindung möglich zu LW12 - Adapter
« am: 12 Februar 2015, 12:39:40 »
Mein Problem ist, dass ich den LW12 - Adapter von FHEM aus nicht erreichen kann.
Ist hier etwas an der Konfiguration / Definition des Adapters falsch?!
Ich habe scheinbar eines der neusten Modelle erwischt, da ich mich übers WebInterface nur mit admin/admin einloggen kann...
Ist ein LaGute LED Wifi-Controller, den ich über eine iPhone App problemlos ansteuern konnte. An/Aus, Farbwechsel usw. hat alles problemlos funktioniert.

Kann hier jmd. weiterhelfen?!

Definition des LW12-Adapters
define LEDcontrolKueche LW12 192.168.2.122
attr LEDcontrolKueche room HUEDevice
define FileLog_LEDcontrolKueche FileLog ./log/LEDcontrolKueche-%Y.log LEDcontrolKueche
attr FileLog_LEDcontrolKueche archivedir ./archive/
attr FileLog_LEDcontrolKueche logtype text
attr FileLog_LEDcontrolKueche nrarchive 1
attr FileLog_LEDcontrolKueche room HUEDevice

Auszug aus dem Log:
2015.02.12 12:32:15 4: LEDcontrolKueche switched off
2015.02.12 12:32:17 3: Can't connect to socket!
2015.02.12 12:32:17 4: LEDcontrolKueche switched on

Kann mir hier jmd. einen Tipp bzgl. der Konfiguration geben. (Muss Server oder client Mode eingestellt werden?!, stimmt der Port?!, client mode desination address ist mein FHEM-Server)

Log beim Startup von FHEM:
2015.02.12 13:29:04 3: Can't connect to socket!
2015.02.12 13:29:04 1: PERL WARNING: Use of uninitialized value $res in uc at ./FHEM/98_LW12.pm line 478.
2015.02.12 13:29:04 1: PERL WARNING: Use of uninitialized value $colors[3] in hex at ./FHEM/98_LW12.pm line 482.
2015.02.12 13:29:04 1: PERL WARNING: Use of uninitialized value $colors[5] in hex at ./FHEM/98_LW12.pm line 483.
2015.02.12 13:29:04 1: PERL WARNING: Use of uninitialized value $colors[2] in string eq at ./FHEM/98_LW12.pm line 484.
2015.02.12 13:29:04 1: PERL WARNING: Use of uninitialized value $colors[6] in hex at ./FHEM/98_LW12.pm line 491.
2015.02.12 13:29:04 1: PERL WARNING: Use of uninitialized value $colors[7] in hex at ./FHEM/98_LW12.pm line 492.
2015.02.12 13:29:04 1: PERL WARNING: Use of uninitialized value $colors[8] in hex at ./FHEM/98_LW12.pm line 493.
« Letzte Änderung: 12 Februar 2015, 13:34:42 von Alex85 »

Offline Kuzl

  • Sr. Member
  • ****
  • Beiträge: 887
Antw:keine Verbindung möglich zu LW12 - Adapter
« Antwort #1 am: 12 Februar 2015, 14:37:31 »
Hallo Alex,

so wie es aussieht hast du einen neuen LW12 - ob der mit dem Modul funktioniert kann ich noch nicht sagen.
Erstmal musst du den LW12 in DEIN VORHANDENES netzwerk einbinden.
Das bedeutet du musst im Client-Mode arbeiten. Solange er nicht bei dir im Netzwerk ist wirds schwierig, es sei denn FHEM verbindet sich mit dem WLAN des LW12 aber dann bist du ja nicht mehr in deinem Netzwerk.
Was du da genau einstellen musst kann ich dir leider nicht sagen, da der Webserver meines LW12 komplett anders aussieht.

Gruß
Kuzl

Offline Alex85

  • Full Member
  • ***
  • Beiträge: 105
Antw:keine Verbindung möglich zu LW12 - Adapter
« Antwort #2 am: 12 Februar 2015, 14:44:23 »
Hallo Kuzl,

in meinem Netzwerk befindet sich das Teil bereits.
(sehe den Adapter in meiner FritzBox Netzwerkübersicht mit IP und kann ihn problemlos pingen + konfigurieren per WebInterface)
Die Frage ist nur, nachdem ich einen Socket error bekomme, welchen Port das Modul zum verbinden nimmt.
Bei mir war Port 5000 Standardeinstellung. Sehe in einigen Posts hier, dass es anscheinend mal: 5577 war...

Habe es auf client-mode umgestellt aber selbiges Problem.

Gruß,
Alex

Offline Kuzl

  • Sr. Member
  • ****
  • Beiträge: 887
Antw:keine Verbindung möglich zu LW12 - Adapter
« Antwort #3 am: 13 Februar 2015, 07:05:26 »
Ja in meinem Modul ist es auch 5577. Du hast anscheinend eine andere Firmware drauf.
Du kannst mal versuchen bei dir den Port einfach auf 5577 umzustellen allerdings wärs ein Glück wenn sie nichts an den Kommandos geändert hätten so wie ich die chienesen kenne.

Offline Alex85

  • Full Member
  • ***
  • Beiträge: 105
Antw:keine Verbindung möglich zu LW12 - Adapter
« Antwort #4 am: 13 Februar 2015, 09:23:31 »
Habe ich auch schon probiert, also den Port umzustellen.
Leider ist das einzige Resultat, dass FHEM nach dem hinzufügen der Definition des Gerätes in die fhem.cfg dann im Nirvana ist. -> Timeouts
FHEMweb nicht mehr aufrufbar.

Offline Wuppi68

  • Developer
  • Hero Member
  • ****
  • Beiträge: 2161
  • On the Highway to Shell
Antw:keine Verbindung möglich zu LW12 - Adapter
« Antwort #5 am: 13 Februar 2015, 09:29:45 »
nimm mal nen Wireshark um den Verkehr von der App zu loggen ... dann siehst Du auch den genauen Port
Jetzt auf nem I3 und primär Homematic - kein Support für cfg Editierer

Support heißt nicht wenn die Frau zu Ihrem Mann sagt: Geh mal bitte zum Frauenarzt, ich habe Bauchschmerzen

Offline Alex85

  • Full Member
  • ***
  • Beiträge: 105
Antw:keine Verbindung möglich zu LW12 - Adapter
« Antwort #6 am: 13 Februar 2015, 09:34:05 »
Hm naja, da standardmäßig Port 5000 eingestellt war und im Modul der Port 5577 hinterlegt ist, frage ich mich zu welcher Erkenntnis mich das dann führen soll?!

Offline herrmannj

  • Global Moderator
  • Hero Member
  • ****
  • Beiträge: 5117
Antw:keine Verbindung möglich zu LW12 - Adapter
« Antwort #7 am: 13 Februar 2015, 11:08:20 »
Hallo,

es gibt vom KW12 verschiedene Versionen. Beginnt die SSID den LW12 eigenen WLAN mit "hx ..." ?
Installiere den mal mit Wifilight http://forum.fhem.de/index.php/topic,18958.0.html als:

define <name> WifiLight RGB LW12HX:<IP|FQDN>
vg
jörg
smartVisu mit fronthem, einiges an HM, RFXTRX, Oregon, CUL, Homeeasy, ganz viele LED + Diverse

Offline Alex85

  • Full Member
  • ***
  • Beiträge: 105
Antw:keine Verbindung möglich zu LW12 - Adapter
« Antwort #8 am: 13 Februar 2015, 11:51:19 »
Hey Jörg,

ich habe anscheinend schon die nächste Version davon erwischt. Das Teil hat sich initial mit nem FX... W-Lan gemeldet.
Habe es schon mit dem anderen Modul versucht, jedoch bekam ich hier folgende Fehlermeldung:

-> Connection Type: UDP
2015.02.13 11:40:30 3: LEDcontrolKueche RGB LW12HX set on (0, 0, 100) 0
2015.02.13 11:40:30 3: LEDcontrolKueche set HSV 0, 0, 100 with ramp: 0, flags:
2015.02.13 11:40:30 3: LEDcontrolKueche low level cmd queue send ERROR 9d620600000060f0b040000000f0f04010101006, qlen 1 (reconnect giving up)


-> Connection Type: TCP
2015.02.13 11:44:57 3: LEDcontrolKueche RGB LW12HX set on (0, 0, 100) 0
2015.02.13 11:44:57 3: LEDcontrolKueche set HSV 0, 0, 100 with ramp: 0, flags:
2015.02.13 11:44:57 3: LEDcontrolKueche low level cmd queue send ERROR 9d620600000060f0b040000000f0f04010101006, qlen 1 (reconnect giving up)

Settings:
Port: 5577
Server/Client Mode: client
Client Mode-Destination Address: mein FHEM-Server

Jedenfalls kommt hier die folgende Meldung nicht mehr mit o.g. settings.:
define LEDcontrolKueche: can't reach (IO::Socket::INET: connect: Connection refused)

D.h. ich bin schonmal einen Schritt weiter. FHEM versucht jedenfalls schon mit dem Teil zu kommunizieren, aber irgendwas scheint noch falsch an den settings.

An den serial settings (siehe screenshot) kann es ja nicht liegen, oder ist hier so ne Art LAN zu RS-232 bridge integriert?!

Gruß,
Alex
« Letzte Änderung: 13 Februar 2015, 11:56:00 von Alex85 »

Offline herrmannj

  • Global Moderator
  • Hero Member
  • ****
  • Beiträge: 5117
Antw:keine Verbindung möglich zu LW12 - Adapter
« Antwort #9 am: 13 Februar 2015, 12:11:09 »
FX ist doof. Mach mal einen reset des controllers, der läuft mit den default settings.
Dann per app ins WLAN nehmen und gern beides ausprobieren, LW12 und LW12HX.

Wenns dann nicht läuft hast Du eine dritte Variante entdeckt :)

vg
jörg
smartVisu mit fronthem, einiges an HM, RFXTRX, Oregon, CUL, Homeeasy, ganz viele LED + Diverse

Offline Alex85

  • Full Member
  • ***
  • Beiträge: 105
Antw:keine Verbindung möglich zu LW12 - Adapter
« Antwort #10 am: 13 Februar 2015, 12:16:00 »
Ne das Teil hängt schon bei mir im WLAN. Was ich beschrieben hatte war die Werkseinstellung.
Da war wie gesagt ein FX... - WLAN aktiv.

Habe mal diese settings probiert (screenshot). Selbe Fehlermeldung im LOG:
2015.02.13 12:10:15 3: LEDcontrolKueche low level cmd queue send ERROR 9d62060000006000000000000000004000101005, qlen 1 (reconnect giving up)
Port: 5000 (geändert auf default / Werkseinstellung)
Server/Client Mode: client
Client Mode-Destination Address: mein FHEM-Server
Baudrate: 19200 oder Baudrate: 4800 (geändert von default / Werkseinstellung: 57600)
Protokoll: TCP oder UDP (default: TCP)

Offline herrmannj

  • Global Moderator
  • Hero Member
  • ****
  • Beiträge: 5117
Antw:keine Verbindung möglich zu LW12 - Adapter
« Antwort #11 am: 13 Februar 2015, 12:41:30 »
Na, Du hast ja beim ausprobieren doch einiges geändert, port, baut, client usw. Jetzt läufst Du halt Gefahr da was zu übersehen hast. Letztendlich musst Du das selber wissen, DU möchtest den zum laufen bekommen  ;)

Gib Dir nen Ruck, mach einen Werksreset, nimm ihn über die app in Dein WLAN. An den settings des lw12 brauchst Du nichts zu ändern (bringt auch alles nichts außer zusätzlichen Fehlerquellen)

Danach Wifilight
define <name> WifiLight RGB LW12HX:<IP|FQDN>
sicherheitshalber Neustart von fhem bitte.

Der logeintrag oben deutet darauf hin das die Einstellungen nicht in Ordnung sind (!). Anstelle von <IP|FQDN> die IP vom LW12, denke das ist klar. Deinem log zeigt das die Verbindung nicht oK ist - das hat nichts mit dem Protokoll zu tun.

vg
jörg
smartVisu mit fronthem, einiges an HM, RFXTRX, Oregon, CUL, Homeeasy, ganz viele LED + Diverse

Offline Alex85

  • Full Member
  • ***
  • Beiträge: 105
Antw:keine Verbindung möglich zu LW12 - Adapter
« Antwort #12 am: 13 Februar 2015, 12:53:55 »
Mein Problem war anfangs auch, dass ich das Teil nicht mit der APP ins heimische WLAN bekommen hatte. Die einzige APP (iPhone) die funktionierte und das Teil gefunden hat, bot keine Option um ein anderes WLAN auszuwählen o.ä. / Habe alle verfügbaren Apps ausprobiert, jedoch hatte nur die APP in der Bedienungsanleitung funktioniert.

Folglich musste ich mich mit meinem Notebook ins WLAN (Fx...) des Adapters einbuchen und das ganze übers WebInterface konfigurieren.

Ich habe in einem anderen Forum von den unterschiedlichen Baudraten / Ports gelesen, die anscheinend zwischen den verschiedenen Bauzuständen / Firmwares des Gerätes differieren.

Zitat
wer hat auch einen "neuen" controller --- und eine lösung?
 hier nur nochmal das problem ....:
 -> http://www.ip-symcon.de/forum/threads/23844-RGB-Wlan-Controller-in-IPS-einbinden/page4

"ich habe hier einen "wie oben beschriebenen" Controller im Netz, und seit heute 6 Controller, mit etwas anderer Firmware?

Der funktionierende controller hat die Firmware: "4.02.11T.15"
 unter Application setting ist der default Port auf 5577
 und die Baudrate auf 4800 Baud gestellt.
 Sowie das default Passwort des AP Modes auf "88888888"

und die nicht funktionierenden haben die "4.02.10.hx08"
 Port 5000 und Baudrate 19200 und kein Passwort auf dem AP.

Es scheint so als ob der Controller auf Daten aus dem WLan hört, jedoch wohl ein anderes Protokoll spricht.

Quelle: http://www.meintechblog.de/2014/05/die-hue-alternative-preiswert-die-lichtstimmung-im-smart-home-pimpen/

Offline Alex85

  • Full Member
  • ***
  • Beiträge: 105
Antw:keine Verbindung möglich zu LW12 - Adapter
« Antwort #13 am: 13 Februar 2015, 13:04:06 »
Kann jmd. ggf. mal die kompletten settings eines LW12 (Standard) und LW12HX posten?!
Oder gibt es da das WebInterface in der Form gar nicht / oder nur mit weniger Wahlmöglichkeiten?!

Offline herrmannj

  • Global Moderator
  • Hero Member
  • ****
  • Beiträge: 5117
Antw:keine Verbindung möglich zu LW12 - Adapter
« Antwort #14 am: 13 Februar 2015, 13:12:27 »
ok verstehe.

Also zwei Möglichkeiten: wenn Du die Chance hast schick das Ding zurück und hole Dir einen LD382 (LED Ufo), den kannst Du per wps button in Dein Netz nehmen und der kostet de-facto das gleiche.

Wenn das ausscheidet mach einen Werksreset und nimm ihn nochmal mit dem NB ins Netz. Verändere nichts anderes, nur das WLAN. In dem screenshot oben sehe ich zb UDP, das ist doch nicht ab Werk - oder ?

vg
Jörg

edith:
diese ganzen Halbweisheiten mit Port/Baud etc kannst Du alle ignorieren, das sind einfach unterschiedliche Geräte. Aus einer Giraffe wird kein Elefant nur weil man einen Rüssel anklebt.
« Letzte Änderung: 13 Februar 2015, 13:14:00 von herrmannj »
smartVisu mit fronthem, einiges an HM, RFXTRX, Oregon, CUL, Homeeasy, ganz viele LED + Diverse