Autor Thema: KNX/EIB - Dimmen - Merten 649310  (Gelesen 6361 mal)

smarthomenord

  • Gast
KNX/EIB - Dimmen - Merten 649310
« am: 17 Februar 2015, 15:09:20 »
Hallo ,

wir nutzen den FHEM Server als VISU für KNX/EIB per Raspberry TUL Busware.

Das schalten der Lampen via Schaltaktor über FHEM funktioniert.


Probleme gibt leider beim Dimmaktor Merten 649310.. per Schalter funktioniert der Dimmvorgang, ausserdem über die Konsole mit eibd

Wir haben schon unzählige Varianten probiert, um den Dimmaktor in FHEM einzubinden.

z.B.

http://www.fhemwiki.de/wiki/Dimmer_f%C3%BCr_EIB/KNX

unsere aktuelle Definition des Dimmers:

ets:

1bit Schalten 1/1/2
4bit relatives Dimmen 1/1/0
1byte absolutes Dimmen 1/1/4

Rückmeldung Schalten 7/1/0
Rückmeldung Wertobjekt/helligskeitswert 7/1/2

fhem:

define Dimmer EIB 1/1/0
attr Dimmer  IODev EIB
attr Dimmer  model percent
attr Dimmer  room Wohnzimmer
attr Dimmer  webCmd value

Offline ZeitlerW

  • Full Member
  • ***
  • Beiträge: 154
Antw:KNX/EIB - Dimmen - Merten 649310
« Antwort #1 am: 18 Februar 2015, 08:49:50 »
Hallo smarthomenord,

müßte das nicht

define Dimmer EIB 1/1/4 7/1/2

heißen?
Du willst doch mit einem Slider den Absolutwert dimmen und die Rückmeldung im Slider darstellen.

vG
Wolfgang

smarthomenord

  • Gast
Antw:KNX/EIB - Dimmen - Merten 649310
« Antwort #2 am: 18 Februar 2015, 10:18:08 »
Hallo Wolfgang,
Das Problem fängt ja leider schon damit an, das ich es nicht hinbekommen die an den Dimmer angeschlossene Lampe über FHEM zu schalten.
Per Eibd über das Terminal, lässt die Lampe sich sowohl schalten als auch dimmen.
Mit freundlichen Grüßen Smarthomenord

Offline ZeitlerW

  • Full Member
  • ***
  • Beiträge: 154
Antw:KNX/EIB - Dimmen - Merten 649310
« Antwort #3 am: 18 Februar 2015, 13:20:35 »
Hallo,

naja erst mal ein TUL definieren, welches mit dem EIBD kommuniziert:
define KNX TUL eibd:127.0.0.1 1.1.255
dann
Device definieren

define Dimmer EIB 1/1/4 7/1/2
dann IODev des Devices definieren:

attr Dimmer  IODev KNX

dann sonstige Attribute:
attr Dimmer  model percent
attr Dimmer  room Wohnzimmer
attr Dimmer  webCmd value


vG
Wolfgang
« Letzte Änderung: 18 Februar 2015, 13:22:16 von ZeitlerW »

smarthomenord

  • Gast
Antw:KNX/EIB - Dimmen - Merten 649310
« Antwort #4 am: 18 Februar 2015, 14:29:09 »
Hallo Wolfgang,

ich muss um auf den KNX Bus zu kommen folgende Zeile verwenden:

define EIB TUL tul:/dev/ttyAMA0 1.1.255
mit der von dir genannten Zeile, funktioniert leider auch nicht mehr das einfache Schalten der Lampen, das via FHEM schon funktioniert.

Das Modul von Busware verwende ich
http://busware.de/tiki-index.php?page=ROT_Installation

Auszug auf dem Logfile
2015.02.18 14:19:05 3: TUL opening EIB device tul:/dev/ttyAMA0
2015.02.18 14:19:05 3: TUL setting EIB baudrate to 19200
2015.02.18 14:19:05 3: TUL device opened
2015.02.18 14:19:05 3: TUL opening KNX device eibd:127.0.0.1
2015.02.18 14:19:05 3: Can't connect to eibd:127.0.0.1: Connection refused


2015.02.18 14:19:27 2: EIB set Dimmer value 35
2015.02.18 14:19:29 2: EIB set Dimmer value 59
2015.02.18 14:19:32 2: EIB set Dimmer value 90
2015.02.18 14:19:33 2: EIB set Dimmer value 41
2015.02.18 14:19:34 2: EIB set Dimmer value 13
2015.02.18 14:19:35 2: EIB set Dimmer value 44


Laut Logfile kann sich der FHEM auch nicht mit dem eibd auf dem Raspberry verbinden ??

Oder verstehe ich jetzt irgendwas falsch ?

MfG
Fabian

Offline ZeitlerW

  • Full Member
  • ***
  • Beiträge: 154
Antw:KNX/EIB - Dimmen - Merten 649310
« Antwort #5 am: 18 Februar 2015, 15:52:51 »
Hallo Fabian,

wenn Du den ROT verwendest kannst du ENTWEDER direkt auf den ROT zugreifen per:
define KNX TUL tul:/dev/ttyAMA0 1.1.255
oder via eibd - Daemon, den du erst installieren müßtest per:
define KNX TUL eibd:127.0.0.1 1.1.255
Ich habe den Eindruck, daß durch Deine Definition: define EIB TUL ...
und dem Attribut attr Dimmer  IODev EIB etwas durcheinander kommt.


Also probier mal:
define KNX TUL tul:/dev/ttyAMA0 1.1.255
define Dimmer EIB 1/1/4 7/1/2
attr Dimmer  IODev KNX
attr Dimmer  model percent
attr Dimmer  room Wohnzimmer
attr Dimmer  webCmd value


Dabei muß sichergestellt sein, daß der eibd - Daemon nicht läuft.

Meine Installation hier läuft halt über ein IP - Gateway und den eibd. Deshalb bin ich beim ROT nicht wirklich aussagefähig.

vG
wolfgang

smarthomenord

  • Gast
Antw:KNX/EIB - Dimmen - Merten 649310
« Antwort #6 am: 18 Februar 2015, 16:14:15 »
Hallo Wolfgang,

wenn ich versuche mit der Zeile:
define KNX TUL eibd:127.0.0.1 1.1.255
auf den KNX Bus zu kommen, dann erhalte ich folgende Meldung im Log:

2015.02.18 16:04:19 3: TUL opening KNX device eibd:127.0.0.1
2015.02.18 16:04:19 3: Can't connect to eibd:127.0.0.1: Connection refused

auch mit der Netzwerkadresse:
2015.02.18 16:06:04 3: TUL opening KNX device eibd:192.168.178.32
2015.02.18 16:06:04 3: Can't connect to eibd:192.168.178.32: Connection refused



Ich habe habe eibd nach folgender Anleitung installiert :
https://github.com/mknx/smarthome/wiki/Komplettanleitung-Installation-sh.py-,-smartVISU,-eibd-und-1-Wire

Per eibd über das Terninal konnte ich auch problemlos alles im KNX Bus steuern und auslesen, also scheint korrekt installiert zu sein..
vielleicht eine falsche Konfiguration in eibd ??

MfG
Fabian

Offline ZeitlerW

  • Full Member
  • ***
  • Beiträge: 154
Antw:KNX/EIB - Dimmen - Merten 649310
« Antwort #7 am: 18 Februar 2015, 17:42:03 »
Hallo Fabian,

wenn Du über die shell sendest wie machst Du das?

groupswrite ip:localhost 1/2/3 0

oder

groupswrite local:/tmp/eib 1/2/3 0


Falls 2. dann könnte es sein, daß der eibd falsch konfiguriert ist und keinen ip-socket zur Verfügung stellt.

vG
Wolfgang

smarthomenord

  • Gast
Antw:KNX/EIB - Dimmen - Merten 649310
« Antwort #8 am: 18 Februar 2015, 18:23:55 »
Hallo Wolfgang,
wenn ich das über die Shell mache gehe ich wie folgt vor:

1.                                 eibd -t1023 -D -S -i  -e 1.0.255 tpuarts:/dev/ttyAMA0
2.                                 groupswrite ip:localhost 1/1/2 0              <<< Für AN/AUS
3.                                 groupwrite ip:localhost 1/1/4 57            <<< Für Wert Dimmen

Grüße Fabian
« Letzte Änderung: 18 Februar 2015, 21:41:36 von smarthomenord »

Offline ZeitlerW

  • Full Member
  • ***
  • Beiträge: 154
Antw:KNX/EIB - Dimmen - Merten 649310
« Antwort #9 am: 19 Februar 2015, 08:03:25 »
Hmmm.

dann paßt das mit dem EIBD eigentlich.

Die Standard  - Konfig für FHEM müßte dann wie folgt aussehen:
define KNX TUL eibd:127.0.0.1 1.0.255
define Dimmer EIB 1/1/4 7/1/2
attr Dimmer  IODev KNX
attr Dimmer  model percent
attr Dimmer  room Wohnzimmer
attr Dimmer  webCmd value

... leider habe ich sonst keine weitere Idee mehr :(

vG
Wolfgang

smarthomenord

  • Gast
Antw:KNX/EIB - Dimmen - Merten 649310
« Antwort #10 am: 19 Februar 2015, 10:09:30 »
Hallo Wolfgang,

vielen Dank!, der Dimmvorgang funktioniert jetzt wie er soll.

Ich vermute es lag daran, dass sich der FHEM nicht korrekt mit eibd verbinden konnte.

2015.02.18 16:04:19 3: TUL opening KNX device eibd:127.0.0.1
2015.02.18 16:04:19 3: Can't connect to eibd:127.0.0.1: Connection refused

----------------------------------

2015.02.19 09:35:04 3: TUL opening KNX device eibd:127.0.0.1
2015.02.19 09:35:04 3: TUL device opened

Neues Problem

Es ändert sich der Zustand/Wert des Schiebereglers nicht, wenn ich die Lampe direkt über den Taster dimme.
Auch nicht wenn ich die Seite mit F5 aktualisiere. Bei Events wird auch kein Ereignis angezeigt.

Grüße
Fabian

Offline ZeitlerW

  • Full Member
  • ***
  • Beiträge: 154
Antw:KNX/EIB - Dimmen - Merten 649310
« Antwort #11 am: 19 Februar 2015, 11:32:08 »
Hallo,

mach doch mal ein Device in dem nur der Rückmeldewert des Dimmers.

also so in etwa:

define RM_Dimmer EIB  7/1/2
attr Dimmer  IODev KNX
attr Dimmer  model percent
attr Dimmer  room Wohnzimmer
attr Dimmer  webCmd value

Dann sollte sich bei manuellem Dimmen der Wert ändern. Wenn nicht beim Merten  - Dimmer nachsehen.

vG
Wolfgang

smarthomenord

  • Gast
Antw:KNX/EIB - Dimmen - Merten 649310
« Antwort #12 am: 19 Februar 2015, 12:39:47 »
Hallo,

dieser Wert ändert sich leider auch nicht, wenn ich den Dimmer manuell per Taster betätige.

Ich vermute mal, dass dann die Einstellung in der ETS für den Rückgabewert des Dimmers falsch ist.

Die Diagnose Anzeige in der ETS liefert auch keine Meldung, wenn der Taster des Dimmers betätigt wird.

Aber der Dimmvorgang funktioniert ja, woran kann das liegen ?

Grüße
Fabian

Offline ZeitlerW

  • Full Member
  • ***
  • Beiträge: 154
Antw:KNX/EIB - Dimmen - Merten 649310
« Antwort #13 am: 19 Februar 2015, 13:14:15 »
Ü - Flag?

siehe auch:http://knx-user-forum.de/335165-post4.html

vG
Wolfgang
« Letzte Änderung: 19 Februar 2015, 13:17:06 von ZeitlerW »

smarthomenord

  • Gast
Antw:KNX/EIB - Dimmen - Merten 649310
« Antwort #14 am: 19 Februar 2015, 14:29:18 »
hallo,

das Ü-Flag ist gesetzt !?

Grüße
Fabian

 

decade-submarginal