CUL > Ankündigungen

LaCrosse für CUL

<< < (3/27) > >>

locutus:

--- Zitat von: mac973 am 15 Oktober 2015, 21:43:04 ---Was muss man da noch machen?

--- Ende Zitat ---

Die Emulation der Sensoren in board.h aktivieren…

--- Code: ---#define LACROSSE_HMS_EMU
--- Ende Code ---
… und die Firmware neu kompilieren.

mac973:
Ich stelle mich vielleicht etwas blöde an, aber wenn ich den Eintrag in der board.h ändere oder halt hinzufüge, dann ist es genau gleich wie vorher. Der Befehl raw N oder raw Nr funktionieren trotzdem nicht.



--- Code: ---2015.10.17 16:38:08 3: set CUL2 raw N1
2015.10.17 16:38:08 2: CUL2: unknown message ? (N1 is unknown) Use one of B C F i A Z E G M K U Y R T V W X e f m l t u x

--- Ende Code ---


Leider.

Gruß
S.



Nachtrag: Jetzt ging es doch noch irgendwie anders und habe jetzt V 1.65 868 (bei den CMDs ist jetzt auch "N" dabei, aber wenn ich die Befehle ausprobiere, dann bekomme ich


--- Code: ---2015.10.17 16:59:11 3: CUL1: Possible commands: BCFiAZNkGMKUYRTVWXefmLltux
2015.10.17 17:14:28 3: set CUL1 raw N
2015.10.17 17:14:28 2: CUL1: unknown message 00
2015.10.17 17:16:48 3: set CUL1 raw Nr1
2015.10.17 17:16:48 2: CUL1: unknown message 01

--- Ende Code ---

???


Schöne Grüße
Sascha

Tedious:
Ich hab's auch aufgegeben, nachdem ich diverse Firmware-Versionen kompiliert und geflasht habe. Hab einen Jeelink gekauft und alles läuft sauber ;)

locutus:
Das Makefile sollte folgende Einträge beinhalten:

--- Code: --- ../../clib/rf_native.c      \
../../clib/lacrosse.c      \
--- Ende Code ---

board.h:

--- Code: ---#define HAS_RFNATIVE
#define LACROSSE_HMS_EMU
--- Ende Code ---

Die Zeile muss weg oder wird auskommentiert:

--- Code: ---//# define OFF_LACROSSE_HMS_EMU
--- Ende Code ---

In CUL.c dürfen diese Einträge nicht fehlen:

--- Code: ---#ifdef HAS_RFNATIVE
#include "rf_native.h"
#endif

#ifdef HAS_RFNATIVE
  { 'N', native_func },
#endif

#ifdef HAS_RFNATIVE
    native_task();
#endif

--- Ende Code ---

Wenn alles richtig ist, dann wird ein HMS Device per autocrate angelegt.

--- Code: ---2015.10.17 21:00:06 3: set CUL raw Nr1
2015.10.17 21:00:06 2: CUL: unknown message 01
2015.10.17 21:00:30 2: CUL: unknown message N0191860140EBAAAA0000210022
2015.10.17 21:00:30 3: Unknown HMS device 1000/4306, please define it
2015.10.17 21:00:30 2: autocreate: define HMS100TF_4306 HMS 4306
2015.10.17 21:00:30 2: autocreate: define FileLog_HMS100TF_4306 FileLog ./log/HMS100TF_4306-%Y.log HMS100TF_4306:T:.*
2015.10.17 21:00:30 2: autocreate: define SVG_HMS100TF_4306 SVG FileLog_HMS100TF_4306:temp4hum6:CURRENT
2015.10.17 21:00:34 2: CUL: unknown message N0191860140EBAAAA0000000240
2015.10.17 21:00:42 2: CUL: unknown message N0191860140EBAAAA0000400094
2015.10.17 21:00:50 2: CUL: unknown message N0191860140EBAAAA0000516090
--- Ende Code ---

mac973:
Hallo,
danke – habe es probiert.
Hatte auf einmal eine Zeile mit "CUL: unknown message N..." alle 5 Sekunden im Log.
Aber kein Autocreate.
Habe dann mal fheminfo aufgerufen und gesehen, das die installation fhem 5.5 drauf hatte.
Nach einem UPDATE habe ich jetzt zwar 5.6 allerdings gibt es mir die Zeilen nicht mehr aus.

Schade.

Sascha

Navigation

[0] Themen-Index

[#] Nächste Seite

[*] Vorherige Sete

Zur normalen Ansicht wechseln