Autor Thema: CUL disconnected, waiting to reappear (CUL) - Fehlersuche  (Gelesen 2166 mal)

Offline digitalyours

  • New Member
  • *
  • Beiträge: 9
Hallo zusammen,

die letzten Monate läuft mein Gespann aus Raspberry, FHEM und CUL [1] sehr stabil und bisher gab es keinen Grund zu klagen. Seit gestern Abend/Nacht stehe ich jedoch vor einem Problem, das ich nicht lösen kann. Ohne an der Konfiguration/Aufbau etwas geändert zu haben, meldet sich der CUL an mein RPi ständig an- und ab. [2] Zunächst hatte ich die FHEM-SW in Verdacht und habe daraufhin einen restart durchgeführt. Leider ergab sich keine Besserung. Auch ein Neustart des RPi brachte keine Änderung. Im folgenden habe ich dann, nach etwas Recherche im Internet, das Netzteil getauscht, sowie FHEM und Linux ein Update verpasst. Leider brachten diese Aktionen keine Veränderung des Problems. Auch die Aktualisierung der Firmware des CULs auf das aktuellste Release hat ohne Schwierigkeiten funktioniert. Leider hat sich das Problem dadurch auch nicht gelöst.

Einen Auszug des Fehlers aus dem Log (attr global verbose 5) ist unter [3] zu sehen. Ich bin mit meinem Latein nun völlig am Ende und bräuchte Hinweise wie und wo ich die Fehlersuche fortsetzen kann.

vG und 1000Dank
Christoph

[1]
RPI Raspbian 3.18.11+
CUL V 1.61 CUL868

[2]
2015.05.24 23:13:51 1: /dev/ttyACM0 disconnected, waiting to reappear (CUL)
2015.05.24 23:13:52 3: Setting CUL baudrate to 9600
2015.05.24 23:13:52 1: /dev/ttyACM0 reappeared (CUL)
2015.05.24 23:13:52 3: CUL: Possible commands: BCFiAZEGMRTVWXefmltux

[3]
2015.05.25 09:19:17 4: 2751:FHEMWEB:127.0.0.1:33001: /fhem?cmd.Kueche.Hauptlicht=set%20Kueche.Hauptlicht%20on&room=K%C3%BCche&room=all&XHR=1 / RL:20 / text/plain; charset=UTF-8 / Content-Encoding: gzip
 /
2015.05.25 09:19:17 4: Connection closed for FHEMWEB:127.0.0.1:32965: EOF
2015.05.25 09:19:17 4: Connection accepted from FHEMWEB:127.0.0.1:33002
2015.05.25 09:19:17 4: Connection accepted from FHEMWEB:127.0.0.1:33003
2015.05.25 09:19:17 4: HTTP FHEMWEB:127.0.0.1:33002 GET /fhem/images/default/set_on.png
2015.05.25 09:19:17 4: HTTP FHEMWEB:127.0.0.1:33003 GET /fhem/images/default/set_on.png
2015.05.25 09:19:18 4: CUL_HM_Resend: Kueche.Hauptlicht nr 2
2015.05.25 09:19:18 5: CUL sending As0E03A0115BE35D1FDA140201C80000
2015.05.25 09:19:18 4: CUL_send:  CULAs 0E 03 A011 5BE35D 1FDA14 0201C80000
2015.05.25 09:19:19 1: /dev/ttyACM0 disconnected, waiting to reappear (CUL)
2015.05.25 09:19:19 5: Triggering CUL (1 changes)
2015.05.25 09:19:19 5: Notify loop for CUL DISCONNECTED
2015.05.25 09:19:20 4: Connection accepted from FHEMWEB:127.0.0.1:33004
2015.05.25 09:19:20 3: Setting CUL baudrate to 9600
2015.05.25 09:19:20 1: /dev/ttyACM0 reappeared (CUL)
2015.05.25 09:19:20 4: CUL_send:  CULV     
2015.05.25 09:19:20 5: CUL/RAW (ReadAnswer): V 1.61 CUL868

2015.05.25 09:19:20 4: CUL_send:  CUL?     
2015.05.25 09:19:20 5: CUL/RAW (ReadAnswer): ? (? is unknown) Use one of B b C F i A Z E G M K U Y R T V W X e f m l t u x

2015.05.25 09:19:20 3: CUL: Possible commands: BbCFiAZEGMKUYRTVWXefmltux
2015.05.25 09:19:20 4: CUL_send:  CULX2 1     
2015.05.25 09:19:20 4: CUL_send:  CULAr     
2015.05.25 09:19:20 4: CUL_send:  CULT0 1     
2015.05.25 09:19:20 5: CUL/RAW (ReadAnswer): 1034
« Letzte Änderung: 25 Mai 2015, 18:42:18 von digitalyours »

Offline rudolfkoenig

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 22552
Antw:CUL disconnected, waiting to reappear (CUL) - Fehlersuche
« Antwort #1 am: 25 Mai 2015, 11:44:08 »
Du betreibst das CUL im HomeMatic Modus. Fuehrt jedes HM-Sendebefehl zum Absturz? Funktioniert Empfang?
Ich vermute deine Meldung ist in dem HomeMatic Forumsbereich besser aufgehoben.

Offline digitalyours

  • New Member
  • *
  • Beiträge: 9
Antw:CUL disconnected, waiting to reappear (CUL) - Fehlersuche
« Antwort #2 am: 25 Mai 2015, 12:46:47 »
Du betreibst das CUL im HomeMatic Modus.
Fuehrt jedes HM-Sendebefehl zum Absturz?

Ja, soweit ich das hier sehen kann führen alle Befehle zum Absturz.

Funktioniert Empfang?

Tatsächlich registriert FHEM den Zustandswechsel beim Küchenlicht (Schalter direkt gekoppelt)

Ich vermute deine Meldung ist in dem HomeMatic Forumsbereich besser aufgehoben.

Alles klar, war mir unsicher wo es besser passt. Das Thema darf gerne verschoben werden.
« Letzte Änderung: 25 Mai 2015, 12:50:19 von digitalyours »