Autor Thema: Autostart von EIBD auf Raspi2  (Gelesen 46409 mal)

Offline smurfix

  • Developer
  • Full Member
  • ****
  • Beiträge: 277
Antw:Autostart von EIBD auf Raspi2
« Antwort #120 am: 09 September 2015, 23:29:33 »
Hi,
bootstrap.sh: 2: bootstrap.sh: libtoolize: not foundDas sieht nach fehlendem
apt-get install autoconf automake libtoolaus; ich werde das gleich nachtragen.

PS: ich frage mich, wie so viele Leute auf die Idee kommen, "sudo dpkg-buildpackage -b" zu verwenden… das ist sinnfrei.

Offline speedschmidt

  • Full Member
  • ***
  • Beiträge: 134
Antw:Autostart von EIBD auf Raspi2
« Antwort #121 am: 13 September 2015, 22:50:41 »
High smurfi,

nach:

sudo apt-get install autoconf automake libtool

lief

sudo dpkg-buildpackage -b

natürlich durch und auch

cd ..
sudo dpkg -i knxd_*.deb knxd-tools_*.deb

hat keine Fehlermeldungen mehr ausgeworfen.

ABER:
Autostart erst nach:

sudo systemctl enable knxd
Könnte das bitte mit in die Readme rein?

und dann ganz wichtig:
Die Argumente in der /etc/knxd.conf nicht vergessen einzutragen (bei systemd und Systembezogen und siehe weiter vorn).

Und ganz großen Dank nochmal

Ingo

PS: Merkwürdig fand ich folgende Reaktion:

Erst nach einem (oder mehreren) erfolgreichen groupswrite wurde der Dienst als gestartet gemeldet:

pi@raspberrypi ~ $ /etc/init.d/knxd status
● knxd.service - KNX Daemon
   Loaded: loaded (/lib/systemd/system/knxd.service; enabled)
   Active: failed (Result: exit-code) since So 2015-09-13 22:08:39 CEST; 1min 34s ago
  Process: 526 ExecStart=/usr/bin/knxd $KNXD_OPTS (code=exited, status=1/FAILURE)
 Main PID: 526 (code=exited, status=1/FAILURE)
pi@raspberrypi ~ $ knxtool groupswrite ip: 0/2/9 1
Send request
pi@raspberrypi ~ $ knxtool groupswrite ip: 0/2/9 0
Send request
pi@raspberrypi ~ $ knxtool groupswrite ip: 0/2/9 1
Send request
pi@raspberrypi ~ $ /etc/init.d/knxd status
● knxd.service - KNX Daemon
   Loaded: loaded (/lib/systemd/system/knxd.service; enabled)
   Active: active (running) since So 2015-09-13 22:10:30 CEST; 14s ago
 Main PID: 809 (knxd)
   CGroup: /system.slice/knxd.service
           └─809 /usr/bin/knxd -c -D -R -T --no-tunnel-client-queuing -S ipt:...

Aber ich erinnere mich auch wie du schriebst, dass der Dienst erst startet wenn er benötigt wird (oder so ähnlich).

Offline knxfreund13

  • New Member
  • *
  • Beiträge: 34
Antw:Autostart von EIBD auf Raspi2
« Antwort #122 am: 15 September 2015, 09:25:06 »
Also ich habe leider bei diesem Thread ein Problem. Titel heisst Autostart von EIBD auf Raspi2 und ich finde so gut wie keine klare Aussage was tut man wenn EIBD wunderbar funktioniert auch in FHEM nur man muss beim Neustart wieder händisch den EIBD starten.

' eibd -d -D -S -T -i ipt:192.168.xxx.xxx:3671 ' startet den eibd

Wo ist denn nur die Anleitung was muss ich tun damit ich diesen Start nicht immer selber machen muss sondern der Raspi das selbst macht


Offline smurfix

  • Developer
  • Full Member
  • ****
  • Beiträge: 277
Antw:Autostart von EIBD auf Raspi2
« Antwort #123 am: 15 September 2015, 09:35:57 »
Eintragen in /etc/rc.local und fertig.
(Ans Ende der Zeile muss dann noch ein &-Zeichen.)

Es gibt noch diverse aufwändige Startskripte, an denen rumzubasteln sich aber allesamt nicht wirklich lohnt.

Offline knxfreund13

  • New Member
  • *
  • Beiträge: 34
Antw:Autostart von EIBD auf Raspi2
« Antwort #124 am: 15 September 2015, 10:38:12 »
Hallo smurfix

wäre ja gut wenn das so einfach funktionieren würde tut es aber leider nicht

Die Zeile  ' eibd -d -D -S -T -i ipt:192.168.xxx.xxx:3671 & '  eingefügt in /etc/rc.local

Wo liegt das Problem ?

Offline smurfix

  • Developer
  • Full Member
  • ****
  • Beiträge: 277
Antw:Autostart von EIBD auf Raspi2
« Antwort #125 am: 15 September 2015, 11:22:16 »
Wo hast du die denn eigefügt, nach dem "exit 0" das da schon drinsteht, oder davor?

Evtl. /usr/local/bin/eibd statt nur eibd schreiben, je nachdem wo das Ding hininstalliert wurde

Offline knxfreund13

  • New Member
  • *
  • Beiträge: 34
Antw:Autostart von EIBD auf Raspi2
« Antwort #126 am: 15 September 2015, 11:31:21 »
selbstverständlich vor dem ' exit 0 '

aber ohne Angabe vom Speicherort. Den muss ich dann mal noch suchen !

Offline SvenJust

  • Full Member
  • ***
  • Beiträge: 408
Autostart von EIBD auf Raspi2
« Antwort #127 am: 15 September 2015, 11:52:18 »
"which eibd" gibt den Dateipfad
FTUI, Raspberry PI/SSD, CUL CC1101, HMLAN, 10x HM-LC-Bl1PBU-FM, HM-LC-Sw4-WM (KWL Pluggit P300), HM-WDS30-OT2-SM (Sonnensensor), HM-Sec-SCo, LW-12 Wifi LED, CUL Selbstbau nanoCUL 433 (IT), Arduino (S0-Stromverbrauch), OW DS2480 (OWX_ASYNC) 8x DS18B20, MQTT (Fröling P4), MYSENSORS (Roto Rollläden)

Offline knxfreund13

  • New Member
  • *
  • Beiträge: 34
Antw:Autostart von EIBD auf Raspi2
« Antwort #128 am: 15 September 2015, 12:04:22 »
Hallo an alle den Instalationspfad von EIBD gefunden den Eintrag entsprechend erweitert und es FUNKTIONIERT !!!
Ich danke smurfix als auch SvenJust für Ihre selbstlose Unterstützung
 :) :) :) :)

Offline smurfix

  • Developer
  • Full Member
  • ****
  • Beiträge: 277
systemd und Autostart
« Antwort #129 am: 15 September 2015, 17:19:11 »
Das aktuelle Installationsskript macht "systemctl enable" auf Socket und Service.

Mit dem Autostart via Socket ist das so eine Sache. Rein theoretisch sollte das sauber funktionieren; in der Praxis kann es vorkommen, dass der Code auf Interface A schon munter Daten liest, aber nicht an B weiterleitet, weil Interface B einfach noch nicht initialisiert ist. (Das zu beheben wäre im Rahmen des geplanten libpthsem-Rauswurfs sinnvoll.) Fazit: lieber gleich beim Booten starten.

Offline MarcelT

  • New Member
  • *
  • Beiträge: 11
Antw:Autostart von EIBD auf Raspi2
« Antwort #130 am: 12 Dezember 2015, 15:21:46 »
Guten Tag zusammen,

ich möchte den Thread noch mal hochholen - bin am Verzweifeln mangels autostart von knxd.

Stand der Dinge ist: Ich habe wheezy komplett neu aufgesetzt und den knxd gemäß Wiki installiert. Ging problemlos. Da ich einen TUL am Raspberry angeschlossen habe und ETS über einen Windows-Rechner im Netzwerk, habe ich /etc/default/knxd wie folgt angepasst:
START_KNXD=YES
DAEMON_ARGS="-e 0.0.1 -i -D -T -R -S -b tpuarts:/dev/ttyACM0"

Manuelles Starten über service knxd start führt genau zum gewünschten Ergebnis.

Autostart nach reboot funktioniert nicht. Im Unterschied zu speedschmidt läuft bei mir ja, so wie ich es verstanden habe, kein systemd. Auch sehe ich überall in den /etc/rc2.d bis /etc/rc5.d den Link auf S02knxd.
Wenn ich den Aufruf um Parameter -f 9 ergänze, passiert nichts. Eine /var/log/eibd.log gibt es nicht. Jessie habe ich ebenfalls nicht.

Habt ihr Ideen was schief gelaufen sein könnte / wo ich hinschauen muss?

Grüße
Marcel

 

decade-submarginal