Autor Thema: "Save Config ?" verschwindet nicht  (Gelesen 2292 mal)

Offline dantist

  • Full Member
  • ***
  • Beiträge: 261
"Save Config ?" verschwindet nicht
« am: 02 Juli 2015, 22:56:18 »
Hallo,

seit ein paar Stunden habe ich das Problem, dass der Button "Save Config ?" nicht mehr verschwindet.

Wenn man ihn anklickt, wird er ausgeblendet, beim nächsten Klick in der Weboberfläche ist er sofort wieder da. Auch mein Texteditor meldet jedes Mal eine Aktualisierung der Config, obwohl ein diff ergibt, dass sich nichts geändert hat. Tatsächliche Änderungen werden weiterhin korrekt gespeichert, aber der Button mit dem orangen Fragezeichen bleibt.

Ein shutdown restart hat auch nicht geholfen.

EDIT: Wie es aussieht, liegt es an einem oft gefeuerten notify, das folgenden Befehl auslöst:
attr ZuHause userattr $NAME
Der Befehl wird bei jedem notify in der Config gespeichert. Lässt sich das irgendwie umgehen?

EDIT 2: Habe es gelöst, indem ich einen zweiten Dummy anstelle eines Attributs angelegt habe. Der Thread kann eigentlich weg  ::)

Gruß
Daniel
« Letzte Änderung: 02 Juli 2015, 23:52:03 von dantist »

Offline fhem-hm-knecht

  • Hero Member
  • *****
  • Beiträge: 2216
  • Fhem User seit 2010
Antw:"Save Config ?" verschwindet nicht
« Antwort #1 am: 03 Juli 2015, 02:09:36 »
Ich hab den Nerve SaveButton schon lange entsorgt,
ist leider so, für neuanfänger ganz ok, ;)
Hary


HC 1  getrennte Fhem Instanzen HM|INETdienste|Heizung|TEST|Bedienoberfläche -->alles nur noch über MQTT2 und CLIENT auch abgesetzte Pi's/LAN

Offline rudolfkoenig

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 22552
Antw:"Save Config ?" verschwindet nicht
« Antwort #2 am: 03 Juli 2015, 07:10:07 »
Um irgendwelche Zustaende zu speichern sollte man nicht Attribute aendern, sondern entweder Status oder Readings modifizieren. Der Aufwand fuers Nachforschen haelt sich in Grenzen: ein Klick auf das Fragezeigen zeigt was sich geaendert hat.
Gefällt mir Gefällt mir x 2 Liste anzeigen

Offline dantist

  • Full Member
  • ***
  • Beiträge: 261
Antw:"Save Config ?" verschwindet nicht
« Antwort #3 am: 03 Juli 2015, 09:16:28 »
ein Klick auf das Fragezeigen zeigt was sich geaendert hat.

Danke für den Tip, das war mir nicht bewusst  :)

Offline fstefan1960

  • Full Member
  • ***
  • Beiträge: 249
  • FHEM ist Hobby und Luxus zugleich ...
Antw:"Save Config ?" verschwindet nicht
« Antwort #4 am: 03 Juli 2015, 15:52:28 »
Der Thread hat mir einige neue Infos gebracht, daher bitte nicht löschen. Das hilft sicher auch anderen ... :D
FHEM auf PC: CUL868, CUL 443, HM_LAN, JeeLink
FHEM auf Raspi: CUL868
div. LaCrosse Temp/Hum-Sensoren, HM-Heizkörperventile, Schaltaktoren, etc.
Zustimmung Zustimmung x 1 Liste anzeigen

 

decade-submarginal