Autor Thema: Neues Modul - 74_Unifi - Für den Ubiquiti Networks (UBNT) - Unifi Controller  (Gelesen 297438 mal)

Offline remo

  • Full Member
  • ***
  • Beiträge: 168
Guten Abend.

Wenn ich mich mal mit einem Anliegen einreihen dürfte…

Ich nutze set UNIFI switchSiteLEDs on und
set UNIFI switchSiteLEDs off mit jeweils einem at, um meine FlexHD
als „Nachtlicht“ benutzen zu wollen.

Leider funktioniert das nicht.
Ein manuelles ON oder OFF funktioniert nur manchmal.
Nämlich dann, wenn ich die LEDs zuvor im Controller manuell deaktiviert und wieder aktiviert habe.
 
Die at an sich schalten grundsätzlich- getestet mit einem normalen Schalter.

Dennoch, aktiviere ich die LEDs am Abend manuell über den Controller, sind diese am nächsten Morgen auch aus. Korrekt soweit. Aber sie schalten am Abend nicht wieder ein. Das muss ich dann wieder über den Controller erledigen…

Ist dazu etwas bekannt?


Ich wünsche einen schönen Abend.


Offline Freibeuter

  • Full Member
  • ***
  • Beiträge: 142
Hallo,
habe das Problem nur, wenn ich mehrere Befehle an den Unifi Controller versende ( Schalte Nachts einige AP per POE an Switch aus), dann kommt Murks dabei heraus, wenn ich zwischen den Befehlen 90 Sekunden Wait habe ( DOIF), dann läuft es.
Ist im Controller ja auch so, wenn ein Gerät beim Provisioning ist, kann man ja auch nichts ändern.

Offline remo

  • Full Member
  • ***
  • Beiträge: 168
Hi. Ok.
Eigentlich finden zu diesen Zeiten keine Befehle Richtung Controller statt..

Offline remo

  • Full Member
  • ***
  • Beiträge: 168
So. Heute lief eigenartigerweise alles nach Plan.
Beobachten.

Offline remo

  • Full Member
  • ***
  • Beiträge: 168
Ich wieder.

switchSiteLEDs off mittels at funktioniert super und zuverlässig.
on hat von 10x nur 1x funktioniert.

Eigenartig.

Ist dazu ein Bug bekannt?

Offline Wolle02

  • Sr. Member
  • ****
  • Beiträge: 581
Ich habe letztes Wochenende meine UDM Pro auf Firmware Version 1.10.0 upgedatet und im Anschluss die Network Application auf Version 6.4.54 gebracht. Jetzt ist mir aufgefallen, dass in Fhem die UDM Pro als "disconnected" angezeigt wird. Sowohl mit der Originalversion von 74_Unifi als auch mit dem Patch aus #1520 (https://forum.fhem.de/index.php/topic,40287.msg1169883.html#msg1169883) bekomme ich beim Einloggen mit verbose 5 im Logfile ein "Failed with HTTP Code 404!" angezeigt.
Ein Reload 74_Unifi und ein erneutes Einloggen (modify-Button)habe ich durchgeführt.

Hier mal ein Logfileauszug:
2021.10.15 11:04:12 5: UniFi_UDM (Unifi_Login_Send) - executed.
2021.10.15 11:04:12 5: UniFi_UDM (Unifi_Login_Receive) - executed.
2021.10.15 11:04:12 5: UniFi_UDM (Unifi_Login_Receive) - Failed with HTTP Code 404!
2021.10.15 11:04:12 5: UniFi_UDM (Unifi_Login_Receive) - Connect/Login to Unifi-Controller failed. Will try again after interval...
2021.10.15 11:04:17 5: UniFi_UDM: get called with ?.
2021.10.15 11:04:24 5: UniFi_UDM: Defined with url:https://192.168.1.1/proxy/network/api/s/default/, interval:30
2021.10.15 11:04:24 5: UniFi_UDM (Unifi_Notify) - executed.
2021.10.15 11:04:24 5: UniFi_UDM (Unifi_Notify) - checking 1 0_newClients
2021.10.15 11:04:24 5: UniFi_UDM (Unifi_Notify) - checking 1 0_WLAN_Clients
2021.10.15 11:04:24 5: UniFi_UDM (Unifi_Notify) - checking 1 0_WLAN_Status
2021.10.15 11:04:24 5: UniFi_UDM (Unifi_Notify) - checking 1 0_WAN_IP
2021.10.15 11:04:24 5: UniFi_UDM (Unifi_Notify) - checking 1 0_Gast_WLAN_Clients
2021.10.15 11:04:24 5: UniFi_UDM (Unifi_Notify) - checking 1 state
2021.10.15 11:04:24 5: UniFi_UDM (Unifi_Notify) - executed. - Remove all Timers & Call DoUpdate...
2021.10.15 11:04:24 5: UniFi_UDM (Unifi_DoUpdate) - executed.
2021.10.15 11:04:24 5: UniFi_UDM (Unifi_Login_Send) - executed.
2021.10.15 11:04:24 5: UniFi_UDM (Unifi_initCustomClientReadings) - parsed part: .  ->  ^accesspoint|^essid|^hostname|^last_seen|^snr|^uptime
2021.10.15 11:04:24 5: UniFi_UDM (Unifi_initCustomClientReadings) - parsed Attribute customClientReadings: {"attr_value":".:^accesspoint|^essid|^hostname|^last_seen|^snr|^uptime","parts":{"0000000_part":{"ReadingRegEx":"^accesspoint|^essid|^hostname|^last_seen|^snr|^uptime","nameRegEx":"."}}}.
2021.10.15 11:04:25 5: UniFi_UDM (Unifi_Login_Receive) - executed.
2021.10.15 11:04:25 1: PERL WARNING: Use of uninitialized value in string eq at ./FHEM/74_Unifi.pm line 949.
2021.10.15 11:04:25 1: PERL WARNING: Use of uninitialized value in concatenation (.) or string at ./FHEM/74_Unifi.pm line 988.
2021.10.15 11:04:25 5: UniFi_UDM (Unifi_Login_Receive) - Login Failed (without msg)! - state:''
2021.10.15 11:04:25 5: UniFi_UDM (Unifi_Login_Receive) - Connect/Login to Unifi-Controller failed. Will try again after interval...
2021.10.15 11:04:55 5: UniFi_UDM (Unifi_Login_Send) - executed.
2021.10.15 11:04:56 5: UniFi_UDM (Unifi_Login_Receive) - executed.
2021.10.15 11:04:56 5: UniFi_UDM (Unifi_Login_Receive) - Login Failed (without msg)! - state:''
2021.10.15 11:04:56 5: UniFi_UDM (Unifi_Login_Receive) - Connect/Login to Unifi-Controller failed. Will try again after interval...
2021.10.15 11:05:26 5: UniFi_UDM (Unifi_Login_Send) - executed.
2021.10.15 11:05:28 5: UniFi_UDM (Unifi_Login_Receive) - executed.
2021.10.15 11:05:28 5: UniFi_UDM (Unifi_Login_Receive) - Login Failed (without msg)! - state:''
2021.10.15 11:05:28 5: UniFi_UDM (Unifi_Login_Receive) - Connect/Login to Unifi-Controller failed. Will try again after interval...
2021.10.15 11:05:58 5: UniFi_UDM (Unifi_Login_Send) - executed.

Scheinbar wurde seitens Ubiquiti wieder etwas am Einlogprozedere geändert? Oder habe ich hier irgendwas versäumt?

Offline Masterfunk

  • Full Member
  • ***
  • Beiträge: 309
Ich habe gerade festgestellt das bei mir das Modul keine Unifi Devices (Switche, AP etc.)mehr aktualisiert bzw. neu einloiest. Daher geht auch Unifi Switch nicht mehr.

Hab eine UDM-Pro aktuelle EA.

Hat sonst noch wer das Problem?

Offline hoppel118

  • Hero Member
  • *****
  • Beiträge: 1095
Ich habe letztes Wochenende meine UDM Pro auf Firmware Version 1.10.0 upgedatet und im Anschluss die Network Application auf Version 6.4.54 gebracht. Jetzt ist mir aufgefallen, dass in Fhem die UDM Pro als "disconnected" angezeigt wird. Sowohl mit der Originalversion von 74_Unifi als auch mit dem Patch aus #1520 (https://forum.fhem.de/index.php/topic,40287.msg1169883.html#msg1169883) bekomme ich beim Einloggen mit verbose 5 im Logfile ein "Failed with HTTP Code 404!" angezeigt.
Ein Reload 74_Unifi und ein erneutes Einloggen (modify-Button)habe ich durchgeführt.

Hier mal ein Logfileauszug:
2021.10.15 11:04:12 5: UniFi_UDM (Unifi_Login_Send) - executed.
2021.10.15 11:04:12 5: UniFi_UDM (Unifi_Login_Receive) - executed.
2021.10.15 11:04:12 5: UniFi_UDM (Unifi_Login_Receive) - Failed with HTTP Code 404!
2021.10.15 11:04:12 5: UniFi_UDM (Unifi_Login_Receive) - Connect/Login to Unifi-Controller failed. Will try again after interval...
2021.10.15 11:04:17 5: UniFi_UDM: get called with ?.
2021.10.15 11:04:24 5: UniFi_UDM: Defined with url:https://192.168.1.1/proxy/network/api/s/default/, interval:30
2021.10.15 11:04:24 5: UniFi_UDM (Unifi_Notify) - executed.
2021.10.15 11:04:24 5: UniFi_UDM (Unifi_Notify) - checking 1 0_newClients
2021.10.15 11:04:24 5: UniFi_UDM (Unifi_Notify) - checking 1 0_WLAN_Clients
2021.10.15 11:04:24 5: UniFi_UDM (Unifi_Notify) - checking 1 0_WLAN_Status
2021.10.15 11:04:24 5: UniFi_UDM (Unifi_Notify) - checking 1 0_WAN_IP
2021.10.15 11:04:24 5: UniFi_UDM (Unifi_Notify) - checking 1 0_Gast_WLAN_Clients
2021.10.15 11:04:24 5: UniFi_UDM (Unifi_Notify) - checking 1 state
2021.10.15 11:04:24 5: UniFi_UDM (Unifi_Notify) - executed. - Remove all Timers & Call DoUpdate...
2021.10.15 11:04:24 5: UniFi_UDM (Unifi_DoUpdate) - executed.
2021.10.15 11:04:24 5: UniFi_UDM (Unifi_Login_Send) - executed.
2021.10.15 11:04:24 5: UniFi_UDM (Unifi_initCustomClientReadings) - parsed part: .  ->  ^accesspoint|^essid|^hostname|^last_seen|^snr|^uptime
2021.10.15 11:04:24 5: UniFi_UDM (Unifi_initCustomClientReadings) - parsed Attribute customClientReadings: {"attr_value":".:^accesspoint|^essid|^hostname|^last_seen|^snr|^uptime","parts":{"0000000_part":{"ReadingRegEx":"^accesspoint|^essid|^hostname|^last_seen|^snr|^uptime","nameRegEx":"."}}}.
2021.10.15 11:04:25 5: UniFi_UDM (Unifi_Login_Receive) - executed.
2021.10.15 11:04:25 1: PERL WARNING: Use of uninitialized value in string eq at ./FHEM/74_Unifi.pm line 949.
2021.10.15 11:04:25 1: PERL WARNING: Use of uninitialized value in concatenation (.) or string at ./FHEM/74_Unifi.pm line 988.
2021.10.15 11:04:25 5: UniFi_UDM (Unifi_Login_Receive) - Login Failed (without msg)! - state:''
2021.10.15 11:04:25 5: UniFi_UDM (Unifi_Login_Receive) - Connect/Login to Unifi-Controller failed. Will try again after interval...
2021.10.15 11:04:55 5: UniFi_UDM (Unifi_Login_Send) - executed.
2021.10.15 11:04:56 5: UniFi_UDM (Unifi_Login_Receive) - executed.
2021.10.15 11:04:56 5: UniFi_UDM (Unifi_Login_Receive) - Login Failed (without msg)! - state:''
2021.10.15 11:04:56 5: UniFi_UDM (Unifi_Login_Receive) - Connect/Login to Unifi-Controller failed. Will try again after interval...
2021.10.15 11:05:26 5: UniFi_UDM (Unifi_Login_Send) - executed.
2021.10.15 11:05:28 5: UniFi_UDM (Unifi_Login_Receive) - executed.
2021.10.15 11:05:28 5: UniFi_UDM (Unifi_Login_Receive) - Login Failed (without msg)! - state:''
2021.10.15 11:05:28 5: UniFi_UDM (Unifi_Login_Receive) - Connect/Login to Unifi-Controller failed. Will try again after interval...
2021.10.15 11:05:58 5: UniFi_UDM (Unifi_Login_Send) - executed.

Scheinbar wurde seitens Ubiquiti wieder etwas am Einlogprozedere geändert? Oder habe ich hier irgendwas versäumt?

Habe die gleiche UDM-Pro und Network Application installiert. Bei mir läuft noch alles.

Gruß Hoppel
Server: Openmediavault, XEON E3-1240L-v5, Supermicro X11SSH-CTF, 64GB ECC RAM, SSD, RAID-Z2
Homebridge | Alexa | Yowsup
Homematic: VCCU 2xHMUSB, 1xWLGW | HomeConnect | Philips Hue | Sonos: Beam, Sub, One, Symfonisk | Unifi: USG, USW, AC-AP-Pro | Xiaomi: S50, Smart Fan | vbus: Vitosolic 200SD4

Offline Fillip

  • Full Member
  • ***
  • Beiträge: 122
    • Blog
Ich habe gerade festgestellt das bei mir das Modul keine Unifi Devices (Switche, AP etc.)mehr aktualisiert bzw. neu einloiest. Daher geht auch Unifi Switch nicht mehr.

Hab eine UDM-Pro aktuelle EA.

Hat sonst noch wer das Problem?
Ja, was problem habe ich auch so etwa einmal im Monat, ich definiere das Gerät dann einmal neu, bzw gebe unter DEF die IP, Benutzername und Passwort nochmal neu ein und setzte das Attribut isUDM kurz auf 0 und wieder auf 1, danach läuft es dann wieder

Offline Masterfunk

  • Full Member
  • ***
  • Beiträge: 309
Ja, was problem habe ich auch so etwa einmal im Monat, ich definiere das Gerät dann einmal neu, bzw gebe unter DEF die IP, Benutzername und Passwort nochmal neu ein und setzte das Attribut isUDM kurz auf 0 und wieder auf 1, danach läuft es dann wieder

Hilft bei mir leider nicht.

Offline sTaN

  • Full Member
  • ***
  • Beiträge: 400
Hallo Wuehler,

ich nutze nun schon seit Ewigkeiten das Unifiziert Modul und schiebe schon länger das Problem vor mir her, dass beim Ein- und Ausschalten meiner Gäste WLAN SSID auch immer das normale WLAN Ein- bzw. ausgeschaltet wird.
Schalte ich also über z.B.: FHEM Web im Controller mittels set disableWLAN NameSSID_guest aus, wird auch mein normales WLAN mit NameSSID kurzzeitig deaktiviert.

Gibt es dafür eine Lösung oder habe ich ggf. nur etwas falsch konfiguriert?
Welche Infos zur Analyse des Problems werden hierfür benötigt?

Ich nutze im Unifi Controller selbst nur ein zweite Wireless Network und keinen Voucher oder Guest Portal etc.

Gruß
sTaN
« Letzte Änderung: 07 November 2021, 15:12:08 von sTaN »
Raspberry Pi 3
2 x CUL CC1101-USB-Lite 868MHz
FS20 Komponenten, Philips HUE, Alexa-Fhem, MAX! Geräte, homebridge, harmony, Unifi, FirtzBox, MQTT, Aurora, Denon, Sonos, TabletUI, CALENDAR, EGPM2LAN, Pushover

Offline MadMax-FHEM

  • Hero Member
  • *****
  • Beiträge: 11300
  • NIVEAu ist keine Creme...
Das ist auch so, wenn du es über den UnifiController direkt machst (zumindest bei mir)...

Hat also mMn nichts mit dem Modul zu tun sondern wie eben der UnifiController die AP "provisioniert"...
...wobei ich nicht weiß, ob die anderen SSDIs wirklich weg sind oder es nur so "aussieht"...

Gruß, Joachim
FHEM PI3B+ Buster: HM-CFG-USB, 40x HM, ZWave-USB, 13x ZWave, EnOcean-PI, 15x EnOcean, HUE/deCONZ, CO2, ESP-Multisensor, Shelly, alexa-fhem, ...
FHEM PI2 Buster: HM-CFG-USB, 25x HM, ZWave-USB, 4x ZWave, EnOcean-PI, 3x EnOcean, Shelly, ha-bridge, ...
FHEM PI3 Buster (Test)
FHEM PI3 RaspiOS (Test)

Offline sTaN

  • Full Member
  • ***
  • Beiträge: 400
Na das ist ja blöd. Also die Clients disconnecten dann auch kurzzeitig und die Verbindung ist weg bzw. wird unterbrochen, daher fällt es ja so auf.
Ansonsten wäre mir das egal. Aber ist mir noch gar nicht aufgefallen, dass es sich im UnifiController selbst auch so verhält.

Gruß
sTaN
Raspberry Pi 3
2 x CUL CC1101-USB-Lite 868MHz
FS20 Komponenten, Philips HUE, Alexa-Fhem, MAX! Geräte, homebridge, harmony, Unifi, FirtzBox, MQTT, Aurora, Denon, Sonos, TabletUI, CALENDAR, EGPM2LAN, Pushover

Offline MadMax-FHEM

  • Hero Member
  • *****
  • Beiträge: 11300
  • NIVEAu ist keine Creme...
Ansonsten wäre mir das egal. Aber ist mir noch gar nicht aufgefallen, dass es sich im UnifiController selbst auch so verhält.

Einfach mal ausprobieren... ;)

Gruß, Joachim
FHEM PI3B+ Buster: HM-CFG-USB, 40x HM, ZWave-USB, 13x ZWave, EnOcean-PI, 15x EnOcean, HUE/deCONZ, CO2, ESP-Multisensor, Shelly, alexa-fhem, ...
FHEM PI2 Buster: HM-CFG-USB, 25x HM, ZWave-USB, 4x ZWave, EnOcean-PI, 3x EnOcean, Shelly, ha-bridge, ...
FHEM PI3 Buster (Test)
FHEM PI3 RaspiOS (Test)