Autor Thema: Newbie Frage: CUNX mit Firmware versehen?  (Gelesen 3990 mal)

macmark

  • Gast
Newbie Frage: CUNX mit Firmware versehen?
« am: 13 Oktober 2015, 18:04:54 »
Hallo zusammen,

habe als Newbie ein paar Fragen und koennte ggf. hilfreiche Links gebrauchen :-)
Ich habe hier einen Raspberry mit Volkszaehler laufen und will diesen nun mithilfe eines CUNX (http://shop.busware.de/product_info.php/cPath/1/products_id/47) erweitern um HomeMatic Sensoren/Aktoren zu nutzen.

Leider ist aktuell keine Firmware installiert, kann mir jemand eine hilfreiche Anleitung schicken?

Die SUFU hat zwar teilweilse geholfen, aber dann fehlten wieder direkte Links zu den Treibern etc. :-/


Bisher gefunden:
http://busware.de/tiki-index.php?page=DFU+Bootloader
CUNX HEX unter https://github.com/tostmann/culfw/tree/culfw-v2.x/Devices/CUNX

Auch unter http://fhemwiki.de/wiki/CUN_unter_Windows_7_64_Bit_flashen finde ich die benoetigten Treiber fuer Windows von SL nicht. :-/

Wuerde es am liebsten per USB am Mac (OS 10.11) oder Win7 flashen.

Ueber eine Hilfestellung waere ich dankbar!

VG
Mark

macmark

  • Gast
erledigt / Antw:Newbie Frage: CUNX mit Firmware versehen?
« Antwort #1 am: 18 Oktober 2015, 12:58:10 »
Hallo nochmal,

kam zwar keinerlei Reaktion, aber falls andere Anfaenger mal selbiges Problem haben anbei die Links.
Habe unter Win7 (64Bit) den CUNx mit FLIP geflasht.


Folgende Schritte waren bei mir erfolgreich:

Flip 3.4.7 laden unter http://www.atmel.com/tools/FLIP.aspx

Direktlink für Windows 98/Me/NT/2000/XP/Vista/7/8
http://www.atmel.com/images/Flip%20Installer%20-%203.4.7.112.exe


Anleitung unter http://www.atmel.com/images/doc8429.pdf
Installation der USB Treiber auf Seite 9 von 13)

Flip starten / Device Select / ATxmega128A4U

Hex File fuer CUNX laden unter https://raw.githubusercontent.com/tostmann/culfw/culfw-v2.x/Devices/CUNX/CUNX.hex

In Flip die entsprechende HEX auswählen via "File / Load Hex" und auf den CUNX laden (Starten im Programmiermodus mit gedrückter Flash Taste)

Anschliessend auf das Gerät senden

Nach dem Anschluss am Router war DHCP aktiv und die entsprechende IP konnte ausgelesen werden.

Die weitere Einrichtung des CUNx in FHEM ist ja ausreichend beschrieben.

VG
Mark

Offline DerFrickler

  • Sr. Member
  • ****
  • Beiträge: 584
Antw:Newbie Frage: CUNX mit Firmware versehen?
« Antwort #2 am: 30 April 2016, 17:48:48 »
Hallo zusammen,

wie kann man dem CUNX eine feste IP Adresse zuweisen?

Gruß!

Offline MarkusAutomaticus

  • Full Member
  • ***
  • Beiträge: 479
Antw:Newbie Frage: CUNX mit Firmware versehen?
« Antwort #3 am: 27 Juli 2016, 15:24:58 »
Hallo,

das macht man normalerweise im Router.
Von der Fritz.box kenne ich es so, dass man in die Geräteübersicht des Heimnetzes geht,
dort das entsprechende Gerät auswählt, dann die Settings editiert.

Dort gibt es einen Punkt der in etwa lautet "immer dieselbe IP-Adresse verwenden".
Dort den Haken setzen und speichern.

Dann vergibt die Fritz.Box immer wenn sich das Gerät im Netz anmeldet, dieselbe IP-Adresse

Gruß
Markus
FHEM 5.8 |intel NUC Core i3: Ubuntu 16.04 | z-Wave: Aeon Labs USB Stick | Jeelink (v3c): LaCrosse-Sensoren | DuoFern Stick: Rademacher Gurtwickler | Philips Hue Bridge | CUNX: HomeMatic, EnOcean-Pigator

Offline saddelfest

  • New Member
  • *
  • Beiträge: 22
CUNX mit Firmware versehen DHCP Probleme
« Antwort #4 am: 30 März 2018, 15:49:08 »
Hallo, ich habe mir  ebenfalls einen CUNX von Busware gekauft. Mit einen Pigator Modul für OW Sensoren.
Wollte jetzt die Firmware updaten und habe mir dazu auf einem Windows Rechner (ansonsten verwende ich MAC) FLIP installiert. Der CUNX wurde dort auch am USB erkannt und ich konnte die HEX Datei dort hin senden. Weiss nicht ob das geklappt hat. Fehlermeldung kam keine allerdings kommen mir zwei Dinge eigenartig vor:
1) die LED hat ständig geleuchtet, obwohl ich die Programmiertaste gedrückt hielt als ich den USB Port verbunden hab. Ich dachte die LED zeigt irgendwie den Programmiermodus durch blinken an...

2) die USB Veribndung wurde nach der Übertragung automatisch unterbrochen und ich weiß nicht, ob das normal ist.

Hab dann den CUNX danach jedenfalls an mein Heimnetzwerk angeschlossen. Leider bekommt das Gerät keine IP Adresse zugewiesen und ich kann ihn über FHEM nicht ansprechen, um zu sehen, ob er funktioniert.
Hab auch schon mal den CUNX direkt über USB mit dem raspberry verbunden. Er wird in FHEM nicht automatisch erkannt - bei einm CUL- USB Stick dagegen funktioniert das autodetect problemlos.

Wer kennt sich mit CUNX aus und kann mir ein paar Tipps geben.
Dokumentation zu dem Teil ist etwas dürftig oder ich hab noch nicht die richtige Seite gefunden.
Schöne Osterfeiertage,
Manfred

 

Offline saddelfest

  • New Member
  • *
  • Beiträge: 22
Antw:Newbie Frage: CUNX mit Firmware versehen?
« Antwort #5 am: 02 April 2018, 22:43:39 »
keine antwort. Benutzt hier keiner den CUNNX unter FHEM?

Offline noansi

  • Sr. Member
  • ****
  • Beiträge: 594
Antw:Newbie Frage: CUNX mit Firmware versehen?
« Antwort #6 am: 04 April 2018, 19:37:58 »
Hallo Manfred,

bezüglich IP Adresse schau mal hier:
https://forum.fhem.de/index.php/topic,83300.msg757823.html#msg757823

Bedingt dann aber auch eine funktionierende USB Verbindung zum CUNX um die Befehle hin schicken zu können und die Antworten zu betrachten.
z.B. danach https://forum.fhem.de/index.php/topic,83300.msg757036.html#msg757036

Zitat
Hab auch schon mal den CUNX direkt über USB mit dem raspberry verbunden. Er wird in FHEM nicht automatisch erkannt - bei einm CUL- USB Stick dagegen funktioniert das autodetect problemlos./quote]
Nach autodetect code sollte der CUNX automatisch erkannt werden, sofern richtig angewendet.
usb scansollte ihn finden und
usb createauch anlegen.

CUNX muss dazu auf 'V' mit dem Versionsstring antworten. Wenn er das nicht tut, dann war Dein Flashversuch nicht erfolgreich.
Wenn mit Strom versorgt sollte die orange Led zwischen Netzwerk- und USB-Anschluss auch langsam Blinken.

Gruß, Ansgar.

Offline saddelfest

  • New Member
  • *
  • Beiträge: 22
CUNX lässt mich verzweifeln...
« Antwort #7 am: 16 April 2018, 12:34:13 »
Hallo,
alle meine Bemühungen, den CUNX in Betrieb zu nehmen waren bisher leider erfolglos. Ich weiß nicht woran es liegt und leider finde ich die Unterstützung durch Busware bzw Doku im Internet nicht sehr zufriedenstellend. Ich weiß nicht, ob das Modul überhaupt auf meine Bemühungen reagiert. Egal, ob mit gedrückter Programmiertaste oder ohne, die LED unter dem Taster leuchte immer konstant grün. Ich hätte gedacht, da gibt es eine Art Rückmeldung, ob das Modul in den Programmiermodus gestzt wurde, z.B. indem die LED blinkt oder so.
Was ich bisher versucht habe: 
1) mit einem Windos PC und FLIP die Firmware einzuspielen. Modul wurde am USB Port erkannt und ich konnet den Treiber dafür installieren. Dann mit FLIP das hex File übertragn und alles lief ohne probleme durch. Danach wurd das Modul allerdings nicht mehr in meinem Netzwerk erkannt und ich kann nicht darauf zugreifen.
2) Der Versuch über den Raspberry mit neuem Raspbian klappte nicht, da der DFU-Programmer nicht installiert werden konnte
3) Dann wollte ich es gemäß der Anleitung
https://www.fam-moser.de/blog/computer/fhem/cunx-vorbereiten.html
versuchen. Habe dazu UNBUNTU auf meinem Raspberry installiert und bin nach der Anleitung vorgegangen:
Alles lief ohne Problem bis zum entscheidenden Schritt:
sudo dfu-programmer atxmega128a4u flash CUNX.hex
Da kam die fehlermeldung
Error opening the file. Something went wrong with creating the memory image.
Jetzt bin ich einigermaßen ratlos.
Weder eine Nachfrage beim Verfasser des Blogs noch bei Herrn Tostmann (Busware) brachte bisher eine Lösung.

Wenn jemand hier eine Idee hat, wäre ich dafür sehr dankbar.
Ansonsten muss ich nach einer anderen Lösung suchen, wie ich meine One-Wire Sensoren sinnvoll in FHEM einbinden kann. Ich dachte der CUNX mit OW-Pigator Modul wäre eine optimale Lösung.
Scheint leider nicht zu funktionieren. Vielleicht ist es ja auch ein reines Hardware problem und das Modul ist defekt...

Schöne Grüße, Manfred
 

Offline noansi

  • Sr. Member
  • ****
  • Beiträge: 594
Antw:Newbie Frage: CUNX mit Firmware versehen?
« Antwort #8 am: 16 April 2018, 20:44:00 »
Hallo Manfred,

Zitat
mit gedrückter Programmiertaste
mit Strom versorgt -> grüne LED leuchtet konstant
Das Drücken kann, montiert im Gehäuse, aber auch daneben gehen, da der Taster recht klein ist.
Die dmesg Ausgabe sollte zeigen, dass er als Product DFU ATXMEGA128A4U, Manufacturer ATMEL erkannt wird.

Zitat
oder ohne
-> grüne LED leuchtet konstant und die orange sollte langsam blinken, wenn die Firmware erfolgreich geflashed ist und anläuft
Die dmesg Ausgabe sollte zeigen, dass er als Product CUL868, Manufacturer busware erkannt wird.

Zitat
Danach wurd das Modul allerdings nicht mehr in meinem Netzwerk erkannt und ich kann nicht darauf zugreifen.
Teste erst, ob es mit USB geht!
Netzwerk geht erst mit manueller Einstellung der IP-Adresse!

Zitat
Error opening the file. Something went wrong with creating the memory image.
??? zuvor cd zum richtigen Ordner, in dem die CUNX.hex liegt?
Speicherlimit erreicht?
Hex Datei korrupt?
falsche Version dfu-programmer?
Zitat
###Flashen Mit der Version 0.7.0+ des dfu-programmers

Gruß, Ansgar.

Offline saddelfest

  • New Member
  • *
  • Beiträge: 22
Antw:Newbie Frage: CUNX mit Firmware versehen?
« Antwort #9 am: 27 April 2018, 14:19:03 »
Hallo Ansgar, vielen Dank für die Tipps. ich bin inzwischen schon ein paar Schritte weiter gekommen. Dank tatkräftiger Unterstützung von Experten. Leider sind die Fortschritte halt aber immer jwweils nur kleine Schritte. Das Flashen hat funktioniert und das Gerät wird auch am USB erkannt. Auch attr frequency: SlowRf geht und FS 20 Aktoren werden automatisch erkannt, sobald ich sie manuell betätige und anlerne.  D.h die Funktion als CUL ist schon mal gegeben. Aber dafür habe ich mir den CUNX eigentlich nicht gekauft (das machen schon meine CUL USB sticks recht zuverlässig ). EIGENTLICH möchte ich gerne einen CUL in meinem LAN zur verfügung stellen. und damit größere Entfernungen zwischen meinem FHEM Server (RPI 3)  und meinen Sensoren/Aktoren realisieren.  UND langfristig will ich über das PIGATOR Modul des CUNX ein 1-wire SensorNetzwerk  auslesen.


Nach dem Flaschen des CUNX hab ich die USB Verbindung zum RPi getrennt und den CUNX ans LAN angeschlossen. Die Fritzbox hat ihn leider nicht erkannt (kein DHCP) und ich hab über FHEM raw Befehle manuell eine Netzwerkadresse zugewiesen.  Auch nach dieser Aktion wurde der CUNX nicht in der Fritzbox unter Netzwerkgeräte gelistet und ich war mir nicht sicher ob de manuelle Adresszuweisung funktioniert hat.  Allerdings hab ich ihn dann per NMAP vom RPi aus gefunden. Die dort aufgelistete Netzwerkadresse 192.168.xxx.40 hab ich dann in FHEM einem CUL1 zugewiesen unter Port 2323. CUL1 steht jetzt auch auf 2initialized" und ich kann raw Befehle an das Gerät schicken und mir z.B. die Version anzeigen lassen.

Allerdings klappt es über das Netzwerk nicht, die Frequenz auf SlowRF zu stellen. d.h. die FS20 Aktoren werden nicht erkannt, während das bei Verbindung über USB tadellos ging. Das Pigator Modul CUL2 unter derselben Netzwerk Adresse aber Port 2324 steht auf "started". Damit kann ich im Moment noch nicht viel anfangen. Langfristig will ich damit OW Temperatursensoren in dem (Heiz) Raum abfragen. Leider hab ich dazu bisher noch keinerlei Info im Netz gefunden, wie ich das in FHEM realisiere. gehe davon aus, dass ich erst einen OW Server installieren muss,  und diesem irgendie beibringen, dass er die Sensoren über das PIGATOR Modul auslesen soll.

Zunächst möchte ich allerdings erst mal das CUNX Modul besser verstehen und in Betrieb nehmen.

Wünsche schon mal ein schönes verlängertes Wochenende.

Manfred


 

Offline noansi

  • Sr. Member
  • ****
  • Beiträge: 594
Antw:Newbie Frage: CUNX mit Firmware versehen?
« Antwort #10 am: 28 April 2018, 00:16:31 »
Hallo Manfred,

Zitat
mir z.B. die Version anzeigen lassen
Dann hast Du Verbindung, wenn sie Versionsabfrage mit "V 2.67 CUL868" beantwortet wird.

Zitat
attr frequency: SlowRf
Du meinst wohl
attr CUL1 rfmode SlowRF
Wenn Du
attr CUL1 verbose 5einstellst, dann sollten F....... Nachrichten in Deinem Log auftauchen, wenn FS20 Nachrichten empfangen werden.
Werden keine empfangen, dann kontrolliere mit ccconf mal, ob CUNX noch auf 868.3MHz steht.
Wenn sie empfangen werden, dann werden sie in FHEM auch genauso verarbeitet, wie bei Anschluss über USB.

Mehr kann ich Dir dazu leider nicht weiter helfen, da ich weder FS20 noch Onewire im Einsatz habe.

Gruß, Ansgar.
« Letzte Änderung: 28 April 2018, 11:53:30 von noansi »

Offline saddelfest

  • New Member
  • *
  • Beiträge: 22
Antw:Newbie Frage: CUNX mit Firmware versehen?
« Antwort #11 am: 29 April 2018, 22:01:28 »
Hallo Ansgar. das war in der Tat der Fehler.
Frequenz stand uf 0.000MHz. Sehr eigenartig- hatte ich doch
attr CUN1 rfmode SlowRF
gesetzt.
Hab jetzt alle Daten derr CCConf manuell gesetzt und jetzt funktioniert's am LAN mit fester IP Adresse ebenso wie am USB Port d.h.    FX 20 Aktoren  werden erkannt und können geschaltet werden


In meinem Übermut wollte ich jetzt auch gleich as OW Pigator Modul in Betrieb nehmen.

Steht in FHEM unter  der gleichen IP-Adresse mit Port 2324 (state "opened"
Bin dazu nach der Busware Anleitung vorgegangen. Lief alles ohne Fehlermeldungen.
leider liefert i2cdetect -y 1nur leere Einträge d.h. dass der OW Adapter nicht gefunden wird. Egal ob ich einen OW sensor angeklemmt habe, oder nicht, es sind immer alle Einträge leer.


     0  1  2  3  4  5  6  7  8  9  a  b  c  d  e  f
00:          -- -- -- -- -- -- -- -- -- -- -- -- --
10: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
20: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
30: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
40: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
50: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
60: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
70: -- -- -- -- -- -- -- --

OWServer und OWHTTP neu gestartet.

Das Webinterface raspberry:2121kann ich starten, aber ich auch dort finde ich keine Devices/Sensoren.

Schöne grüße,
Manfred

Offline noansi

  • Sr. Member
  • ****
  • Beiträge: 594
Antw:Newbie Frage: CUNX mit Firmware versehen?
« Antwort #12 am: 30 April 2018, 03:05:57 »
Hallo Manfred,

Zitat
Frequenz stand uf 0.000MHz. Sehr eigenartig- hatte ich doch
attr CUN1 rfmode SlowRF
gesetzt.
Das eine hat mit dem anderen nichts zu tun. die Frequenz ist im EEPROM des CUNX gespeichert. Und wenn da Quatsch drin steht, dann kommt Quatsch raus.
Das Attribut legt lediglich den grundsätzlichen Betriebsmodus fest.

Mit raw e kannst du das EEPROM neu mit den Defaults beschreiben. Danach musst Du allerdings auch die Netzwerkadresse wieder neu einstellen, weil die dabei auch wieder zurück gesetzt wird.

Und wie schon geschrieben, zu OneWire habe ich keine Erfahrungen beizusteuern.

Gruß, Ansgar.

Offline saddelfest

  • New Member
  • *
  • Beiträge: 22
Antw:Newbie Frage: CUNX mit Firmware versehen?
« Antwort #13 am: 01 Mai 2018, 09:25:30 »
hab's scheinbar hinbekommen:
https://forum.fhem.de/index.php/topic,87442.0.html#new
Vielen Dank nochmal an alle, die hier Untersttzungsarbeit geleistet haben
Manfred

 

decade-submarginal