Autor Thema: Sonos Player disappeared  (Gelesen 59369 mal)

Offline aherby

  • Full Member
  • ***
  • Beiträge: 182
Antw:Sonos Player disappeared
« Antwort #30 am: 13 Januar 2016, 19:33:19 »
Hallo Reiner,

sorry für die Arbeit die ich Dir mache.

Also wenn Sonos im FHEM hängen bleibt kann ich weiterhin die Geräte über die Sonos-App oder den alten Raspi steuern.

Auf den Raspi und Raspi2 sind scheinbar die „vergleichbaren“ Modul-Stände:

Zitat
# SONOS.pm (c) by Reiner Leins, December 2015
# rleins at lmsoft dot de
#
# $Id: 00_SONOS.pm 10316 2015-12-31 11:29:40Z rleins $


Ich schalte z.B nachts immer das Sonos-Hauptgerät (Playbar) aus.
Es kann Zufall sein aber durch das Ausschalten kommt glaube ich der „Fehler“ schneller.

Auf den Raspi funktioniert das Sonos-Modul ohne Problem auch mit

set Sonos RescanNetwork

Auf den Raspi2, wo gestern eine komplette Neuinstallation erst mit „Wheezy“ und dann zum Vergleichstest mit „Jessie“
durchgeführt wurde, hängt sich das Modul auf.
Ich starte dann immer FHEM neu, dadurch funktioniert das Modul lang. Sprich um 16:00 Uhr wird neugestartet und Sonos ist bis Mitternacht steuerbar.
Morgens um 06:00 Uhr sind die Player nicht steuerbar. Heute morgen habe ich dann die Playbar ausgeschaltet und der Fehler ist recht schnell wieder gekommen.

Anbei mal meine Logs, ich hoffe sie sind brauchbar.

Wenn ich weitere Informationen liefern kann, einfach melden.

Danke

Mfg Alex
FHEM 6.0 auf Raspberry Pi 4b 4GB, RaspberryMatic auf Raspi3b mit Charly-Funkmodul, ZigeeBridge mt deCONZ... . Homematic mittels HMCCU, Sonos 3xS1, 1xS6 (Play5 in der 2te Generation), 1xS9 (Soundbar), 1x SonosSub
1-Wire® to I2C host interface with ESD mit DS18B/S20.

Offline Reinerlein

  • Developer
  • Hero Member
  • ****
  • Beiträge: 2134
Antw:Sonos Player disappeared
« Antwort #31 am: 13 Januar 2016, 22:49:00 »
Hi Alex,

hmm... also um 7:36:58 hast du ein kurzes Netzwerkproblem, da dein HMLAN 10 Sekunden vorher auch einen Timeout gemeldet hatte.
Zu diesem Zeitpunkt hat sich der Player offiziell abgemeldet (mittels eines UPnP-ByeBye-Signals), ist aber weiterhin per Ping erreichbar gewesen. Damit kann das Modul mit sicherheit eher weniger gut umgehen. Kannst du mal den Pingtype testweise auf icmp umstellen? Das braucht aber Root-Rechte...

Des Weiteren verwendest du die 6.1er Firmware. Vielleicht läuft die auch noch nicht richtig rund, oder hat neue Features, die im Modul berücksichtigt werden müssten... Das kann ich so aber nicht sagen...

Das mit dem ByeBye-Signal melden die Player eigentlich nur, wenn sie wieder eingeschaltet werden. Erst ein kurzes ByeBye und direkt hinterher ein DeviceAdd-Signal... Das sieht hier etwas anders aus... Vielleicht eine Folge der Firmware...

Grüße
Reiner

Offline aherby

  • Full Member
  • ***
  • Beiträge: 182
Antw:Sonos Player disappeared
« Antwort #32 am: 14 Januar 2016, 07:52:49 »
Hi Reiner,
danke dass du dir schon wieder Zeit genommen hast.

Die Sonos-Firmwar 6.1 ist die letzte, die es von Sonos gibt. Ein weiteres Update habe ich nicht gefunden.

Komisch ist nur, dass der Raspi im gleichen Netzwerk weiterläuft, nur der Rasp2 dann Probleme macht.
Wobei der Raspi, die Playbar und andere Geräte direkt an einem Switch angeschlossen sind und der Raspi2
an der „vorgelagertem“ Router.

Ok ich sollte vielleicht mal aufschreiben wann ich die Playbar vom Netz trenne und beobachten was dann im Netzwerk passiert.
Vorhin ein Test, wo nur 10 Min die Playbar ausgeschaltet wurde, verlief ohne Probleme. Werde es nachher noch mal testen und dann die Log´s
von beiden Raspi´s mitschicken.

Um ein Ping vom Typ icml auszulösen, muss ich doch irgendwie fhem als root laufen lassen oder?
Dazu fehlt mir jetzt vor der Arbeit die Zeit, um mich einzulesen wie ich das geschickt anstelle.
Gibt es dazu hier im Forum was?

So die Arbeit ruft.....

Danke erstmal

Gruß Alex



FHEM 6.0 auf Raspberry Pi 4b 4GB, RaspberryMatic auf Raspi3b mit Charly-Funkmodul, ZigeeBridge mt deCONZ... . Homematic mittels HMCCU, Sonos 3xS1, 1xS6 (Play5 in der 2te Generation), 1xS9 (Soundbar), 1x SonosSub
1-Wire® to I2C host interface with ESD mit DS18B/S20.

Offline Reinerlein

  • Developer
  • Hero Member
  • ****
  • Beiträge: 2134
Antw:Sonos Player disappeared
« Antwort #33 am: 14 Januar 2016, 09:36:10 »
Hi Alex,

die Firmware 6.1 klingt neuer als die letzte Offizielle :) Ich habe hier nur 6.0. Es ist wohl eine Vorab- oder Betaversion?

Zum Root-laufen-lassen:
Du musst nur temporär die Zeile mit dem Benutzer "fhem" in der Datei "/etc/passwd" mittels eines vorangestellten "#" deaktivieren, und fhem mittels "sudo" direkt auf der Konsole starten (vorher den alten Prozess beenden)...

Schau mal, ob der vorgelagerte Router um die Zeit einen Neustart gemacht hat. Manchmal gehen die ja auch kaputt, und zeigen komische Verhaltensweisen :) Meiner tut das gerade auch, und wird damit nach 4,5 Jahren durchgehendem Betrieb demnächst ausgetauscht...

Grüße
Reiner

Offline Nobby1805

  • Sr. Member
  • ****
  • Beiträge: 692
Antw:Sonos Player disappeared
« Antwort #34 am: 14 Januar 2016, 11:10:15 »
6.1.1 fügt Unterstützung für das Betaprogramm zu Apple Music auf Sonos hinzu, für den Mainstream gibt es 6.0.
... und das ist nicht die LETZTE sondern die JÜNGSTE Version ;)
FHEM-Featurelevel: 6   (fhem.pl:23904/2021-03-07) auf Windows 10 Pro mit Strawberry Perl 5.26.1.1-32bit
TabletUI: 2.7.15
IO: 2xHMLAN(0.965)|HMUSB2(0.967)

Offline rapster

  • Developer
  • Sr. Member
  • ****
  • Beiträge: 929
Antw:Sonos Player disappeared
« Antwort #35 am: 14 Januar 2016, 14:29:43 »
Hi Reiner,

ist denn der Player über den Original Controller noch steuerbar?
Angezeigt wird er ja auch weiterhin (da der Controller einen fehlenden Player nicht automatisch feststellt), er wäre ja nur nicht steuerbar.
Ja ist er, nur über fhem tut sich nichts mehr.

Zitat
Des Weiteren verwendest du die 6.1er Firmware. Vielleicht läuft die auch noch nicht richtig rund, oder hat neue Features, die im Modul berücksichtigt werden müssten... Das kann ich so aber nicht sagen...

Das mit dem ByeBye-Signal melden die Player eigentlich nur, wenn sie wieder eingeschaltet werden. Erst ein kurzes ByeBye und direkt hinterher ein DeviceAdd-Signal... Das sieht hier etwas anders aus... Vielleicht eine Folge der Firmware...
Bei mir ist ebenfalls Firmware 6.1 seit mehreren Wochen aktiv (mindestens seit 15.12.2015).
Bzgl. ByeBye  ;), mir kam es auch so vor als ob die 2 disappeared Player sich neugestartet hatten, da anschließend keine Playliste mehr vorhanden war.

Zitat
du mal den Pingtype testweise auf icmp umstellen? Das braucht aber Root-Rechte...
Pingtype ist bei mir seit jeher auf icmp eingestellt.

Irgendwelche SONOS Geräte aktiv vom Netz trennen tue ich nicht.
Ausfälle von anderen Netzwerkgeräte (meiner 3 HMLAN's usw.) passieren ebenfalls nicht.

Wie allerdings schon Andre mal anmerkte, kommunizieren der/die Player manchmal zu der Uhrzeit ebenfalls über mein normales WLAN, ob der wechsel zwischen LAN/WLAN hierfür verantwortlich ist?

Gerade eben waren wieder meine Player über fhem nicht mehr ansprechbar.
Nach einem Neustart wurde zwar einmal kurz ein Command an einen Player gesendet, das Modul verabschiedete sich anschließend allerdings sofort wieder mit dieser Logmeldung:
2016.01.14 14:19:28.782 1: SONOS1: GroupRendering-Service-subscribing NOT successful
Subscription request failed with error: 500 Server closed connection without sending any data back at ./FHEM/00_SONOS.pm line 5364 thread 1.
...
2016.01.14 14:18:54.311 1: SONOS3: Restore-Thread gestartet. Warte auf Arbeit...
2016.01.14 14:18:54.284 1: SONOS2: IsAlive-Thread gestartet. Warte 120 Sekunden und pruefe dann alle 30 Sekunden...

Gruß
  Claudiu
« Letzte Änderung: 14 Januar 2016, 14:35:59 von rapster »

Offline Reinerlein

  • Developer
  • Hero Member
  • ****
  • Beiträge: 2134
Antw:Sonos Player disappeared
« Antwort #36 am: 14 Januar 2016, 17:04:37 »
Hi Claudiu,

da scheint was wirklich komisch zu laufen...
Die Anmeldung zum GroupRenderingEvent ist nicht die erste (und auch nicht die letzte) Event-Registrierung.
Das bedeutet, dass die vorhergehenden beiden geklappt haben, und erst hier ein Fehler aufgetreten ist.

Für den Player heißt das, erst nimmt er ein paar Registrierungen an, und dann verweigert er die nächsten... Wieso sollte er das tun?

Kannst du testweiße auf 6.0 zurückgehen?
Mich würde interessieren, ob es ein 6.1er Problem ist. Dass hieße dann, dass Sonos vielleicht was gebaut hat, was im Modul irgendwie berücksichtigt werden muss... Vielleicht ein bestimmtes Zeitverhalten oder Zugriffe nur von bestimmten Ports o.ä.

Grüße
Reiner

Offline rapster

  • Developer
  • Sr. Member
  • ****
  • Beiträge: 929
Antw:Sonos Player disappeared
« Antwort #37 am: 14 Januar 2016, 17:45:55 »
Schaun wir mal, hab jetzt downgegraded auf 6.0.
Jetzt heist es abwarten, hat ja auch mit 6.1 teils über eine Woche gut funktioniert  ;)

Gruß
  Claudiu

Offline aherby

  • Full Member
  • ***
  • Beiträge: 182
Antw:Sonos Player disappeared
« Antwort #38 am: 15 Januar 2016, 22:48:02 »
Naben Zusammen,

ich habe jetzt zum Test auch zurück auf Sonos 6.0 die Player gebracht.
Aber es bringt auch keine Verbesserung.

Der alte Raspi macht keine Probleme, da kann die Playbar locker 10 Stunden vom Strom getrennt sein aber danach gehts einfach.
Ach funktioniert dort :
set Sonos RescnNetwork

Auf dem Raspberry Pi 2B funktioniert der oben genannte Befehl nicht mehr.
Ach lassen sich die Player nach einer Zeit nicht mehr steuern.
Wenn man den / die Player aktiv betreibt ist dies auch scheinbar kein Problem, nur wenn man die Player ausschaltet und
nach einer Zeit gehts nicht mehr.

Zitat
pi@zwerg2:~ $ sudo ps -aux | grep perl
root      2667  1.2  5.1  54052 49284 ?        R    17:56   3:42 /usr/bin/perl fhem.pl fhem.cfg
root      2683  0.5  4.4  73664 42300 ?        Sl   17:58   1:30 /usr/bin/perl ./FHEM/00_SONOS.pm 4713 5 0
pi        3401  0.0  0.1   4260  1872 pts/0    S+   22:42   0:00 grep --color=auto perl

Anbei noch ein Log aber da auch nichts gesehen:


Danke

Gruß Alex
FHEM 6.0 auf Raspberry Pi 4b 4GB, RaspberryMatic auf Raspi3b mit Charly-Funkmodul, ZigeeBridge mt deCONZ... . Homematic mittels HMCCU, Sonos 3xS1, 1xS6 (Play5 in der 2te Generation), 1xS9 (Soundbar), 1x SonosSub
1-Wire® to I2C host interface with ESD mit DS18B/S20.

Offline rapster

  • Developer
  • Sr. Member
  • ****
  • Beiträge: 929
Antw:Sonos Player disappeared
« Antwort #39 am: 18 Januar 2016, 08:55:30 »
Moin,

bei mir hats am Sonntag Nachmittag ebenfalls wieder mit der 6.0'er geknallt.
2 Player disappeared, die anderen 3 Player keine Kommunikation mehr über fhem.

Da bei mir die Modulabstürze mit ziemlicher Sicherheit auf SONOSNET Konnunikationsprobleme zurückzuführen sind, habe ich jetzt erstmal Geld in die Hand genommen und versuche dem ganzen mit einem zusätzlichen BOOST entgegenzuwirken.

Gruß
  Claudiu

Offline rapster

  • Developer
  • Sr. Member
  • ****
  • Beiträge: 929
Antw:Sonos Player disappeared
« Antwort #40 am: 21 Januar 2016, 10:55:01 »
Ich schalte z.B nachts immer das Sonos-Hauptgerät (Playbar) aus.
Es kann Zufall sein aber durch das Ausschalten kommt glaube ich der „Fehler“ schneller.

Ich hätte ne Idee was du mal versuchen könntest um das Problem bei dir zu lösen.
Falls deine Playbar die "Root Bridge" sein sollte (siehst du unter der network matrix unter http://<ip>:1400/support/review) könntest du die Root Bridge auf einen Player ändern welcher dauerhaft an bleibt.
Hierzu musst du FirstZP - disable über die URL http://<ip>:1400/advconfig.htm deiner momentanen Root Bridge submitten, und das selbe mit enable auf der neuen Root Bridge durchführen, sowie beide Player einmal rebooten. (über http://<ip>:1400/reboot z.B.)

Bei mir scheint das Problem durch den zusätzlichen Boost und ein stabiles SONOSNET erstmal behoben zu sein   :D

Gruß
  Claudiu
Gefällt mir Gefällt mir x 1 Liste anzeigen

Offline aherby

  • Full Member
  • ***
  • Beiträge: 182
Antw:Sonos Player disappeared
« Antwort #41 am: 24 Januar 2016, 13:49:24 »
Hallo Claudiu,

danke für deinen Tipp auch wenn ich ihn noch nicht ganz verstehe   :-[.

Ich nutze die Sonos-Geräte seit 2 Jahren und habe nur die Playbar am Lan angeschlossen. Diese sorgt dann für das Sonosnet und wird immer beim Verlassen
ausgeschaltet. Funktioniert seit Jahren. Der Play1 im Bad ist leider immer eingeschaltet aber dort komme ich mit dem Lan nicht hin.
Früher gab es ja die Möglichkeit nicht, die Sonos Gerät ins heimische WLAN aufzunehmen, daher habe ich auch nie drüber nachgedacht.
Vielleicht muss ich die Anbindung mal ändern.

Mich wundert dass scheinbar kein andere Benutzer die Sonos-Geräte ausschaltet. Der Standby-Verbrauch ist ja nicht gerade gering. Bei der Sonos Playbar soll es laut
Tests im Netzwerkbetrieb schon bei 5.8 Watt liegen. Rechnet man das mit steigender Gerätezahl hoch hat man schon einen Betrag, den man besser verwenden kann.

Zudem sind meine Probleme ja auch leider nach einen Update vom FHEM z.B. Linux-System aufgetaucht. Vorher hat es immer ohne Probleme funktioniert.
Leider hatte ich das lauffähige Image nicht richtig gesichert und kann es nicht mehr nutzen.

Die Neuinstallationen auf einen Raspberry Pi 2 Model B sowohl bei Wheezy und Jessie bringt die Fehler / Probleme.

Auch funktioniert die Option
set Sonos RescanNetwork
nicht mehr.

Habe mich halt dummerweise zu sehr dran gewohnt das morgens eine Sonos-Gruppe gebildet wird, die in der jeweiligen richtigen Lautstärke einen Radiosender abspielt
automatisch funktioniert. So ziehe ich wie ganz am Anfang wieder morgens mein Handy und richtige es manuell ein.

Gruß Alex
FHEM 6.0 auf Raspberry Pi 4b 4GB, RaspberryMatic auf Raspi3b mit Charly-Funkmodul, ZigeeBridge mt deCONZ... . Homematic mittels HMCCU, Sonos 3xS1, 1xS6 (Play5 in der 2te Generation), 1xS9 (Soundbar), 1x SonosSub
1-Wire® to I2C host interface with ESD mit DS18B/S20.

Offline rapster

  • Developer
  • Sr. Member
  • ****
  • Beiträge: 929
Antw:Sonos Player disappeared
« Antwort #42 am: 24 Januar 2016, 13:58:21 »
Hi Alex,

wenn nur deine Playbar am LAN hängt, macht mein Vorschlag keinen Sinn.

Das einzige was du denke ich von deiner Seite machen könntest, falls Reiner den fehler im UPNP-Modul nicht finden sollte,
währe meiner Meinung nach einen zusätzlichen BOOST mit LAN-Anschluss zu installieren und diesen als Root-Bridge zu verwenden.

Der Boost ist mit 2,3 Watt stromsparender und du könntest zusätzlich noch das WLAN an deiner Playbar deaktivieren welches 2 Watt einspart.

Welche Signalstärken haben deine anderen Player zur Playbar? Weil die SONOS-Modul Abstürze bei mir z.B. an einem zu geringer SONOSNET WLAN-Signal lagen.

Gruß
  Claudiu

Offline aherby

  • Full Member
  • ***
  • Beiträge: 182
Antw:Sonos Player disappeared
« Antwort #43 am: 24 Januar 2016, 17:08:47 »
Hallo Claudiu,

ich werde mal zum Test die Sonos-Geräte ins eigene WLAN bringen vielleicht wird es besser wenn min ein Player erreichbar ist.
Solange die Playbar eingeschaltet ist kann ich über Stunden aus dem FHEM die Steuerung durchführen.
Nur wenn die Playbar x Min ausgeschaltet war kam das Sonos-Modul nicht mit klar.

In einer kleinen oder normalen Mietwohnung alles auf einer Etage und durch max. eine Wand getrennt sollte das Sonos-Netz aber noch gut funktionieren.
Gibt es da irgendwo Pegellisten bis wann die Geräte noch funktionieren?

Die Pegel kann ich über

ip:1400/support/review

Network Matrix erfragen oder seh ich das auch in der App?

Gruß Alex
FHEM 6.0 auf Raspberry Pi 4b 4GB, RaspberryMatic auf Raspi3b mit Charly-Funkmodul, ZigeeBridge mt deCONZ... . Homematic mittels HMCCU, Sonos 3xS1, 1xS6 (Play5 in der 2te Generation), 1xS9 (Soundbar), 1x SonosSub
1-Wire® to I2C host interface with ESD mit DS18B/S20.

Offline rapster

  • Developer
  • Sr. Member
  • ****
  • Beiträge: 929
Antw:Sonos Player disappeared
« Antwort #44 am: 24 Januar 2016, 20:15:00 »
Genau, Pegel siehst du in der Network Matrix.

Bei mir war die Playbar auch das einzige Gerät am LAN, die 2 Problem-Player welche das Modul zum abschmieren brachten waren beide max 5 Meter von der Playbar entfernt auf einer Etage.

Allerdings sind bei mir aufgrund mehrerer Accesspoints recht hohe Interferenzen welche dem SONOSNET nicht wirklich gefallen haben...

 

decade-submarginal