Autor Thema: knxd auf Debian Jessie installieren  (Gelesen 4918 mal)

Offline knxhm

  • Jr. Member
  • **
  • Beiträge: 62
knxd auf Debian Jessie installieren
« am: 22 Dezember 2015, 22:04:27 »
Hallo,

bin dem Wiki http://www.fhemwiki.de/wiki/Knxd gefolgt, fast alles gut,
nur wenn man das auf einem neuen Debian Jessie macht, dann fehlt noch was bei 1. Installation:

sudo apt-get install libsystemd-daemon-dev dh-systemd

Dann gehts.

Bitte an einen Wiki Schreibberechtigten das einzufügen.
KNX, HM, HMLAN, RPi 2 mit Raspbian Jessie, knxd und FHEM, 1w Temperaturmessung mit gpio4, Dämmerungssensor, autom. Rolladensteuerung

Offline ZeitlerW

  • Full Member
  • ***
  • Beiträge: 151
Antw:knxd auf Debian Jessie installieren
« Antwort #1 am: 11 Januar 2016, 14:09:23 »
Hallo knxhm,

done siehe: http://www.fhemwiki.de/wiki/Knxd

lG
Wolfgang

Offline Alveole

  • Full Member
  • ***
  • Beiträge: 163
Antw:knxd auf Debian Jessie installieren
« Antwort #2 am: 16 Oktober 2016, 17:30:25 »
Hallo,
ich muss mal wieder dieses Thema aufgreifen, denn Ihr hab ja wohl irgendwie einen guten Draht zu dem knxd Wiki-Schreiber.

Was meint er mit:
Zitat
(Bei Debian Jessie-Lite fehlt noch mehr)

Ich habe meinen Raspi gerade neu aufgesetzt und fhem und diverse andere Dinge am Laufen. Aber eben mit Jessie light.
Nur leider will mein knxd mit TUL-Stick nicht zu recht zusammenarbeiten. Es kommen keine Befehle auf dem KNX-Bus an. Per Lan und Lan-Koppler gehts.
Nun vermute ich, das da noch irgend ein anderes Packet fehlt. Nur welches???

Danke!

Oder andere Ideen?

Offline visionsurfer

  • Sr. Member
  • ****
  • Beiträge: 934
Antw:knxd auf Debian Jessie installieren
« Antwort #3 am: 16 Oktober 2016, 18:55:22 »
Hallo,

ich versuche auch gerade meinen KNX Bus ins FHEM zu bekommen, bzw. meine KNX Geräte ansprechen zu können.

Ich habe ein IP Gateway. IP Adresse von dem Gateway ist bekannt.

Ich hab einen neuen Raspberry mit Raspian Jessie laufen (nicht light Version). FHEM ist auch installiert und funkt schon mit Homematic Geräte.

Ich habe gedacht ich muss dann alles das hier installieren: http://www.fhemwiki.de/wiki/Knxd

Nun hab ich an einer anderen stelle gelesen, das man das gar nicht braucht, wenn man seine KNX Geräte nicht programmieren will. Programmieren tue ich die alle über ETS.
Von meinem Elektriker habe ich die ganzen Adresse bekommen. In der Form "Bürolampe 1/1/17 Schalten Ein/Aus".

Muss ich alles wie in der Wiki beschrieben installieren oder reicht es in FHEM per Define nur das Gateway als KNX CUL einzurichten ?

Weil ich habe schon alles aus der Wiki installiert.
Nur wenn ich wie folgt den Status abrufe, bekomme ich eine Fehlermeldung. Siehe Anhang.

/etc/init.d/knxd status
Kann mir jemand erklären was zu tun ist ?

Grüße,
Visionsurfer

Offline Alveole

  • Full Member
  • ***
  • Beiträge: 163
Antw:knxd auf Debian Jessie installieren
« Antwort #4 am: 16 Oktober 2016, 19:43:04 »
Wie sieht Deine Config von knxd aus?

Wenn ich das richtig verstanden hab, macht knxd zwei Ding
- bindet Dein KNX an fhem an und Puffern die empfangenen Daten zwischen damit bei hoher Buslast fhem nicht überfordert ist und abstürzt (war bei mir so)
- gibt die Verbindung zu KNX frei (stellt sie im Lan bereit) um dann über ETS oder andere Programme auf den Bus zuzugreifen.

Offline visionsurfer

  • Sr. Member
  • ****
  • Beiträge: 934
Antw:knxd auf Debian Jessie installieren
« Antwort #5 am: 16 Oktober 2016, 19:55:55 »
Hi,

als Anlage mal beide Configs. Also so wie im WIKI beschrieben:

Aber über ETS läuft da aus meinem Wissen nichts ? Weil ETS läuft bei mir ja gar nicht. Also ich meine nicht dauerhaft. Das wurde alles einmal programmiert und fertig.

Aber wie gesagt hier die Configs. Ich habe einfach nur das eingefügt wie in der WIKI beschrieben. Ich glaube aber das ist falsch.

Grüße,
Visionsurfer

Offline Alveole

  • Full Member
  • ***
  • Beiträge: 163
Antw:knxd auf Debian Jessie installieren
« Antwort #6 am: 18 Oktober 2016, 19:50:12 »
Hallo,
ich hab mich bestimmt falsch ausgedrückt.
Über ETS läuft logisch nichts.
mit
Zitat
gibt die Verbindung zu KNX frei (stellt sie im Lan bereit) um dann über ETS oder andere Programme auf den Bus zuzugreifen.
meine ich, das dann Deine ETS über knxd auf den KNX-Bus zugreifen kann.

meine Config-Zeile lautet wie folgt und funktioniert:
KNXD_OPTS="-e 0.0.101 -c -D -T -R -S -b ipt:192.168.1.235"und steht in /etc/knxd.conf

« Letzte Änderung: 18 Oktober 2016, 19:52:56 von Alveole »

Offline visionsurfer

  • Sr. Member
  • ****
  • Beiträge: 934
Antw:knxd auf Debian Jessie installieren
« Antwort #7 am: 18 Oktober 2016, 19:54:41 »
Hi,

Danke für die Info.

Ich hab es seit letzte Nacht zum laufen bekommen.
Gerade bin ich dabei einiges in FHEM einzubinden. Bisher läuft alles. Schauen wir mal.

Grüße,
Visionsurfer

golpinho

  • Gast
Antw:knxd auf Debian Jessie installieren
« Antwort #8 am: 22 Oktober 2016, 15:42:07 »
Hallo Kollegen,
ich versuche seit Stunden meine kleine KNX-Anlage zuhause mit Raspi und USB-Schnittstelle von ABB.

Ich habe alles installiert wie auf FHEMWiki beschriben bis auf die KNXD_OPTS, da ich eine USB-SS habe und kein IP Gateway.
Wenn ich den status aufrufe kommt einen Fehler:

:~ $ /etc/init.d/knxd status
: not found/knxd: 4: /etc/default/knxd:
: not found/knxd: 8: /etc/default/knxd:
: not found/knxd: 12: /etc/default/knxd:
: not found/knxd: 17: /etc/default/knxd:
: not found/knxd: 19: /etc/default/knxd:
: not found/knxd: 31: /etc/default/knxd:
● knxd.service - KNX Daemon
   Loaded: loaded (/lib/systemd/system/knxd.service; enabled)
   Active: activating (auto-restart) (Result: exit-code) since Sa 2016-10-22 15:38:24 CEST; 6s ago
  Process: 1872 ExecStart=/usr/bin/knxd $KNXD_OPTS (code=exited, status=1/FAILURE)
 Main PID: 1872 (code=exited, status=1/FAILURE)


Könnt ihr mir weiterhelfen?

DAnke!!



Offline buchner51

  • Full Member
  • ***
  • Beiträge: 129
Antw:knxd auf Debian Jessie installieren
« Antwort #9 am: 23 November 2017, 11:49:22 »
Hallo zusammen,

leider komme ich auch nicht weiter.

ich musste mein Banana neu aufsetzen und scheitere am KNXD..


Ich hab ein Banana Image aufgespielt und ein Update von Jessie auf strech durch danach fhem installiert, alles ok.
Aber knxd macht Probleme https://wiki.fhem.de/wiki/Knxd ich habe die Anleitung befolgt und alle Pakete die hingen nachinstalliert, aber welche bei meiner Fehler Meldung fehlen verstehe ich nicht.

Ich hab auch von git "git checkout stable" auf "git checkout v0.14 - und v0.16" gewechselt aber ohne Erfolg.

Wer kann mir helfen??

ite-cgi '/root/knxd/debian/tmp/usr/lib/knxd'
libtool: warning: '../client/c/libeibclient.la' has not been installed in '/usr/lib/arm-linux-gnueabihf'
libtool: install: /usr/bin/install -c .libs/knxtool /root/knxd/debian/tmp/usr/bin/knxtool
libtool: warning: '../client/c/libeibclient.la' has not been installed in '/usr/lib/arm-linux-gnueabihf'
libtool: install: /usr/bin/install -c .libs/eibread-cgi /root/knxd/debian/tmp/usr/lib/knxd/eibread-cgi
libtool: warning: '../client/c/libeibclient.la' has not been installed in '/usr/lib/arm-linux-gnueabihf'
libtool: install: /usr/bin/install -c .libs/eibwrite-cgi /root/knxd/debian/tmp/usr/lib/knxd/eibwrite-cgi
make: *** [binary] Fehler 2
dpkg-buildpackage: Fehler: Fehler-Exitstatus von debian/rules binary war 2
dpkg-buildpackage -b -uc  1342,42s user 86,65s system 161% cpu 14:45,82 total
2 root@fhem-server ~/knxd (git)-[v0.14] #
Raspberry pi 3+
KNX mit TUL, FHEM mit SMARTVISU 2.9