Autor Thema: eBus Schaltung in Betrieb nehmen  (Gelesen 286377 mal)

Offline Reinhart

  • Hero Member
  • *****
  • Beiträge: 2077
Antw:eBus Schaltung in Betrieb nehmen
« Antwort #255 am: 18 Januar 2016, 22:31:47 »
normalerweise müsste es nach dem Busfehler wieder weiter laufen, immerhin bis du sehr nahe dran, weil die Daten ja schon ankommen.

USB solltest du aber in den Logs des Raspberry finden.

Was ergibt "lsusb" wenn der Fehler da war, ist der USB-Konverter dann noch zu sehen?

pi@raspberry2 ~ $ lsusb
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp.
Bus 001 Device 004: ID 0403:6001 Future Technology Devices International, Ltd FT232 USB-Serial (UART) IC

LG
FHEM auf Raspy4 mit Buster + SSD, mit FS20, Homematic, ESP8266, Sonoff, Electrodragon, eBus, RPi mit COC,NanoCUL, MapleCUL, HM-CFG-LAN Adapter, MQTT2, Alexa

Offline harry66

  • Full Member
  • ***
  • Beiträge: 138
Antw:eBus Schaltung in Betrieb nehmen
« Antwort #256 am: 18 Januar 2016, 22:45:02 »
ich denke das hier wird der Grund sein :'(
pi@raspberrypi /etc/init.d $ sudo ebusd -f -c /tmp --logareas bus --loglevel info -d /dev/ttyUSB0
2016-01-18 22:38:56.348 [bus notice] signal acquired
2016-01-18 22:38:56.477 [bus notice] new master 10, master count 2
2016-01-18 22:38:56.481 [bus notice] new master 3f, master count 3
2016-01-18 22:39:02.051 [bus error] signal lost
pi@raspberrypi ~ $ tail -f /var/log/syslog
Jan 18 22:38:59 raspberrypi kernel: [ 8046.111211] ftdi_sio ttyUSB0: usb_serial_generic_read_bulk_callback - urb stopped: -32
Jan 18 22:39:00 raspberrypi kernel: [ 8046.443616] ftdi_sio ttyUSB0: usb_serial_generic_read_bulk_callback - urb stopped: -32

ich werde morgen mal ein anderes usb Kabel besorgen oder ebusd auf meinem BananaPi installieren.
An der Abstimmung dreh ich erstmal nix mehr.
BananaPI, RPI, nanoCUL433, RCS 1000 N Comfort, Dect200, Powerline546E, MAX!Cube, 7xMAX! HT's,3xMAX!FK HMLAN, HM-LC-Bl1PBU-FM, HM-LC-Sw4-Ba-PCB Relay Karte,  LW12, Sqeezelite, TabletUI=Kindel 8" FireHD+Handy,AmazonEcho

Offline Reinhart

  • Hero Member
  • *****
  • Beiträge: 2077
Antw:eBus Schaltung in Betrieb nehmen
« Antwort #257 am: 18 Januar 2016, 22:57:58 »
Ja ist klar, der USB hängt sich auf und gleich darauf kommt logischerweise Signal Lost.

Ich würde auch nix mehr drehen, die Abstimmung hast schon gut hinbekommen.
Zumindest kennst jetzt die Richtung wo du suchen musst. Ich habe immer 2 unterschiedliche Konverter herumliegen, weil die nix kosten und schnell für Tests benötigt werden.

Was hast den für eine Version, denn es gibt mehrere Hinweise auf den Kernel wenn du nach dem Fehler suchst.

pi@raspberry2 ~ $ uname -a
Linux raspberry2 3.18.7+ #755 PREEMPT Thu Feb 12 17:14:31 GMT 2015 armv6l GNU/Linux

LG
« Letzte Änderung: 18 Januar 2016, 23:05:29 von Reinhart »
FHEM auf Raspy4 mit Buster + SSD, mit FS20, Homematic, ESP8266, Sonoff, Electrodragon, eBus, RPi mit COC,NanoCUL, MapleCUL, HM-CFG-LAN Adapter, MQTT2, Alexa

Offline harry66

  • Full Member
  • ***
  • Beiträge: 138
Antw:eBus Schaltung in Betrieb nehmen
« Antwort #258 am: 18 Januar 2016, 23:05:08 »
hab gerade gelesen das Zentis666 das gleiche Problem hatte und mit Kernel Downgade hinbekommen hat. Da hab ich ja noch Hoffnung 8)

Danke für die schnelle Hilfe zu später Stunde

Gruß Rolf
BananaPI, RPI, nanoCUL433, RCS 1000 N Comfort, Dect200, Powerline546E, MAX!Cube, 7xMAX! HT's,3xMAX!FK HMLAN, HM-LC-Bl1PBU-FM, HM-LC-Sw4-Ba-PCB Relay Karte,  LW12, Sqeezelite, TabletUI=Kindel 8" FireHD+Handy,AmazonEcho

Offline Reinhart

  • Hero Member
  • *****
  • Beiträge: 2077
Antw:eBus Schaltung in Betrieb nehmen
« Antwort #259 am: 18 Januar 2016, 23:10:59 »
Alles klar, das ist eine wichtige Erkenntnis weil man leicht vom tatsächlichen Fehler abgelenkt wird. Gut, dass du das so schnell im Log gefunden hast!

LG
FHEM auf Raspy4 mit Buster + SSD, mit FS20, Homematic, ESP8266, Sonoff, Electrodragon, eBus, RPi mit COC,NanoCUL, MapleCUL, HM-CFG-LAN Adapter, MQTT2, Alexa

christianh

  • Gast
Antw:eBus Schaltung in Betrieb nehmen
« Antwort #260 am: 19 Januar 2016, 17:39:30 »
@Amunra

Danke der Code hat funktioniert!
Code: [Auswählen]
wget https://github.com/john30/ebusd/releases/download/v2.0/ebusd-2.0_armhf.deb
wget https://github.com/john30/ebusd-configuration/releases/download/v2.0.1/ebusd-configuration-2.0.5aa482c-de_all.deb
sudo dpkg -i --force-overwrite ebusd-2.0_armhf.deb
sudo dpkg -i --force-overwrite ebusd-configuration-2.0.*.deb

wenn ich nun ebusctl scan eingebe erhalte ich error connecting to localhost :8888

wenn ich mit sudo service ebusd start - läuft zwar der ebus aber als scan result bekomme ich empty!

Wie bekomme ich ebusd zum laufen (autostart) und dass er was anzeigt...  zur Info habe den gekauften adapter....




nochwas ... ich glaube dass es kein usb Gerät findet obwohl es angesteckt ist und blinkt....
Bus 001 Device 006: ID 0403:6001 Future Technology Devices International, Ltd FT232 USB-Serial (UART) IC  ist da richtig?



« Letzte Änderung: 19 Januar 2016, 20:07:16 von christianh »

Offline harry66

  • Full Member
  • ***
  • Beiträge: 138
Antw:eBus Schaltung in Betrieb nehmen
« Antwort #261 am: 19 Januar 2016, 19:46:32 »
Hallo,

bei meinem Problem:
ich denke das hier wird der Grund sein :'(

2016-01-18 22:39:02.051 [bus error] signal lost

pi@raspberrypi ~ $ tail -f /var/log/syslog
Jan 18 22:38:59 raspberrypi kernel: [ 8046.111211] ftdi_sio ttyUSB0: usb_serial_generic_read_bulk_callback - urb stopped: -32

hat folgende Lösung bei mir geholfen:

in der Datei "/boot/cmdline.txt"

 folgendes hinzufügen dwc_otg.speed=1dann den Pi neustarten

das setzt den USB auf 1.0 seit dem habe ich keine aussetzter mehr ;D

zur info ich hab folgende Version drauf:"Linux raspberrypi 4.1.7+ #817 PREEMPT Sat Sep 19 15:25:36 BST 2015 armv6l GNU/Linux"

Gruß Rolf
« Letzte Änderung: 19 Januar 2016, 19:49:17 von harry66 »
BananaPI, RPI, nanoCUL433, RCS 1000 N Comfort, Dect200, Powerline546E, MAX!Cube, 7xMAX! HT's,3xMAX!FK HMLAN, HM-LC-Bl1PBU-FM, HM-LC-Sw4-Ba-PCB Relay Karte,  LW12, Sqeezelite, TabletUI=Kindel 8" FireHD+Handy,AmazonEcho

Offline R2D2_

  • Full Member
  • ***
  • Beiträge: 112
Antw:eBus Schaltung in Betrieb nehmen
« Antwort #262 am: 19 Januar 2016, 20:47:23 »
Linux raspberrypi 4.1.15+ #830 Tue Dec 15 16:58:28 GMT 2015 armv6l GNU/Linux

Funktioniert auch bei mir UND ohne den Eintrag in /boot/cmdline.txt.

Vielleicht hängt's auch mit Deinem USB2SER-Wandler zusammen. Hast Du den von ELV ?

Offline harry66

  • Full Member
  • ***
  • Beiträge: 138
Antw:eBus Schaltung in Betrieb nehmen
« Antwort #263 am: 19 Januar 2016, 21:29:14 »
Hallo,
klar liegt bestimmt am Wandler, ich hatte im Netz einige gefunden die mit dem Teil (http://www.amazon.de/gp/product/B00YMDN2Z6?psc=1&redirect=true&ref_=oh_aui_detailpage_o04_s00) die gleichen Probleme hatten, so hab ich ja auch die Lösung für mich gefunden.

Die Anleitung sollte ja nur zur Info für Leute mit dem gleichen Problem sein.

Gruß Rolf
BananaPI, RPI, nanoCUL433, RCS 1000 N Comfort, Dect200, Powerline546E, MAX!Cube, 7xMAX! HT's,3xMAX!FK HMLAN, HM-LC-Bl1PBU-FM, HM-LC-Sw4-Ba-PCB Relay Karte,  LW12, Sqeezelite, TabletUI=Kindel 8" FireHD+Handy,AmazonEcho

amunra

  • Gast
Antw:eBus Schaltung in Betrieb nehmen
« Antwort #264 am: 20 Januar 2016, 00:07:47 »
@Amunra

Danke der Code hat funktioniert!
Code: [Auswählen]
wget https://github.com/john30/ebusd/releases/download/v2.0/ebusd-2.0_armhf.deb
wget https://github.com/john30/ebusd-configuration/releases/download/v2.0.1/ebusd-configuration-2.0.5aa482c-de_all.deb
sudo dpkg -i --force-overwrite ebusd-2.0_armhf.deb
sudo dpkg -i --force-overwrite ebusd-configuration-2.0.*.deb

wenn ich nun ebusctl scan eingebe erhalte ich error connecting to localhost :8888

wenn ich mit sudo service ebusd start - läuft zwar der ebus aber als scan result bekomme ich empty!

Wie bekomme ich ebusd zum laufen (autostart) und dass er was anzeigt...  zur Info habe den gekauften adapter....




nochwas ... ich glaube dass es kein usb Gerät findet obwohl es angesteckt ist und blinkt....
Bus 001 Device 006: ID 0403:6001 Future Technology Devices International, Ltd FT232 USB-Serial (UART) IC  ist da richtig?

per default nutzt ebusd /dev/ttyUSB0 passt das bei dir?
Autostart sollte, nach der Installation über packages, bereits funktionieren - is das nicht der Fall?.
Ich würde mich zunächst, um das USB Device Thema kümmern.
Welchen Port dein USB Device nutzt bekommst du z.B so:
sudo dmesg | grep -i ttyraus.
Sollte der Port nicht passen, dann kannst du den in der EBUSD CONFIG anpassen (siehe ebusd wiki run und wiki unter Software) - anschließend ebusd restarten.

Viele Grüße
Arthur

Offline john30

  • Hero Member
  • *****
  • Beiträge: 1143
    • ebusd.eu
Antw:eBus Schaltung in Betrieb nehmen
« Antwort #265 am: 20 Januar 2016, 07:05:41 »
Sporadisch, 5-8 Fehler/d im log:
12:49:51.193 [bus error] send to 08: ERR: read timeout, retry
Hat jemand eine Ahnung, wo ich schrauben muss ? Kann es sein, dass 8 Aufrufe gleichzeitig (lesend, r -f) zuviel sind ?
Gleichzeitige Aufrufe in diesem Sinn gibt es auf dem Bus nicht. Alles was per Kommando oder über irgendein UI im ebusd initiiert wird, wird erst dann auf dem Bus ausgeführt, wenn dieser das auch zulässt (sog. Arbitrierung).

Könnte mir höchstens vorstellen, dass der Empfänger zu dem Zeitpunkt nicht bereit war, zu antworten. Oder schlicht und einfach die abgesetzte Nachricht nicht verarbeiten will/kann.

Ganz ehrlich: 8 Fehler pro Tag ist bei der Menge an Nachrichten so gut wie gar nichts. Das fällt unter normales Rauschen.
author of ebusd

christianh

  • Gast
Antw:eBus Schaltung in Betrieb nehmen
« Antwort #266 am: 21 Januar 2016, 20:23:56 »
Hallo Artur!

Juhu EbusD läuft!!!! oder auch nur Teilweise...
pi@raspberrypi ~ $ ebusctl scan full
done

pi@raspberrypi ~ $ ebusctl scan result
08;Vaillant;BAI00;0703;7401
15;Vaillant;47000;0420;1403
50;Vaillant;V6100;0418;1902

pi@raspberrypi ~ $ ebusctl read -m 10 outsidetemp
^C
pi@raspberrypi ~ $ ebusctl info
^C
pi@raspberrypi ~ $ ebusctl scan result
^C
pi@raspberrypi ~ $ ebusctl scan full
^C
pi@raspberrypi ~ $ ebusctl scan result

und jetzt kommt nichts mehr.... muss ich bei die csv datein wieder einzeln herunterladen?
« Letzte Änderung: 21 Januar 2016, 20:53:15 von christianh »

amunra

  • Gast
Antw:eBus Schaltung in Betrieb nehmen
« Antwort #267 am: 21 Januar 2016, 21:57:45 »
las mich raten:

sudo service ebusd start hat geholfen bzw. du hast dein pi neugestartet ;o)

Bist Du dir sicher, dass bei
ebusctl infokein Ergebnis kommt?
Das muss in etwa so aussehen:
version: ebusd 2.0.0ea7efc
signal: acquired
symbol rate: 22
masters: 3
messages: 424
address 03: master #3
address 08: slave #3, scanned "MF=Vaillant;ID=BAI00;SW=0516;HW=7401", loaded "vaillant/08.bai.HW7401.csv"
address 10: master #6
address 15: slave #6, scanned "MF=Vaillant;ID=43000;SW=0215;HW=2002", loaded "vaillant/15.430.csv"
Hier siehst du auch welche CSV Dateien geladen wurden.
Die Konfigurationsdateien hast du schon installiert, denke ich? Falls nicht dann dies bitte nachholen mit:
wget https://github.com/john30/ebusd-configuration/releases/download/v2.0.1/ebusd-configuration-2.0.5aa482c-de_all.deb
sudo dpkg -i --force-overwrite ebusd-configuration-2.0.*.deb
Viele Grüße
Arthur

christianh

  • Gast
Antw:eBus Schaltung in Betrieb nehmen
« Antwort #268 am: 22 Januar 2016, 10:40:00 »
offensichtlich bin ich zu ungeduldig!!

habs die nacht durchlaufen lassen und heute früh dass....

pi@raspberrypi ~ $ ebusctl scan result
08;Vaillant;BAI00;0703;7401
15;Vaillant;47000;0420;1403;21;14;51;0020171280;0082;062525;N6
26;Vaillant;47000;0420;1403;21;14;51;0020171280;0082;062525;N6

pi@raspberrypi ~ $ ebusctl read -m 10 outsidetemp
-7.375

Danke !!!!!!

Kannst du mir auch helfen bei FHEM?
Haber Fhem installiert...
sudo apt-get install perl libdevice-serialport-perl libio-socket-ssl-perl libwww-perl libxml-simple-perl
sudo wget http://fhem.de/fhem-5.6.deb
sudo dpkg -i fhem-5.6.deb
cd /opt
sudo chmod -R a+w fhem && sudo usermod -a -G tty pi && sudo usermod -a -G tty fhem

kann aber nicht auf die Weboberfläche zugreifen....
Es kommt einfach nicht wenn ich die IP:8083 eingebe....
« Letzte Änderung: 22 Januar 2016, 12:52:33 von christianh »

Offline rufus999

  • Jr. Member
  • **
  • Beiträge: 71
Antw:eBus Schaltung in Betrieb nehmen
« Antwort #269 am: 22 Januar 2016, 11:51:52 »
@Reinhart
Vielen Dank für dein Beispiel aus Antwort #238!
Ich habe soweit alles eingerichtet und doch ergeben sich noch Probleme/Fragen.
Du schreibst, etwas von/durch Beobachtung ermittelten Werten. Genau darin liegt mein Problem. Wie hast du diese ermittelt? Und woher hast du die "Grenzwerte" der Heizkurve. Meine Heizkurve wurde durch den Heizungsbauer auf 1,4 festgelegt, deshalb weiß ich überhaupt nicht welche Werte, "von bis", ich überhaupt nehmen soll. Ich denke der obere Wert wird dann 1,4 sein aber wie weit gehe ich runter? Nur durch testen, also wenn es zu kalt wird wieder anheben?

Sorry, für die vielen Fragen aber das Thema ist doch sehr umfangreich.

Gruß rufus999

 

decade-submarginal