Autor Thema: Icon wird nicht angezeigt im Floorplan (shell)  (Gelesen 545 mal)

Offline accessburn

  • Sr. Member
  • ****
  • Beiträge: 760
  • Lecker Raspberry-Cocktail!
    • TRcoding
Icon wird nicht angezeigt im Floorplan (shell)
« am: 06 Januar 2016, 11:07:01 »
Ich versuche ein simples Shell einzufügen per Button.

Beim ersten start wird mir jedoch statt das Icon nur "???" angezeigt. Beim ersten Klick darauf dann "on".
Nie und nimmer nicht sehe ich das icon "pc_it". Es soll auch nicht wechseln, sondern stur das eine icon da stehen bleiben.

Was tun?


define PC_Starten dummy
attr PC_Starten devStateIcon on:pc_on
attr PC_Starten fp_Grundriss 378,1026,2, ,PC_Starten
attr PC_Starten group Wohnzimmer
attr PC_Starten icon it_pc
attr PC_Starten room Wohnzimmer
attr PC_Starten webCmd on

define pc_on notify PC_Starten:on {system("sudo etherwake xx:xx:xx:xx:xx &");;}
attr pc_on icon it_pc
Wezzy Rpi2b> FHEM, Elro, Intenso, FTUI, Jeelink v3, Max!Cube, Fire5, Foscam, NAS, Fritz!Box + Fon, Max!Wandthermostat, Amazon Echo
Wezzy Rp3b> OctoPi
Jessie Rp3b> UPNP, NAS, Pi-Hole

Offline UliM

  • Global Moderator
  • Hero Member
  • ****
  • Beiträge: 2707
Antw:Icon wird nicht angezeigt im Floorplan (shell)
« Antwort #1 am: 06 Januar 2016, 18:33:08 »
Hi,
das Attribut icon legt fest, welches icon in FHEMWEB in der Raumübersicht links neben dem device-namen angezeigt wird. Dieses icon wird in floorplan gar nicht verwendet.

Du brauchst vermutlich devstateicon.
Spiel damit rum, bis das state-icon in FHEMWEB so aussieht wie Du's brauchst, in floorplan erscheint's dann genauso.

Gruß, Uli
RPi2/Raspbian, CUL V3 (FS20, CUL_WS), HM-CFG-USB (ca. 30 HomeMatic-devices), LAN (HueBridge, iTunes, HarmonyHub etc.). Slave-Installation auf OSX.
Aktives Mitglied des FHEM e.V. (Marketing)

Offline accessburn

  • Sr. Member
  • ****
  • Beiträge: 760
  • Lecker Raspberry-Cocktail!
    • TRcoding
Antw:Icon wird nicht angezeigt im Floorplan (shell)
« Antwort #2 am: 06 Januar 2016, 21:07:56 »
Wenn du die meinen Codeabschnitt anschaust ist devstateicon drin, bekomme ich aber nicht auf die reihe. Irgendwo ist etwas falsch :-(
Wezzy Rpi2b> FHEM, Elro, Intenso, FTUI, Jeelink v3, Max!Cube, Fire5, Foscam, NAS, Fritz!Box + Fon, Max!Wandthermostat, Amazon Echo
Wezzy Rp3b> OctoPi
Jessie Rp3b> UPNP, NAS, Pi-Hole

 

decade-submarginal