Autor Thema: ebus Koppler mit calorMatic versteht sich nicht  (Gelesen 1670 mal)

Offline JeyPee

  • New Member
  • *
  • Beiträge: 8
ebus Koppler mit calorMatic versteht sich nicht
« am: 14 Januar 2016, 21:06:13 »
Moin zusammen und erstmal großen Respekt an das Projekt und das Forum. Ich stöbere hier schon länger und habe mich endlich dazu durchgerungen, einen Raspberry aufzusetzen und diesen mit FHEM zu bestücken.

Mein erstes Projekt ist anscheinend auch etwas komplizierter als gedacht.

Ich habe vor, einen ebus Koppler an meine Heizung zu klemmen und darüber erstmal ein simples Monitoring zu gestalten.

Hardware:
- Vaillant atmoTec therme mit VR39 Bus Koppler
- calorMatic 430 Regelung
- eservice eBus Koppler
- Raspberry

Nun habe ich alles ausgepackt und angeklemmt und bekomme auch die ersten Meldungen im ebusd2. Soweit, so gut.
Allerdings quittiert mir, sobald ich den eBus Koppler an den Bus hänge, die calorMatic den Dienst mit der Meldung "Verbindung zu Heizgerät fehlt". Und ich bekomme über ebusd keine vernünftigen Daten.

Da habe ich mal bei eservice angerufen und den Vorschlag, mal einen 200Ohm, Widerstand zum Koppler zu schalten, in die Tat umgesetzt. Leider kein Erfolg.

Jedes Gerät einzeln für sich am Bus tut was es soll.

Kann mir hier vielleicht einer der eBus/Elektrotechnik Profis ein wenig unter die Arme greifen? Komme echt nicht weiter.

Vorab schonmal tausend Dank.
Jan

Offline Prof. Dr. Peter Henning

  • Developer
  • Hero Member
  • ****
  • Beiträge: 4842
Antw:ebus Koppler mit calorMatic versteht sich nicht
« Antwort #1 am: 17 Januar 2016, 17:33:25 »
Das ist schon der 2. Bericht mit denselben Symptomen, beide mit dem Koppler von eservice.

Siehe http://forum.fhem.de/index.php/topic,47245.0.html

Vorschlag: Hier gemeinsam weiter diskutieren, als Maßnahme ggf. einern der Selbstbaukoppler nach meiner Schaltung ausleihen (siehe Waillant-Thread)

Nach meiner Erfahrung treten die o.a. Symptome auf, wenn der Bus permanent auf "Low" gezogen wird (9V). Kann man mit einem einfachen Voltmeter messen.

LG

pah

Offline fz69412

  • Jr. Member
  • **
  • Beiträge: 59
Antw:ebus Koppler mit calorMatic versteht sich nicht
« Antwort #2 am: 17 Januar 2016, 18:17:14 »
Das gleiche Problem hatte ich Anfangs auch.
Ich habe dann das Poti mal auf Mittelstellung gesetzt , Bus wieder verbunden und dann erst die Geräte wieder eingeschalten.
Das Poti auch nur ganz , ganz vorsichtig verstellen.

Nutze diese Anleitung von John zum Einstellen:

Noch ein Hinweis zur Poti Einstellung:

Ich finde es leichter, wenn man zur ersten Justierung des Potis den Dienst stoppt (service ebusd stop) und statt dessen mit minimalen Parametern und ohne irgendwelche CSVs direkt in der Kommandozeile startet, z.B. so:
ebusd -f -c /tmp --logareas bus --loglevel info -d $DEVICE$DEVICE dabei einfach durch das entsprechende /dev/ttyUSB0 o.ä. ersetzen.

Danach aktiviere ich noch aus einem zweiten Terminal (oder über screen) wie folgt den raw output:
ebusctl raw
Somit erhält man im ebusd Fenster die empfangenen Bytes als Hex, also z.B.:
2015-12-24 12:07:16.955 [bus notice] <aa
2015-12-24 12:07:17.001 [bus notice] <aa
2015-12-24 12:07:17.047 [bus notice] <aa
2015-12-24 12:07:17.093 [bus notice] <aa
2015-12-24 12:07:17.097 [bus notice] <10
2015-12-24 12:07:17.102 [bus notice] <50
2015-12-24 12:07:17.107 [bus notice] <b5
2015-12-24 12:07:17.111 [bus notice] <04

Wenn gerade kein Gerät den Bus benutzt, dann sollten etwa 20 Zeilen pro Sekunde ausgegeben werden und zwar mit "<aa" (im Beispiel die oberen 4 Zeilen).

Sobald ein Gerät den Bus benutzt, sieht das natürlich wieder anders aus. Da sind dann kurze Peaks mit was anderem als "aa" zu sehen. Das sollte man dann ignorieren (im Beispiel die unteren 4 Zeilen).

Wichtig ist dann bei der Poti Einstellung, dass man vor allem die regulären "aa"s zu sehen bekommt. Erst wenn die zuverlässig reinlaufen, kann man sich der nächsten Stufe widmen und ebusd wieder regulär als Dienst starten.

Gruß Frank

Offline JeyPee

  • New Member
  • *
  • Beiträge: 8
Antw:ebus Koppler mit calorMatic versteht sich nicht
« Antwort #3 am: 18 Januar 2016, 15:19:06 »
Erstmal danke für die Antworten.

@pah:
Wie kann ich denn die Spannung des Busses messen?

Ich bin zwar Softwarteentwickler, aber Elektrotechnik ist nicht so meins. :D

Multimeter vorhanden.

Offline Prof. Dr. Peter Henning

  • Developer
  • Hero Member
  • ****
  • Beiträge: 4842
Antw:ebus Koppler mit calorMatic versteht sich nicht
« Antwort #4 am: 18 Januar 2016, 15:22:33 »
Einfach das Multimeter an den Bus klemmen. Wenn der Buskoppler den Bus dauerhaft auf "Low" ziehen sollte, fällt die Spannung des eBus auf unter 12 V ab.

LG

pah

Offline JeyPee

  • New Member
  • *
  • Beiträge: 8
Antw:ebus Koppler mit calorMatic versteht sich nicht
« Antwort #5 am: 18 Januar 2016, 15:47:56 »
Und wenn die Spannung so abfallen sollte, gibt es eine Möglichkeit das zu verhindern?

Offline Prof. Dr. Peter Henning

  • Developer
  • Hero Member
  • ****
  • Beiträge: 4842
Antw:ebus Koppler mit calorMatic versteht sich nicht
« Antwort #6 am: 18 Januar 2016, 18:27:24 »
Das würde auf einen Fehler im Koppler hindeuten - der darf das nämlich nicht machen.

LG

pah

Offline JeyPee

  • New Member
  • *
  • Beiträge: 8
Antw:ebus Koppler mit calorMatic versteht sich nicht
« Antwort #7 am: 19 Januar 2016, 15:50:05 »
So, habe jetzt mal die Anleitung befolgt.

Erst alle Geräte an den Bus, den Poti vom Koppler auf Mitte gestellt und die Heizung neu gestartet.

Ergebnis:
Immer noch der selbe Mist.
Bei angeklemmten Koppler zeigt die Calormatic keine Daten der Heizung dar.

Mit dem Voltmeter bin ich auch mal an den Koppler bzw. an den Bus und bekomme hier relativ konstannt 21V. Wenn Daten auf dem Bus gesendet werden, schwankt die Spannung und fällt kurz auf maximal 13V ab.

Irgendwelche Ratschläge?

Danke.

Offline pc1246

  • Hero Member
  • *****
  • Beiträge: 1472
  • tempus fugit
Antw:ebus Koppler mit calorMatic versteht sich nicht
« Antwort #8 am: 19 Januar 2016, 16:35:16 »
Hallo JeyPee
OT Ein
Woran wird der VR 39 angeschlossen? Ich habe das halbe Netz durchsucht, kann aber nichts finden! Ich suche naemlich so einen Koppler um meine Therme eBus faehig zu bekommen!
OT aus
Gruss Christoph
RasPi2
Onkyo_AVR;3 Enigma2; SB_Server ; SB_Player; HM-USB mit 15 HM-CC-RT-DN, 3 HM_WDS10_TH_O, 6 HM-Sec-SCo, 4 HM-Sec-MDIR-2, 1 HM-Sen-MDIR-O-2, 8 Ferion 5000 OW ; PhilipsTV; add-on board mit 6 IT-Steckdosen;3 harmony hub; Jeelink mit 9 PCA301; Somfy; S7-300; 3 LGW; KS300; ESA2000

Offline JeyPee

  • New Member
  • *
  • Beiträge: 8
Antw:ebus Koppler mit calorMatic versteht sich nicht
« Antwort #9 am: 19 Januar 2016, 16:51:23 »
Hallo JeyPee
OT Ein
Woran wird der VR 39 angeschlossen? Ich habe das halbe Netz durchsucht, kann aber nichts finden! Ich suche naemlich so einen Koppler um meine Therme eBus faehig zu bekommen!
OT aus
Gruss Christoph

Hi Christoph,

ich hatte an der Platine der Therme einen kleinen RJ11 (oderso) Stecker für die Diagnose-Software. Da wird der VR39 Koppler einfach dran eingesteckt. Kabelk liegt dem VR39 bei.

Offline JeyPee

  • New Member
  • *
  • Beiträge: 8
Antw:ebus Koppler mit calorMatic versteht sich nicht
« Antwort #10 am: 21 Januar 2016, 22:13:56 »
Hat jemand noch eine Idee bevor ich das Ding zurück schicke, sofern das noch geht?

Wie bereits erwähnt:
1. Spannung auch mit ebus Koppler im Rahmen.
2. Jedes Gerät einzeln am Bus funktioniert tadellos.
3. Jegliche Einstellung des Potis am Koppler bringt die calorMAtic nicht wieder dazu, zu funktionieren.

Danke

Offline SLidynia

  • Newbie
  • Beiträge: 1
Antw:ebus Koppler mit calorMatic versteht sich nicht
« Antwort #11 am: 15 Juli 2017, 21:17:05 »
Gibt es mittlerweile eine Lösung für dieses Problem?

Ich habe nämlich selbiges und weiß noch nicht woran es liegen könnte.

Offline pc1246

  • Hero Member
  • *****
  • Beiträge: 1472
  • tempus fugit
Antw:ebus Koppler mit calorMatic versteht sich nicht
« Antwort #12 am: 17 Juli 2017, 07:26:34 »
Moin
Und ein herzliches Willkommen im Forum! Leider kann ich Dir noch nicht weiterhelfen, da ich den RPI mit ebusD noch nicht aufgesetzt und im Einsatz habe! Was mir aber aufgefallen ist, ist dass das ganze Konstrukt bei mir schon von Anfang an sehr wackelig war. Ein paar mal ist die Calormatic gar nicht hochgefahren, und bis die Aussentemperaturwerte und Uhrzeit kommen, vergehen auch mal 6 Minuten! Zudem musste ich mein DCF77 Signal jetzt abklemmen, da meine Heizung sonst immer um 4 bis 6 Stunden zurueck ist. Das wiederum ist bloed, da es dann zur falschen Zeit warmes Wasser gibt!
Gruss Christoph
RasPi2
Onkyo_AVR;3 Enigma2; SB_Server ; SB_Player; HM-USB mit 15 HM-CC-RT-DN, 3 HM_WDS10_TH_O, 6 HM-Sec-SCo, 4 HM-Sec-MDIR-2, 1 HM-Sen-MDIR-O-2, 8 Ferion 5000 OW ; PhilipsTV; add-on board mit 6 IT-Steckdosen;3 harmony hub; Jeelink mit 9 PCA301; Somfy; S7-300; 3 LGW; KS300; ESA2000

Offline pc1246

  • Hero Member
  • *****
  • Beiträge: 1472
  • tempus fugit
Antw:ebus Koppler mit calorMatic versteht sich nicht
« Antwort #13 am: 12 Oktober 2017, 22:07:33 »
Moin
Ich muss mich noch mal melden. Inzwischen laeuft es bei mir hervorragend! Das Problem mit dem DCF Signal ist wohl ein anderes, so dass ich das ausklammern moechte.
Ich habe den Selbstbauadapter im Einsatz, sogar mit dem Poti und nicht dem Spindeltrimmer. Insgesamt habe ich allerdings keine 12 Meter Kabel verlegt. Andererseits geht es wir durcheinander, Telefon, Netzwerk, SAT und 230V liegen im Fussboden und im Schrank eher wild durcheinander!
Aus diesem Grund wuerde ich anstelle des komerziellen Adapters auf den Selbstbauadapter umsteigen. Und wenn es dann nicht draengt, dann wuerde ich sogar warten, bis die Version 2.0 von Chons fertig ist. Denn dann bekommt Ihr noch viel mehr, als Ihr Euch vorstellen koennt.
Gruss Christoph
RasPi2
Onkyo_AVR;3 Enigma2; SB_Server ; SB_Player; HM-USB mit 15 HM-CC-RT-DN, 3 HM_WDS10_TH_O, 6 HM-Sec-SCo, 4 HM-Sec-MDIR-2, 1 HM-Sen-MDIR-O-2, 8 Ferion 5000 OW ; PhilipsTV; add-on board mit 6 IT-Steckdosen;3 harmony hub; Jeelink mit 9 PCA301; Somfy; S7-300; 3 LGW; KS300; ESA2000