Autor Thema: fhem hängt bei vorhandenen Daten auf /dev/ttyAMA0  (Gelesen 943 mal)

Offline Crawler

  • Full Member
  • ***
  • Beiträge: 125
fhem hängt bei vorhandenen Daten auf /dev/ttyAMA0
« am: 19 Januar 2016, 12:19:46 »
Das Web Frontend hängt wenn fhem neustartet und Daten auf /dev/ttyAMA0 vorhanden sind.
Serielle Daten kommen alle 2 sek mit 9600_7E1 
Hier mal das Log in verbose 5
2016.01.19 11:58:42 5: Cmd: >usb create<
2016.01.19 11:58:42 1: usb create starting
2016.01.19 11:58:43 4: ### ttyAMA0: checking if it is a CUL
2016.01.19 11:58:43 3: Probing CUL device /dev/ttyAMA0
2016.01.19 11:58:43 5: SW: 0a
2016.01.19 11:58:43 5: SW: 560a
2016.01.19 11:58:43 4: got wrong answer for a CUL
2016.01.19 11:58:43 4: ### ttyAMA0: checking if it is a TCM_ESP3
2016.01.19 11:58:43 3: Probing TCM_ESP3 device /dev/ttyAMA0
2016.01.19 11:58:43 5: SW: 5500010005700838
2016.01.19 11:58:44 4: got wrong answer for a TCM_ESP3
2016.01.19 11:58:44 4: ### ttyAMA0: checking if it is a FRM
2016.01.19 11:58:44 3: Probing FRM device /dev/ttyAMA0
2016.01.19 11:58:44 5: SW: f9
2016.01.19 12:16:06 5: SW: f079f7
2016.01.19 12:16:06 4: got wrong answer for a FRM
2016.01.19 12:16:06 1: usb create end
2016.01.19 12:16:06 2: SecurityCheck:  WEB,WEBphone,WEBtablet has no basicAuth $
2016.01.19 12:16:06 0: Featurelevel: 5.7
2016.01.19 12:16:06 0: Server started with 9 defined entities (version $Id: fhe$
2016.01.19 12:16:06 5: Triggering global (1 changes)
2016.01.19 12:16:06 5: Notify loop for global SHUTDOWN
2016.01.19 12:16:06 0: Server shutdown
Falls das kein Fehler ist dann bitte löschen ;-)
FHEM auf Raspi + HMLan + 14 Aktoren + OBIS(Strom) über GPIO

Offline rudolfkoenig

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 16433
Antw:fhem hängt bei vorhandenen Daten auf /dev/ttyAMA0
« Antwort #1 am: 19 Januar 2016, 13:06:42 »
In der Voreinstellung ist /dev/ttyAMA0 auf dem RPi mit der Console verbunden, allerdings kann man ueber die gleiche Schnittstelle auch zahlreiche Empfaenger wie SCC/etc anbinden. Falls man nichts angebunden hat, und der Haenger, was nur beim Start von FHEM auftritt, nervt, dann sollte man das usb scan im fhem.cfg auskommentieren.

Offline Crawler

  • Full Member
  • ***
  • Beiträge: 125
Antw:fhem hängt bei vorhandenen Daten auf /dev/ttyAMA0
« Antwort #2 am: 19 Januar 2016, 18:16:10 »
die Console ist deaktiviert und dafür habe ich einen Stromzähler angeschlossen der das Programm blockiert.
Auskommentieren hab ich und funktioniert auch.

Hatte mich nur gewundert das der FRM erst nach Neustart merkt das er nix mit den Daten anfangen kann.

2016.01.19 11:58:44 3: Probing FRM device /dev/ttyAMA0
2016.01.19 11:58:44 5: SW: f9
###hier war der stop start Befehl über /etc/init.d/fhem
2016.01.19 12:16:06 5: SW: f079f7
2016.01.19 12:16:06 4: got wrong answer for a FRM
« Letzte Änderung: 19 Januar 2016, 23:47:26 von Crawler »
FHEM auf Raspi + HMLan + 14 Aktoren + OBIS(Strom) über GPIO

Offline Crawler

  • Full Member
  • ***
  • Beiträge: 125
Antw:fhem hängt bei vorhandenen Daten auf /dev/ttyAMA0
« Antwort #3 am: 20 Januar 2016, 18:03:29 »
nur für die Vollständigkeit der Hänger ist dauerhaft bis stop gemacht wird das web frontend ist nicht erreichbar
FHEM auf Raspi + HMLan + 14 Aktoren + OBIS(Strom) über GPIO