Autor Thema: Probleme mit milight  (Gelesen 1905 mal)

Offline betonmoewe

  • New Member
  • *
  • Beiträge: 41
Probleme mit milight
« am: 23 Januar 2016, 15:21:58 »
Hi,

ich habe hier 3 MiLight RGBWW Lampen und ein MiLight Wifi Modul. Die 3 Lampen sind jeweils einer der 3 Gruppen zugeordnet, aber alle zusammen im Badezimmer. Ich möchte diese für bestimmte Sachen getrennt, aber auch zusammen steuern (was leider mit dem wifilight Modul nicht geht weshalb ich wieder zurück zum milight Modul bin). Dies hatte auch mal funktioniert (vor einigen updates zumindest), nun habe ich aber das Problem, das die einzelnen Module sich farblich steuern lassen, aber wenn ich versuche, allen zusammen eine Farbe zuzuordnen, wird nur blau eingestellt :(, egal was ich anwähle.
define MiLight_Bad MilightBridge 192.168.1.122
attr MiLight_Bad checkInterval 10
attr MiLight_Bad event-on-change-reading state
attr MiLight_Bad port 8899
attr MiLight_Bad room Badezimmer
attr MiLight_Bad sendInterval 100
define LED_1_Bad MilightDevice RGBW MiLight_Bad 5
attr LED_1_Bad IODev MiLight_Bad
attr LED_1_Bad devStateIcon {Color_devStateIcon(ReadingsVal($name,"RGB","000000"))}
attr LED_1_Bad event-on-change-reading state,transitionInProgress
attr LED_1_Bad group Licht
attr LED_1_Bad lightSceneParamsToSave hsv
attr LED_1_Bad room Badezimmer
attr LED_1_Bad webCmd on:off:dim:hue:night:rgb ffffff:rgb ff0000:rgb 00ff00:rgb 0000ff:rgb ffff00
define LED_2_Bad MilightDevice RGBW MiLight_Bad 6
attr LED_2_Bad IODev MiLight_Bad
attr LED_2_Bad devStateIcon {Color_devStateIcon(ReadingsVal($name,"RGB","000000"))}
attr LED_2_Bad event-on-change-reading state,transitionInProgress
attr LED_2_Bad group Licht
attr LED_2_Bad lightSceneParamsToSave hsv
attr LED_2_Bad room Badezimmer
attr LED_2_Bad webCmd on:off:dim:hue:night:rgb ffffff:rgb ff0000:rgb 00ff00:rgb 0000ff:rgb ffff00
define LED_3_Bad MilightDevice RGBW MiLight_Bad 7
attr LED_3_Bad IODev MiLight_Bad
attr LED_3_Bad devStateIcon {Color_devStateIcon(ReadingsVal($name,"RGB","000000"))}
attr LED_3_Bad event-on-change-reading state,transitionInProgress
attr LED_3_Bad group Licht
attr LED_3_Bad lightSceneParamsToSave hsv
attr LED_3_Bad room Badezimmer
attr LED_3_Bad webCmd on:off:dim:hue:night:rgb ffffff:rgb ff0000:rgb 00ff00:rgb 0000ff:rgb ffff00
define LED_ALL_Bad MilightDevice RGBW MiLight_Bad A
attr LED_ALL_Bad IODev MiLight_Bad
attr LED_ALL_Bad devStateIcon {Color_devStateIcon(ReadingsVal($name,"RGB","000000"))}
attr LED_ALL_Bad event-on-change-reading state,transitionInProgress
attr LED_ALL_Bad group Licht
attr LED_ALL_Bad lightSceneParamsToSave hsv
attr LED_ALL_Bad room Badezimmer
attr LED_ALL_Bad webCmd on:off:dim:hue:night:rgb ffffff:rgb ff0000:rgb 00ff00:rgb 0000ff:rgb ffff00
define Sonnenschalter_Bad dummy
attr Sonnenschalter_Bad group Licht
attr Sonnenschalter_Bad room Badezimmer
attr Sonnenschalter_Bad setList on off
#attr sonne_schalter_Bad eventMap on:aufgehend off:untergehend
#attr Sonnenschalter_Bad webCmd aufgehend untergehend
define Sonne_Bad notify Sonnenschalter_Bad {\
  if ( "$EVENT" eq "on" ) \
  {\
    fhem("set LED_ALL_Bad hsv 240,100,0;;\
          set LED_ALL_Bad hsv 240,100,20 60 q;;\
          set LED_ALL_Bad hsv 200,100,50 60 q;;\
          set LED_ALL_Bad hsv 0,100,80 36 q;;\
          set LED_ALL_Bad hsv 60,100,100 30 q;;\
          set LED_ALL_Bad hsv 0,0,50 5 q;;\
          set LED_ALL_Bad hsv 0,0,100 60 q ")\
  } \
  else \
  {\
    fhem("set LED_ALL_Bad hsv 60,100,100;;\
          set LED_ALL_Bad hsv 60,100,100 20 q;;\
          set LED_ALL_Bad hsv 0,100,80 36 q;;\
          set LED_ALL_Bad hsv 200,100,50 60 q;;\
          set LED_ALL_Bad hsv 240,100,20 60 q;;\
          set LED_ALL_Bad hsv 240,100,0 90 q ")\
  }\
}

Was kann der Grund hierfür sein (wie gesagt, es lief mal)?

Gruß

die Betonmöwe

Offline Markus M.

  • Developer
  • Hero Member
  • ****
  • Beiträge: 2747
Antw:Probleme mit milight
« Antwort #1 am: 23 Januar 2016, 15:39:38 »
Grade mal probiert, alles blau.
Ich seh's mir bei Gelegenheit an!
FHEM dev + HomeBridge + Lenovo Flex15 + HM-CFG-USB + RFXtrx433 + Fritz!Box 7590/7580/546E

HM Aktor/Sensor/Winmatic/Keymatic/Thermostat, HUE, Netatmo Weather/Security/Heating, Xiaomi AirPurifier/Vacuum, Withings Aura/BPM/Cardio/Go/Pulse/Thermo, VSX828, Harmony, Siro ERB15LE
https://paypal.me/mm0

Offline Markus M.

  • Developer
  • Hero Member
  • ****
  • Beiträge: 2747
Antw:Probleme mit milight
« Antwort #2 am: 23 Januar 2016, 17:55:28 »
Bitte testen und danach melden ob's funktioniert, diese Version sollte das Problem beheben.
War wohl meine Schuld  :-[
FHEM dev + HomeBridge + Lenovo Flex15 + HM-CFG-USB + RFXtrx433 + Fritz!Box 7590/7580/546E

HM Aktor/Sensor/Winmatic/Keymatic/Thermostat, HUE, Netatmo Weather/Security/Heating, Xiaomi AirPurifier/Vacuum, Withings Aura/BPM/Cardio/Go/Pulse/Thermo, VSX828, Harmony, Siro ERB15LE
https://paypal.me/mm0

Offline betonmoewe

  • New Member
  • *
  • Beiträge: 41
Antw:Probleme mit milight
« Antwort #3 am: 23 Januar 2016, 19:06:40 »
@Markus M.: alles wieder gut  :D

noch ne Frage: wäre es schwierig, ähnlich wie bei wifilight eine Möglichkeit zu implementieren, optional das Ende der Queue Abarbeitung mitzubekommen (dort kann optional ein Bezeichner mitgegeben werden auf den dann ein Notify reagieren kann)? Ich bin gerade verzweifelt dabei mit eine Hilfslösung zu implementieren, denn ich würde gerne einen Farbverlauf mehrmals hintereinander durchlaufen lassen (Anzahl durch Slider gesteuert) und dies funktioniert nicht, wenn der Befehl gesendet wird bei noch aktiver Queue (und ohne die q Option wird auch kein richtiger Schuh draus).   

Gruß und auch ein dickes DANKE für die schnelle Behebung des Fehlers!

die Betonmöwe

Offline Markus M.

  • Developer
  • Hero Member
  • ****
  • Beiträge: 2747
Antw:Probleme mit milight
« Antwort #4 am: 23 Januar 2016, 19:25:11 »
noch ne Frage: wäre es schwierig, ähnlich wie bei wifilight eine Möglichkeit zu implementieren, optional das Ende der Queue Abarbeitung mitzubekommen

Über das Reading transitionInProgress z.B.?
FHEM dev + HomeBridge + Lenovo Flex15 + HM-CFG-USB + RFXtrx433 + Fritz!Box 7590/7580/546E

HM Aktor/Sensor/Winmatic/Keymatic/Thermostat, HUE, Netatmo Weather/Security/Heating, Xiaomi AirPurifier/Vacuum, Withings Aura/BPM/Cardio/Go/Pulse/Thermo, VSX828, Harmony, Siro ERB15LE
https://paypal.me/mm0

Offline betonmoewe

  • New Member
  • *
  • Beiträge: 41
Antw:Probleme mit milight
« Antwort #5 am: 23 Januar 2016, 20:47:59 »
hatte ich schon versucht, aber haut irgendwie nicht hin, da der Wechsel des Attributes nicht zugeordnet werden kann (oder zumindest ich keine Idee habe wie ich das machen könnte)  :( Z.B. bekomme ich ja auch dieses notify, wenn ich die Helligkeit ändere oder manuell die Farbe. Wie kann ich denn feststellen, welche Aktion die transition ausgelöst hat ??? Und ich kann auch nicht erkennen, ob die queue ganz beendet wurde, oder abgebrochen durch eine andere Aktion

Gruß

die Betonmöwe


« Letzte Änderung: 23 Januar 2016, 21:26:25 von betonmoewe »

Offline betonmoewe

  • New Member
  • *
  • Beiträge: 41
Antw:Probleme mit milight
« Antwort #6 am: 24 Januar 2016, 14:12:46 »
@Markus,

wenn ich versuche transitionInProgress einzusetzen habe ich zusätzlich folgendes Problem / inkonsistenz(?):

set LED_ALL_Bad hsv 0,100,50;set LED_ALL_Bad hsv 359,100,50 60 l q -> 4 Events (2 x 1, 2 x 0)

set LED_ALL_Bad hsv 60,100,100;set LED_ALL_Bad hsv 60,100,100 20 q;set LED_ALL_Bad hsv 0,100,80 36 q;set LED_ALL_Bad hsv 200,100,50 60 q;set LED_ALL_Bad hsv 240,100,20 60 q;set LED_ALL_Bad hsv 240,100,0 90 q -> merkwürdigerweise nur 2 Events (1 x 1, 1 x 0)

dies macht es zusätzlich schwierig, hier einen Workaround zu bauen :(

Aber vielleicht hast Du ja eine Idee, wie ich dies mit Deinem Modul abfangen könnte

Gruß

Die Betonmöwe

 

decade-submarginal