Autor Thema: Bestellung v1.x - Relay Platine auf HM (AES), MySensors, ZWave Basis  (Gelesen 89886 mal)

Offline Spezialtrick

  • Hero Member
  • *****
  • Beiträge: 1015
Antw:Bestellung v1.x - Relay Platine auf HM, MySensors, ZWave Basis
« Antwort #300 am: 06 Juni 2016, 22:28:27 »
Hallo Miro
Nein das Pairen startet nicht.

Der Taster hat, zumindest fuer mich ersichtlich, keine Funktion. Leider weiss ich aber auch nicht wann er was machen soll. Wie gesagt, seitdem die Firmware OTA geflasht ist, leuchtet die LED fuer knapp 2 Sekunden. danach blinkt sie noch 2mal kurz hintereinander.

Ok. Dann haben wir beide offenbar zwei Platinen, die sich identisch verhalten. Papa und ich suchen bereits nach einer Lösung.

Normalzustand: Nachdem die Firmware per OTA geflasht ist, startet sich die Platine neu. Dann blinkt die Led sieben Mal auf. Hier gibt der Bootloader seine Version aus. Dann startet die eigentliche Firmware. Nun sollte nach Betätigung des Taster das Pairen starten und die Led zyklisch im 1sek Takt blinken.

Zitat
Ich verstehe ja, dass es sehr viel Input ist, was momentan auf Dich einstuermt.

Das habe ich mit der Sammelbestellung wohl oder übel auf mich genommen.  ::)

Zitat
Zum Thema Arduino IDE: Ich hatte mal gefragt, wie ich diesen Weg beschreiten kann, nur leider keine Antwort bekommen, mit der ich weiter gekommen waere.

Ich versuche auch das noch in den ersten Beitrag zu schreiben. Dazu komme ich heute Abend aber leider nicht mehr. Im Prinzip funktioniert es aber auch wie mit jedem anderen Sketch der Arduino IDE.

Zitat
Das Relais sollte doch eigentlich nicht angezogen sein, oder ist Highpegel auf dem RELAY1 (Pin11) im Urzustand des Arduino?
Das Relay1 ist auf Pin D5 des Arduinos angeschlossen:

https://www.dropbox.com/sc/e933akv2uqa010q/AADqTV5bGUQFNIEIFiW5y49wa?preview=Schaltplan+1.1.jpg

Normalerweise zieht das Relay auch nicht sofort an.
FHEM - ZBox - Homematic - Sonos - MiLight -Homekit

Offline papa

  • Developer
  • Hero Member
  • ****
  • Beiträge: 1543
Antw:Bestellung v1.x - Relay Platine auf HM, MySensors, ZWave Basis
« Antwort #301 am: 06 Juni 2016, 22:44:43 »
Ich würde hier wirklich auf einen Kurzschluß irgendwo bei der Relaisansteuerung tippen. Außerdem sehen die Lötstellen auf dem Arduino teilweise so aus, als hätten sie keinen richtigen Kontakt.
BananaPi + CUL868 + CUL433 + HM-UART + 1Wire

Offline Spezialtrick

  • Hero Member
  • *****
  • Beiträge: 1015
Antw:Bestellung v1.x - Relay Platine auf HM, MySensors, ZWave Basis
« Antwort #302 am: 06 Juni 2016, 22:49:14 »
Außerdem sehen die Lötstellen auf dem Arduino teilweise so aus, als hätten sie keinen richtigen Kontakt.

Meine Worte:

Teilweise sieht es aber so auch als sei nicht jeder Pin des Pro Minis verlötet?

FHEM - ZBox - Homematic - Sonos - MiLight -Homekit

Offline hexenmeister

  • Developer
  • Hero Member
  • ****
  • Beiträge: 4550
    • tech_LogBuch
Antw:Bestellung v1.x - Relay Platine auf HM, MySensors, ZWave Basis
« Antwort #303 am: 07 Juni 2016, 00:44:08 »
Hallo Christoph,

wir sprechen aneinander vorbei  ;D
Ich meine nicht diese Schaltung, sondern, dass man ein Relay durchaus mit einem µC steuern kann indem der Steuer-PIN zum Anziehen des Relays auf Low gelegt werden muss. Lassen wir  ;)
Laut Schaltplan kann das Relais anziehen, wenn die Leitung Relay1 high ist, oder? Als "lowactive" verstehe ich, dass bei logisch Null (0) das Geraet aktiv ist. Ein Relais kann das per se nicht sein, da es dazu eine Hilfsschaltung braucht, sonst haette es irgendwo einen Energiespeicher in sich, mit dem man die Spule erregen kann. Ich lasse mich aber gerne korrigieren!
In Verwendung: HM, EnOcean, 1wire, Firmata, MySensors, ESPEasy, MQTT*, NodeRED, Alexa, Telegram,..
Maintainer: MQTT_GENERIC_BRIDGE, SYSMON, SMARTMON, systemd_watchdog, MQTT, MQTT_DEVICE, MQTT_BRIDGE
Contrib: dev_proxy
Kaffeekasse: https://www.paypal.me/s6z

Offline pc1246

  • Hero Member
  • *****
  • Beiträge: 2726
  • Kein support per PN oder eMail
Antw:Bestellung v1.x - Relay Platine auf HM, MySensors, ZWave Basis
« Antwort #304 am: 07 Juni 2016, 10:31:34 »
Hallo
Sorry ich meinte auch Pin8! Die Lötstellen sehen auf dem Photo teilweise schlechter aus, als auf in Wirklichkeit. Ich hatte auch geschrieben, dass ich schon einige nachgeloetet habe.
Nochmal zum Startverhalten: Es blinkt immer noch 7mal nach dem Einschalten, dann folgt eine Pause, danach ein ca. 2 Sekunden langes Leuchten, dann nach einer weiteren Pause, zweimal Blinken kurz hintereinander. Die Sequenz langes Leuchten und Blinken wiederholt sich alle 8 Sekunden.
Gruss Christoph
RasPi2
Onkyo_AVR;3 Enigma2; SB_Server ; SB_Player; HM-USB mit 15 HM-CC-RT-DN, 3 HM_WDS10_TH_O, 6 HM-Sec-SCo, 4 HM-Sec-MDIR-2, 1 HM-Sen-MDIR-O-2, 8 Ferion 5000 OW ; PhilipsTV; add-on board mit 6 IT-Steckdosen;3 harmony hub; Jeelink mit 9 PCA301; Somfy; S7-300; 3 LGW; KS300; ESA2000; HUE

Offline PeMue

  • Developer
  • Hero Member
  • ****
  • Beiträge: 5010
Antw:Bestellung v1.x - Relay Platine auf HM, MySensors, ZWave Basis
« Antwort #305 am: 08 Juni 2016, 08:12:48 »
Hallo zusammen,

gibt es die HM Firmware auch als hex bzw. liegt der Quelltext irgendwo?

Danke + Gruß

Peter
1x FB7170 (29.04.88) 5.7 1xCUNO2 1.67 2xEM1000WZ 2xUniroll 1xASH2200 3xHMS100T(F)
1x RPi BV2LCDCSM 1.63 5.7 2xMAX HKT, 1xMAX RT, V200KW1
1xFB 7490 (113.06.05) 5.7 1xCUL V3 1.63 1xHM-CC-RT-DN 1.4 1xHM-TC-IT-WM 1.1 1xHB-UW-Sen-THPL-O 0.15 1x-I 0.14OTAU 1xRFXtrx 90 1xWT440H 1xCM160 3xTFA30.3150 5xFA21

Offline papa

  • Developer
  • Hero Member
  • ****
  • Beiträge: 1543
Antw:Bestellung v1.x - Relay Platine auf HM, MySensors, ZWave Basis
« Antwort #306 am: 08 Juni 2016, 09:33:46 »
Den Quelltext gibt es in meinem Github-Fork im Branch "HMRy".

https://github.com/pa-pa/NewAskSin/tree/HMRy
BananaPi + CUL868 + CUL433 + HM-UART + 1Wire

Offline sentinel1

  • Full Member
  • ***
  • Beiträge: 134
Antw:Bestellung v1.0 - Relay Platine auf HM, MySensors, ZWave Basis
« Antwort #307 am: 09 Juni 2016, 07:00:29 »
Hallo,

ich möchte die Firmware probieren,wann muss A0 und A1 kurz geschlossen werden?

Gruß,
Claudiu



Ich habe mal zum Probieren eine Low/High Umschaltung in die Firmware eingebaut.

Wenn A0 & A1 kurz geschlossen werden, dann wird der Arbeitsmodus auf Low Aktive umgestellt. Firmware zum flashen ist angehängt. Wenn die Lösung zusagt, baue ich das dauerhaft ein. Die nächste Platine kann ja dafür nen Jumper kriegen.

Offline Spezialtrick

  • Hero Member
  • *****
  • Beiträge: 1015
Antw:Bestellung v1.x - Relay Platine auf HM, MySensors, ZWave Basis
« Antwort #308 am: 09 Juni 2016, 07:23:19 »
A0 und A1 müssen verbunden werden, wenn die externen Relays von einem Low statt einem High Signal getriggert werden sollen.
FHEM - ZBox - Homematic - Sonos - MiLight -Homekit

Offline Spezialtrick

  • Hero Member
  • *****
  • Beiträge: 1015
Antw:Bestellung v1.x - Relay Platine auf HM, MySensors, ZWave Basis
« Antwort #309 am: 09 Juni 2016, 07:31:11 »
Nochmal zum Startverhalten: Es blinkt immer noch 7mal nach dem Einschalten, dann folgt eine Pause, danach ein ca. 2 Sekunden langes Leuchten, dann nach einer weiteren Pause, zweimal Blinken kurz hintereinander. Die Sequenz langes Leuchten und Blinken wiederholt sich alle 8 Sekunden.

Leider kann ich das Verhalten nicht erklären. Spiel bitte die anhängige Firmware auf die Platine. Damit kannst du die Debuging Ausgaben mit dem Serial Monitors in der Arduino IDE einsehen und hier posten.

Hast du auch schon deine zweite Platine aufgebaut?
FHEM - ZBox - Homematic - Sonos - MiLight -Homekit

Offline pc1246

  • Hero Member
  • *****
  • Beiträge: 2726
  • Kein support per PN oder eMail
Antw:Bestellung v1.x - Relay Platine auf HM, MySensors, ZWave Basis
« Antwort #310 am: 09 Juni 2016, 09:17:18 »
Hallo Miro
Nein die zweite Platine habe ich noch nicht angefangen, zum Einen aus Mangel an Zeit, und zum Anderen um nicht unnoetig Schrott zu produzieren. Denn beim besten Willen habe ich es noch nicht geschafft etwas wieder auszuloeten, was mehr als vier Beine hat. Und schon gar nicht ohne dabei Schaden anzurichten. Danke fuer die Firmware, die auch wieder OTA? Den seriellen Monitor vom Arduino kenne ich, aber womit schliesse ich mich da jetzt an den Arduino an. USB-seriell an den seitlichen Pins RX/TX ? Oder wieder USBASP, den kriege ich glaube ich gar nicht in die Arduino-IDE integriert.

Heute nachmittag habe ich Zeit!

Gruss Christoph
RasPi2
Onkyo_AVR;3 Enigma2; SB_Server ; SB_Player; HM-USB mit 15 HM-CC-RT-DN, 3 HM_WDS10_TH_O, 6 HM-Sec-SCo, 4 HM-Sec-MDIR-2, 1 HM-Sen-MDIR-O-2, 8 Ferion 5000 OW ; PhilipsTV; add-on board mit 6 IT-Steckdosen;3 harmony hub; Jeelink mit 9 PCA301; Somfy; S7-300; 3 LGW; KS300; ESA2000; HUE

Offline papa

  • Developer
  • Hero Member
  • ****
  • Beiträge: 1543
Antw:Bestellung v1.x - Relay Platine auf HM, MySensors, ZWave Basis
« Antwort #311 am: 09 Juni 2016, 13:14:37 »
Dir Firmeare per OTA einspielen und dann mittels USB-seriell an den TX/RX Pins die Ausgaben einsammeln. Baudrate sollte 57600 sein.
BananaPi + CUL868 + CUL433 + HM-UART + 1Wire

Offline pc1246

  • Hero Member
  • *****
  • Beiträge: 2726
  • Kein support per PN oder eMail
Antw:Bestellung v1.x - Relay Platine auf HM, MySensors, ZWave Basis
« Antwort #312 am: 09 Juni 2016, 18:17:53 »
Moin
Das Verhalten ist weiterhin das Gleiche!
R1 gegen Masse gemessen ergibt ca. 0 Volt!
Debugausgabe ist:
AskSin OTA Bootloader V0.7.0

TX bootloader sequence
Wait for CB msg
Timeout
CRC fail, Reboot
Gruss Christoph
RasPi2
Onkyo_AVR;3 Enigma2; SB_Server ; SB_Player; HM-USB mit 15 HM-CC-RT-DN, 3 HM_WDS10_TH_O, 6 HM-Sec-SCo, 4 HM-Sec-MDIR-2, 1 HM-Sen-MDIR-O-2, 8 Ferion 5000 OW ; PhilipsTV; add-on board mit 6 IT-Steckdosen;3 harmony hub; Jeelink mit 9 PCA301; Somfy; S7-300; 3 LGW; KS300; ESA2000; HUE

Offline PeMue

  • Developer
  • Hero Member
  • ****
  • Beiträge: 5010
Antw:Bestellung v1.x - Relay Platine auf HM, MySensors, ZWave Basis
« Antwort #313 am: 09 Juni 2016, 19:00:58 »
Hallo Christoph,

ich habe nur halb mitgelesen, aber von mir folgende Fragen:
- der OTA Bootloader scheint drauf zu sein 7x Blinken, korrekt?
- hast Du eine vernünftige Verbindung zu fhem bzw. zum hmcfgusb? kann man das überhaupt prüfen?
- ist die Antennenlänge korrekt?
Heute ist meine 0402Spule gekommen, D.h. spätestens am Wochenende geht's auch bei mir weiter ...

Gruß Peter
1x FB7170 (29.04.88) 5.7 1xCUNO2 1.67 2xEM1000WZ 2xUniroll 1xASH2200 3xHMS100T(F)
1x RPi BV2LCDCSM 1.63 5.7 2xMAX HKT, 1xMAX RT, V200KW1
1xFB 7490 (113.06.05) 5.7 1xCUL V3 1.63 1xHM-CC-RT-DN 1.4 1xHM-TC-IT-WM 1.1 1xHB-UW-Sen-THPL-O 0.15 1x-I 0.14OTAU 1xRFXtrx 90 1xWT440H 1xCM160 3xTFA30.3150 5xFA21

Offline pc1246

  • Hero Member
  • *****
  • Beiträge: 2726
  • Kein support per PN oder eMail
Antw:Bestellung v1.x - Relay Platine auf HM, MySensors, ZWave Basis
« Antwort #314 am: 09 Juni 2016, 19:07:16 »
Hallo Peter
Ich bekomme die Platine nicht eingebunden. OTA flashen geht, mit 3 NAK's! Antennenlänge ist derzeit noch nicht angepasst, da meiner Meinung nach der Draht eher nicht so toll ist, ist mir schon einmal abgebrochen!
Gruss Christoph
RasPi2
Onkyo_AVR;3 Enigma2; SB_Server ; SB_Player; HM-USB mit 15 HM-CC-RT-DN, 3 HM_WDS10_TH_O, 6 HM-Sec-SCo, 4 HM-Sec-MDIR-2, 1 HM-Sen-MDIR-O-2, 8 Ferion 5000 OW ; PhilipsTV; add-on board mit 6 IT-Steckdosen;3 harmony hub; Jeelink mit 9 PCA301; Somfy; S7-300; 3 LGW; KS300; ESA2000; HUE

 

decade-submarginal