Autor Thema: Temperatur-/Luftfeuchesensoren GT-WT-01  (Gelesen 4423 mal)

Offline Talkabout

  • Developer
  • Sr. Member
  • ****
  • Beiträge: 886
Temperatur-/Luftfeuchesensoren GT-WT-01
« am: 29 Januar 2016, 18:04:36 »
Hallo zusammen,

nachdem es mit der aculfw ja möglich ist, Sensoren des Typs GT-WT-01 zu empfangen, habe ich mir mal 3 davon gegönnt. Leider musste ich feststellen, dass 2 davon als genau das selbe Device erkannt werden. Ist es tatsächlich so, dass es nicht empfohlen ist, mehrere davon nebeneinander laufen zu lassen, oder ist es möglich FHEM beizubringen, alle 3 voneinander zu unterscheiden?

Danke!

Gruss

Offline defdanny

  • New Member
  • *
  • Beiträge: 24
Antw:Temperatur-/Luftfeuchesensoren GT-WT-01
« Antwort #1 am: 16 März 2016, 18:50:17 »
Hallo Talkabout, schade, dass es zu dieser Frage noch keine Antwort gibt.
Ich stehe nämlich vor genau dem gleichen Problem, wobei ich gerne drei GT-WT-02 Sensoren von von Globaltronics einbinden möchte.
Per "autocreate" wird allerdings nur ein Sensor erkannt....
Raspberry Pi Modell B mit CUL V3 433 Mhz
MAX!Cube als CUN mit alternativer FW

Offline Talkabout

  • Developer
  • Sr. Member
  • ****
  • Beiträge: 886
Antw:Temperatur-/Luftfeuchesensoren GT-WT-01
« Antwort #2 am: 19 März 2016, 00:06:47 »
Hallo Talkabout, schade, dass es zu dieser Frage noch keine Antwort gibt.
Ich stehe nämlich vor genau dem gleichen Problem, wobei ich gerne drei GT-WT-02 Sensoren von von Globaltronics einbinden möchte.
Per "autocreate" wird allerdings nur ein Sensor erkannt....
Die Sensoren funktionieren so, dass jedes mal, wenn die Batterie raus-und wieder reingelegt wird, eine neue eindeutige Kennung generiert wird. Heisst also, dass DU einfach mal die Batterie raus holen musst, dann sollte der Sensor als ein neuer erkannt werden.

Gruss

Offline defdanny

  • New Member
  • *
  • Beiträge: 24
Antw:Temperatur-/Luftfeuchesensoren GT-WT-01
« Antwort #3 am: 19 März 2016, 09:36:31 »
Hey danke. Das hat funktioniert!

Gesendet von meinem Tab2A7-10F mit Tapatalk

Raspberry Pi Modell B mit CUL V3 433 Mhz
MAX!Cube als CUN mit alternativer FW

Offline Ralf9

  • Developer
  • Hero Member
  • ****
  • Beiträge: 4301
Antw:Temperatur-/Luftfeuchesensoren GT-WT-01
« Antwort #4 am: 22 März 2016, 18:55:34 »
Wenn es nicht mehr als 3 Sensoren sind, dann lässt sich mit dem Attribut "longids" festlegen, daß für den Devicecode nicht die ID sondern der Kanal verwendet wird. Dann gibt es beim Batteriewechsel keinen neuen Devicecode.

Gruß Ralf
« Letzte Änderung: 23 März 2016, 12:49:33 von Ralf9 »
FHEM auf Cubietruck mit Igor-Image, SSD und  hmland + HM-CFG-USB-2,  HMUARTLGW Lan,   HM-LC-Bl1PBU-FM, HM-CC-RT-DN, HM-SEC-SC-2, HM-MOD-Re-8, HM-MOD-Em-8
HM-Wired:  HMW_IO_12_FM, HMW_Sen_SC_12_DR, Selbstbau IO-Module HBW_IO_SW
Maple-SIGNALduino, WH3080,  Hideki, Id 7

Offline defdanny

  • New Member
  • *
  • Beiträge: 24
Antw:Temperatur-/Luftfeuchesensoren GT-WT-01
« Antwort #5 am: 28 März 2016, 21:09:19 »
Hallo Ralf, gut zu wissen. Ich hatte mich schon gefragt, wie man den Funkkanal fur die ID nutzen könnte.
Raspberry Pi Modell B mit CUL V3 433 Mhz
MAX!Cube als CUN mit alternativer FW

Offline FHEm2005

  • Sr. Member
  • ****
  • Beiträge: 669
    • Squeezebox mit RFID-Karten steuern
Antw:Temperatur-/Luftfeuchesensoren GT-WT-01
« Antwort #6 am: 25 November 2016, 13:42:50 »
Hallo,
ich muss das Thema noch einmal aufgreifen. Ich besitze ebenfalls einen Außensensor GT-WT-01 und möchte die Außentemperatur in FHEM benutzen. Leider bin ich bis jetzt überhaupt nicht erfolgreich.

Empfänger: NanoCUL mit FW v 1.66 nanoCUL433
Einzelheiten hier:
Internals:
   CMDS       BCFiAZEkGMKUYRTVWXefltxz
   Clients    :FS20:FHT.*:KS300:USF1000:BS:HMS: :CUL_EM:CUL_WS:CUL_FHTTK:CUL_HOERMANN: :ESA2000:CUL_IR:CUL_TX:Revolt:IT:UNIRoll:SOMFY: :STACKABLE_CC:CUL_RFR::CUL_TCM97001:CUL_REDIRECT:
   DEF        /dev/serial/by-id/usb-FTDI_FT232R_USB_UART_A900HL6H-if00-port0@38400 4321
   DeviceName /dev/serial/by-id/usb-FTDI_FT232R_USB_UART_A900HL6H-if00-port0@38400
   FD         29
   FHTID      4321
   NAME       nanoCUL
   NR         1205
   PARTIAL
   STATE      Initialized
   TYPE       CUL
   VERSION    V 1.66 nanoCUL433
   initString X21
   Matchlist:
     1:USF1000  ^81..(04|0c)..0101a001a5ceaa00....
     2:BS       ^81..(04|0c)..0101a001a5cf
     3:FS20     ^81..(04|0c)..0101a001
     4:FHT      ^81..(04|09|0d)..(0909a001|83098301|c409c401)..
     5:KS300    ^810d04..4027a001
     6:CUL_WS   ^K.....
     7:CUL_EM   ^E0.................$
     8:HMS      ^810e04....(1|5|9).a001
     9:CUL_FHTTK ^T[A-F0-9]{8}
     A:CUL_RFR  ^[0-9A-F]{4}U.
     B:CUL_HOERMANN ^R..........
     C:ESA2000  ^S................................$
     D:CUL_IR   ^I............
     E:CUL_TX   ^TX[A-F0-9]{10}
     F:Revolt   ^r......................$
     G:IT       ^i......
     H:STACKABLE_CC ^\*
     I:UNIRoll  ^[0-9A-F]{5}(B|D|E)
     J:SOMFY    ^Y[r|t|s]:?[A-F0-9]+
     K:CUL_TCM97001 ^s[A-F0-9]+
     L:CUL_REDIRECT ^o+
   Readings:
     2016-11-25 12:40:46   ccconf          freq:433.920MHz bWidth:58KHz rAmpl:42dB sens:4dB
     2016-11-25 13:18:49   cmds             B C F i A Z E k G M K U Y R T V W X e f l t x z
     2016-11-24 14:25:34   credit10ms      900
     2016-11-20 14:58:32   fhtbuf          AE
     2016-11-25 13:18:49   raw             No answer
     2016-11-25 13:18:49   state           Initialized
     2016-11-20 14:56:46   uptime          0 00:01:22
     2016-11-20 17:36:09   version         V 1.66 nanoCUL433
   Helper:
     2405e8:
       QUEUE:
Attributes:
   longids    1
   model      nanoCUL
   rfmode     SlowRF
   room       CUL
   showtime   1
   verbose    5

Dazu habe ich ein  device CUL_TCM97001 kreiert:

Internals:
   CODE       1
   DEF        1
   IODev      nanoCUL
   NAME       GT_WT
   NR         1214
   STATE      Defined
   TYPE       CUL_TCM97001
   lastH      0
   lastT      0
Attributes:
   IODev      nanoCUL
   model      Unknown
   room       CUL
   verbose    5

Den erforderlichen Code habe ich auf "1" gesetzt weil ich die ersten beiden hex-Werte nicht kenne. Der Kanalschalter steht auf "1" und im nanoCUL ist das attr "longids 1"  Das model habe ich auf unknown gesetzt, weil ich gelesen habe, dass nur WT-02 funktioniert. Ich sitze hier schon einige Zeit vor dem EventMonitor und warte auf ein Lebenszeichen, aber leider erfolglos.

Kann mir jemand helfen aus dem WT-01 etwas herauszulesen? Ich verstehe das mit der aculfw nicht.
Gruß Eberhard

Raspi3: FHEM, CULV3 (V1.61), EnOcean Pi 868, nanoCUL433, HUE-Bridge und Tradfri-Bridge; Raspi4: Node-red, MQTT

Offline FHEm2005

  • Sr. Member
  • ****
  • Beiträge: 669
    • Squeezebox mit RFID-Karten steuern
Antw:Temperatur-/Luftfeuchesensoren GT-WT-01
« Antwort #7 am: 25 November 2016, 15:07:49 »
Jetzt bin ich ein wenig weiter.
ich habe die a-culfw als hex.Datei (nanoCUL433.hex) und möchte diese jetzt in den NanoCUL flashen. Deshalb konkrete Fragen:

- Wohin muss ich diese Datei schieben? Da wo auch nanoCUL.hex liegt ?
- Welchen Befehl muss ich absetzen, damit die neue Datei (nanoCUL433.hex) geflasht wird?

Gruß Eberhard
Raspi3: FHEM, CULV3 (V1.61), EnOcean Pi 868, nanoCUL433, HUE-Bridge und Tradfri-Bridge; Raspi4: Node-red, MQTT

centurion

  • Gast
Antw:Temperatur-/Luftfeuchesensoren GT-WT-01
« Antwort #8 am: 19 Dezember 2016, 19:53:33 »
Nun ja , bin auch neu hier . Und meine Frage wäre !!? Geht der Wettersensor GT-WT-01 mit der Stock Fhem oder nur mit der a-fhem ? Ich habe nämlich noch so eine rum liegen .
Gruß Horst

Offline FHEm2005

  • Sr. Member
  • ****
  • Beiträge: 669
    • Squeezebox mit RFID-Karten steuern
Antw:Temperatur-/Luftfeuchesensoren GT-WT-01
« Antwort #9 am: 20 Dezember 2016, 08:37:23 »
Hallo Horst,

meine Frage wäre: was ist Stock fhem und a-fhem. Aber trotzdem versuche ich mal auf deine Frage zu antworten.

Ich habe ebenfalls einen Wettersensor GT-WT-01 in Betrieb. Die Daten empfange ich mit nanoCUL und der a-culfw. Dann wurde der Sonsor relativ schnell erkannt und hat das attr model automatisch auf Prologue eingestellt.

Die oben aufgeführten Probleme kamen aus dem System. Zur deren Beseitigung habe ich das gesamte System neu aufsetzen müssen. Wo der eigentliche Fehler lag kann ich also nicht mehr sagen.

Hilft Dir das weiter?

Gruß Eberhard
Raspi3: FHEM, CULV3 (V1.61), EnOcean Pi 868, nanoCUL433, HUE-Bridge und Tradfri-Bridge; Raspi4: Node-red, MQTT

sirnoname

  • Gast
Antw:Temperatur-/Luftfeuchesensoren GT-WT-01
« Antwort #10 am: 05 Januar 2017, 23:24:24 »
Sorry wenn ich diesen Thread nochmal anfasse.
Auch ich habe ein GT-WT-01 und ein nanoCUL 433MHz. Als Firmware wird mir in FHEM 1.66 angezeigt. Diese wurde wie in der nanoCul Seite compiliert und bespielt.
Geräte mit 433MHz funktionieren (Baumarkt Steckdosen Set). Der GT-WT-01 wird nicht mit autocreate angezeigt.

define nanoCUL433 CUL /dev/serial/by-path/platform-3f980000.usb-usb-0:1.5:1.0-port0@38400 0000
Was ist eine a-culfw?
Was muss ich mit longID's machen (wenn überhaupt)?
Hat es was mit dem 0000 hinter dem nanoCUL define zu tun?
« Letzte Änderung: 06 Januar 2017, 00:02:27 von sirnoname »

Offline KölnSolar

  • Developer
  • Hero Member
  • ****
  • Beiträge: 5687
Antw:Temperatur-/Luftfeuchesensoren GT-WT-01
« Antwort #11 am: 06 Januar 2017, 08:24:00 »
Die Fragen müssten sich aber alle mit der SuFu beantworten lassen  :(
Zitat
Was ist eine a-culfw?
Alternative culfw. Eine inoffizielle Weiterentwicklung der CUL-firmware. https://forum.fhem.de/index.php/topic,35064.0.html
Bietet bessere IT- und Wettersensor-Unterstützung. Für 433MHz sehr zu empfehlen.
Zitat
Was muss ich mit longID's machen (wenn überhaupt)?
longIDs sind eindeutige IDs von T/F-Sensoren, die bei der Unterscheidung mehrerer Sensoren helfen. In fhem wird dazu beim Transceiver das Attribut longids mit Angabe der Sensortypen gesetzt.
Zitat
Hat es was mit dem 0000 hinter dem nanoCUL define zu tun?
Nein. Das ist die FHTID. Findet Verwendung bei 868MHz-Systemen.
Grüße Markus

RPi3/2 buster/stretch-SamsungAV_E/N-RFXTRX-IT-RSL-NC5462-Oregon-CUL433-GT-TMBBQ-01e-CUL868-FS20-EMGZ-1W(GPIO)-DS18B20-CO2-USBRS232-USBRS422-Betty_Boop-EchoDot-OBIS(Easymeter-Q3/EMH-KW8)-PCA301(S'duino)-Deebot(mqtt2)-zigbee2mqtt

Offline FHEm2005

  • Sr. Member
  • ****
  • Beiträge: 669
    • Squeezebox mit RFID-Karten steuern
Antw:Temperatur-/Luftfeuchesensoren GT-WT-01
« Antwort #12 am: 06 Januar 2017, 08:41:33 »
Hallo Sirnoname,

a_culfw bedeutet eine alternative Firmware für die CUL. Die normale FW empfängt keine Befehle , die von einer IT-Fernbedienung abgesetzt werden (bei mir wenigstens) . Dadurch muss der angezeigte Zustand nicht dem wahren Zustand entsprechen, wenn mit einer Fernbedienung zwischendurch geschaltet wurde.  Dieses Manko behebt die a-culfw. Die a-culfw empfängt und erkennt mehr Geräte als die normale culfw.

Bei mir hatte ich die beiden Themen (autocreate und long ID) ebenfalls. Nach flashen der a-culfw brauchte ich mich um diese Themen nicht mehr zu kümmern. Ich empfange mehrere Temperatursensoren und 4 Schaltsteckdosen in der Nachbarschaft.

Im Forum findest Du die a-culfw unter:     FHEM Forum » CUL » Hard- und Firmware » Alternative culfw

Ich kann sie Dir nur empfehlen.

Gruß Eberhard

... KölnSolar war schneller - und genauer. ;) ;)
« Letzte Änderung: 06 Januar 2017, 08:44:07 von FHEm2005 »
Raspi3: FHEM, CULV3 (V1.61), EnOcean Pi 868, nanoCUL433, HUE-Bridge und Tradfri-Bridge; Raspi4: Node-red, MQTT

sirnoname

  • Gast
Antw:Temperatur-/Luftfeuchesensoren GT-WT-01
« Antwort #13 am: 07 Januar 2017, 00:02:33 »
Danke für die Antworten.
Nein ich konnte mit der Forumssuche hier nichts passendes zu a-culfw finden, daher Danke für den direkten Link.
Der Umstieg ging leider in die Hose, anscheinend kann man nach dem Flashen nicht mehr Senden.
Die IT Erkennung lief auch schon vorher mit der Standard. Durch die a-culfw war tatsächlich der Sensor erkannt worden. Die Firmware hing sich allerdings bei meinen Testversuchen immer nach kurzer Zeit auf und der Sensor stoppte.

Offline fhemjan

  • New Member
  • *
  • Beiträge: 35
Antw:Temperatur-/Luftfeuchesensoren GT-WT-01
« Antwort #14 am: 12 August 2022, 19:51:43 »
Möchte den Thread auch noch mal aufgreifen...
Habe jetzt einen GT-WT-01 hier und würde ihn gern mit einem nanoCUL433 mit a-culfw betreiben. Ich habe autocreate an, was bei Intertechno Steckdosen auch wunderbar funktioniert. Aber den Sensor findet er nicht, im Eventmonitor taucht auch nichts auf wenn ich die Batterien neu einlege oder wenn ich die TX-Taste am Sensor (bin etwas unsicher wofür die ist) drücke...
Hat jemand Rat? Oder muss ich noch irgendwas einstellen damit der Sensor erkannt wird?

 

decade-submarginal